Wireless ad hoc network: 2nd PC not getting IP on network

Discussion in 'Wireless Networking' started by Miles, Aug 22, 2006.

  1. Miles

    Miles Guest

    I've put together a simple home network like this:

    broadband cable modem
    ¦
    v
    VOIP phone gateway SVA-600
    ¦
    v
    PC#1 )))) (ad hoc wireless connection) (((( PC#2

    Both PCs are running Windows XP SP2 and have D-Link DWL-G510 PCI wireless
    network cards. I've used the D-Link configuration utility to set both cards
    to ad hoc mode, set up an SSID and got the two devices to connect (the "D"
    in the utility turns green).

    Data encryption is disabled, and I've turned off all firewalls on both
    machines for the moment.

    I then ran the Windows XP network setup wizard on PC#1, to enable internet
    connection, file and printer sharing on the network. I said PC#1 was
    connected directly to the internet. I then ran the wizard on PC#2, saying
    that it connected to the internet through another computer.

    The second PC is not given an IP address on the network. I tried repairing
    the connection several times, but each time it's given an IP starting with
    169, when it should be 192.168.88.101 (PC#1 is 192.168.88.100. The gateway
    is 192.168.88.1). I tried manually entering the IP setting details, but PC#2
    still could not ping any other device on the network.

    I am pretty new to this, so if anyone could explain how I should go about
    setting up the above network, I'd be very grateful.
     
    Miles, Aug 22, 2006
    #1
    1. Advertising

  2. Hi

    If you do not want to share the Internet and just need connection between
    those two computers, you need to assign a static IP to each computer. E.g.
    PC#1 192.168.1.1 and PC#2 192.168.1.2

    If you would like to share the Internet too, disable the original Utility
    and use Windows ICS to Auto assign the IP.

    The principle here,
    http://www.microsoft.com/windowsxp/using/networking/expert/bowman_02april08.mspx?pf=trueHi

    Jack (MVP-Networking).



    "Miles" <> wrote in message
    news:IxLGg.10816$...
    > I've put together a simple home network like this:
    >
    > broadband cable modem
    > ¦
    > v
    > VOIP phone gateway SVA-600
    > ¦
    > v
    > PC#1 )))) (ad hoc wireless connection) (((( PC#2
    >
    > Both PCs are running Windows XP SP2 and have D-Link DWL-G510 PCI wireless
    > network cards. I've used the D-Link configuration utility to set both
    > cards to ad hoc mode, set up an SSID and got the two devices to connect
    > (the "D" in the utility turns green).
    >
    > Data encryption is disabled, and I've turned off all firewalls on both
    > machines for the moment.
    >
    > I then ran the Windows XP network setup wizard on PC#1, to enable internet
    > connection, file and printer sharing on the network. I said PC#1 was
    > connected directly to the internet. I then ran the wizard on PC#2, saying
    > that it connected to the internet through another computer.
    >
    > The second PC is not given an IP address on the network. I tried repairing
    > the connection several times, but each time it's given an IP starting with
    > 169, when it should be 192.168.88.101 (PC#1 is 192.168.88.100. The gateway
    > is 192.168.88.1). I tried manually entering the IP setting details, but
    > PC#2 still could not ping any other device on the network.
    >
    > I am pretty new to this, so if anyone could explain how I should go about
    > setting up the above network, I'd be very grateful.
    >
     
    Jack \(MVP-Networking\)., Aug 23, 2006
    #2
    1. Advertising

  3. Miles

    Miles Guest

    "Jack (MVP-Networking)." <> wrote in message
    news:...
    > Hi
    >
    > If you do not want to share the Internet and just need connection between
    > those two computers, you need to assign a static IP to each computer.
    > E.g. PC#1 192.168.1.1 and PC#2 192.168.1.2
    >
    > If you would like to share the Internet too, disable the original Utility
    > and use Windows ICS to Auto assign the IP.
    >
    > The principle here,
    > http://www.microsoft.com/windowsxp/using/networking/expert/bowman_02april08.mspx?pf=trueHi
    >
    > Jack (MVP-Networking).


    I've uninstalled the D-link software, and used Windows to configure the
    wireless settings. Set it up as per the tutorial you linked to. The
    connection appears to be there, however:

    I ran the Network setup wizard again on both PCs.

    PC#2 still ends up with a 169.*.*.* IP, can't connect to the internet,
    doesn't appear in the "view workgroup computers", and can't ping PC#1 or the
    gateway.

    Tomorrow I'll try removing the VoIP adapterm, to see if the network will
    work in its most basic form.
     
    Miles, Aug 24, 2006
    #3
  4. Miles

    Miles Guest

    "Miles" <> wrote in message
    news:tc5Hg.9530$...
    > "Jack (MVP-Networking)." <> wrote in message
    > news:...
    >> Hi
    >>
    >> If you do not want to share the Internet and just need connection between
    >> those two computers, you need to assign a static IP to each computer.
    >> E.g. PC#1 192.168.1.1 and PC#2 192.168.1.2
    >>
    >> If you would like to share the Internet too, disable the original Utility
    >> and use Windows ICS to Auto assign the IP.
    >>
    >> The principle here,
    >> http://www.microsoft.com/windowsxp/using/networking/expert/bowman_02april08.mspx?pf=trueHi
    >>
    >> Jack (MVP-Networking).

    >
    > I've uninstalled the D-link software, and used Windows to configure the
    > wireless settings. Set it up as per the tutorial you linked to. The
    > connection appears to be there, however:
    >
    > I ran the Network setup wizard again on both PCs.
    >
    > PC#2 still ends up with a 169.*.*.* IP, can't connect to the internet,
    > doesn't appear in the "view workgroup computers", and can't ping PC#1 or
    > the gateway.
    >
    > Tomorrow I'll try removing the VoIP adapterm, to see if the network will
    > work in its most basic form.


    Well, I've done this now. This time I can sucessfully share files between
    the two computers, but PC#2 still cannot access the shared internet
    connection!

    (For info, both computers have the wireless network connection with
    169.254.x.x addresses).
     
    Miles, Aug 25, 2006
    #4
  5. Miles

    Miles Guest

    "Miles" <> wrote in message
    news:8fLHg.9$...
    > "Miles" <> wrote in message
    > news:tc5Hg.9530$...
    >> "Jack (MVP-Networking)." <> wrote in message
    >> news:...
    >>> Hi
    >>>
    >>> If you do not want to share the Internet and just need connection
    >>> between those two computers, you need to assign a static IP to each
    >>> computer. E.g. PC#1 192.168.1.1 and PC#2 192.168.1.2
    >>>
    >>> If you would like to share the Internet too, disable the original
    >>> Utility and use Windows ICS to Auto assign the IP.
    >>>
    >>> The principle here,
    >>> http://www.microsoft.com/windowsxp/using/networking/expert/bowman_02april08.mspx?pf=trueHi
    >>>
    >>> Jack (MVP-Networking).

    >>
    >> I've uninstalled the D-link software, and used Windows to configure the
    >> wireless settings. Set it up as per the tutorial you linked to. The
    >> connection appears to be there, however:
    >>
    >> I ran the Network setup wizard again on both PCs.
    >>
    >> PC#2 still ends up with a 169.*.*.* IP, can't connect to the internet,
    >> doesn't appear in the "view workgroup computers", and can't ping PC#1 or
    >> the gateway.
    >>
    >> Tomorrow I'll try removing the VoIP adapterm, to see if the network will
    >> work in its most basic form.

    >
    > Well, I've done this now. This time I can sucessfully share files between
    > the two computers, but PC#2 still cannot access the shared internet
    > connection!
    >
    > (For info, both computers have the wireless network connection with
    > 169.254.x.x addresses).


    Finally got everything working (for those that may be interested).

    Manually configured the wireless adapters on PC#1 to 192.168.0.1 and PC#2 to
    192.168.0.2. Then set the default gateway on PC#2 to 192.168.0.1, and
    entered in the IPs of my ISP's DNS servers.
     
    Miles, Aug 31, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?amFyYXlh?=

    How to setup ad hoc wireless network

    =?Utf-8?B?amFyYXlh?=, Jul 31, 2004, in forum: Wireless Networking
    Replies:
    1
    Views:
    19,834
    =?Utf-8?B?VmVua2F0ZXNoIFtNUyBJbmRpYSBDb21tdW5pdHkg
    Aug 2, 2004
  2. =?Utf-8?B?S2VpdGg=?=

    Very slow file transfer on wireless-g ad-hoc network

    =?Utf-8?B?S2VpdGg=?=, Sep 7, 2004, in forum: Wireless Networking
    Replies:
    0
    Views:
    3,219
    =?Utf-8?B?S2VpdGg=?=
    Sep 7, 2004
  3. =?Utf-8?B?Q2FtMDA5?=

    Wireless ad hoc network (2 Computers) gateway not connecting

    =?Utf-8?B?Q2FtMDA5?=, Jan 24, 2006, in forum: Wireless Networking
    Replies:
    3
    Views:
    6,905
    =?Utf-8?B?Q2FtMDA5?=
    Jan 27, 2006
  4. =?Utf-8?B?V2Vp?=

    How to add a wireless printer to a ad hoc wireless network?

    =?Utf-8?B?V2Vp?=, Jan 16, 2007, in forum: Wireless Networking
    Replies:
    1
    Views:
    1,467
    Jack \(MVP-Networking\).
    Jan 16, 2007
  5. CliveDarling

    Ad-hoc wireless Versus Wireless Router

    CliveDarling, Aug 24, 2009, in forum: Wireless Networking
    Replies:
    1
    Views:
    1,092
    Jack [MVP-Networking]
    Aug 24, 2009
Loading...

Share This Page