Windows XP doesn't recognizes dhcp server on cisco router

Discussion in 'Cisco' started by Faustino Dina, Sep 25, 2004.

  1. I'm trying to enable dhcp server on a cisco router, but it doesn't works.
    The client dhcp I use for testing (a WIndows XP) doesn't get the address.
    But the cisco router says that it was binded to the test pc. What can be
    wrong?

    For testing I connected a spare router to the 10.10.10.0/24 segment. I
    configured the interface ethernet 0 with address 10.10.10.34/24. The other
    interface (serial 0) is configured but not connected to any device. I'm
    trying to use the router as a DHCP server for testing the configuration
    before trying on the production router.

    The dhcp specific configuration is the following:

    ip dhcp database ************ // I tryed also "no ip dhcp conflict
    logging" command

    ip dhcp excluded-address 10.10.10.1 10.10.10.60
    ip dhcp excluded-address 10.10.10.64 10.10.10.254
    !
    ip dhcp pool net10
    network 10.10.10.0 255.255.255.0
    domain-name matusa.net
    dns-server 10.10.10.1
    netbios-name-server 10.10.10.1
    netbios-node-type h-node
    default-router 10.10.10.254
    lease 2

    When configured with DHCP the XP, and after restarting it, the "show ip dhcp
    binding" command states:

    IP address Hardware address Lease expiration Type
    10.10.10.62 0100.c09f.411e.af Sep 27 2004 07:00 PM Automatic

    The hardware address is the same of the XP PC, but it looks like the PC
    doesn't acknowledges the leased address.
    What can be wrong?

    Thanks in advance. The full router configuration is the following:

    Current configuration:
    !
    ! Last configuration change at 19:01:46 UTC Sat Sep 25 2004
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname BOTTOM
    !
    logging buffered 4096 debugging
    no logging console
    no logging monitor
    enable secret 5 $1$7EuZ$g36owPnYubs6eYJmu6fFD1
    enable password ****
    !
    !
    !
    !
    !
    network-clock base-rate 56k
    ip subnet-zero
    ip dhcp database ***********
    ip dhcp excluded-address 10.10.10.1 10.10.10.60
    ip dhcp excluded-address 10.10.10.64 10.10.10.254
    !
    ip dhcp pool net10
    network 10.10.10.0 255.255.255.0
    domain-name matusa.net
    dns-server 10.10.10.1
    netbios-name-server 10.10.10.1
    netbios-node-type h-node
    default-router 10.10.10.254
    lease 2
    !
    ip multicast-routing
    ip dvmrp route-limit 20000
    !
    !
    !
    process-max-time 200
    !
    interface Ethernet0
    ip address 10.10.10.34 255.255.255.0
    no ip directed-broadcast
    ip pim sparse-dense-mode
    no ip mroute-cache
    !
    interface Serial0
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    !
    interface Serial1
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    !
    interface Async1
    ip address 192.168.10.2 255.255.255.0
    ip directed-broadcast
    ip pim sparse-dense-mode
    encapsulation ppp
    async dynamic routing
    async mode dedicated
    !
    interface Switch0
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    no ip mroute-cache
    no fair-queue
    !
    no ip http server
    no ip classless
    ip route 0.0.0.0 0.0.0.0 10.10.10.254
    !
    logging trap debugging
    logging 10.10.10.67
    snmp-server engineID local 000000090200003094FB7AF5
    snmp-server community BOTTOM RO
    !
    line con 0
    exec-timeout 0 0
    transport input none
    line aux 0
    modem InOut
    transport input all
    speed 38400
    flowcontrol hardware
    line 2 3
    line vty 0 4
    password ****
    login
    !
    !
    voice-port 1/1
    timeouts call-disconnect 0
    !
    voice-port 1/2
    timeouts call-disconnect 0
    !
    voice-port 1/5
    timeouts call-disconnect 0
    timing hookflash-out 0
    !
    voice-port 1/6
    timeouts call-disconnect 0
    timing hookflash-out 0
    !
    !
    end


    --
    Faustino Dina
    --------------------------------------------------------
    If my email address starts with two 'f'
    drop the first 'f' when mailing me.
     
    Faustino Dina, Sep 25, 2004
    #1
    1. Advertising

  2. Faustino Dina

    mh Guest

    put a packet capture program like Etherreal on PC to see if it
    actually receives a DHCP server response
     
    mh, Sep 26, 2004
    #2
    1. Advertising

  3. On Sat, 25 Sep 2004 14:27:55 -0500, Faustino Dina wrote:

    > I'm trying to enable dhcp server on a cisco router, but it doesn't works.
    > The client dhcp I use for testing (a WIndows XP) doesn't get the address.
    > But the cisco router says that it was binded to the test pc. What can be
    > wrong?
    >


    [Snip]

    > The dhcp specific configuration is the following:
    >
    > ip dhcp database ************ // I tryed also "no ip dhcp conflict
    > logging" command
    >
    > ip dhcp excluded-address 10.10.10.1 10.10.10.60 ip dhcp excluded-address
    > 10.10.10.64 10.10.10.254 !
    > ip dhcp pool net10
    > network 10.10.10.0 255.255.255.0
    > domain-name matusa.net
    > dns-server 10.10.10.1
    > netbios-name-server 10.10.10.1
    > netbios-node-type h-node
    > default-router 10.10.10.254
    > lease 2
    >
    > When configured with DHCP the XP, and after restarting it, the "show ip
    > dhcp binding" command states:
    >
    > IP address Hardware address Lease expiration Type
    > 10.10.10.62 0100.c09f.411e.af Sep 27 2004 07:00 PM Automatic
    >
    > The hardware address is the same of the XP PC, but it looks like the PC
    > doesn't acknowledges the leased address. What can be wrong?


    Dunno. Get a "debug ip dhcp server packet" and release renew on the
    Windoze box. Might tell you something?

    --
    Rgds,
    Martin
     
    Martin Gallagher, Sep 26, 2004
    #3
  4. > put a packet capture program like Etherreal on PC to see if it
    > actually receives a DHCP server response


    Wise advice. The problem was on a second unknown dhcp server on the segment.
    It was a wireless hub somebody installed and leave the dhcp server option ON
    without properly configuring it. Useful stuff that Ethereal. Thank you guys
     
    Faustino Dina, Sep 27, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Will
    Replies:
    0
    Views:
    499
  2. Herb
    Replies:
    4
    Views:
    3,573
    Toolman Tim
    Feb 19, 2005
  3. Adam Steiner

    Computer only recognizes 2 HD's, not 1 (on the same channel)

    Adam Steiner, Dec 1, 2003, in forum: Computer Information
    Replies:
    11
    Views:
    647
    Grump
    Dec 4, 2003
  4. Replies:
    0
    Views:
    449
  5. =?Utf-8?B?c2N3?=

    router recognizes printer / printer does not recognixe router

    =?Utf-8?B?c2N3?=, Aug 3, 2006, in forum: Wireless Networking
    Replies:
    1
    Views:
    1,734
Loading...

Share This Page