Windows unable to find certificate.....

Discussion in 'Wireless Networking' started by tcarp, Jan 28, 2008.

  1. tcarp

    tcarp Guest

    I get the message "Windows was unable to find a certificate to log you on to
    the network" but I still am able to connect to my preferred SSID.

    I've googled and most of the reasoning has to do with IEEE enabled. That is
    not the case here. This, of course, may not be a Windows issue but I need
    some help figuring out what it might be.

    This began when I set up encryption on my wireless network. I'm pretty
    comfortable with router and client settings although this is the first time I
    enabled encryption. The router is set up to automatically recognize what the
    client is using and my client is set for WPA2 (WPA and AES). I tried to set
    the client to WPA with TKIP but that didn't seem to make a difference. My
    better half doesn't seem to have the problem on her laptop (we're both
    running XP but it may be different versions).

    Any ideas from anyone?

    Thanks

    Tom
     
    tcarp, Jan 28, 2008
    #1
    1. Advertising

  2. tcarp

    Lem Guest

    tcarp wrote:
    > I get the message "Windows was unable to find a certificate to log you on to
    > the network" but I still am able to connect to my preferred SSID.
    >
    > I've googled and most of the reasoning has to do with IEEE enabled. That is
    > not the case here. This, of course, may not be a Windows issue but I need
    > some help figuring out what it might be.
    >
    > This began when I set up encryption on my wireless network. I'm pretty
    > comfortable with router and client settings although this is the first time I
    > enabled encryption. The router is set up to automatically recognize what the
    > client is using and my client is set for WPA2 (WPA and AES). I tried to set
    > the client to WPA with TKIP but that didn't seem to make a difference. My
    > better half doesn't seem to have the problem on her laptop (we're both
    > running XP but it may be different versions).
    >
    > Any ideas from anyone?
    >
    > Thanks
    >
    > Tom


    What make/model of router?

    Are you using Windows to configure your wireless adapter or a utility
    provided by the manufacturer? What about the other computer (the one
    without the issue)?

    Assuming that you're using Windows --

    Go to the Properties of your wireless network connection.

    Click on the Wireless Networks tab, select your SSID from the list of
    Preferred Networks, and click Properties.

    On the Authentication tab, make sure to UNcheck the box to "Enable IEEE
    802.1x authentication for this network."

    OK your way out.

    --
    Lem -- MS-MVP - Networking

    To the moon and back with 2K words of RAM and 36K words of ROM.
    http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
    http://history.nasa.gov/afj/compessay.htm
     
    Lem, Jan 28, 2008
    #2
    1. Advertising

  3. tcarp

    tcarp Guest

    "Lem" wrote:


    > What make/model of router?


    D-Link DIR 655
    >
    > Are you using Windows to configure your wireless adapter or a utility
    > provided by the manufacturer? What about the other computer (the one
    > without the issue)?


    On my laptop (the one with the problem) I use windows to configure the
    adapter (if I understand that you mean set the profile on the preferred
    network). On hers, I use a utility from the manufacturer (interesting).

    > Assuming that you're using Windows --
    >
    > Go to the Properties of your wireless network connection.
    >
    > Click on the Wireless Networks tab, select your SSID from the list of
    > Preferred Networks, and click Properties.
    >
    > On the Authentication tab, make sure to UNcheck the box to "Enable IEEE
    > 802.1x authentication for this network."
    >
    > OK your way out.
    >

    As I mentioned in my original post, the Enable IEEE 802.1x...box is NOT
    checked on my laptop (in fact it's grayed out). The IEEE solution is the one
    you find when you google this problem. Because the box is already unchecked
    is why I came here for help.

    Thanks

    Tom
     
    tcarp, Jan 29, 2008
    #3
  4. tcarp

    Lem Guest

    tcarp wrote:
    > I get the message "Windows was unable to find a certificate to log you on to
    > the network" but I still am able to connect to my preferred SSID.
    >
    > I've googled and most of the reasoning has to do with IEEE enabled. That is
    > not the case here. This, of course, may not be a Windows issue but I need
    > some help figuring out what it might be.
    >
    > This began when I set up encryption on my wireless network. I'm pretty
    > comfortable with router and client settings although this is the first time I
    > enabled encryption. The router is set up to automatically recognize what the
    > client is using and my client is set for WPA2 (WPA and AES). I tried to set
    > the client to WPA with TKIP but that didn't seem to make a difference. My
    > better half doesn't seem to have the problem on her laptop (we're both
    > running XP but it may be different versions).
    >
    > Any ideas from anyone?
    >
    > Thanks
    >
    > Tom


    You wrote that, "The router is set up to automatically recognize what
    the client is using." Is the router's "security mode" set to
    "WPA-Personal" and the router's "WPA Mode" set to "Auto"?

    In the problem client, does the setting actually say WPA2 or does it say
    WPA and then ask you to choose either TKIP or AES? Assuming that it's
    the latter, have you tried setting the router's "WPA Mode" to "WPA only"?

    Have you double-checked to make sure that the problem computer is not
    running *both* Windows Wireless Zero Configuration *and* a
    manufacturer's configuration utility? It may be a bit difficult to
    determine if a manufacturer's utility is running (unless you see an icon
    in the notification area). Look in Task Manager, but if it's running as
    a service, it may be difficult to identify. Try checking the list of
    startup applications with msconfig (or better, with autoruns
    http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx). Or you
    could temporarily disable wzc and see if another configurator appears
    (http://www.ezlan.net/wzc.html)

    Does the other computer explicitly offer WPA2?
    --
    Lem -- MS-MVP - Networking

    To the moon and back with 2K words of RAM and 36K words of ROM.
    http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
    http://history.nasa.gov/afj/compessay.htm
     
    Lem, Jan 29, 2008
    #4
  5. tcarp

    tcarp Guest

    >
    > You wrote that, "The router is set up to automatically recognize what
    > the client is using." Is the router's "security mode" set to
    > "WPA-Personal" and the router's "WPA Mode" set to "Auto"?


    Yes

    > In the problem client, does the setting actually say WPA2 or does it say
    > WPA and then ask you to choose either TKIP or AES? Assuming that it's
    > the latter, have you tried setting the router's "WPA Mode" to "WPA only"?


    The problem computer is managed through WZC and the setting is WPA-PSK.
    I've tried both AES and TKIP but the problem occurs with either.

    > Have you double-checked to make sure that the problem computer is not
    > running *both* Windows Wireless Zero Configuration *and* a
    > manufacturer's configuration utility? It may be a bit difficult to
    > determine if a manufacturer's utility is running (unless you see an icon
    > in the notification area). Look in Task Manager, but if it's running as
    > a service, it may be difficult to identify. Try checking the list of
    > startup applications with msconfig (or better, with autoruns
    > http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx). Or you
    > could temporarily disable wzc and see if another configurator appears
    > (http://www.ezlan.net/wzc.html)


    This one's interesting. I started on this journey trying to diagonse an
    intermittent problem with the wireless connection (no signal or very slow
    speed). The advice was to look to a third party piece of software to look at
    networks and the one recommended was Network Stumbler. That software
    temporarily disables/deactivates wzc and then is supposed to put it back. I
    fooled around with NS for awhile but didn't use it much. What's interesting
    is that NS now will start but doesn't see any networks (which isn't true).

    Maybe it's the problem although I have to admit I don't remember when I
    started using NS (and when it stopped working) and when I started getting the
    certificate messages. I suspect I either need to uninstall NS or maybe
    reinstall it first to get it working properly and then uninstall it.


    > Does the other computer explicitly offer WPA2?

    The other computer uses intel proset to manage the adapter. It's set to
    WPA2-Personal and I have it using TKIP (I was confused at first with the CCMP
    suffix to the AES setting. I'll probably reset to AES when I get a chance).
     
    tcarp, Feb 2, 2008
    #5
  6. tcarp

    Lem Guest

    tcarp wrote:
    >> You wrote that, "The router is set up to automatically recognize what
    >> the client is using." Is the router's "security mode" set to
    >> "WPA-Personal" and the router's "WPA Mode" set to "Auto"?

    >
    > Yes
    >
    >> In the problem client, does the setting actually say WPA2 or does it say
    >> WPA and then ask you to choose either TKIP or AES? Assuming that it's
    >> the latter, have you tried setting the router's "WPA Mode" to "WPA only"?

    >
    > The problem computer is managed through WZC and the setting is WPA-PSK.
    > I've tried both AES and TKIP but the problem occurs with either.
    >
    >> Have you double-checked to make sure that the problem computer is not
    >> running *both* Windows Wireless Zero Configuration *and* a
    >> manufacturer's configuration utility? It may be a bit difficult to
    >> determine if a manufacturer's utility is running (unless you see an icon
    >> in the notification area). Look in Task Manager, but if it's running as
    >> a service, it may be difficult to identify. Try checking the list of
    >> startup applications with msconfig (or better, with autoruns
    >> http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx). Or you
    >> could temporarily disable wzc and see if another configurator appears
    >> (http://www.ezlan.net/wzc.html)

    >
    > This one's interesting. I started on this journey trying to diagonse an
    > intermittent problem with the wireless connection (no signal or very slow
    > speed). The advice was to look to a third party piece of software to look at
    > networks and the one recommended was Network Stumbler. That software
    > temporarily disables/deactivates wzc and then is supposed to put it back. I
    > fooled around with NS for awhile but didn't use it much. What's interesting
    > is that NS now will start but doesn't see any networks (which isn't true).
    >
    > Maybe it's the problem although I have to admit I don't remember when I
    > started using NS (and when it stopped working) and when I started getting the
    > certificate messages. I suspect I either need to uninstall NS or maybe
    > reinstall it first to get it working properly and then uninstall it.
    >
    >
    >> Does the other computer explicitly offer WPA2?

    > The other computer uses intel proset to manage the adapter. It's set to
    > WPA2-Personal and I have it using TKIP (I was confused at first with the CCMP
    > suffix to the AES setting. I'll probably reset to AES when I get a chance).



    About the only idea I have left is to uninstall Network Stumbler, make
    sure that there isn't something analogous to Intel ProSet running, and
    make sure wzc is started and running. See Jack's ezlan page for details
    concerning wzc.

    Alternatively, you could stop wzc and install the mfr's adapter
    configuration utility (if one exists -- I don't recall if you identified
    what you were using as an adapter).

    Sorry I couldn't be of more help.

    --
    Lem -- MS-MVP - Networking

    To the moon and back with 2K words of RAM and 36K words of ROM.
    http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
    http://history.nasa.gov/afj/compessay.htm
     
    Lem, Feb 3, 2008
    #6
  7. tcarp

    tcarp Guest


    > Sorry I couldn't be of more help.
    >


    Actually you helped quite a bit. As I said at the beginning, google
    searches all pointed to the IEEE check box which wasn't selected in my case.
    You (and others) eliminated the possibility that it was something else others
    had run across.

    I did uninstall Network Stumbler and took a look at the Task Manager (wzc is
    started) but as you mentioned it wasn't obvious if there was something else
    running that was interfering.

    So far this has been a curiousity since it doesn't seem to affect my ability
    to connect.

    Thanks for taking the time to help.

    Tom
     
    tcarp, Feb 3, 2008
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?Sm9obiBN?=

    Unable to see machines on the ethernet; Unable to find printers

    =?Utf-8?B?Sm9obiBN?=, Jun 6, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    921
    Jack \(MVP\)
    Jun 7, 2005
  2. harry.wj

    "Windows was unable to find a certificate..." problem

    harry.wj, Feb 28, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    11,364
    harry.wj
    Feb 28, 2006
  3. Lorenzo Sandini
    Replies:
    7
    Views:
    60,800
    Jessei Medina
    Feb 23, 2010
  4. =?Utf-8?B?S3J5cw==?=

    Windows unable to locate a certificate...

    =?Utf-8?B?S3J5cw==?=, Oct 16, 2007, in forum: Wireless Networking
    Replies:
    3
    Views:
    842
  5. billsieczkowski

    windows "unable to find certificate to log on"

    billsieczkowski, Sep 16, 2008, in forum: Wireless Networking
    Replies:
    5
    Views:
    6,309
Loading...

Share This Page