Windows Task Scheduler password problem

Discussion in 'Computer Support' started by David, Oct 9, 2003.

  1. David

    David Guest

    I configured the Windows Task Scheduler to run a program automatically at
    startup. However, it doesn't run. Instead, the Task Scheduler says that
    "The scheduled task did not run because no user account password was
    enetered." (OK, the Task Scheduler Wizard did say that programs might not
    run without a password.) So I re-did the Task Scheduler and added a
    password. The program still didn't run and I got a message saying it did
    not run because the password enetered was incorrect.

    This is my home laptop, I am the administrator, I don't use passwords to log
    on, so what password is it looking for? And can I bypass the password
    feature and still get the Task Scheduler to execute the program? Thanks.
    David, Oct 9, 2003
    #1
    1. Advertising

  2. David

    °Mike° Guest

    Windows XP cannot run a scheduled task configured
    with a null password?
    http://www.jsiinc.com/SUBI/tip4400/rh4456.htm

    HOW TO: Troubleshoot Scheduled Tasks in Windows XP
    http://support.microsoft.com/default.aspx?kbid=308558


    On Thu, 09 Oct 2003 01:12:46 GMT, in
    <iC2hb.60897$>
    David scrawled:

    >I configured the Windows Task Scheduler to run a program automatically at
    >startup. However, it doesn't run. Instead, the Task Scheduler says that
    >"The scheduled task did not run because no user account password was
    >enetered." (OK, the Task Scheduler Wizard did say that programs might not
    >run without a password.) So I re-did the Task Scheduler and added a
    >password. The program still didn't run and I got a message saying it did
    >not run because the password enetered was incorrect.
    >
    >This is my home laptop, I am the administrator, I don't use passwords to log
    >on, so what password is it looking for? And can I bypass the password
    >feature and still get the Task Scheduler to execute the program? Thanks.
    >


    --
    Basic computer maintenance
    http://uk.geocities.com/personel44/maintenance.html
    °Mike°, Oct 9, 2003
    #2
    1. Advertising

  3. David

    David Guest

    Hi Mike. I went to the web pages you suggest, and they say a password is
    required for security reasons in XP. (Even though the Help page in Task
    Scheduler says a password isn't always required.) Neverthess, I reran the
    task wizard in Task Scheduler and entered a new password. I also typed that
    password in the Task Scheduler Properties box. When I rebooted, the same
    error message appeared telling me the password I entered was incorrect.

    I have no idea what password it's looking for, since I don't use a password
    for anything in Windows XP. I must be doing something wrong, but darned if
    I can think of what it is....

    "°Mike°" <> wrote in message
    news:...
    > Windows XP cannot run a scheduled task configured
    > with a null password?
    > http://www.jsiinc.com/SUBI/tip4400/rh4456.htm
    >
    > HOW TO: Troubleshoot Scheduled Tasks in Windows XP
    > http://support.microsoft.com/default.aspx?kbid=308558
    >
    >
    > On Thu, 09 Oct 2003 01:12:46 GMT, in
    > <iC2hb.60897$>
    > David scrawled:
    >
    > >I configured the Windows Task Scheduler to run a program automatically at
    > >startup. However, it doesn't run. Instead, the Task Scheduler says that
    > >"The scheduled task did not run because no user account password was
    > >enetered." (OK, the Task Scheduler Wizard did say that programs might

    not
    > >run without a password.) So I re-did the Task Scheduler and added a
    > >password. The program still didn't run and I got a message saying it did
    > >not run because the password enetered was incorrect.
    > >
    > >This is my home laptop, I am the administrator, I don't use passwords to

    log
    > >on, so what password is it looking for? And can I bypass the password
    > >feature and still get the Task Scheduler to execute the program? Thanks.
    > >

    >
    > --
    > Basic computer maintenance
    > http://uk.geocities.com/personel44/maintenance.html
    David, Oct 9, 2003
    #3
  4. David

    °Mike° Guest

    I'm not familiar with XP, but you say you don't use a
    password for anything, yet the article says you must.

    Follow the troubleshooting steps in the second link.


    On Thu, 09 Oct 2003 01:51:57 GMT, in
    <1b3hb.60928$>
    David scrawled:

    >Hi Mike. I went to the web pages you suggest, and they say a password is
    >required for security reasons in XP. (Even though the Help page in Task
    >Scheduler says a password isn't always required.) Neverthess, I reran the
    >task wizard in Task Scheduler and entered a new password. I also typed that
    >password in the Task Scheduler Properties box. When I rebooted, the same
    >error message appeared telling me the password I entered was incorrect.
    >
    >I have no idea what password it's looking for, since I don't use a password
    >for anything in Windows XP. I must be doing something wrong, but darned if
    >I can think of what it is....
    >
    >"°Mike°" <> wrote in message
    >news:...
    >> Windows XP cannot run a scheduled task configured
    >> with a null password?
    >> http://www.jsiinc.com/SUBI/tip4400/rh4456.htm
    >>
    >> HOW TO: Troubleshoot Scheduled Tasks in Windows XP
    >> http://support.microsoft.com/default.aspx?kbid=308558
    >>
    >>
    >> On Thu, 09 Oct 2003 01:12:46 GMT, in
    >> <iC2hb.60897$>
    >> David scrawled:
    >>
    >> >I configured the Windows Task Scheduler to run a program automatically at
    >> >startup. However, it doesn't run. Instead, the Task Scheduler says that
    >> >"The scheduled task did not run because no user account password was
    >> >enetered." (OK, the Task Scheduler Wizard did say that programs might

    >not
    >> >run without a password.) So I re-did the Task Scheduler and added a
    >> >password. The program still didn't run and I got a message saying it did
    >> >not run because the password enetered was incorrect.
    >> >
    >> >This is my home laptop, I am the administrator, I don't use passwords to

    >log
    >> >on, so what password is it looking for? And can I bypass the password
    >> >feature and still get the Task Scheduler to execute the program? Thanks.
    >> >

    >>
    >> --
    >> Basic computer maintenance
    >> http://uk.geocities.com/personel44/maintenance.html

    >


    --
    Basic computer maintenance
    http://uk.geocities.com/personel44/maintenance.html
    °Mike°, Oct 9, 2003
    #4
  5. David

    Jimmy Dean Guest

    On Thu, 09 Oct 2003 01:12:46 GMT, "David" <> wrote:

    >I configured the Windows Task Scheduler to run a program automatically at
    >startup. However, it doesn't run. Instead, the Task Scheduler says that
    >"The scheduled task did not run because no user account password was
    >enetered." (OK, the Task Scheduler Wizard did say that programs might not
    >run without a password.) So I re-did the Task Scheduler and added a
    >password. The program still didn't run and I got a message saying it did
    >not run because the password enetered was incorrect.
    >
    >This is my home laptop, I am the administrator, I don't use passwords to log
    >on, so what password is it looking for? And can I bypass the password
    >feature and still get the Task Scheduler to execute the program? Thanks.


    Hi David

    I also had this problem.

    I had 2 scheduled tasks without username/passwords which ran quite
    happily for a time, then something happened and I got the same error
    you describe.

    One way to solve it was to enter a password for the current user (in
    Control Panel, user accounts) - nuisance if you don't want to enter a
    password, then enter this user/password combo in scheduled tasks.

    I also managed to delete the task, then recreate it again with no
    user/password, and get it to run. This was a bit tricky and I'm not
    quite sure how I did it.

    jd
    Jimmy Dean, Oct 10, 2003
    #5
  6. David

    Brian H¹© Guest

    Jimmy Dean said:

    > On Thu, 09 Oct 2003 01:12:46 GMT, "David" <> wrote:
    >
    >> I configured the Windows Task Scheduler to run a program automatically at
    >> startup. However, it doesn't run. Instead, the Task Scheduler says that
    >> "The scheduled task did not run because no user account password was
    >> enetered." (OK, the Task Scheduler Wizard did say that programs might not
    >> run without a password.) So I re-did the Task Scheduler and added a
    >> password. The program still didn't run and I got a message saying it did
    >> not run because the password enetered was incorrect.
    >>
    >> This is my home laptop, I am the administrator, I don't use passwords to log
    >> on, so what password is it looking for? And can I bypass the password
    >> feature and still get the Task Scheduler to execute the program? Thanks.

    >
    > Hi David
    >
    > I also had this problem.
    >
    > I had 2 scheduled tasks without username/passwords which ran quite
    > happily for a time, then something happened and I got the same error
    > you describe.
    >
    > One way to solve it was to enter a password for the current user (in
    > Control Panel, user accounts) - nuisance if you don't want to enter a
    > password, then enter this user/password combo in scheduled tasks.
    >
    > I also managed to delete the task, then recreate it again with no
    > user/password, and get it to run. This was a bit tricky and I'm not
    > quite sure how I did it.
    >
    > jd


    Excuse piggy-back, can't see OP.

    After some system changes, permissions get changed to "Jobs" run in Scheduled
    Tasks.
    The simplest way of getting the jobs to activate again, is to:-
    Right click the task and choose Properties.
    Click on the Settings tab.
    Select and then deselect any one of the boxes and click Apply then OK.
    Your task should now Run normally again.
    Brian H¹©, Oct 10, 2003
    #6
  7. David

    Brian H¹© Guest

    Brian H¹© said:

    > Jimmy Dean said:
    >
    >> On Thu, 09 Oct 2003 01:12:46 GMT, "David" <> wrote:
    >>
    >>> I configured the Windows Task Scheduler to run a program automatically at
    >>> startup. However, it doesn't run. Instead, the Task Scheduler says that
    >>> "The scheduled task did not run because no user account password was
    >>> enetered." (OK, the Task Scheduler Wizard did say that programs might not
    >>> run without a password.) So I re-did the Task Scheduler and added a
    >>> password. The program still didn't run and I got a message saying it did
    >>> not run because the password enetered was incorrect.
    >>>
    >>> This is my home laptop, I am the administrator, I don't use passwords to log
    >>> on, so what password is it looking for? And can I bypass the password
    >>> feature and still get the Task Scheduler to execute the program? Thanks.

    >>
    >> Hi David
    >>
    >> I also had this problem.
    >>
    >> I had 2 scheduled tasks without username/passwords which ran quite
    >> happily for a time, then something happened and I got the same error
    >> you describe.
    >>
    >> One way to solve it was to enter a password for the current user (in
    >> Control Panel, user accounts) - nuisance if you don't want to enter a
    >> password, then enter this user/password combo in scheduled tasks.
    >>
    >> I also managed to delete the task, then recreate it again with no
    >> user/password, and get it to run. This was a bit tricky and I'm not
    >> quite sure how I did it.
    >>
    >> jd

    >
    > Excuse piggy-back, can't see OP.
    >
    > After some system changes, permissions get changed to "Jobs" run in Scheduled
    > Tasks.
    > The simplest way of getting the jobs to activate again, is to:-
    > Right click the task and choose Properties.
    > Click on the Settings tab.
    > Select and then deselect any one of the boxes and click Apply then OK.
    > Your task should now Run normally again.


    You may find it necessary to select a box, click apply, deselect that box and
    then click apply again before OK.
    Brian H¹©, Oct 10, 2003
    #7
  8. David

    buddymags

    Joined:
    Jan 22, 2009
    Messages:
    1
    Here's an easy fix

    If you don't have a password created in control panel, user accounts, Computer Administrator, create one. Don't worry we'll work around it in a minute.

    Schedule your task, leave the default username of %COMPUTERNAME%/Compaq_Administrator in the username field. In the paswword field, enter the password you created in user accounts.

    The task should run, but wait, now you have to type in a password every time you restart the computer!! That sucks!!

    Here is the workaround. It's call autologin, it takes some registry editing but don't worry it's a piece of cake!! Read this, it only takes a couple of minutes and it enters the logon password for you.

    You can use Registry Editor to add your log on information. To do this, follow these steps:
    Click Start, click Run, type regedit, and then click OK.
    Locate the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    Using your account name and password, double-click the DefaultUserName entry, type your user name, and then click OK.
    Double-click the DefaultPassword entry, type your password under the value data box, and then click OK.

    If there is no DefaultPassword value, create the value. To do this, follow these steps:
    In Registry Editor, click Edit, click New, and then click String Value.
    Type DefaultPassword as the value name, and then press ENTER.
    Double-click the newly created key, and then type your password in the Value Data box.
    If no DefaultPassword string is specified, Windows XP automatically changes the value of the AutoAdminLogon registry key from 1 (true) to 0 (false) to turn off the AutoAdminLogon feature.
    Double-click the AutoAdminLogon entry, type 1 in the Value Data box, and then click OK.

    If there is no AutoAdminLogon entry, create the entry. To do this, follow these steps:
    In Registry Editor, click Edit, click New, and then click String Value.
    Type AutoAdminLogon as the value name, and then press ENTER.
    Double-click the newly created key, and then type 1 in the Value Data box.
    Quit Registry Editor.
    Click Start, click Restart, and then click OK.
    After your computer restarts and Windows XP starts, you can log on automatically.

    If you want to bypass the automatic logon to log on as a different user, hold down the SHIFT key after you log off or after Windows XP restarts. Note that this procedure applies only to the first logon. To enforce this setting for future logoffs, the administrator must set the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

    Value:ForceAutoLogon
    Type: REG_SZ
    Data: 1
    You can also use turn on automatic logon without editing the registry in Microsoft Windows XP Home Edition and in Microsoft Windows XP Professional on a computer that is not joined to a domain. To do this, follow these steps:
    Click Start, and then click Run.
    In the Open box, type control userpasswords2, and then click OK.

    Note When users try to display help information in the User Accounts window in Windows XP Home Edition, the help information is not displayed. Additionally, users receive the following error message:
    Cannot find the Drive:\Windows\System32\users.hlp Help file. Check to see that the file exists on your hard disk drive. If it does not exist, you must reinstall it.
    Clear the "Users must enter a user name and password to use this computer" check box, and then click Apply.
    In the Automatically Log On window, type the password in the Password box, and then retype the password in the Confirm Password box.
    Click OK to close the Automatically Log On window, and then click OK to close the User Accounts window.

    --------------------------------------------------------------------------------

    APPLIES TO
    Microsoft Windows XP Home Edition
    Microsoft Windows XP Professional
    Microsoft Windows XP Professional x64 Edition

    Info supplied from
    support.microsoft.com/default.aspx?scid=kb;en-us;315231
    buddymags, Jan 22, 2009
    #8
  9. David

    rk_garg

    Joined:
    Feb 10, 2009
    Messages:
    1
    Click on RUN tab
    select "Run only if logged ON"
    Apply
    Now you are OK. No need to enter password.
    rk_garg, Feb 10, 2009
    #9
  10. David

    babyoxide

    Joined:
    Nov 10, 2009
    Messages:
    1
    er i run into the same problem only few minutes later i found a solution to it

    under the properties of the task ... click / tick the option RUN ONLY when log on ... this removes the need for the password...

    if u nvr had a password even as admin, you gonna be logged on anyway so it works perfectly fine..
    babyoxide, Nov 10, 2009
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. rtdos \(\)

    windows xp home edition task scheduler problems

    rtdos \(\), Jul 15, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    545
    rtdos \(\)
    Jul 15, 2003
  2. David

    Windows Task Scheduler

    David, Oct 7, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    490
    David
    Oct 7, 2003
  3. =?ISO-8859-1?Q?Brian_H=B9=A9?=

    Re: Task Scheduler problem/question

    =?ISO-8859-1?Q?Brian_H=B9=A9?=, Jan 13, 2006, in forum: Computer Support
    Replies:
    3
    Views:
    452
    Kryspin Pichler
    Jan 13, 2006
  4. akashmonu

    Task Scheduler problem

    akashmonu, Aug 14, 2008, in forum: Software
    Replies:
    0
    Views:
    752
    akashmonu
    Aug 14, 2008
  5. Richard
    Replies:
    10
    Views:
    1,812
    Flatus Ohlfahrt
    Dec 7, 2009
Loading...

Share This Page