Windows Service does not start on reboot

Discussion in 'Windows 64bit' started by Charlie Russel - MVP, Sep 16, 2008.

  1. Try setting the service for delayed automatic start. (that's a new option in
    Server 2k8.) You're likely running into a timing issue.

    That being said, the service needs to be a _service_, with no console or
    active user logon required. But I'm assuming here that you've met that
    requirement and it's a real service.

    --
    Charlie.
    http://msmvps.com/blogs/xperts64
    http://mvp.support.microsoft.com/profile/charlie.russel

    "Usman Jamil" <> wrote in message
    news:utKD2w$...
    > Hi
    >
    > I'm running domain controller and I have a service that I want to run
    > under a particular active directory user. The service gets started from
    > SCM if I start it. But it does not start automatically on a reboot and the
    > error logged in the event viewer is
    >
    > The service did not start due to a logon failure
    >
    > I've rechecked the username, its password. I've also granted it "Log on as
    > Service" rights. I dont know why does it happen only when the system
    > reboots. Otherwise once you log on to system and manually start it, it
    > gives no error.
    >
    > P.S I'm running a 64 bit Windows 2008 machine.
    >
    > Regards
    >
    > Usman
    >
    Charlie Russel - MVP, Sep 16, 2008
    #1
    1. Advertising

  2. Charlie Russel - MVP

    Usman Jamil Guest

    Hi

    I'm running domain controller and I have a service that I want to run under
    a particular active directory user. The service gets started from SCM if I
    start it. But it does not start automatically on a reboot and the error
    logged in the event viewer is

    The service did not start due to a logon failure

    I've rechecked the username, its password. I've also granted it "Log on as
    Service" rights. I dont know why does it happen only when the system
    reboots. Otherwise once you log on to system and manually start it, it gives
    no error.

    P.S I'm running a 64 bit Windows 2008 machine.

    Regards

    Usman
    Usman Jamil, Sep 16, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Darren Green
    Replies:
    1
    Views:
    899
    Walter Roberson
    Mar 14, 2006
  2. =?Utf-8?B?amd3YWxsYWNlMw==?=

    Wireless connection does not work unless I reboot

    =?Utf-8?B?amd3YWxsYWNlMw==?=, Jul 26, 2006, in forum: Wireless Networking
    Replies:
    1
    Views:
    636
    Ryan Younger
    Aug 5, 2006
  3. sean

    PC does not start and does not turn off

    sean, Dec 27, 2006, in forum: Computer Support
    Replies:
    3
    Views:
    476
  4. =?Utf-8?B?Tmlja04=?=

    i8042prt service does not start

    =?Utf-8?B?Tmlja04=?=, Oct 8, 2005, in forum: Windows 64bit
    Replies:
    0
    Views:
    1,914
    =?Utf-8?B?Tmlja04=?=
    Oct 8, 2005
  5. Lawrence D'Oliveiro

    Reboot, reboot, reboot

    Lawrence D'Oliveiro, Mar 6, 2009, in forum: NZ Computing
    Replies:
    12
    Views:
    904
    Lawrence D'Oliveiro
    Mar 7, 2009
Loading...

Share This Page