Why trunk does not work?

Discussion in 'Cisco' started by Vitor Flausino, Feb 28, 2005.

  1. Hello all!
    What is missing?

    I want to connect two Catalys 2950 in a trunk mode. The connection is
    made using port 48 from switch LISAN017 and port 20 of switch LISAN006.

    Here is the configuration for switch LISAN017

    LISAN017#show interface FastEthernet 0/48 switchport
    Name: Fa0/48
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 2 (interna)
    Voice VLAN: none
    Administrative private-vlan host-association: none
    Administrative private-vlan mapping: none
    Administrative private-vlan trunk native VLAN: none
    Administrative private-vlan trunk encapsulation: dot1q
    Administrative private-vlan trunk normal VLANs: none
    Administrative private-vlan trunk private VLANs: none
    Operational private-vlan: none
    Trunking VLANs Enabled: 2,100
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL
    Protected: false
    Appliance trust: none


    LISAN017#show interfaces trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/48 on 802.1q trunking 2
    Po1 on 802.1q trunking 2

    Port Vlans allowed on trunk
    Fa0/48 2,100
    Po1 none

    Port Vlans allowed and active in management domain
    Fa0/48 2,100
    Po1 none

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/48 none
    Po1 none


    LISAN017#show interface Vlan 2
    Vlan2 is up, line protocol is up
    Hardware is CPU Interface, address is 0012.d967.b340 (bia 0012.d967.b340)
    Internet address is 57.227.235.89/23
    MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 1d18h, output never, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 1000 bits/sec, 2 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    432877 packets input, 32298093 bytes, 0 no buffer
    Received 247647 broadcasts (0 IP multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 225092 ignored
    29637 packets output, 2253056 bytes, 0 underruns
    0 output errors, 2 interface resets
    0 output buffer failures, 0 output buffers swapped out


    And for switch LISAN006


    LISAN006#show interface FastEthernet 0/20 switchport
    Name: Fa0/20
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 2 (interna)
    Voice VLAN: none
    Administrative private-vlan host-association: none
    Administrative private-vlan mapping: none
    Administrative private-vlan trunk native VLAN: none
    Administrative private-vlan trunk encapsulation: dot1q
    Administrative private-vlan trunk normal VLANs: none
    Administrative private-vlan trunk private VLANs: none
    Operational private-vlan: none
    Trunking VLANs Enabled: 2,100
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL
    Protected: false
    Appliance trust: none

    LISAN006#show interfaces trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/20 on 802.1q trunking 2
    Po1 on 802.1q trunking 2

    Port Vlans allowed on trunk
    Fa0/20 2,100
    Po1 none

    Port Vlans allowed and active in management domain
    Fa0/20 2,100
    Po1 none

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/20 2,100
    Po1 none

    LISAN006#show interface Vlan 2
    Vlan2 is up, line protocol is up
    Hardware is CPU Interface, address is 000f.2479.d8c0 (bia 000f.2479.d8c0)
    Internet address is 57.227.235.88/23
    MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:00, output never, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 4000 bits/sec, 6 packets/sec
    5 minute output rate 9000 bits/sec, 8 packets/sec
    966048 packets input, 75123372 bytes, 0 no buffer
    Received 256341 broadcasts (0 IP multicast)
    0 runts, 0 giants, 13 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    1460405 packets output, 124633446 bytes, 0 underruns
    0 output errors, 1 interface resets
    0 output buffer failures, 0 output buffers swapped out


    Both ligths are grenn and blinking.

    I'm able to ping LISAN006 but not LISAN017. WHY????

    Best regards and thaknx,
    -vcf
     
    Vitor Flausino, Feb 28, 2005
    #1
    1. Advertising

  2. Vitor Flausino

    Guest

    What does your VTP Configuration look like?
    Can you post the show run pls.
     
    , Feb 28, 2005
    #2
    1. Advertising

  3. wrote:
    > What does your VTP Configuration look like?
    > Can you post the show run pls.
    >


    here is the show run of LISAN0017


    Building configuration...

    Current configuration : 4396 bytes
    !
    ! Last configuration change at 09:38:46 UTC Mon Feb 28 2005
    ! NVRAM config last updated at 09:39:20 UTC Mon Feb 28 2005
    !
    version 12.1
    no service pad
    service timestamps debug datetime
    service timestamps log datetime
    service password-encryption
    no service dhcp
    !
    hostname LISAN017
    !
    no logging monitor
    enable secret 5 $1$favU$cKgRu5OMeBP.sM72IsaKs/
    enable password 7 01100F175804
    !
    ip subnet-zero
    !
    ip domain-name pga.pt
    ip name-server 57.227.234.35
    ip name-server 10.27.2.2
    !
    !
    spanning-tree mode mst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    no spanning-tree vlan 1-2,100
    !
    spanning-tree mst configuration
    name PGA
    !
    !
    !
    !
    !
    interface Port-channel1
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    spanning-tree portfast
    !
    interface FastEthernet0/1
    switchport access vlan 2
    !
    interface FastEthernet0/2
    switchport access vlan 2
    !
    interface FastEthernet0/3
    switchport access vlan 2
    !
    interface FastEthernet0/4
    switchport access vlan 2
    !
    interface FastEthernet0/5
    switchport access vlan 2
    !
    interface FastEthernet0/6
    switchport access vlan 2
    !
    interface FastEthernet0/7
    switchport access vlan 2
    !
    interface FastEthernet0/8
    switchport access vlan 2
    !
    interface FastEthernet0/9
    switchport access vlan 2
    !
    interface FastEthernet0/10
    switchport access vlan 2
    switchport mode access
    switchport nonegotiate
    !
    interface FastEthernet0/11
    switchport access vlan 2
    !
    interface FastEthernet0/12
    switchport access vlan 2
    !
    interface FastEthernet0/13
    switchport access vlan 2
    !
    interface FastEthernet0/14
    switchport access vlan 2
    !
    interface FastEthernet0/15
    switchport access vlan 2
    !
    interface FastEthernet0/16
    switchport access vlan 2
    !
    interface FastEthernet0/17
    switchport access vlan 100
    !
    interface FastEthernet0/18
    switchport access vlan 100
    !
    interface FastEthernet0/19
    switchport access vlan 100
    !
    interface FastEthernet0/20
    switchport access vlan 100
    !
    interface FastEthernet0/21
    switchport access vlan 100
    !
    interface FastEthernet0/22
    switchport access vlan 100
    !
    interface FastEthernet0/23
    switchport access vlan 100
    !
    interface FastEthernet0/24
    switchport access vlan 100
    !
    interface FastEthernet0/25
    switchport access vlan 100
    !
    interface FastEthernet0/26
    switchport access vlan 100
    !
    interface FastEthernet0/27
    switchport access vlan 100
    !
    interface FastEthernet0/28
    switchport access vlan 100
    !
    interface FastEthernet0/29
    switchport access vlan 100
    !
    interface FastEthernet0/30
    switchport access vlan 100
    !
    interface FastEthernet0/31
    switchport access vlan 100
    !
    interface FastEthernet0/32
    switchport access vlan 100
    !
    interface FastEthernet0/33
    !
    interface FastEthernet0/34
    !
    interface FastEthernet0/35
    !
    interface FastEthernet0/36
    !
    interface FastEthernet0/37
    !
    interface FastEthernet0/38
    !
    interface FastEthernet0/39
    !
    interface FastEthernet0/40
    !
    interface FastEthernet0/41
    !
    interface FastEthernet0/42
    !
    interface FastEthernet0/43
    !
    interface FastEthernet0/44
    !
    interface FastEthernet0/45
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    channel-group 1 mode desirable
    spanning-tree portfast
    !
    interface FastEthernet0/46
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    channel-group 1 mode desirable
    spanning-tree portfast
    !
    interface FastEthernet0/47
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    channel-group 1 mode desirable
    spanning-tree portfast
    !
    interface FastEthernet0/48
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100
    switchport mode trunk
    spanning-tree portfast
    !
    interface GigabitEthernet0/1
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
    no ip address
    no ip route-cache
    shutdown
    !
    interface Vlan2
    ip address 57.227.235.89 255.255.254.0
    no ip route-cache
    !
    interface Vlan100
    no ip address
    no ip route-cache
    shutdown
    !
    ip default-gateway 57.227.235.254
    ip http server
    snmp-server community public RO
    !
    line con 0
    line vty 0 4
    password 7 110A1016141D
    login
    line vty 5 15
    password 7 00071A150754
    login
    !
    ntp clock-period 17179871
    ntp server 10.27.2.7
    ntp server 57.227.234.35
    !
    end




    and LISAN006


    LISAN006#show run
    Building configuration...

    Current configuration : 3555 bytes
    !
    ! Last configuration change at 09:36:03 UTC Mon Feb 28 2005
    ! NVRAM config last updated at 09:36:46 UTC Mon Feb 28 2005
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname LISAN006
    !
    enable secret 5 $1$EzQX$acdBnoMmZo/X0idASOGMz/
    !
    ip subnet-zero
    !
    ip domain-name pga.pt
    ip name-server 57.227.234.35
    ip name-server 10.27.2.2
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    !
    !
    interface Port-channel1
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    shutdown
    flowcontrol send off
    spanning-tree portfast
    !
    interface FastEthernet0/1
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/2
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/3
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/4
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/5
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/6
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/7
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/8
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/9
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/10
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/11
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/12
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/13
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/14
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/15
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/16
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/17
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    channel-group 1 mode desirable
    spanning-tree portfast
    !
    interface FastEthernet0/18
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    channel-group 1 mode desirable
    spanning-tree portfast
    !
    interface FastEthernet0/19
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100,1002-1005
    switchport mode trunk
    switchport nonegotiate
    shutdown
    channel-group 1 mode desirable
    spanning-tree portfast
    !
    interface FastEthernet0/20
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,100
    switchport mode trunk
    spanning-tree portfast
    !
    interface FastEthernet0/21
    switchport access vlan 4
    spanning-tree portfast
    !
    interface FastEthernet0/22
    switchport access vlan 4
    spanning-tree portfast
    !
    interface FastEthernet0/23
    switchport access vlan 4
    spanning-tree portfast
    !
    interface FastEthernet0/24
    switchport access vlan 4
    spanning-tree portfast
    !
    interface Vlan1
    no ip address
    no ip route-cache
    shutdown
    !
    interface Vlan2
    ip address 57.227.235.88 255.255.254.0
    no ip route-cache
    !
    interface Vlan100
    no ip address
    no ip route-cache
    shutdown
    !
    ip default-gateway 57.227.235.254
    ip http server
    !
    snmp-server community public RO
    !
    line con 0
    password cisco
    login
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    ntp clock-period 17180043
    ntp server 10.27.2.7
    ntp server 57.227.234.35
    end


    Thankx,
    -vcf
     
    Vitor Flausino, Feb 28, 2005
    #3
  4. Vitor Flausino

    Kevin Widner Guest

    My hunch thus far....


    LISAN017#show interfaces trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/48 on 802.1q trunking 2
    Po1 on 802.1q trunking 2

    Port Vlans allowed on trunk
    Fa0/48 2,100
    Po1 none

    Port Vlans allowed and active in management domain
    Fa0/48 2,100
    Po1 none

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/48 none
    Po1 none


    >From your output, it may be a spanning-tree issue, since it looks as if

    the switches understand the config, but the vlans have not gone
    forwarding over the trunk. Post a "show spanning-tree active", and a
    diagram of how you have the two connected. Also, have you thought about
    removing the portfast command and explicitly stating the trunk
    encapsulation? "switchport trunk encapsulation dot1q" Not saying
    these last two things are your problem, but it would seem wise.
     
    Kevin Widner, Feb 28, 2005
    #4
  5. Vitor Flausino

    Eric Louie Guest

    One of them needs to be a server, the other a client. Just defining them on
    a port does not make them "exist", that does not define their
    characteristics.

    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a008007e91e.html

    Eric

    "Vitor Flausino" <> wrote in message
    news:42231131$0$3682$...
    > Hello all!
    > What is missing?
    >
    > I want to connect two Catalys 2950 in a trunk mode. The connection is made
    > using port 48 from switch LISAN017 and port 20 of switch LISAN006.
    >
    > Here is the configuration for switch LISAN017
    >
    > LISAN017#show interface FastEthernet 0/48 switchport
    > Name: Fa0/48
    > Switchport: Enabled
    > Administrative Mode: trunk
    > Operational Mode: trunk
    > Administrative Trunking Encapsulation: dot1q
    > Operational Trunking Encapsulation: dot1q
    > Negotiation of Trunking: On
    > Access Mode VLAN: 1 (default)
    > Trunking Native Mode VLAN: 2 (interna)
    > Voice VLAN: none
    > Administrative private-vlan host-association: none
    > Administrative private-vlan mapping: none
    > Administrative private-vlan trunk native VLAN: none
    > Administrative private-vlan trunk encapsulation: dot1q
    > Administrative private-vlan trunk normal VLANs: none
    > Administrative private-vlan trunk private VLANs: none
    > Operational private-vlan: none
    > Trunking VLANs Enabled: 2,100
    > Pruning VLANs Enabled: 2-1001
    > Capture Mode Disabled
    > Capture VLANs Allowed: ALL
    > Protected: false
    > Appliance trust: none
    >
    >
    > LISAN017#show interfaces trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/48 on 802.1q trunking 2
    > Po1 on 802.1q trunking 2
    >
    > Port Vlans allowed on trunk
    > Fa0/48 2,100
    > Po1 none
    >
    > Port Vlans allowed and active in management domain
    > Fa0/48 2,100
    > Po1 none
    >
    > Port Vlans in spanning tree forwarding state and not pruned
    > Fa0/48 none
    > Po1 none
    >
    >
    > LISAN017#show interface Vlan 2
    > Vlan2 is up, line protocol is up
    > Hardware is CPU Interface, address is 0012.d967.b340 (bia
    > 0012.d967.b340)
    > Internet address is 57.227.235.89/23
    > MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input 1d18h, output never, output hang never
    > Last clearing of "show interface" counters never
    > Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    > Queueing strategy: fifo
    > Output queue: 0/40 (size/max)
    > 5 minute input rate 1000 bits/sec, 2 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 432877 packets input, 32298093 bytes, 0 no buffer
    > Received 247647 broadcasts (0 IP multicast)
    > 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 225092 ignored
    > 29637 packets output, 2253056 bytes, 0 underruns
    > 0 output errors, 2 interface resets
    > 0 output buffer failures, 0 output buffers swapped out
    >
    >
    > And for switch LISAN006
    >
    >
    > LISAN006#show interface FastEthernet 0/20 switchport
    > Name: Fa0/20
    > Switchport: Enabled
    > Administrative Mode: trunk
    > Operational Mode: trunk
    > Administrative Trunking Encapsulation: dot1q
    > Operational Trunking Encapsulation: dot1q
    > Negotiation of Trunking: On
    > Access Mode VLAN: 1 (default)
    > Trunking Native Mode VLAN: 2 (interna)
    > Voice VLAN: none
    > Administrative private-vlan host-association: none
    > Administrative private-vlan mapping: none
    > Administrative private-vlan trunk native VLAN: none
    > Administrative private-vlan trunk encapsulation: dot1q
    > Administrative private-vlan trunk normal VLANs: none
    > Administrative private-vlan trunk private VLANs: none
    > Operational private-vlan: none
    > Trunking VLANs Enabled: 2,100
    > Pruning VLANs Enabled: 2-1001
    > Capture Mode Disabled
    > Capture VLANs Allowed: ALL
    > Protected: false
    > Appliance trust: none
    >
    > LISAN006#show interfaces trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/20 on 802.1q trunking 2
    > Po1 on 802.1q trunking 2
    >
    > Port Vlans allowed on trunk
    > Fa0/20 2,100
    > Po1 none
    >
    > Port Vlans allowed and active in management domain
    > Fa0/20 2,100
    > Po1 none
    >
    > Port Vlans in spanning tree forwarding state and not pruned
    > Fa0/20 2,100
    > Po1 none
    >
    > LISAN006#show interface Vlan 2
    > Vlan2 is up, line protocol is up
    > Hardware is CPU Interface, address is 000f.2479.d8c0 (bia
    > 000f.2479.d8c0)
    > Internet address is 57.227.235.88/23
    > MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input 00:00:00, output never, output hang never
    > Last clearing of "show interface" counters never
    > Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    > Queueing strategy: fifo
    > Output queue: 0/40 (size/max)
    > 5 minute input rate 4000 bits/sec, 6 packets/sec
    > 5 minute output rate 9000 bits/sec, 8 packets/sec
    > 966048 packets input, 75123372 bytes, 0 no buffer
    > Received 256341 broadcasts (0 IP multicast)
    > 0 runts, 0 giants, 13 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 1460405 packets output, 124633446 bytes, 0 underruns
    > 0 output errors, 1 interface resets
    > 0 output buffer failures, 0 output buffers swapped out
    >
    >
    > Both ligths are grenn and blinking.
    >
    > I'm able to ping LISAN006 but not LISAN017. WHY????
    >
    > Best regards and thaknx,
    > -vcf
     
    Eric Louie, Mar 1, 2005
    #5
  6. I just need to do that if I want to publich the vlan configuration...


    When a switch is in VTP server mode, you can change the VLAN
    configuration and have it propagated throughout the network.

    Thanks any way for the tip...
    -vcf



    Eric Louie wrote:
    > One of them needs to be a server, the other a client. Just defining them on
    > a port does not make them "exist", that does not define their
    > characteristics.
    >
    > http://www.cisco.com/en/US/products...figuration_guide_chapter09186a008007e91e.html
    >
    > Eric
    >
    > "Vitor Flausino" <> wrote in message
    > news:42231131$0$3682$...
    >
    >>Hello all!
    >>What is missing?
    >>
    >>I want to connect two Catalys 2950 in a trunk mode. The connection is made
    >>using port 48 from switch LISAN017 and port 20 of switch LISAN006.
    >>
    >>Here is the configuration for switch LISAN017
    >>
    >>LISAN017#show interface FastEthernet 0/48 switchport
    >>Name: Fa0/48
    >>Switchport: Enabled
    >>Administrative Mode: trunk
    >>Operational Mode: trunk
    >>Administrative Trunking Encapsulation: dot1q
    >>Operational Trunking Encapsulation: dot1q
    >>Negotiation of Trunking: On
    >>Access Mode VLAN: 1 (default)
    >>Trunking Native Mode VLAN: 2 (interna)
    >>Voice VLAN: none
    >>Administrative private-vlan host-association: none
    >>Administrative private-vlan mapping: none
    >>Administrative private-vlan trunk native VLAN: none
    >>Administrative private-vlan trunk encapsulation: dot1q
    >>Administrative private-vlan trunk normal VLANs: none
    >>Administrative private-vlan trunk private VLANs: none
    >>Operational private-vlan: none
    >>Trunking VLANs Enabled: 2,100
    >>Pruning VLANs Enabled: 2-1001
    >>Capture Mode Disabled
    >>Capture VLANs Allowed: ALL
    >>Protected: false
    >>Appliance trust: none
    >>
    >>
    >>LISAN017#show interfaces trunk
    >>
    >>Port Mode Encapsulation Status Native vlan
    >>Fa0/48 on 802.1q trunking 2
    >>Po1 on 802.1q trunking 2
    >>
    >>Port Vlans allowed on trunk
    >>Fa0/48 2,100
    >>Po1 none
    >>
    >>Port Vlans allowed and active in management domain
    >>Fa0/48 2,100
    >>Po1 none
    >>
    >>Port Vlans in spanning tree forwarding state and not pruned
    >>Fa0/48 none
    >>Po1 none
    >>
    >>
    >>LISAN017#show interface Vlan 2
    >>Vlan2 is up, line protocol is up
    >> Hardware is CPU Interface, address is 0012.d967.b340 (bia
    >>0012.d967.b340)
    >> Internet address is 57.227.235.89/23
    >> MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    >> reliability 255/255, txload 1/255, rxload 1/255
    >> Encapsulation ARPA, loopback not set
    >> ARP type: ARPA, ARP Timeout 04:00:00
    >> Last input 1d18h, output never, output hang never
    >> Last clearing of "show interface" counters never
    >> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    >> Queueing strategy: fifo
    >> Output queue: 0/40 (size/max)
    >> 5 minute input rate 1000 bits/sec, 2 packets/sec
    >> 5 minute output rate 0 bits/sec, 0 packets/sec
    >> 432877 packets input, 32298093 bytes, 0 no buffer
    >> Received 247647 broadcasts (0 IP multicast)
    >> 0 runts, 0 giants, 0 throttles
    >> 0 input errors, 0 CRC, 0 frame, 0 overrun, 225092 ignored
    >> 29637 packets output, 2253056 bytes, 0 underruns
    >> 0 output errors, 2 interface resets
    >> 0 output buffer failures, 0 output buffers swapped out
    >>
    >>
    >>And for switch LISAN006
    >>
    >>
    >>LISAN006#show interface FastEthernet 0/20 switchport
    >>Name: Fa0/20
    >>Switchport: Enabled
    >>Administrative Mode: trunk
    >>Operational Mode: trunk
    >>Administrative Trunking Encapsulation: dot1q
    >>Operational Trunking Encapsulation: dot1q
    >>Negotiation of Trunking: On
    >>Access Mode VLAN: 1 (default)
    >>Trunking Native Mode VLAN: 2 (interna)
    >>Voice VLAN: none
    >>Administrative private-vlan host-association: none
    >>Administrative private-vlan mapping: none
    >>Administrative private-vlan trunk native VLAN: none
    >>Administrative private-vlan trunk encapsulation: dot1q
    >>Administrative private-vlan trunk normal VLANs: none
    >>Administrative private-vlan trunk private VLANs: none
    >>Operational private-vlan: none
    >>Trunking VLANs Enabled: 2,100
    >>Pruning VLANs Enabled: 2-1001
    >>Capture Mode Disabled
    >>Capture VLANs Allowed: ALL
    >>Protected: false
    >>Appliance trust: none
    >>
    >>LISAN006#show interfaces trunk
    >>
    >>Port Mode Encapsulation Status Native vlan
    >>Fa0/20 on 802.1q trunking 2
    >>Po1 on 802.1q trunking 2
    >>
    >>Port Vlans allowed on trunk
    >>Fa0/20 2,100
    >>Po1 none
    >>
    >>Port Vlans allowed and active in management domain
    >>Fa0/20 2,100
    >>Po1 none
    >>
    >>Port Vlans in spanning tree forwarding state and not pruned
    >>Fa0/20 2,100
    >>Po1 none
    >>
    >>LISAN006#show interface Vlan 2
    >>Vlan2 is up, line protocol is up
    >> Hardware is CPU Interface, address is 000f.2479.d8c0 (bia
    >>000f.2479.d8c0)
    >> Internet address is 57.227.235.88/23
    >> MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    >> reliability 255/255, txload 1/255, rxload 1/255
    >> Encapsulation ARPA, loopback not set
    >> ARP type: ARPA, ARP Timeout 04:00:00
    >> Last input 00:00:00, output never, output hang never
    >> Last clearing of "show interface" counters never
    >> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    >> Queueing strategy: fifo
    >> Output queue: 0/40 (size/max)
    >> 5 minute input rate 4000 bits/sec, 6 packets/sec
    >> 5 minute output rate 9000 bits/sec, 8 packets/sec
    >> 966048 packets input, 75123372 bytes, 0 no buffer
    >> Received 256341 broadcasts (0 IP multicast)
    >> 0 runts, 0 giants, 13 throttles
    >> 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    >> 1460405 packets output, 124633446 bytes, 0 underruns
    >> 0 output errors, 1 interface resets
    >> 0 output buffer failures, 0 output buffers swapped out
    >>
    >>
    >>Both ligths are grenn and blinking.
    >>
    >>I'm able to ping LISAN006 but not LISAN017. WHY????
    >>
    >>Best regards and thaknx,
    >>-vcf

    >
    >
    >
     
    Vitor Flausino, Mar 1, 2005
    #6
  7. Here goes the information.....

    The switchs are directly connected.

    _____________ __________ __________
    |My Computer|---(other switchs)-----|LISAN017|-------|LISAN006|
    ------------- ---------- ----------


    LISAN017#show spanning-tree active

    MST00
    Spanning tree enabled protocol mstp
    Root ID Priority 32768
    Address 0012.d967.b340
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32768 (priority 32768 sys-id-ext 0)
    Address 0012.d967.b340
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Interface Role Sts Cost Prio.Nbr Type
    ---------------- ---- --- --------- --------
    --------------------------------
    Fa0/48 Desg BKN*200000 128.48 P2p Bound(PVST) *ROOT_Inc


    --------------------------------------------------------------------------------------------------

    LISAN006#show spanning-tree active

    VLAN0002
    Spanning tree enabled protocol ieee
    Root ID Priority 20481
    Address 000f.8fe5.ac00
    Cost 20023
    Port 1 (FastEthernet0/1)
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32770 (priority 32768 sys-id-ext 2)
    Address 000f.2479.d8c0
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 300

    Interface Role Sts Cost Prio.Nbr Type
    ---------------- ---- --- --------- --------
    --------------------------------
    Fa0/1 Root FWD 19 128.1 P2p
    Fa0/4 Desg FWD 19 128.4 Edge P2p
    Fa0/5 Desg FWD 19 128.5 Edge P2p
    Fa0/6 Desg FWD 19 128.6 Edge P2p
    Fa0/7 Desg FWD 19 128.7 Edge P2p
    Fa0/9 Desg FWD 19 128.9 Edge P2p
    Fa0/20 Desg FWD 19 128.20 P2p


    VLAN0004
    Spanning tree enabled protocol ieee
    Root ID Priority 32772
    Address 000f.2479.d8c0
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32772 (priority 32768 sys-id-ext 4)
    Address 000f.2479.d8c0
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 300

    Interface Role Sts Cost Prio.Nbr Type
    ---------------- ---- --- --------- --------
    --------------------------------
    Fa0/21 Desg FWD 19 128.21 Edge P2p
    Fa0/22 Desg FWD 19 128.22 Edge P2p
    Fa0/24 Desg FWD 19 128.24 Edge P2p


    VLAN0100
    Spanning tree enabled protocol ieee
    Root ID Priority 32868
    Address 000f.2479.d8c0
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32868 (priority 32768 sys-id-ext 100)
    Address 000f.2479.d8c0
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 300

    Interface Role Sts Cost Prio.Nbr Type
    ---------------- ---- --- --------- --------
    --------------------------------
    Fa0/20 Desg FWD 19 128.20 P2p


    Kevin Widner wrote:
    > My hunch thus far....
    >
    >
    > LISAN017#show interfaces trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/48 on 802.1q trunking 2
    > Po1 on 802.1q trunking 2
    >
    > Port Vlans allowed on trunk
    > Fa0/48 2,100
    > Po1 none
    >
    > Port Vlans allowed and active in management domain
    > Fa0/48 2,100
    > Po1 none
    >
    > Port Vlans in spanning tree forwarding state and not pruned
    > Fa0/48 none
    > Po1 none
    >
    >
    >>From your output, it may be a spanning-tree issue, since it looks as if

    > the switches understand the config, but the vlans have not gone
    > forwarding over the trunk. Post a "show spanning-tree active", and a
    > diagram of how you have the two connected. Also, have you thought about
    > removing the portfast command and explicitly stating the trunk
    > encapsulation? "switchport trunk encapsulation dot1q" Not saying
    > these last two things are your problem, but it would seem wise.
    >
     
    Vitor Flausino, Mar 1, 2005
    #7
  8. By the way....
    I tried to force the encapsulation to dot1q but I dont know how. I had
    already tried to give the command you sent but it seams that command is
    invalid...

    LISAN017(config-if)#switchport trunk ?
    allowed Set allowed VLAN characteristics when interface is in
    trunking mode
    native Set trunking native characteristics when interface is in
    trunking
    mode
    pruning Set pruning VLAN characteristics when interface is in
    trunking mode

    Thanks,
    -vcf

    Kevin Widner wrote:
    > My hunch thus far....
    >
    >
    > LISAN017#show interfaces trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/48 on 802.1q trunking 2
    > Po1 on 802.1q trunking 2
    >
    > Port Vlans allowed on trunk
    > Fa0/48 2,100
    > Po1 none
    >
    > Port Vlans allowed and active in management domain
    > Fa0/48 2,100
    > Po1 none
    >
    > Port Vlans in spanning tree forwarding state and not pruned
    > Fa0/48 none
    > Po1 none
    >
    >
    >>From your output, it may be a spanning-tree issue, since it looks as if

    > the switches understand the config, but the vlans have not gone
    > forwarding over the trunk. Post a "show spanning-tree active", and a
    > diagram of how you have the two connected. Also, have you thought about
    > removing the portfast command and explicitly stating the trunk
    > encapsulation? "switchport trunk encapsulation dot1q" Not saying
    > these last two things are your problem, but it would seem wise.
    >
     
    Vitor Flausino, Mar 1, 2005
    #8
  9. Found the problem!!!!!
    It was the STP. It was different on both switchs

    Thanks!!!!!

    Best regards,
    -vcf


    Vitor Flausino wrote:
    > By the way....
    > I tried to force the encapsulation to dot1q but I dont know how. I had
    > already tried to give the command you sent but it seams that command is
    > invalid...
    >
    > LISAN017(config-if)#switchport trunk ?
    > allowed Set allowed VLAN characteristics when interface is in
    > trunking mode
    > native Set trunking native characteristics when interface is in
    > trunking
    > mode
    > pruning Set pruning VLAN characteristics when interface is in
    > trunking mode
    >
    > Thanks,
    > -vcf
    >
    > Kevin Widner wrote:
    >
    >> My hunch thus far....
    >>
    >>
    >> LISAN017#show interfaces trunk
    >>
    >> Port Mode Encapsulation Status Native vlan
    >> Fa0/48 on 802.1q trunking 2
    >> Po1 on 802.1q trunking 2
    >>
    >> Port Vlans allowed on trunk
    >> Fa0/48 2,100
    >> Po1 none
    >>
    >> Port Vlans allowed and active in management domain
    >> Fa0/48 2,100
    >> Po1 none
    >>
    >> Port Vlans in spanning tree forwarding state and not pruned
    >> Fa0/48 none
    >> Po1 none
    >>
    >>
    >>> From your output, it may be a spanning-tree issue, since it looks as if

    >>
    >> the switches understand the config, but the vlans have not gone
    >> forwarding over the trunk. Post a "show spanning-tree active", and a
    >> diagram of how you have the two connected. Also, have you thought about
    >> removing the portfast command and explicitly stating the trunk
    >> encapsulation? "switchport trunk encapsulation dot1q" Not saying
    >> these last two things are your problem, but it would seem wise.
    >>
     
    Vitor Flausino, Mar 1, 2005
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tx2

    Why does this page not work?

    Tx2, Jul 7, 2004, in forum: Firefox
    Replies:
    4
    Views:
    400
    Grinder
    Jul 8, 2004
  2. Illusion

    Can't get trunk to work

    Illusion, Nov 26, 2003, in forum: Cisco
    Replies:
    6
    Views:
    4,695
    Andre Beck
    Dec 7, 2003
  3. prash
    Replies:
    0
    Views:
    468
    prash
    Sep 27, 2003
  4. Replies:
    1
    Views:
    738
    Jimmy
    Sep 11, 2005
  5. =?Utf-8?B?SkdQRw==?=

    Why my Windows Vista X86 does not work on AMD Athlon 64

    =?Utf-8?B?SkdQRw==?=, Aug 18, 2006, in forum: Windows 64bit
    Replies:
    5
    Views:
    359
    Dennis Pack x64, v64B2 \(5384\), OPP2007B2
    Aug 19, 2006
Loading...

Share This Page