Why must Firefox nag me and treat me like an idiot?

Discussion in 'Firefox' started by Janice P., Dec 31, 2006.

  1. Janice P.

    Janice P. Guest

    For the same reason as Microsoft, I suppose. Play to the
    computer-illiterate crowd and let the people with a little bit of savvy
    suffer, rather than simply offer a choice.

    Today's gripe is the "Security Warning" when I have entered information into
    a form on an encrypted page, and by clicking the button it will take me to
    an unencrypted page. Oh, no! "Although this page is encrypted, the
    information you have entered is to be sent over an unencrypted connection
    and could easily be read by a third party. Are you sure you want to
    continue sending this information?"

    My nag-zapper doesn't see this dialog so it won't close it for me. It comes
    up all the time, and I'm sick of it. I'm perfectly aware of where I stand
    on the pages at issue. But the nag dialog doesn't have the "Don't nag me
    about this anymore" tick box I crave so badly. No doubt, if I could ask
    why, the programmer would say "To protect you from your own stupid foolish
    forgetful self, silly!"

    Or maybe not. Whatever the case, I really want rid of this thing. I can't
    find anything that looks likely in about:config. I tried changing
    roaming.showInitialWarning to False, but it had no effect.

    Can anyone help?

    J.
     
    Janice P., Dec 31, 2006
    #1
    1. Advertising

  2. Janice P.

    Guest

    Janice P. wrote:
    > For the same reason as Microsoft, I suppose. Play to the
    > computer-illiterate crowd and let the people with a little bit of savvy
    > suffer, rather than simply offer a choice.
    >
    > Today's gripe is the "Security Warning" when I have entered information into
    > a form on an encrypted page, and by clicking the button it will take me to
    > an unencrypted page. Oh, no! "Although this page is encrypted, the
    > information you have entered is to be sent over an unencrypted connection
    > and could easily be read by a third party. Are you sure you want to
    > continue sending this information?"
    >
    > My nag-zapper doesn't see this dialog so it won't close it for me.


    what nag-zapper?


    > It comes
    > up all the time, and I'm sick of it. I'm perfectly aware of where I stand
    > on the pages at issue. But the nag dialog doesn't have the "Don't nag me
    > about this anymore" tick box I crave so badly. No doubt, if I could ask
    > why, the programmer would say "To protect you from your own stupid foolish
    > forgetful self, silly!"
    >


    there should be a check box? Mine did.

    > Or maybe not. Whatever the case, I really want rid of this thing. I can't
    > find anything that looks likely in about:config. I tried changing
    > roaming.showInitialWarning to False, but it had no effect.
    >
    > Can anyone help?
    >
    > J.


    you're looking at the wrong one. You need to set these to false:

    security.warn_entering_secure
    security.warn_entering_weak
    security.warn_leaving_secure
    security.warn_submit_insecure
    security.warn_viewing_mixed
     
    , Dec 31, 2006
    #2
    1. Advertising

  3. Janice P.

    Janice P. Guest

    Re: Re: Why must Firefox nag me and treat me like an idiot?

    On 31 Dec 2006 14:42:07 -0800, posted:

    Thank you for replying to help...

    >what nag-zapper?


    Buzof

    >there should be a check box? Mine did.


    Mine doesn't. Firefox 1.5.0.4

    >you're looking at the wrong one. You need to set these to false:
    >
    >security.warn_entering_secure
    >security.warn_entering_weak
    >security.warn_leaving_secure
    >security.warn_submit_insecure
    >security.warn_viewing_mixed


    They were all False already, except security.warn_entering_weak
    which I changed to False, but still it had no effect. I closed Firefox
    completely and reopened, and went back to the problem pages, and I still get
    the nag.

    Each of the above also had a second entry, with .show_once at the end.
    Those five were all true, so I changed all of them to False, so now all ten
    are False, and still it has no effect. I still get the nag.

    J.
     
    Janice P., Jan 1, 2007
    #3
  4. Janice P.

    Miller Guest

    *Janice P.* wrote on 01.01.07 11:17:
    > On 31 Dec 2006 14:42:07 -0800, posted:
    >
    > Thank you for replying to help...
    >
    >>what nag-zapper?

    >
    > Buzof
    >
    >>there should be a check box? Mine did.

    >
    > Mine doesn't. Firefox 1.5.0.4


    At least when you upgrade to FF 2.0 you'll find
    Tools -> Options -> Security -> Warning Messages..

    HTH, M.
     
    Miller, Jan 1, 2007
    #4
  5. Janice P.

    Guest

    Janice P. wrote:
    > and went back to the problem pages, and I still get
    > the nag.
    >


    then how about providing a link to those problem pages so someone can
    go and check them out?
     
    , Jan 1, 2007
    #5
  6. Janice P.

    Janice P. Guest

    Re: Re: Why must Firefox nag me and treat me like an idiot?

    On 1 Jan 2007 10:48:25 -0800,
    posted:

    >
    >Janice P. wrote:
    >> and went back to the problem pages, and I still get
    >> the nag.
    >>

    >
    >then how about providing a link to those problem pages so someone can
    >go and check them out?


    Sure. At deepdiscountdvd.com on the shopping cart page there is also a
    search box. When I fill in the search and click Go is when I get the nag,
    because I'm leaving the secure area and going out into the plain old web
    pages, I guess.

    J.
     
    Janice P., Jan 2, 2007
    #6
  7. Janice P.

    Janice P. Guest

    Re: Re: Why must Firefox nag me and treat me like an idiot?

    On Mon, 01 Jan 2007 11:29:04 +0100, Miller <> posted:

    >At least when you upgrade to FF 2.0 you'll find
    >Tools -> Options -> Security -> Warning Messages..


    I'm still so new to Firefox that I had hoped to acclimate a little better
    before tackling a big change, but I suppose I will bite the bullet and do
    the upgrade.

    J.
     
    Janice P., Jan 2, 2007
    #7
  8. On 01/02/2007 05:15 AM, Janice P. wrote:
    > On Mon, 01 Jan 2007 11:29:04 +0100, Miller <> posted:
    >
    >> At least when you upgrade to FF 2.0 you'll find
    >> Tools -> Options -> Security -> Warning Messages..

    >
    > I'm still so new to Firefox that I had hoped to acclimate a little better
    > before tackling a big change, but I suppose I will bite the bullet and do
    > the upgrade.
    >
    > J.
    >


    I don't think upgrading would make any difference in this case because
    I'm using FF 2.0, and the option to turn off that particular nag does
    not exist.

    I suggest using two tabs at www.deepdiscountdvd.com . One tab would
    contain the secure (https://) shopping cart page, and the other would be
    an insecure (http://) page used for browsing and searching the site.

    You might have to hit the refresh button from time to time in the
    shopping cart tab to get current information.

    BTW, the shopping cart page is insecure (http://) for me--probably
    because I don't have an account there; however, I can reproduce the
    problem by going to the login page and doing a search.


    --

    Windows Vista and your freedom in conflict:
    http://www.badvista.org/
     
    Mumia W. (on aioe), Jan 2, 2007
    #8
  9. Janice P.

    Janice P. Guest

    Re: Re: Why must Firefox nag me and treat me like an idiot?

    On Tue, 02 Jan 2007 06:56:19 -0600, "Mumia W. (on aioe)"
    <> posted:

    >I suggest using two tabs


    I don't think this would work for me even if I were willing to do it, mainly
    because I'd be on the "insecure" page and forget the other tab and go look
    at my cart and I'd be right back at square one.

    >I can reproduce the
    >problem by going to the login page and doing a search.


    Well thanks for caring enough to go actually visit the site and look for a
    solution!

    J.
     
    Janice P., Jan 2, 2007
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. graham

    Autocomplete nag

    graham, Nov 29, 2003, in forum: Computer Support
    Replies:
    1
    Views:
    551
  2. Getting rid of SP2 nag screen

    , Sep 30, 2004, in forum: Computer Support
    Replies:
    20
    Views:
    1,919
    Slacker
    Oct 2, 2004
  3. graham

    Nag box removal

    graham, Jan 15, 2005, in forum: Computer Support
    Replies:
    5
    Views:
    1,351
    nogeekatall
    Jan 16, 2005
  4. GraB

    Nag problem in XP

    GraB, Sep 12, 2004, in forum: NZ Computing
    Replies:
    4
    Views:
    388
  5. nutzel

    Disable Norton nag screen??

    nutzel, Feb 17, 2008, in forum: Computer Support
    Replies:
    15
    Views:
    4,719
    nutzel
    Feb 17, 2008
Loading...

Share This Page