Where are my High Speed USB 2.0 ports?

Discussion in 'Computer Information' started by John Richards, Feb 6, 2008.

  1. I have a "USB 2.0 HIGH-SPEED Front Bay Hub" with two ports connected to one
    of two spare USB 2.0 pin headers on the motherboard (also High Speed). The
    motherboard has two ports which appear on the back of the PC and are (I
    think) USB1.1 ports. Looking at Device Manager at Universal Serial Bus
    controllers, 4 USB Root Hubs are listed. The first three show 2 ports each
    (on the "Power" tab under properties) and the fourth one shows 6 ports.
    Also under Universal Serial Bus controllers, there are 4 Host controllers.
    The first three are designated "VIA Rev 5 or later USB Universal Host
    Controller" which I'm assuming relate to the first three USB Root Hubs and
    are USB 1.1. The fourth controller is designated "VIA USB Enhanced Host
    Controller" which I assume relates to the fourth USB Root Hub and is USB 2.0
    High Speed.
    John Richards, Feb 6, 2008
    #1
    1. Advertising

  2. Sorry! Didn't mean to send the unfinished post.

    I did do some more research and think I know what might be happening but
    have no idea why.

    I recently installed a USB 2.0 front bay hub and connected it to a USB 2.0
    pin header on the mother board (MSI KT3 Ultra2). When I plug a High-Speed
    USB 2.0 flash drive into one of the connectors on the front bay hub, a
    notice on the screen suggests that I connect the device to a High Speed USB
    2.0 Port and then offers a list of 6 available unused ports under the
    Enhanced Host Controller (USB 2.0) heading. When I look at Device Manager,
    it shows that the flash drive appears on a universal port. If I move the
    flash drive to one of the original USB connectors on the back of the PC, the
    flash drive appears on one of the 6 ports under the Enhanced Host
    Controller, yet when a USB 1.1 device is plugged into the same connector on
    the back, the device shows up on a universal port.

    While doing some research, I came across a FAQ
    http://www.everythingusb.com/usb2/faq.htm , which states; "The USB
    controller routes signals to the correct controller chip depending on how a
    device is recognized. Where a device is physically plugged in has no bearing
    on how it is routed. All ports on a USB 2.0 motherboard can host any USB
    devices at all as long as the system and devices are healthy." This
    statement seems to agree with what happens when a USB 1.1 or USB 2.0 device
    is plugged into the original rear connectors (they are "routed" to the
    appropriate "port").

    My problem, then, is that although the flash drive is correctly recognized
    as a USB 2.0 device, why isn't it just routed to one of the available USB
    2.0 ports (according to the notice on the screen) like it is when plugged
    into one of the rear connectors.

    Incidentally, the PC is running Windows XP SP2.

    Any ideas?

    John
    John Richards, Feb 6, 2008
    #2
    1. Advertising

  3. Depending on the age of your machine, the FRONT ports may or may not be USB
    1.0, and the rear ports are likely to be an add-on USB 2.0 card.

    If your machine has ANY USB 1.0 ports, then it must have an add-on card that
    plugs into a PCI slot to give you USB 2.0 capability. Since this is true,
    any USB 2.0 ports that you have on an old machine will be located on the
    back. Having said that, just because you have ports on the back does not
    mean they will be USB 2.0.

    If you have a printer with memory card reader ports, these will be USB, but
    since the printer plugs into a USB 1.0 port on the machine, the ports on the
    printer will also be 1.0. You must have a USB 2.0 card that is plugged into
    a PCI slot, OR all USB ports will be 2.0 already.

    There is no reason to build a machine with both 1.0 and 2.0 USB ports. They
    built machines for a couple of years with 1.0 ports, then switched to the
    faster 2.0 convention. You can add the 2.0 capability, or the computer
    builder will have put it in, but he will not have put in both.



    "John Richards" <> wrote in message
    news:47a9bdcb$0$4928$...
    >I have a "USB 2.0 HIGH-SPEED Front Bay Hub" with two ports connected to one
    >of two spare USB 2.0 pin headers on the motherboard (also High Speed). The
    >motherboard has two ports which appear on the back of the PC and are (I
    >think) USB1.1 ports. Looking at Device Manager at Universal Serial Bus
    >controllers, 4 USB Root Hubs are listed. The first three show 2 ports each
    >(on the "Power" tab under properties) and the fourth one shows 6 ports.
    >Also under Universal Serial Bus controllers, there are 4 Host controllers.
    >The first three are designated "VIA Rev 5 or later USB Universal Host
    >Controller" which I'm assuming relate to the first three USB Root Hubs and
    >are USB 1.1. The fourth controller is designated "VIA USB Enhanced Host
    >Controller" which I assume relates to the fourth USB Root Hub and is USB
    >2.0 High Speed.
    >
    Jeff Strickland, Feb 7, 2008
    #3
  4. If a USB 2.0 device is plugged into a USB 1.0 port, there is typically a
    message to alert you that the high speed device will not run at high speed.
    I suppose a high speed device may elect to not work at all, and in this
    instance it may work fine when you insert it into a different port.



    "John Richards" <> wrote in message
    news:47a9f7d5$0$30706$...
    > Sorry! Didn't mean to send the unfinished post.
    >
    > I did do some more research and think I know what might be happening but
    > have no idea why.
    >
    > I recently installed a USB 2.0 front bay hub and connected it to a USB 2.0
    > pin header on the mother board (MSI KT3 Ultra2). When I plug a High-Speed
    > USB 2.0 flash drive into one of the connectors on the front bay hub, a
    > notice on the screen suggests that I connect the device to a High Speed
    > USB 2.0 Port and then offers a list of 6 available unused ports under the
    > Enhanced Host Controller (USB 2.0) heading. When I look at Device
    > Manager, it shows that the flash drive appears on a universal port. If I
    > move the flash drive to one of the original USB connectors on the back of
    > the PC, the flash drive appears on one of the 6 ports under the Enhanced
    > Host Controller, yet when a USB 1.1 device is plugged into the same
    > connector on the back, the device shows up on a universal port.
    >
    > While doing some research, I came across a FAQ
    > http://www.everythingusb.com/usb2/faq.htm , which states; "The USB
    > controller routes signals to the correct controller chip depending on how
    > a device is recognized. Where a device is physically plugged in has no
    > bearing on how it is routed. All ports on a USB 2.0 motherboard can host
    > any USB devices at all as long as the system and devices are healthy."
    > This statement seems to agree with what happens when a USB 1.1 or USB 2.0
    > device is plugged into the original rear connectors (they are "routed" to
    > the appropriate "port").
    >
    > My problem, then, is that although the flash drive is correctly recognized
    > as a USB 2.0 device, why isn't it just routed to one of the available USB
    > 2.0 ports (according to the notice on the screen) like it is when plugged
    > into one of the rear connectors.
    >
    > Incidentally, the PC is running Windows XP SP2.
    >
    > Any ideas?
    >
    > John
    >
    Jeff Strickland, Feb 7, 2008
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. DannyD1355

    USB High Speed against USB Non High Speed

    DannyD1355, Sep 7, 2003, in forum: Computer Support
    Replies:
    1
    Views:
    574
    Patrick
    Sep 7, 2003
  2. DannyD1355

    High speed USB hub controller

    DannyD1355, Nov 4, 2003, in forum: Computer Support
    Replies:
    3
    Views:
    751
    Kráftéé
    Nov 4, 2003
  3. a.metselaar

    speed speed speed

    a.metselaar, Dec 28, 2003, in forum: Computer Support
    Replies:
    14
    Views:
    983
    BuffNET Tech Support - MichaelJ
    Dec 30, 2003
  4. Mike
    Replies:
    27
    Views:
    1,349
  5. Replies:
    0
    Views:
    1,114
Loading...

Share This Page