weird problem with using a Cisco 1751 as a home office router

Discussion in 'Cisco' started by ken gallagher, Oct 24, 2006.

  1. Hi, all. I was wondering if you could help me with a glitch I keep hitting.

    I just bought a new Cisco 1751 router, and completed configuring it to
    access the Internet and provide internal LAN addresses. For some reason I
    have the ability to access certain websites (such as www.google.ca) but
    cannot perform certain functions such as connecting to MSN messenger (the
    application just times out)

    I'm not quite sure what I'm doing wrong with the configuration at this point

    If anyone has any ideas, I would really appreciate it. I am supplying a
    copy of the running config as well as the output from Show version

    cisco1751#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.3(20), RELEASE
    SOFTWARE (f
    c2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by cisco Systems, Inc.
    Compiled Tue 08-Aug-06 17:59 by kesnyder
    Image text-base: 0x8000816C, data-base: 0x810A3620

    ROM: System Bootstrap, Version 12.2(1r)XE1, RELEASE SOFTWARE (fc1)
    ROM: C1700 Software (C1700-K9O3SY7-M), Version 12.3(20), RELEASE SOFTWARE
    (fc2)

    cisco1751 uptime is 4 minutes
    System returned to ROM by power-on
    System restarted at 05:12:12 UTC Tue Jun 27 2006
    System image file is "flash:c1700-k9o3sy7-mz.123-20.bin"


    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found
    at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    .

    cisco 1751 (MPC860P) processor (revision 0x600) with 81920K/16384K bytes of
    memo
    ry.
    Processor board ID JAD06380IIJ (43364424), with hardware revision 0000
    MPC860P processor: part number 5, mask 2
    Bridging software.
    X.25 software, Version 3.0.0.
    1 Ethernet/IEEE 802.3 interface(s)
    1 FastEthernet/IEEE 802.3 interface(s)
    32K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2101

    cisco1751#sh run
    Building configuration...

    Current configuration : 1818 bytes
    !
    ! No configuration change since last restart
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname cisco1751
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret xxxx
    !
    memory-size iomem 25
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    !
    !
    ip dhcp excluded-address 192.168.1.254
    !
    ip dhcp pool MYPOOL
    import all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    dns-server 206.47.244.138 67.69.184.223
    !
    ip cef
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    !
    !
    username kenjg password 7 001D02031350590008
    !
    !
    !
    !
    !
    interface Ethernet0/0
    no ip address
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 1
    hold-queue 100 out
    !
    interface FastEthernet0/0
    ip address 192.168.1.254 255.255.255.0
    ip mtu 1492
    ip nat inside
    speed auto
    !
    interface Dialer1
    description DSL
    mtu 1452
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxx
    ppp chap password xxxx
    ppp pap sent-username xxxx password xxxx
    !
    ip nat inside source list 101 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    no ip http secure-server
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 1 permit 192.168.2.0 0.0.0.255
    access-list 101 deny tcp any any eq telnet
    access-list 101 permit ip 192.168.1.0 0.0.0.255 any
    access-list 101 permit ip 192.168.2.0 0.0.0.255 any
    !
    !
    line con 0
    password xxxx
    login
    line aux 0
    line vty 0 4
    password xxxx
    login
    !
    end
    ken gallagher, Oct 24, 2006
    #1
    1. Advertising

  2. In article <wXc%g.28681$%>,
    ken gallagher <> wrote:
    >I just bought a new Cisco 1751 router, and completed configuring it to
    >access the Internet and provide internal LAN addresses. For some reason I
    >have the ability to access certain websites (such as www.google.ca) but
    >cannot perform certain functions such as connecting to MSN messenger (the
    >application just times out)


    >I'm not quite sure what I'm doing wrong with the configuration at this point


    I'm going to put on my special Cisco Certified Psychic Network hat...

    "Oh great spirits, show me an image of what ails this man's network!"

    "It's appearing... it's appearing... Yes Yes, I am getting a clear
    picture of a DSL connection!"


    >interface Ethernet0/0
    > no ip address
    > half-duplex
    > pppoe enable
    > pppoe-client dial-pool-number 1
    > hold-queue 100 out


    >interface Dialer1
    > description DSL
    > mtu 1452
    > ip address negotiated
    > ip nat outside
    > encapsulation ppp



    Say, whaddya know? That funny little man in the store that wasn't
    there the next day didn't cheat me on that CCPN hat after all!!


    So what you have is an MTU problem. Make sure your systems are
    configured to use Path MTU Discovery; if that doesn't work, try
    lowering their MTU.

    You might be able to use a noticably larger MTU on the DSL, but
    that depends on the provider. We used to have to use 1452 around here,
    but they modernized a few years ago and 1492 works here now. That
    would -help- with the MTU problem, but it would not fix it.


    I'm not overly familiar with the 175x IOS capabilities. Check to see
    if you can do TCP MSS Adjustment in your IOS version.
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t4/ft_admss.htm
    Walter Roberson, Oct 24, 2006
    #2
    1. Advertising

  3. ken gallagher

    user Guest

    "ken gallagher" <> wrote in message
    news:wXc%g.28681$%...
    > Hi, all. I was wondering if you could help me with a glitch I keep
    > hitting.
    >
    > I just bought a new Cisco 1751 router, and completed configuring it to
    > access the Internet and provide internal LAN addresses. For some reason I
    > have the ability to access certain websites (such as www.google.ca) but
    > cannot perform certain functions such as connecting to MSN messenger (the
    > application just times out)
    >
    > I'm not quite sure what I'm doing wrong with the configuration at this
    > point
    >
    > If anyone has any ideas, I would really appreciate it. I am supplying a
    > copy of the running config as well as the output from Show version
    >
    > cisco1751#sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.3(20), RELEASE
    > SOFTWARE (f
    > c2)
    > Technical Support: http://www.cisco.com/techsupport
    > Copyright (c) 1986-2006 by cisco Systems, Inc.
    > Compiled Tue 08-Aug-06 17:59 by kesnyder
    > Image text-base: 0x8000816C, data-base: 0x810A3620
    >
    > ROM: System Bootstrap, Version 12.2(1r)XE1, RELEASE SOFTWARE (fc1)
    > ROM: C1700 Software (C1700-K9O3SY7-M), Version 12.3(20), RELEASE SOFTWARE
    > (fc2)
    >
    > cisco1751 uptime is 4 minutes
    > System returned to ROM by power-on
    > System restarted at 05:12:12 UTC Tue Jun 27 2006
    > System image file is "flash:c1700-k9o3sy7-mz.123-20.bin"
    >
    >
    > This product contains cryptographic features and is subject to United
    > States and local country laws governing import, export, transfer and
    > use. Delivery of Cisco cryptographic products does not imply
    > third-party authority to import, export, distribute or use encryption.
    > Importers, exporters, distributors and users are responsible for
    > compliance with U.S. and local country laws. By using this product you
    > agree to comply with applicable laws and regulations. If you are unable
    > to comply with U.S. and local laws, return this product immediately.
    >
    > A summary of U.S. laws governing Cisco cryptographic products may be found
    > at:
    > http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    >
    > If you require further assistance please contact us by sending email to
    > .
    >
    > cisco 1751 (MPC860P) processor (revision 0x600) with 81920K/16384K bytes
    > of memo
    > ry.
    > Processor board ID JAD06380IIJ (43364424), with hardware revision 0000
    > MPC860P processor: part number 5, mask 2
    > Bridging software.
    > X.25 software, Version 3.0.0.
    > 1 Ethernet/IEEE 802.3 interface(s)
    > 1 FastEthernet/IEEE 802.3 interface(s)
    > 32K bytes of non-volatile configuration memory.
    > 16384K bytes of processor board System flash (Read/Write)
    >
    > Configuration register is 0x2101
    >
    > cisco1751#sh run
    > Building configuration...
    >
    > Current configuration : 1818 bytes
    > !
    > ! No configuration change since last restart
    > !
    > version 12.3
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > service password-encryption
    > !
    > hostname cisco1751
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > enable secret xxxx
    > !
    > memory-size iomem 25
    > mmi polling-interval 60
    > no mmi auto-configure
    > no mmi pvc
    > mmi snmp-timeout 180
    > no aaa new-model
    > ip subnet-zero
    > !
    > !
    > ip dhcp excluded-address 192.168.1.254
    > !
    > ip dhcp pool MYPOOL
    > import all
    > network 192.168.1.0 255.255.255.0
    > default-router 192.168.1.254
    > dns-server 206.47.244.138 67.69.184.223
    > !
    > ip cef
    > ip audit po max-events 100
    > vpdn enable
    > !
    > vpdn-group 1
    > request-dialin
    > protocol pppoe
    > !
    > !
    > !
    > username kenjg password 7 001D02031350590008
    > !
    > !
    > !
    > !
    > !
    > interface Ethernet0/0
    > no ip address
    > half-duplex
    > pppoe enable
    > pppoe-client dial-pool-number 1
    > hold-queue 100 out
    > !
    > interface FastEthernet0/0
    > ip address 192.168.1.254 255.255.255.0
    > ip mtu 1492
    > ip nat inside
    > speed auto
    > !
    > interface Dialer1
    > description DSL
    > mtu 1452
    > ip address negotiated
    > ip nat outside
    > encapsulation ppp
    > dialer pool 1
    > dialer-group 1
    > ppp authentication chap callin
    > ppp chap hostname xxxx
    > ppp chap password xxxx
    > ppp pap sent-username xxxx password xxxx
    > !
    > ip nat inside source list 101 interface Dialer1 overload
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer1
    > no ip http server
    > no ip http secure-server
    > !
    > !
    > access-list 1 permit 192.168.1.0 0.0.0.255
    > access-list 1 permit 192.168.2.0 0.0.0.255
    > access-list 101 deny tcp any any eq telnet
    > access-list 101 permit ip 192.168.1.0 0.0.0.255 any
    > access-list 101 permit ip 192.168.2.0 0.0.0.255 any
    > !
    > !
    > line con 0
    > password xxxx
    > login
    > line aux 0
    > line vty 0 4
    > password xxxx
    > login
    > !
    > end


    Maybe try;

    interface Ethernet0
    ip tcp adjust-mss 1452

    interface Dialer1
    ip mtu 1492
    user, Oct 24, 2006
    #3
  4. Thanks all for the advice. The problem is fixed
    I had the wrong MTU settings as you all thought

    "user" <user@localhost> wrote in message
    news:453e0713$0$21345$...
    >
    > "ken gallagher" <> wrote in message
    > news:wXc%g.28681$%...
    >> Hi, all. I was wondering if you could help me with a glitch I keep
    >> hitting.
    >>
    >> I just bought a new Cisco 1751 router, and completed configuring it to
    >> access the Internet and provide internal LAN addresses. For some reason
    >> I have the ability to access certain websites (such as www.google.ca) but
    >> cannot perform certain functions such as connecting to MSN messenger (the
    >> application just times out)
    >>
    >> I'm not quite sure what I'm doing wrong with the configuration at this
    >> point
    >>
    >> If anyone has any ideas, I would really appreciate it. I am supplying a
    >> copy of the running config as well as the output from Show version
    >>
    >> cisco1751#sh ver
    >> Cisco Internetwork Operating System Software
    >> IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.3(20), RELEASE
    >> SOFTWARE (f
    >> c2)
    >> Technical Support: http://www.cisco.com/techsupport
    >> Copyright (c) 1986-2006 by cisco Systems, Inc.
    >> Compiled Tue 08-Aug-06 17:59 by kesnyder
    >> Image text-base: 0x8000816C, data-base: 0x810A3620
    >>
    >> ROM: System Bootstrap, Version 12.2(1r)XE1, RELEASE SOFTWARE (fc1)
    >> ROM: C1700 Software (C1700-K9O3SY7-M), Version 12.3(20), RELEASE SOFTWARE
    >> (fc2)
    >>
    >> cisco1751 uptime is 4 minutes
    >> System returned to ROM by power-on
    >> System restarted at 05:12:12 UTC Tue Jun 27 2006
    >> System image file is "flash:c1700-k9o3sy7-mz.123-20.bin"
    >>
    >>
    >> This product contains cryptographic features and is subject to United
    >> States and local country laws governing import, export, transfer and
    >> use. Delivery of Cisco cryptographic products does not imply
    >> third-party authority to import, export, distribute or use encryption.
    >> Importers, exporters, distributors and users are responsible for
    >> compliance with U.S. and local country laws. By using this product you
    >> agree to comply with applicable laws and regulations. If you are unable
    >> to comply with U.S. and local laws, return this product immediately.
    >>
    >> A summary of U.S. laws governing Cisco cryptographic products may be
    >> found at:
    >> http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    >>
    >> If you require further assistance please contact us by sending email to
    >> .
    >>
    >> cisco 1751 (MPC860P) processor (revision 0x600) with 81920K/16384K bytes
    >> of memo
    >> ry.
    >> Processor board ID JAD06380IIJ (43364424), with hardware revision 0000
    >> MPC860P processor: part number 5, mask 2
    >> Bridging software.
    >> X.25 software, Version 3.0.0.
    >> 1 Ethernet/IEEE 802.3 interface(s)
    >> 1 FastEthernet/IEEE 802.3 interface(s)
    >> 32K bytes of non-volatile configuration memory.
    >> 16384K bytes of processor board System flash (Read/Write)
    >>
    >> Configuration register is 0x2101
    >>
    >> cisco1751#sh run
    >> Building configuration...
    >>
    >> Current configuration : 1818 bytes
    >> !
    >> ! No configuration change since last restart
    >> !
    >> version 12.3
    >> service timestamps debug datetime msec
    >> service timestamps log datetime msec
    >> service password-encryption
    >> !
    >> hostname cisco1751
    >> !
    >> boot-start-marker
    >> boot-end-marker
    >> !
    >> enable secret xxxx
    >> !
    >> memory-size iomem 25
    >> mmi polling-interval 60
    >> no mmi auto-configure
    >> no mmi pvc
    >> mmi snmp-timeout 180
    >> no aaa new-model
    >> ip subnet-zero
    >> !
    >> !
    >> ip dhcp excluded-address 192.168.1.254
    >> !
    >> ip dhcp pool MYPOOL
    >> import all
    >> network 192.168.1.0 255.255.255.0
    >> default-router 192.168.1.254
    >> dns-server 206.47.244.138 67.69.184.223
    >> !
    >> ip cef
    >> ip audit po max-events 100
    >> vpdn enable
    >> !
    >> vpdn-group 1
    >> request-dialin
    >> protocol pppoe
    >> !
    >> !
    >> !
    >> username kenjg password 7 001D02031350590008
    >> !
    >> !
    >> !
    >> !
    >> !
    >> interface Ethernet0/0
    >> no ip address
    >> half-duplex
    >> pppoe enable
    >> pppoe-client dial-pool-number 1
    >> hold-queue 100 out
    >> !
    >> interface FastEthernet0/0
    >> ip address 192.168.1.254 255.255.255.0
    >> ip mtu 1492
    >> ip nat inside
    >> speed auto
    >> !
    >> interface Dialer1
    >> description DSL
    >> mtu 1452
    >> ip address negotiated
    >> ip nat outside
    >> encapsulation ppp
    >> dialer pool 1
    >> dialer-group 1
    >> ppp authentication chap callin
    >> ppp chap hostname xxxx
    >> ppp chap password xxxx
    >> ppp pap sent-username xxxx password xxxx
    >> !
    >> ip nat inside source list 101 interface Dialer1 overload
    >> ip classless
    >> ip route 0.0.0.0 0.0.0.0 Dialer1
    >> no ip http server
    >> no ip http secure-server
    >> !
    >> !
    >> access-list 1 permit 192.168.1.0 0.0.0.255
    >> access-list 1 permit 192.168.2.0 0.0.0.255
    >> access-list 101 deny tcp any any eq telnet
    >> access-list 101 permit ip 192.168.1.0 0.0.0.255 any
    >> access-list 101 permit ip 192.168.2.0 0.0.0.255 any
    >> !
    >> !
    >> line con 0
    >> password xxxx
    >> login
    >> line aux 0
    >> line vty 0 4
    >> password xxxx
    >> login
    >> !
    >> end

    >
    > Maybe try;
    >
    > interface Ethernet0
    > ip tcp adjust-mss 1452
    >
    > interface Dialer1
    > ip mtu 1492
    >
    >
    >
    ken gallagher, Oct 24, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andre Gronwald

    voip/sip at cisco 7960 and 1751

    Andre Gronwald, Nov 28, 2003, in forum: Cisco
    Replies:
    0
    Views:
    666
    Andre Gronwald
    Nov 28, 2003
  2. Rob
    Replies:
    3
    Views:
    572
    AnyBody43
    May 11, 2004
  3. Tom

    Cisco 1751 Router

    Tom, May 20, 2004, in forum: Cisco
    Replies:
    0
    Views:
    831
  4. Mike Rahl
    Replies:
    1
    Views:
    697
    www.BradReese.Com
    Oct 16, 2006
  5. doublea1535
    Replies:
    1
    Views:
    3,212
    araishee
    Feb 18, 2010
Loading...

Share This Page