Weird error messages with shell integration in Windows XP

Discussion in 'Firefox' started by Zaghadka, Mar 24, 2007.

  1. Zaghadka

    Zaghadka Guest

    This one cropped up just the other day. Every time I launch a .URL file
    (Internet Shortcut) from the Windows shell, and the Firefox browser is not
    already open, I get an error message:

    "Windows cannot find '[full url here]'. Make sure you typed the name correctly,
    and then try again. To search for a file, click the Start button, and then
    click Search." [Dialogue button: OK]

    (whatever url, e.g. http://www.yahoo.com, appears as the [full url here])

    The same happens when I type a web address into the "Run..." dialogue. It does
    not happen when I double-click a URL from within Agent, however.

    Nevermind that it actually works, and the web page is opened in Firefox, but if
    the browser is not already open to begin with, Windows generates this clearly
    bogus error message on my machine.

    Of course, entering "Set Program Access and Defaults" and chosing "IE" as my
    default browser clears the problem up right away. Except that it launches IE,
    of course.

    Changing it back wasn't easy either, because Firefox also no longer shows up in
    the "Choose a Default Web Browser" section of the "Set Defaults" applet. I'm
    not sure it ever did, but that may be the source of the problem. Several
    reinstalls of Firefox did not fix this problem.

    I'm using version 2.0.0.3, and a revert to 2.0.0.2 also didn't fix the problem,
    so this is apparently Microsoft's problem, as it just stopped working
    yesterday. I am using the latest version of IE 6, instead of IE 7, BTW. Windows
    XP SP2.

    I've tried reassociating "URL" files to "open" with "path:\firefox.exe %L," and
    going directly to regedit and changing the .URL association entry from
    "InternetShortcut" to "FirefoxURL" and get the exact same problem. Error
    message, but the URL otherwise opens fine.

    Is this happening on anyone else's machine? It is completely annoying, and
    given MS's track record, I doubt it is any "bug" on the part of the Mozilla
    team, but rather a direct attempt by Microsoft to make using the Firefox
    browser annoying. They are asserting their "ownership" of *my* desktop, in
    other words. I am not pleased.

    I can find nothing on Bugzilla, nor do I fully understand how to report a bug
    to Bugzilla. There should be a simple way to anonymously post a bug to a
    moderator, but it doesn't seem to exist.

    Thanks for your time.

    --
    Zag


    "The Ends Justify The Means" ~Niccolo Machiavelli, c. 1550

    "The Means Justify The Means" ~George W. Bush, c. 2000
     
    Zaghadka, Mar 24, 2007
    #1
    1. Advertising

  2. Zaghadka

    Guest

    On Mar 23, 10:13 pm, Zaghadka <> wrote:
    > This one cropped up just the other day. Every time I launch a .URL file
    > (Internet Shortcut) from the Windows shell, and the Firefox browser is not
    > already open, I get an error message:
    >
    > "Windows cannot find '[full url here]'. Make sure you typed the name correctly,
    > and then try again. To search for a file, click the Start button, and then
    > click Search." [Dialogue button: OK]
    >
    > (whatever url, e.g.http://www.yahoo.com, appears as the [full url here])
    >
    > The same happens when I type a web address into the "Run..." dialogue. It does
    > not happen when I double-click a URL from within Agent, however.
    >
    > Nevermind that it actually works, and the web page is opened in Firefox, but if
    > the browser is not already open to begin with, Windows generates this clearly
    > bogus error message on my machine.
    >
    > Of course, entering "Set Program Access and Defaults" and chosing "IE" as my
    > default browser clears the problem up right away. Except that it launches IE,
    > of course.
    >
    > Changing it back wasn't easy either, because Firefox also no longer shows up in
    > the "Choose a Default Web Browser" section of the "Set Defaults" applet. I'm
    > not sure it ever did, but that may be the source of the problem. Several
    > reinstalls of Firefox did not fix this problem.
    >


    stop uninstalling and reinstalling. Thats not the problem. All your
    settings, prefs, bookmarks, etc, are stored in an area called the FF
    profile. The profile is located separate from the program. When you
    uninstall, all you're doing is removing the program. The profile is
    not touched. This is where your problem is.

    To set FF as the default, look under Tools, Options, General and it
    should be right in the middle

    > I'm using version 2.0.0.3, and a revert to 2.0.0.2 also didn't fix the problem,
    > so this is apparently Microsoft's problem, as it just stopped working
    > yesterday. I am using the latest version of IE 6, instead of IE 7, BTW. Windows
    > XP SP2.
    >
    > I've tried reassociating "URL" files to "open" with "path:\firefox.exe %L," and


    that should be %1 [one], and it should be in quotation marks, and you
    need to put the full path in. It should be something like this:

    "C:\Program Files\mozilla.org\SeaMonkey\seamonkey.exe" -url "%1"
     
    , Mar 24, 2007
    #2
    1. Advertising

  3. Zaghadka

    Zaghadka Guest

    On 23 Mar 2007 22:40:43 -0700, in alt.fan.mozilla,
    wrote:

    >On Mar 23, 10:13 pm, Zaghadka <> wrote:
    >> This one cropped up just the other day. Every time I launch a .URL file
    >> (Internet Shortcut) from the Windows shell, and the Firefox browser is not
    >> already open, I get an error message:
    >>
    >> "Windows cannot find '[full url here]'. Make sure you typed the name correctly,
    >> and then try again. To search for a file, click the Start button, and then
    >> click Search." [Dialogue button: OK]
    >>
    >> (whatever url, e.g.http://www.yahoo.com, appears as the [full url here])
    >>
    >> The same happens when I type a web address into the "Run..." dialogue. It does
    >> not happen when I double-click a URL from within Agent, however.
    >>
    >> Nevermind that it actually works, and the web page is opened in Firefox, but if
    >> the browser is not already open to begin with, Windows generates this clearly
    >> bogus error message on my machine.
    >>
    >> Of course, entering "Set Program Access and Defaults" and chosing "IE" as my
    >> default browser clears the problem up right away. Except that it launches IE,
    >> of course.
    >>
    >> Changing it back wasn't easy either, because Firefox also no longer shows up in
    >> the "Choose a Default Web Browser" section of the "Set Defaults" applet. I'm
    >> not sure it ever did, but that may be the source of the problem. Several
    >> reinstalls of Firefox did not fix this problem.
    >>

    >
    >stop uninstalling and reinstalling. Thats not the problem. All your
    >settings, prefs, bookmarks, etc, are stored in an area called the FF
    >profile. The profile is located separate from the program.


    Right, on my system the profile is located in "%USERPROFILE%\Application
    Data\Mozilla\Firefox."

    > When you
    >uninstall, all you're doing is removing the program. The profile is
    >not touched. This is where your problem is.
    >

    No. The problem appears to be with shell integration. As I mentioned, Firefox
    launches just fine, the URL opens just fine, but if I don't already have the
    browser open, then I get an error message for no apparent reason.

    It's nothing more than an annoyance at this point.

    >To set FF as the default, look under Tools, Options, General and it
    >should be right in the middle
    >

    It is the default. I've even tried changing key .URL==InternetShortcut to
    "FirefoxURL" and I get the same problem. I thought doing an end run around
    shdocvw.dll would do the trick, but it doesn't.

    However, Firefox no longer shows up in my "Set Program Access and Defaults"
    applet. Do you know if that is normal?

    >> I'm using version 2.0.0.3, and a revert to 2.0.0.2 also didn't fix the problem,
    >> so this is apparently Microsoft's problem, as it just stopped working
    >> yesterday. I am using the latest version of IE 6, instead of IE 7, BTW. Windows
    >> XP SP2.
    >>
    >> I've tried reassociating "URL" files to "open" with "path:\firefox.exe %L," and

    >
    >that should be %1 [one], and it should be in quotation marks, and you
    >need to put the full path in. It should be something like this:
    >

    %L (file link) and %1 (first batch argument) are actually the same thing in
    this case. The default "InternetShortcut" command is:

    rundll32.exe shdocvw.dll,OpenURL %l (That's a lower case "L", not 1)

    They both work, but they both produce this annoying error message. I'll try
    blowing away my FF profile directory next, but I get the feeling something odd
    is happening on my machine. Don't know what I did, but it doesn't sound like
    this is a common problem. ;^)

    Thanks for your help.

    --
    Zag


    "The Ends Justify The Means" ~Niccolo Machiavelli, c. 1550

    "The Means Justify The Means" ~George W. Bush, c. 2000
     
    Zaghadka, Mar 25, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Bun Mui

    Shell icon cache for Windows Xp Home Edition

    Bun Mui, May 24, 2004, in forum: Computer Support
    Replies:
    2
    Views:
    7,605
    Wesley Vogel
    May 24, 2004
  2. yimoot

    error in shell

    yimoot, Nov 16, 2006, in forum: Software
    Replies:
    0
    Views:
    665
    yimoot
    Nov 16, 2006
  3. Thomas G. Madsen

    WinRAR 3.40 shell integration

    Thomas G. Madsen, May 23, 2005, in forum: Windows 64bit
    Replies:
    31
    Views:
    1,979
    =?Utf-8?B?Tm90c29nZW50bGU=?=
    Jun 9, 2005
  4. Andre Da Costa [Extended64]

    Windows "Monad" Shell Beta 2 for x64 released

    Andre Da Costa [Extended64], Oct 30, 2005, in forum: Windows 64bit
    Replies:
    0
    Views:
    462
    Andre Da Costa [Extended64]
    Oct 30, 2005
  5. Zaghadka
    Replies:
    0
    Views:
    406
    Zaghadka
    Mar 27, 2007
Loading...

Share This Page