WCCP redirection thru cat3550EMI and Cacheflow

Discussion in 'Cisco' started by Azani, Jul 19, 2003.

  1. Azani

    Azani Guest

    Dear all,

    Anybody has an experience how to redirect traffic to cache engine in this
    case my is CacheFlow SG-800.
    We have followed documentation by Cisco 3550 and WCCP on how-to and also
    from Cacheflow for simple redirection. But it did not work for some reason.

    Cacheflow did mention in their old websites ( b4 become BlueCoat) with this
    configuration. I believe at that time they do it via
    router as there is no L3 L4 switches at that time.

    In CacheFlow Box create this config.
    WCCP version 2 configuration file:

    wccp enable
    wccp version 2
    service-group web-cache
    home-router 10.1.1.1
    interface 0
    end


    And in Cisco Router.

    To configure WCCP version 2 standard redirection enter the following
    commands from the CLI:

    Router# configure terminal
    Router(config)# ip wccp web-cache
    Router(config)# interface serial 0/0
    Router(config-if)# ip wccp web-cache redirect out

    But we do not create this at our Cisco Cat3550EMI. We follow doc from Cisco
    3550EMI and WCCP
    Azani, Jul 19, 2003
    #1
    1. Advertising

  2. 3550 has limited WCCP functionality, see:

    http://www.cisco.com/en/US/products...tion_guide_chapter09186a00800c6edb.html#28880

    Your 3550 config would be helpful to know.
    It is also important to know that 3550 only does L2 redirection, not GRE

    See:

    http://www.cisco.com/en/US/products...on_guide_chapter09186a00800c6edb.html#xtocid9

    Also, the 3550 isn't going to show the number of packets redirected in
    the show command (sorry, too tired to recall which one)


    Michael

    Azani wrote:
    > Dear all,
    >
    > Anybody has an experience how to redirect traffic to cache engine in this
    > case my is CacheFlow SG-800.
    > We have followed documentation by Cisco 3550 and WCCP on how-to and also
    > from Cacheflow for simple redirection. But it did not work for some reason.
    >
    > Cacheflow did mention in their old websites ( b4 become BlueCoat) with this
    > configuration. I believe at that time they do it via
    > router as there is no L3 L4 switches at that time.
    >
    > In CacheFlow Box create this config.
    > WCCP version 2 configuration file:
    >
    > wccp enable
    > wccp version 2
    > service-group web-cache
    > home-router 10.1.1.1
    > interface 0
    > end
    >
    >
    > And in Cisco Router.
    >
    > To configure WCCP version 2 standard redirection enter the following
    > commands from the CLI:
    >
    > Router# configure terminal
    > Router(config)# ip wccp web-cache
    > Router(config)# interface serial 0/0
    > Router(config-if)# ip wccp web-cache redirect out
    >
    > But we do not create this at our Cisco Cat3550EMI. We follow doc from Cisco
    > 3550EMI and WCCP
    >
    >
    >
    >
    >
    >
    >
    >
    >
    Michael Voight, Jul 19, 2003
    #2
    1. Advertising

  3. Azani

    azani Guest

    Dear Michael

    Do not have the c3550 config right now but I can give ASAP. I had earlier
    gone thru these url
    earlier. I created 3 routed interfaces ( subnet) in C3550emi.

    1) Gateway to internet 192.168.10.202 255.255.255.0 i.e the default gateway
    2) Caching subnet for Cacheflow 192.168.200.33 255.255.255.224 Ip add for
    cacheflow is
    192.168.200.35
    3) customer LAN gateway 10.2.250.1 / 255.255.255.240

    I will get the config of c3550emi and also cacflow later.

    THKS



    "Michael Voight" <> wrote in message
    news:...
    > 3550 has limited WCCP functionality, see:
    >
    >

    http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration
    _guide_chapter09186a00800c6edb.html#28880
    >
    > Your 3550 config would be helpful to know.
    > It is also important to know that 3550 only does L2 redirection, not GRE
    >
    > See:
    >
    >

    http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration
    _guide_chapter09186a00800c6edb.html#xtocid9
    >
    > Also, the 3550 isn't going to show the number of packets redirected in
    > the show command (sorry, too tired to recall which one)
    >
    >
    > Michael
    >
    > Azani wrote:
    > > Dear all,
    > >
    > > Anybody has an experience how to redirect traffic to cache engine in

    this
    > > case my is CacheFlow SG-800.
    > > We have followed documentation by Cisco 3550 and WCCP on how-to and also
    > > from Cacheflow for simple redirection. But it did not work for some

    reason.
    > >
    > > Cacheflow did mention in their old websites ( b4 become BlueCoat) with

    this
    > > configuration. I believe at that time they do it via
    > > router as there is no L3 L4 switches at that time.
    > >
    > > In CacheFlow Box create this config.
    > > WCCP version 2 configuration file:
    > >
    > > wccp enable
    > > wccp version 2
    > > service-group web-cache
    > > home-router 10.1.1.1
    > > interface 0
    > > end
    > >
    > >
    > > And in Cisco Router.
    > >
    > > To configure WCCP version 2 standard redirection enter the following
    > > commands from the CLI:
    > >
    > > Router# configure terminal
    > > Router(config)# ip wccp web-cache
    > > Router(config)# interface serial 0/0
    > > Router(config-if)# ip wccp web-cache redirect out
    > >
    > > But we do not create this at our Cisco Cat3550EMI. We follow doc from

    Cisco
    > > 3550EMI and WCCP
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > >

    >
    azani, Jul 19, 2003
    #3
  4. Azani

    Azani Guest

    Dear Michael

    I have gone thru cacheflow website and upgrade to their lastest version of
    CacheOS :
    If u do not mind can u go thru these.

    Thanking in advance your help

    Azanio


    ~~~ CACHEFLOW 800 ~~~~~
    Version: CA 4.1.10016
    Release id: 19277
    Backplane PIC: not applicable on this platform
    Serial number: 3702000261
    NIC 0 MAC: 00E08120A3FC
    192.168.200.35 - CacheFlow 800#

    Configuration for wccp for CacheFlow 800 - documentation from Cacheflow
    website

    192.168.200.35 - CacheFlow 800#sh wccp configuration
    ; WCCP Settings
    ; CacheOS WCCP version 1.3
    wccp enable
    wccp version 2
    service-group web-cache
    interface 0
    home-router 192.168.200.33
    end

    ~~~ Cisco 3550EMI ~~~~

    ctss#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C3550 Software (C3550-I5Q3L2-M), Version 12.1(12c)EA1, RELEASE
    SOFTWARE (fc1)
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Mon 25-Nov-02 00:07 by antonino
    Image text-base: 0x00003000, data-base: 0x0075FE48

    ROM: Bootstrap program is C3550 boot loader

    ctss uptime is 1 hour, 3 minutes
    System returned to ROM by power-on
    System image file is
    "flash:c3550-i5q3l2-mz.121-12c.EA1/c3550-i5q3l2-mz.121-12c.EA1.bin"

    cisco WS-C3550-24 (PowerPC) processor (revision H0) with 65526K/8192K bytes
    of memory.
    Processor board ID CAT0715X0D5
    Last reset from warm-reset
    Bridging software.
    Running Layer2/3 Switching Image

    Ethernet-controller 1 has 12 Fast Ethernet/IEEE 802.3 interfaces

    Ethernet-controller 2 has 12 Fast Ethernet/IEEE 802.3 interfaces

    Ethernet-controller 3 has 1 Gigabit Ethernet/IEEE 802.3 interface

    Ethernet-controller 4 has 1 Gigabit Ethernet/IEEE 802.3 interface

    24 FastEthernet/IEEE 802.3 interface(s)
    2 Gigabit Ethernet/IEEE 802.3 interface(s)

    The password-recovery mechanism is enabled.
    384K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:0C:CE:04:7E:00
    Motherboard assembly number: 73-5700-10
    Power supply part number: 34-0966-02
    Motherboard serial number: CAT07140GZL
    Power supply serial number: LIT070900LQ
    Model revision number: H0
    Motherboard revision number: A0
    Model number: WS-C3550-24-EMI
    System serial number: CAT0715X0D5
    Configuration register is 0x10F


    Configuration of Cisco:

    ctss#sh config
    Using 2007 out of 393216 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname ctss
    !
    enable secret 5 $1$qwsd$va1sS2bPzsWKNb6bWBG3h/
    enable password hcqny88
    !
    ip subnet-zero
    ip routing
    ip wccp web-cache
    ip name-server 202.188.1.5
    !
    !
    spanning-tree extend system-id
    !
    !
    !
    interface FastEthernet0/1
    description Cacheflow 800 segment 192.168.200.35
    no switchport
    ip address 192.168.200.33 255.255.255.240
    !
    interface FastEthernet0/2
    no ip address
    !
    interface FastEthernet0/3
    no ip address
    !
    interface FastEthernet0/4
    no ip address
    !
    interface FastEthernet0/5
    no ip address
    !
    interface FastEthernet0/6
    no ip address
    !
    interface FastEthernet0/7
    no ip address
    !
    interface FastEthernet0/8
    no ip address
    !
    interface FastEthernet0/9
    no ip address
    !
    interface FastEthernet0/10
    no ip address
    !
    interface FastEthernet0/11
    no ip address
    !
    interface FastEthernet0/12
    no ip address
    !
    interface FastEthernet0/13
    description Subscriber Network
    no switchport
    ip address 10.2.250.1 255.255.255.248
    ip wccp web-cache redirect in
    !
    interface FastEthernet0/14
    no ip address
    !
    interface FastEthernet0/15
    no ip address
    !
    interface FastEthernet0/16
    no ip address
    !
    interface FastEthernet0/17
    no ip address
    !
    interface FastEthernet0/18
    no ip address
    !
    interface FastEthernet0/19
    no ip address
    !
    interface FastEthernet0/20
    no ip address
    !
    interface FastEthernet0/21
    no ip address
    !
    interface FastEthernet0/22
    no ip address
    !
    interface FastEthernet0/23
    no ip address
    !
    interface FastEthernet0/24
    description connected to Internet Router 192.168.10.201
    no switchport
    ip address 192.168.10.202 255.255.255.0
    !
    interface GigabitEthernet0/1
    no ip address
    !
    interface GigabitEthernet0/2
    no ip address
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.10.201
    ip http server
    !
    !
    !
    line con 0
    line vty 0 4
    password hcqny88
    login
    line vty 5 15
    password hcqny88
    login
    !
    end


    Notice some console output ::::

    0000000
    01:15:32: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003B2
    01:15:33: WCCP-EVNT:S00: Here_I_Am packet from 192.168.200.35 w/bad fwd
    method 0
    0000000
    01:15:33: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003B3
    01:15:34: WCCP-EVNT:S00: Here_I_Am packet from 192.168.200.35 w/bad fwd
    method 0
    0000000
    01:15:34: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003B4
    01:15:37: VEGAS/WCCP: Lost service notification
    01:15:37: %WCCP-1-SERVICELOST: Service web-cache lost on Web Cache
    192.168.200.3
    5
    01:15:37: VEGAS/WCCP: Lost service CE (192.168.200.35) from
    vegas_wccp_update_
    service_lost
    01:15:37: VEGAS/WCCP: Cannot find CE (192.168.200.35) to remove service
    01:15:37: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003B5
    01:15:47: WCCP-EVNT:S00: Here_I_Am packet from 192.168.200.35 w/bad fwd
    method 0
    0000000
    01:15:47: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003B6
    01:15:57: WCCP-EVNT:S00: Here_I_Am packet from 192.168.200.35 w/bad fwd
    method 0
    0000000
    01:15:57: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003B7
    01:16:02: WCCP-PKT:S00: Sending Removal_Query packet to 192.168.200.35w/
    rcv_id
    000003B8
    01:16:02: WCCP-EVNT:S00: Here_I_Am packet from 192.168.200.35 w/bad fwd
    method 0
    0000000
    01:16:02: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003B9
    01:16:03: WCCP-EVNT:S00: Here_I_Am packet from 192.168.200.35 w/bad fwd
    method 0
    0000000
    01:16:03: WCCP-PKT:S00: Sending I_See_You packet to 192.168.200.35 w/ rcv_id
    000
    003BA


    Cisco Show Command for WCCP:
    ctss#sh ip wccp web-cache
    Global WCCP information:
    Router information:
    Router Identifier: 192.168.200.33
    Protocol Version: 2.0

    Service Identifier: web-cache
    Number of Cache Engines: 0
    Number of routers: 0
    Total Packets Redirected: 0
    Redirect access-list: -none-
    Total Packets Denied Redirect: 0
    Total Packets Unassigned: 0
    Group access-list: -none-
    Total Messages Denied to Group: 0
    Total Authentication failures: 0

    ctss#
    ctss#
    ctss#
    ctss#
    ctss#
    ctss#sh ip wccp web-cache de
    ctss#sh ip wccp web-cache detail
    WCCP Cache-Engine information:
    IP Address: 192.168.200.35
    Protocol Version: 2.0
    State: NOT Usable
    Redirection: L2
    Initial Hash Info: 00000000000000000000000000000000
    00000000000000000000000000000000
    Assigned Hash Info: 00000000000000000000000000000000
    00000000000000000000000000000000
    Hash Allotment: 0 (0.00%)
    Packets Redirected: 0
    Connect Time: 00:00:07

    ctss#sh ip wccp web-cache vie
    WCCP Routers Informed of:
    -none-

    WCCP Cache Engines Visible:
    192.168.200.35

    WCCP Cache Engines NOT Visible:
    -none-

    ctss#








    "Michael Voight" <> wrote in message
    news:...
    > 3550 has limited WCCP functionality, see:
    >
    >

    http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration
    _guide_chapter09186a00800c6edb.html#28880
    >
    > Your 3550 config would be helpful to know.
    > It is also important to know that 3550 only does L2 redirection, not GRE
    >
    > See:
    >
    >

    http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration
    _guide_chapter09186a00800c6edb.html#xtocid9
    >
    > Also, the 3550 isn't going to show the number of packets redirected in
    > the show command (sorry, too tired to recall which one)
    >
    >
    > Michael
    >
    > Azani wrote:
    > > Dear all,
    > >
    > > Anybody has an experience how to redirect traffic to cache engine in

    this
    > > case my is CacheFlow SG-800.
    > > We have followed documentation by Cisco 3550 and WCCP on how-to and also
    > > from Cacheflow for simple redirection. But it did not work for some

    reason.
    > >
    > > Cacheflow did mention in their old websites ( b4 become BlueCoat) with

    this
    > > configuration. I believe at that time they do it via
    > > router as there is no L3 L4 switches at that time.
    > >
    > > In CacheFlow Box create this config.
    > > WCCP version 2 configuration file:
    > >
    > > wccp enable
    > > wccp version 2
    > > service-group web-cache
    > > home-router 10.1.1.1
    > > interface 0
    > > end
    > >
    > >
    > > And in Cisco Router.
    > >
    > > To configure WCCP version 2 standard redirection enter the following
    > > commands from the CLI:
    > >
    > > Router# configure terminal
    > > Router(config)# ip wccp web-cache
    > > Router(config)# interface serial 0/0
    > > Router(config-if)# ip wccp web-cache redirect out
    > >
    > > But we do not create this at our Cisco Cat3550EMI. We follow doc from

    Cisco
    > > 3550EMI and WCCP
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > >

    >
    >
    Azani, Jul 19, 2003
    #4
  5. Azani

    Syl

    Joined:
    Sep 26, 2007
    Messages:
    1
    Did you ever get wccp to work properly?
    Thanks
    Syl
    Syl, Sep 26, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. news.tm.net.my
    Replies:
    0
    Views:
    555
    news.tm.net.my
    Jul 17, 2003
  2. Patrick

    WCCP and PIX

    Patrick, Dec 29, 2003, in forum: Cisco
    Replies:
    3
    Views:
    6,221
    Rik Bain
    Dec 29, 2003
  3. lv2wrench

    CacheFlow 4.1.08 and websense

    lv2wrench, May 28, 2004, in forum: Cisco
    Replies:
    0
    Views:
    397
    lv2wrench
    May 28, 2004
  4. Jason

    12.3(8)T and WCCP ??

    Jason, Jun 18, 2004, in forum: Cisco
    Replies:
    2
    Views:
    745
    Jason
    Jun 19, 2004
  5. Replies:
    21
    Views:
    1,442
    Shauna
    Aug 26, 2008
Loading...

Share This Page