VPN client will not connect behind firewall

Discussion in 'Cisco' started by lbenes, Aug 4, 2006.

  1. lbenes

    lbenes Guest

    I just setup my first PIX 501. I updated it to 6.3(5) and PDM 3.0(4). I
    used the VPN wizard to make a client VPN, and it works perfectly when
    my PC is connected directly to the internet (has a public IP). When I'm
    behind a firewall, the VPN connects, but I cannot ping or connect to
    any services behind the pix. And ideas?

    : Saved
    : Written by enable_15 at 10:12:23.732 UTC Fri Aug 4 2006
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list joby_splitTunnelAcl permit ip 10.10.11.0 255.255.255.0 any
    access-list inside_outbound_nat0_acl permit ip 10.10.11.0 255.255.255.0
    10.10.11.192 255.255.255.192
    access-list outside_cryptomap_dyn_20 permit ip any 10.10.11.192
    255.255.255.192
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 70.x.x.x 255.255.255.248
    ip address inside 10.10.11.2 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool REAL_VPN_IP_POOL 10.10.11.210-10.10.11.229
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 70.x.x.x 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address
    outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp nat-traversal 20
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup xxxx address-pool REAL_VPN_IP_POOL
    vpngroup xxxx dns-server 10.10.11.10 10.10.11.11
    vpngroup xxxx default-domain joby.local
    vpngroup xxxx split-tunnel joby_splitTunnelAcl
    vpngroup xxxx idle-time 1800
    vpngroup xxxx password

    Thanks for your help!

    -LB
    lbenes, Aug 4, 2006
    #1
    1. Advertising

  2. "lbenes" <> wrote:

    > I just setup my first PIX 501. I updated it to 6.3(5) and PDM 3.0(4). I
    > used the VPN wizard to make a client VPN, and it works perfectly when
    > my PC is connected directly to the internet (has a public IP). When I'm
    > behind a firewall, the VPN connects, but I cannot ping or connect to
    > any services behind the pix. And ideas?
    >
    > crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    > isakmp nat-traversal 20


    When Cisco VPN client tries to connect to a PIX it starts
    with IKE (UDP port 500). If there is no NAT then it tries
    the protocol specified in PIX (in your case that's ESP).
    If NAT is detected it switches to NAT-Traversal mode which
    means UDP port 4500. Does the firewall you are behind allow
    UDP/4500?
    Jyri Korhonen, Aug 4, 2006
    #2
    1. Advertising

  3. lbenes

    lbenes Guest

    My firewall does not have any special rules to forward port 4500. It
    does have the option to allow IPSec pass through enabled. Should I
    change the ipsec transform set? To what?

    thanks

    -LB
    Jyri Korhonen wrote:
    > "lbenes" <> wrote:
    >
    > > I just setup my first PIX 501. I updated it to 6.3(5) and PDM 3.0(4). I
    > > used the VPN wizard to make a client VPN, and it works perfectly when
    > > my PC is connected directly to the internet (has a public IP). When I'm
    > > behind a firewall, the VPN connects, but I cannot ping or connect to
    > > any services behind the pix. And ideas?
    > >
    > > crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    > > isakmp nat-traversal 20

    >
    > When Cisco VPN client tries to connect to a PIX it starts
    > with IKE (UDP port 500). If there is no NAT then it tries
    > the protocol specified in PIX (in your case that's ESP).
    > If NAT is detected it switches to NAT-Traversal mode which
    > means UDP port 4500. Does the firewall you are behind allow
    > UDP/4500?
    lbenes, Aug 4, 2006
    #3
  4. "lbenes" <> wrote:

    >>> I just setup my first PIX 501. I updated it to 6.3(5) and PDM 3.0(4). I
    >>> used the VPN wizard to make a client VPN, and it works perfectly when
    >>> my PC is connected directly to the internet (has a public IP). When I'm
    >>> behind a firewall, the VPN connects, but I cannot ping or connect to
    >>> any services behind the pix. And ideas?
    >>>
    >>> crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    >>> isakmp nat-traversal 20

    >>
    >> When Cisco VPN client tries to connect to a PIX it starts
    >> with IKE (UDP port 500). If there is no NAT then it tries
    >> the protocol specified in PIX (in your case that's ESP).
    >> If NAT is detected it switches to NAT-Traversal mode which
    >> means UDP port 4500. Does the firewall you are behind allow
    >> UDP/4500?

    >
    > My firewall does not have any special rules to forward port 4500. It
    > does have the option to allow IPSec pass through enabled. Should I
    > change the ipsec transform set? To what?


    The other transport protocol you can select in PIX is AH and
    that will not survive any kind of NAT. Protocol ESP will work
    if you have basic 1-to-1 NAT, but not with many-to-1 NAT (aka
    PAT, NAPT etc.). So I don't think that you can gain anything
    by changing the transform set.
    Jyri Korhonen, Aug 4, 2006
    #4
  5. lbenes

    AM Guest

    Jyri Korhonen wrote:


    >
    > The other transport protocol you can select in PIX is AH and
    > that will not survive any kind of NAT. Protocol ESP will work
    > if you have basic 1-to-1 NAT, but not with many-to-1 NAT (aka
    > PAT, NAPT etc.). So I don't think that you can gain anything
    > by changing the transform set.
    >


    I think that if the PIX uses AH the tunel should not get established (after a device doing NAT)

    Alex.
    AM, Aug 4, 2006
    #5
  6. lbenes

    lbenes Guest

    If I use the VPN wizard and create a private IP pool, say
    172.16.200.1-20, then the VPN group that it creates does not work under
    any condition. So I think this is definitely some kind of NAT'ing
    issue with the firewall. Does that help?

    lbenes wrote:
    > I just setup my first PIX 501. I updated it to 6.3(5) and PDM 3.0(4). I
    > used the VPN wizard to make a client VPN, and it works perfectly when
    > my PC is connected directly to the internet (has a public IP). When I'm
    > behind a firewall, the VPN connects, but I cannot ping or connect to
    > any services behind the pix. And ideas?
    >
    > : Saved
    > : Written by enable_15 at 10:12:23.732 UTC Fri Aug 4 2006
    > PIX Version 6.3(5)
    > interface ethernet0 auto
    > interface ethernet1 100full
    > nameif ethernet0 outside security0
    > nameif ethernet1 inside security100
    > fixup protocol dns maximum-length 512
    > fixup protocol ftp 21
    > fixup protocol h323 h225 1720
    > fixup protocol h323 ras 1718-1719
    > fixup protocol http 80
    > fixup protocol rsh 514
    > fixup protocol rtsp 554
    > fixup protocol sip 5060
    > fixup protocol sip udp 5060
    > fixup protocol skinny 2000
    > fixup protocol smtp 25
    > fixup protocol sqlnet 1521
    > fixup protocol tftp 69
    > names
    > access-list joby_splitTunnelAcl permit ip 10.10.11.0 255.255.255.0 any
    > access-list inside_outbound_nat0_acl permit ip 10.10.11.0 255.255.255.0
    > 10.10.11.192 255.255.255.192
    > access-list outside_cryptomap_dyn_20 permit ip any 10.10.11.192
    > 255.255.255.192
    > pager lines 24
    > mtu outside 1500
    > mtu inside 1500
    > ip address outside 70.x.x.x 255.255.255.248
    > ip address inside 10.10.11.2 255.255.255.0
    > ip audit info action alarm
    > ip audit attack action alarm
    > ip local pool REAL_VPN_IP_POOL 10.10.11.210-10.10.11.229
    > pdm logging informational 100
    > pdm history enable
    > arp timeout 14400
    > global (outside) 1 interface
    > nat (inside) 0 access-list inside_outbound_nat0_acl
    > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > route outside 0.0.0.0 0.0.0.0 70.x.x.x 1
    > timeout xlate 0:05:00
    > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > 1:00:00
    > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    > timeout uauth 0:05:00 absolute
    > aaa-server TACACS+ protocol tacacs+
    > aaa-server TACACS+ max-failed-attempts 3
    > aaa-server TACACS+ deadtime 10
    > aaa-server RADIUS protocol radius
    > aaa-server RADIUS max-failed-attempts 3
    > aaa-server RADIUS deadtime 10
    > aaa-server LOCAL protocol local
    > no snmp-server location
    > no snmp-server contact
    > snmp-server community public
    > no snmp-server enable traps
    > floodguard enable
    > sysopt connection permit-ipsec
    > crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    > crypto dynamic-map outside_dyn_map 20 match address
    > outside_cryptomap_dyn_20
    > crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    > crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    > crypto map outside_map interface outside
    > isakmp enable outside
    > isakmp nat-traversal 20
    > isakmp policy 20 authentication pre-share
    > isakmp policy 20 encryption 3des
    > isakmp policy 20 hash md5
    > isakmp policy 20 group 2
    > isakmp policy 20 lifetime 86400
    > vpngroup xxxx address-pool REAL_VPN_IP_POOL
    > vpngroup xxxx dns-server 10.10.11.10 10.10.11.11
    > vpngroup xxxx default-domain joby.local
    > vpngroup xxxx split-tunnel joby_splitTunnelAcl
    > vpngroup xxxx idle-time 1800
    > vpngroup xxxx password
    >
    > Thanks for your help!
    >
    > -LB
    lbenes, Aug 4, 2006
    #6
  7. In article <5%GAg.62638$>, AM <> wrote:
    >Jyri Korhonen wrote:


    >> The other transport protocol you can select in PIX is AH and
    >> that will not survive any kind of NAT. Protocol ESP will work
    >> if you have basic 1-to-1 NAT, but not with many-to-1 NAT (aka
    >> PAT, NAPT etc.).


    >I think that if the PIX uses AH the tunel should not get established
    >(after a device doing NAT)


    The Phase 1 tunnel will be established, because Phase 1 does not
    use AH. The security associations for the Phase 2 tunnel will
    also get more than half established, because AH is not required to
    exchange the SA information. The tunnel would, though, be unable
    to pass any traffic, and might not finish Phase 2.
    Walter Roberson, Aug 6, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. MP
    Replies:
    2
    Views:
    12,212
  2. Corbin O'Reilly
    Replies:
    2
    Views:
    3,094
    Corbin O'Reilly
    May 26, 2004
  3. Tomi
    Replies:
    3
    Views:
    1,917
  4. lbenes
    Replies:
    1
    Views:
    918
    lbenes
    Aug 7, 2006
  5. D K
    Replies:
    4
    Views:
    444
Loading...

Share This Page