VoIP - PRI between Definity G3 and 2611 Gateway

Discussion in 'Cisco' started by Rob, Nov 30, 2004.

  1. Rob

    Rob Guest

    Hi,

    I am having trouble getting a PRI up between an Avaya Definity G3 PBX
    and my 2611 voice gateway. I'm 99% sure I have the correct cable (a T1
    crossover cable) as Layer 1 of the PRI is active and port ser1/0:23
    shows "up up".

    My gateway is registered with CallManager just fine, but I'm pretty
    sure this is simply an ISDN issue. I have the PBX setup as ISDN "user"
    side and the 2611 as ISDN "network" side. We are using National/NI2.
    The Definity is configured as Country code 1, Protocol version a. Does
    anyone know if this is correct? Also, should the "Connect" version on
    the PBX be "pbx" or "line-side"??

    When I do a "show isdn status" the Layer 2 state of "TEI_ASSIGNED" is
    a problem in my mind - I think this should be
    "MULTIPLE_FRAME_ESTABLISHED."

    Thanks - Rob.


    Gateway1#sho isdn status
    Global ISDN Switchtype = primary-ni

    %Q.931 is backhauled to CCM-MANAGER on DSL 0. Layer 3 output may not
    apply

    ISDN Serial1/0:23 interface
    ******* Network side configuration *******
    dsl 0, interface ISDN Switchtype = primary-ni
    L2 Protocol = Q.921 L3 Protocol(s) = CCM-MANAGER
    Layer 1 Status:
    ACTIVE
    Layer 2 Status:
    TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
    0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 94
    Gateway1#
    Gateway1#
    Gateway1#
    Gateway1#sho ip int brief
    Interface IP-Address OK? Method Status
    Prot
    ocol
    FastEthernet0/0 10.10.4.50 YES NVRAM up
    up

    FastEthernet0/1 10.10.5.50 YES NVRAM up
    up

    Serial1/0:0 unassigned YES unset down
    down

    Serial1/0:1 unassigned YES unset down
    down

    Serial1/0:2 unassigned YES unset down
    down

    (snip)

    Serial1/0:21 unassigned YES unset down
    down

    Serial1/0:22 unassigned YES unset down
    down

    Serial1/0:23 unassigned YES NVRAM up
    up
    Gateway1#
    Gateway1#
    Gateway1#sho run

    (some non-relevant config snipped)

    !
    network-clock-participate slot 1
    no network-clock-participate wic 0
    network-clock-select 1 T1 1/0
    network-clock-select 2 T1 1/1
    !
    isdn switch-type primary-ni
    voice-card 1
    !
    ccm-manager redundant-host 10.219.16.1
    ccm-manager mgcp
    ccm-manager music-on-hold
    ccm-manager config server 10.219.16.1
    ccm-manager config
    !
    !
    controller T1 1/0
    framing esf
    fdl att
    linecode b8zs
    pri-group timeslots 1-24 service mgcp
    !
    interface Serial1/0:23
    no ip address
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    isdn bind-l3 ccm-manager
    no cdp enable
    !
    voice-port 1/0:23
    !
    mgcp
    mgcp call-agent 10.219.17.1 service-type mgcp version 0.1
    !
    dial-peer voice 1 pots
    application mgcpapp
    port 1/0:23
    !
    Rob, Nov 30, 2004
    #1
    1. Advertising

  2. This may get you closer to what you want. I have a PRI on a 3620.

    Brian LaVallee

    -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
    Cisco Internetwork Operating System Software
    IOS (tm) 3600 Software (C3620-IS-M), Version 12.3(1a), RELEASE SOFTWARE
    (fc1)
    Copyright (c) 1986-2003 by cisco Systems, Inc.
    Compiled Thu 05-Jun-03 17:53 by dchih
    Image text-base: 0x60008950, data-base: 0x6187C000

    ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)

    Router uptime is 10 weeks, 23 hours, 56 minutes
    System returned to ROM by power-on
    System image file is "flash:c3620-is-mz.123-1a.bin"

    cisco 3620 (R4700) processor (revision 0x81) with 59392K/6144K bytes of
    memory.
    Processor board ID 25119094
    R4700 CPU at 80Mhz, Implementation 33, Rev 1.0
    Bridging software.
    X.25 software, Version 3.0.0.
    Primary Rate ISDN software, Version 1.1.
    1 FastEthernet/IEEE 802.3 interface(s)
    1 Channelized T1/PRI port(s)
    DRAM configuration is 32 bits wide with parity disabled.
    29K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102
    -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=


    Current configuration : 1646 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Hostname
    !
    boot system flash c3620-is-mz.123-9.bin
    enable secret 5 xXxXxXxXxXxXxXxXxXxXxXxXxXxXxXxX
    enable password xXxXxXxX
    !
    voice-card 1
    !
    ip subnet-zero
    !
    ip name-server NNN.NNN.NNN.NNN
    !
    isdn switch-type primary-ni
    isdn voice-call-failure 0
    !
    voice hunt user-busy
    voice call carrier capacity active
    !
    voice service voip
    signaling forward unconditional
    fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
    sip
    !
    voice class codec 99
    codec preference 1 g711ulaw
    codec preference 2 g729r8
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    controller T1 1/0
    framing sf
    linecode ami
    !
    interface FastEthernet0/0
    ip address NNN.NNN.NNN.NNN 255.255.255.240
    speed auto
    full-duplex
    !
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 NNN.NNN.NNN.NNN
    !
    dialer-list 1 protocol ip permit
    !
    dial-peer cor custom
    !
    dial-peer voice 1 voip
    huntstop
    preference 2
    destination-pattern .T
    progress_ind setup enable 3
    no modem passthrough
    voice-class codec 99
    session protocol sipv2
    dtmf-relay rtp-nte
    no vad
    !
    dial-peer voice 2 pots
    preference 2
    application session
    destination-pattern ..........
    translate-outgoing called 300
    no digit-strip
    direct-inward-dial
    forward-digits all
    !
    sip-ua
    retry invite 2
    retry response 3
    retry bye 3
    retry prack 6
    timers expires 300000
    sip-server ipv4:NNN.NNN.NNN.NNN
    no transport tcp
    !
    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
    password 7 xXxXxXxXxXxXxX
    logging synchronous
    login
    !
    end

    "Rob" <> wrote in message
    news:...
    > Hi,
    >
    > I am having trouble getting a PRI up between an Avaya Definity G3 PBX
    > and my 2611 voice gateway. I'm 99% sure I have the correct cable (a T1
    > crossover cable) as Layer 1 of the PRI is active and port ser1/0:23
    > shows "up up".
    >
    > My gateway is registered with CallManager just fine, but I'm pretty
    > sure this is simply an ISDN issue. I have the PBX setup as ISDN "user"
    > side and the 2611 as ISDN "network" side. We are using National/NI2.
    > The Definity is configured as Country code 1, Protocol version a. Does
    > anyone know if this is correct? Also, should the "Connect" version on
    > the PBX be "pbx" or "line-side"??
    >
    > When I do a "show isdn status" the Layer 2 state of "TEI_ASSIGNED" is
    > a problem in my mind - I think this should be
    > "MULTIPLE_FRAME_ESTABLISHED."
    >
    > Thanks - Rob.
    >
    >
    > Gateway1#sho isdn status
    > Global ISDN Switchtype = primary-ni
    >
    > %Q.931 is backhauled to CCM-MANAGER on DSL 0. Layer 3 output may not
    > apply
    >
    > ISDN Serial1/0:23 interface
    > ******* Network side configuration *******
    > dsl 0, interface ISDN Switchtype = primary-ni
    > L2 Protocol = Q.921 L3 Protocol(s) = CCM-MANAGER
    > Layer 1 Status:
    > ACTIVE
    > Layer 2 Status:
    > TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    > Layer 3 Status:
    > 0 Active Layer 3 Call(s)
    > Active dsl 0 CCBs = 0
    > The Free Channel Mask: 0x807FFFFF
    > Number of L2 Discards = 0, L2 Session ID = 94
    > Gateway1#
    > Gateway1#
    > Gateway1#
    > Gateway1#sho ip int brief
    > Interface IP-Address OK? Method Status
    > Prot
    > ocol
    > FastEthernet0/0 10.10.4.50 YES NVRAM up
    > up
    >
    > FastEthernet0/1 10.10.5.50 YES NVRAM up
    > up
    >
    > Serial1/0:0 unassigned YES unset down
    > down
    >
    > Serial1/0:1 unassigned YES unset down
    > down
    >
    > Serial1/0:2 unassigned YES unset down
    > down
    >
    > (snip)
    >
    > Serial1/0:21 unassigned YES unset down
    > down
    >
    > Serial1/0:22 unassigned YES unset down
    > down
    >
    > Serial1/0:23 unassigned YES NVRAM up
    > up
    > Gateway1#
    > Gateway1#
    > Gateway1#sho run
    >
    > (some non-relevant config snipped)
    >
    > !
    > network-clock-participate slot 1
    > no network-clock-participate wic 0
    > network-clock-select 1 T1 1/0
    > network-clock-select 2 T1 1/1
    > !
    > isdn switch-type primary-ni
    > voice-card 1
    > !
    > ccm-manager redundant-host 10.219.16.1
    > ccm-manager mgcp
    > ccm-manager music-on-hold
    > ccm-manager config server 10.219.16.1
    > ccm-manager config
    > !
    > !
    > controller T1 1/0
    > framing esf
    > fdl att
    > linecode b8zs
    > pri-group timeslots 1-24 service mgcp
    > !
    > interface Serial1/0:23
    > no ip address
    > isdn switch-type primary-ni
    > isdn protocol-emulate network
    > isdn incoming-voice voice
    > isdn bind-l3 ccm-manager
    > no cdp enable
    > !
    > voice-port 1/0:23
    > !
    > mgcp
    > mgcp call-agent 10.219.17.1 service-type mgcp version 0.1
    > !
    > dial-peer voice 1 pots
    > application mgcpapp
    > port 1/0:23
    > !
    Brian LaVallee, Dec 3, 2004
    #2
    1. Advertising

  3. Rob

    mbawa Guest

    Hi,

    I am planning to inegrate a Definity PBX with a 2611 router .Can you send
    me the config for Definity and where should I port the PRI on Definity ?

    Thanks,
    Mike

    -------------------------------------
    Rob wrote:


    > Hi,


    > I am having trouble getting a PRI up between an Avaya Definity G3 PBX
    > and my 2611 voice gateway. I'm 99% sure I have the correct cable (a T1
    > crossover cable) as Layer 1 of the PRI is active and port ser1/0:23
    > shows "up up".


    > My gateway is registered with CallManager just fine, but I'm pretty
    > sure this is simply an ISDN issue. I have the PBX setup as ISDN
    > "user"
    > side and the 2611 as ISDN "network" side. We are using
    > National/NI2.
    > The Definity is configured as Country code 1, Protocol version a. Does
    > anyone know if this is correct? Also, should the "Connect"
    > version on
    > the PBX be "pbx" or "line-side"??


    > When I do a "show isdn status" the Layer 2 state of
    > "TEI_ASSIGNED" is
    > a problem in my mind - I think this should be
    > "MULTIPLE_FRAME_ESTABLISHED."


    > Thanks - Rob.



    > Gateway1#sho isdn status
    > Global ISDN Switchtype = primary-ni


    > %Q.931 is backhauled to CCM-MANAGER on DSL 0. Layer 3 output may not
    > apply


    > ISDN Serial1/0:23 interface
    > ******* Network side configuration *******
    > dsl 0, interface ISDN Switchtype = primary-ni
    > L2 Protocol = Q.921 L3 Protocol(s) = CCM-MANAGER
    > Layer 1 Status:
    > ACTIVE
    > Layer 2 Status:
    > TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    > Layer 3 Status:
    > 0 Active Layer 3 Call(s)
    > Active dsl 0 CCBs = 0
    > The Free Channel Mask: 0x807FFFFF
    > Number of L2 Discards = 0, L2 Session ID = 94
    > Gateway1#
    > Gateway1#
    > Gateway1#
    > Gateway1#sho ip int brief
    > Interface IP-Address OK? Method Status
    > Prot
    > ocol
    > FastEthernet0/0 10.10.4.50 YES NVRAM up
    > up


    > FastEthernet0/1 10.10.5.50 YES NVRAM up
    > up


    > Serial1/0:0 unassigned YES unset down
    > down


    > Serial1/0:1 unassigned YES unset down
    > down


    > Serial1/0:2 unassigned YES unset down
    > down


    > (snip)


    > Serial1/0:21 unassigned YES unset down
    > down


    > Serial1/0:22 unassigned YES unset down
    > down


    > Serial1/0:23 unassigned YES NVRAM up
    > up
    > Gateway1#
    > Gateway1#
    > Gateway1#sho run


    > (some non-relevant config snipped)


    > !
    > network-clock-participate slot 1
    > no network-clock-participate wic 0
    > network-clock-select 1 T1 1/0
    > network-clock-select 2 T1 1/1
    > !
    > isdn switch-type primary-ni
    > voice-card 1
    > !
    > ccm-manager redundant-host 10.219.16.1
    > ccm-manager mgcp
    > ccm-manager music-on-hold
    > ccm-manager config server 10.219.16.1
    > ccm-manager config
    > !
    > !
    > controller T1 1/0
    > framing esf
    > fdl att
    > linecode b8zs
    > pri-group timeslots 1-24 service mgcp
    > !
    > interface Serial1/0:23
    > no ip address
    > isdn switch-type primary-ni
    > isdn protocol-emulate network
    > isdn incoming-voice voice
    > isdn bind-l3 ccm-manager
    > no cdp enable
    > !
    > voice-port 1/0:23
    > !
    > mgcp
    > mgcp call-agent 10.219.17.1 service-type mgcp version 0.1
    > !
    > dial-peer voice 1 pots
    > application mgcpapp
    > port 1/0:23
    > !






    ##-----------------------------------------------#
    Article posted with Cabling-Design.com Newsgroup Archiv
    http://www.cabling-design.com/forum
    no-spam read and post WWW interface to your favorite newsgroup -
    comp.dcom.sys.cisco,comp.dcom.voice-over-ip - messages and counting
    ##-----------------------------------------------##
    mbawa, Feb 1, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jamal
    Replies:
    1
    Views:
    831
  2. Replies:
    0
    Views:
    606
  3. Sanal Kisi
    Replies:
    7
    Views:
    885
    Doug McIntyre
    May 1, 2006
  4. Rob
    Replies:
    2
    Views:
    3,116
    mbawa
    Feb 1, 2005
  5. Replies:
    1
    Views:
    1,841
    Someone
    May 1, 2005
Loading...

Share This Page