VOIP and QOS

Discussion in 'Cisco' started by mikeg001@gmail.com, Oct 1, 2007.

  1. Guest

    Hi,
    have limited knowledge of QOS and need to configure QOS on our
    2950s that's running our phone system asterisk, we are using a
    combination of polyocm and aastra sip phones.
    I hope like to configure QOS on and get rid of our current choppy
    calls - anyone can give me an idea or example of the commands I will
    use for QOS?
    , Oct 1, 2007
    #1
    1. Advertising

  2. luvsmecats Guest

    add this to your phone int. works fine for us. Also you will need qos on
    router as well.

    switchport priority extend cos 0

    <> wrote in message
    news:...
    > Hi,
    > have limited knowledge of QOS and need to configure QOS on our
    > 2950s that's running our phone system asterisk, we are using a
    > combination of polyocm and aastra sip phones.
    > I hope like to configure QOS on and get rid of our current choppy
    > calls - anyone can give me an idea or example of the commands I will
    > use for QOS?
    >
    luvsmecats, Oct 1, 2007
    #2
    1. Advertising

  3. Guest

    On Oct 1, 3:15 pm, "luvsmecats" <> wrote:
    > add this to your phone int. works fine for us. Also you will need qos on
    > router as well.
    >
    > switchport priority extend cos 0
    >
    > <> wrote in message
    >
    > news:...
    >
    > > Hi,
    > > have limited knowledge of QOS and need to configure QOS on our
    > > 2950s that's running our phone system asterisk, we are using a
    > > combination of polyocm and aastra sip phones.
    > > I hope like to configure QOS on and get rid of our current choppy
    > > calls - anyone can give me an idea or example of the commands I will
    > > use for QOS?


    Do i apply that to all my ports on my switch ?
    , Oct 1, 2007
    #3
  4. thort

    Joined:
    Sep 26, 2007
    Messages:
    35
    QoS needs to be applied to all the access ports that the phones are connected to, the trunk links that interconnect the switches, and the IP router(s).
    thort, Oct 1, 2007
    #4
  5. Guest

    On Oct 1, 3:47 pm, wrote:
    > On Oct 1, 3:15 pm, "luvsmecats" <> wrote:
    >
    >
    >
    > > add this to your phone int. works fine for us. Also you will need qos on
    > > router as well.

    >
    > > switchport priority extend cos 0

    >
    > > <> wrote in message

    >
    > >news:...

    >
    > > > Hi,
    > > > have limited knowledge of QOS and need to configure QOS on our
    > > > 2950s that's running our phone system asterisk, we are using a
    > > > combination of polyocm and aastra sip phones.
    > > > I hope like to configure QOS on and get rid of our current choppy
    > > > calls - anyone can give me an idea or example of the commands I will
    > > > use for QOS?

    >
    > Do i apply that to all my ports on my switch ?


    I think based on what i have seen this command is for cisco ip phones
    or will that work on any ip phone ?
    , Oct 2, 2007
    #5
  6. luvsmecats Guest

    We ar using it on Cisco phones but we also have customers that have a PBX
    and non Cisco phones. NP
    <> wrote in message
    news:...
    > On Oct 1, 3:47 pm, wrote:
    > > On Oct 1, 3:15 pm, "luvsmecats" <> wrote:
    > >
    > >
    > >
    > > > add this to your phone int. works fine for us. Also you will need qos

    on
    > > > router as well.

    > >
    > > > switchport priority extend cos 0

    > >
    > > > <> wrote in message

    > >
    > > >news:...

    > >
    > > > > Hi,
    > > > > have limited knowledge of QOS and need to configure QOS on our
    > > > > 2950s that's running our phone system asterisk, we are using a
    > > > > combination of polyocm and aastra sip phones.
    > > > > I hope like to configure QOS on and get rid of our current choppy
    > > > > calls - anyone can give me an idea or example of the commands I will
    > > > > use for QOS?

    > >
    > > Do i apply that to all my ports on my switch ?

    >
    > I think based on what i have seen this command is for cisco ip phones
    > or will that work on any ip phone ?
    >
    >
    luvsmecats, Oct 2, 2007
    #6
  7. Arthur Brain Guest

    wrote:
    > Hi,
    > have limited knowledge of QOS and need to configure QOS on our
    > 2950s that's running our phone system asterisk, we are using a
    > combination of polyocm and aastra sip phones.
    > I hope like to configure QOS on and get rid of our current choppy
    > calls - anyone can give me an idea or example of the commands I will
    > use for QOS?


    Originally, I enabled AutoQoS.

    Then, seeing that the automatic QoS configuration had
    mls qos trust cos,
    and all DSCP codes were being lost through trunk ports, I changed each
    interface to this:
    mls qos trust dscp

    After that, I was asked to configure QoS to specifically identify
    voice traffic and give it a high DSCP code and a 0 DSCP code for all
    other traffic, so I did this:

    !
    class-map match-all voice
    match access-group name voice.traffic
    !
    policy-map Assign.DSCP
    class voice
    set dscp ef
    !
    ip access-list extended voice.traffic
    permit ip 10.20.0.0 0.0.255.255 any
    !
    interface FastEthernet1/0/14
    switchport trunk encapsulation dot1q
    switchport mode trunk
    service-policy input Assign.DSCP
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    auto qos voip trust
    spanning-tree portfast
    !

    Having said that, if you don't know *why* the voice is "choppy", then
    chances are that QoS *won't* fix it - 99% of voice-quality problems
    will be caused by bad configuration of the voice system itself, and
    not the network (until you come to put it across WAN links).

    Get Wireshark onto the network and capture an entire phone call - the
    summarised rtp stream details will show you the number of lost packets
    (if any) as well as the average & maximum delays and jitter.

    Check your jitter-buffer settings are comfortably higher than the
    jitter shown in the rtp stream summary.
    Arthur Brain, Oct 4, 2007
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. TechGuy
    Replies:
    0
    Views:
    528
    TechGuy
    Sep 3, 2004
  2. ants

    VOIP and QOS

    ants, Jan 26, 2005, in forum: Cisco
    Replies:
    3
    Views:
    4,182
    Daniel Prinsloo - www.CherryFive.com
    Jan 26, 2005
  3. Bill F

    VoIP QoS and NAT

    Bill F, Feb 3, 2005, in forum: Cisco
    Replies:
    0
    Views:
    1,086
    Bill F
    Feb 3, 2005
  4. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,496
  5. dominix
    Replies:
    2
    Views:
    477
    dominix
    Feb 6, 2007
Loading...

Share This Page