Voice Port Echo

Discussion in 'VOIP' started by TexasMirty@gmail.com, May 2, 2006.

  1. Guest

    On a Cisco 2851 router / Call Manager Express, we have our T1 Voice
    line set as follows:

    In Gain is Set to 0 dB
    Out Attenuation is Set to 0 dB
    Echo Cancellation is enabled
    Echo Cancellation NLP mute is disabled
    Echo Cancellation NLP threshold is -21 dB
    Echo Cancel Coverage is set to 64 ms
    Echo Cancel worst case ERL is set to 6 dB

    We are getting a lot of echo on calls to external analog phones.

    We have tried different settings on the ERL, Echo Cancel Coverage,
    Input Gain and Output Attenuation. So far nothing works to diminish the
    echo. Cisco IOS version is 12.3(11).

    Please advise. Thank you.
     
    , May 2, 2006
    #1
    1. Advertising

  2. jay Guest

    Read up on how echo is formed. Its either feedback from the handset,
    where gain adjustments help minimise the 'applitude' of the echo - and
    the echo problem is therefore at how the remote end is setup (ie echo
    on one end ?) - the router can only do so much, but maybe you tweaking
    the end where the echo is ? instead of remote end ?

    The real killer is analog to digital points in the network. Like where
    you may have an E&M card to PABX ?
     
    jay, May 3, 2006
    #2
    1. Advertising

  3. Zeng Guest

    On 3 May 2006 01:56:59 -0700, "jay" <> wrote:

    >Read up on how echo is formed. Its either feedback from the handset,
    >where gain adjustments help minimise the 'applitude' of the echo - and
    >the echo problem is therefore at how the remote end is setup (ie echo
    >on one end ?) - the router can only do so much, but maybe you tweaking
    >the end where the echo is ? instead of remote end ?
    >
    >The real killer is analog to digital points in the network. Like where
    >you may have an E&M card to PABX ?


    Jay,
    E&M cards are 4-wire devices, i.e., they use a separate pair for tx
    audio and another pair for rcv audio with no hybrid involved.

    TexasMirty,
    I'm not sure about the Ciscos, but in PBX's and channel banks a 2db
    loss and 3db on some chl-banks would be recommended values for a
    Rcv-side loss-insertion.

    I know you said you've played around with those, but maybe by changing
    too many parameters in a short time you lost track of what was tried?

    Assuming the analog phones are called parties directly connected to a
    a Telco C.O., see the following:

    Aside from acoustic echo which is probably not your issue (the handset
    audio coupled back into mic element) the biggest offender is what's
    hitting you--the 2-wire analog set. It uses a device called a hybrid.
    Everytime you convert from 4-wire to two-wire, you need a "hybrid" to
    accomplish that transition. (handset is 4-wire; telco 'drop' line is
    2-wire. It's usually the impedance mismatches or challenges
    accentuated by the hybrid devices that contribute and ultimately cause
    the echo. The end-office E.O or C.O. has to take what arrives as a
    "4-wire" (a separate path each way in other words) circuit [between
    other Telco facilities i.e., that's how call gets there] and with the
    line-side interface convert it to a 2=wire 'drop' to run to the house
    or business. So, viewing it from the PSTN 'cloud' heading toward that
    line-side drop, there's two hybrids. One in the E.O. and another in
    the phone set. The whole point of this was not to place blame on the
    Telco ckts, but rather to offer an understanding. Furthermore, if you
    happen to place a call to an enterprise PBX that has digital trunks
    (local loops) and then on top of that have digital or 4-wire phones on
    the desk--then that will sound good; no echo.

    Try inserting a 2 db loss and see what happens.

    I can't believe I actually spent all this time doing that....must be
    feeling really generous :)

    Zeng
     
    Zeng, May 5, 2006
    #3
  4. Jonathan Guest

    <> wrote in message
    news:...
    > On a Cisco 2851 router / Call Manager Express, we have our T1 Voice
    > line set as follows:
    >
    > In Gain is Set to 0 dB
    > Out Attenuation is Set to 0 dB


    This is your problem.

    You need 6 dB of separation.

    > Echo Cancellation is enabled
    > Echo Cancellation NLP mute is disabled
    > Echo Cancellation NLP threshold is -21 dB
    > Echo Cancel Coverage is set to 64 ms
    > Echo Cancel worst case ERL is set to 6 dB
    >
    > We are getting a lot of echo on calls to external analog phones.
    >
    > We have tried different settings on the ERL, Echo Cancel Coverage,
    > Input Gain and Output Attenuation. So far nothing works to diminish the
    > echo. Cisco IOS version is 12.3(11).
    >
    > Please advise. Thank you.
    >


    Try this:

    Output-gain -3 dB
    Input Attenuation 3dB
    Echo Cancel Coverage 64



    Jonathan


    --
    NewsGuy.Com 30Gb $9.95 Carry Forward and On Demand Bandwidth
     
    Jonathan, May 14, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. craig judd

    echo echo echo

    craig judd, Sep 23, 2003, in forum: Computer Support
    Replies:
    1
    Views:
    539
    Miggsee
    Sep 23, 2003
  2. Sven Holm
    Replies:
    0
    Views:
    1,533
    Sven Holm
    Sep 7, 2003
  3. Sven Holm
    Replies:
    0
    Views:
    1,448
    Sven Holm
    Sep 9, 2003
  4. Voice Port Echo

    , May 2, 2006, in forum: Cisco
    Replies:
    2
    Views:
    1,768
    Jonathan
    May 14, 2006
  5. Replies:
    0
    Views:
    1,816
Loading...

Share This Page