VLAN Trunking/Routing Problem

Discussion in 'Cisco' started by mnkyb0i, Jun 26, 2007.

  1. mnkyb0i

    mnkyb0i

    Joined:
    Jun 25, 2007
    Messages:
    3
    I have a 2620 router, three 2900XL switches, a PIX506E and an ASA5510. The 2620 is acting as a router on a stick with the following interface config:

    interface FastEthernet0/0
    ip address 10.1.1.1 255.255.255.0
    no ip mroute-cache
    duplex auto
    speed 10
    !
    interface FastEthernet0/0.2
    encapsulation dot1Q 2
    ip address 10.1.2.1 255.255.255.0
    no ip redirects
    !
    interface FastEthernet0/0.3
    encapsulation dot1Q 3
    ip address 10.1.3.1 255.255.255.0
    no ip redirects
    !
    interface FastEthernet0/0.4
    encapsulation dot1Q 4
    ip address 10.1.4.1 255.255.255.0
    no ip redirects
    !
    interface FastEthernet0/0.5
    encapsulation dot1Q 5
    ip address 10.1.5.1 255.255.255.0
    no ip redirects
    !
    interface FastEthernet0/0.7
    encapsulation dot1Q 7
    ip address 10.1.7.1 255.255.255.0


    The ports on the switches that connect to the firewall and between one another are set up as dot1q trunk ports:

    interface FastEthernet0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !


    I can ping the router interface IP's from anywhere on the network and I can ping 10.1.3.254 (The internal PIX interface), but I can't ping the ASA Internal interface 10.1.4.254.

    I can't even ping from the ASA to the router interface IP 10.1.4.1. The physical connectivity between the Router and the ASA is ASA--Switch--Switch--Router. The PIX to Router connectivity is PIX--Switch--Switch--Router.

    So I am totally stumped.
     
    mnkyb0i, Jun 26, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. DaZZa
    Replies:
    0
    Views:
    674
    DaZZa
    Feb 16, 2004
  2. JohnD
    Replies:
    3
    Views:
    4,417
    stephen
    Dec 18, 2007
  3. Hkz
    Replies:
    1
    Views:
    680
  4. tman
    Replies:
    1
    Views:
    1,627
  5. Bob Simon

    VLAN Trunking and Routing Qs

    Bob Simon, Nov 18, 2008, in forum: Cisco
    Replies:
    5
    Views:
    1,520
    Stephen
    Nov 20, 2008
Loading...

Share This Page