VLAN routing on Catalyst 4006 with L3-module

Discussion in 'Cisco' started by Catalyst_user, Apr 4, 2005.

  1. Hello all

    I've got a Catalyst 4006 with Supervisor II and an WS-X4232-L3 routing
    module.
    At the moment it's still in a testing environment without any real
    router attached. I 've found some documentation about the module which
    tells me that InterVLAN routing should be possible. I've been trying
    for a week now, but still no routing between vlan's.

    Could anyone give me a sample configuration on how to route between
    vlan's with this setup and without a real router involved ?

    VLAN 1: 10.130.70.0/24
    VLAN 2: 10.130.71.0/24

    Part of Supervisor config:
    #vtp
    set vtp domain XXXXXXXXXX
    set vtp mode transparent
    set vlan 1 name default type ethernet mtu 1500 said 100001 state
    active
    set vlan 100 name RB-RD type ethernet mtu 1500 said 100100 state
    active
    #ip
    set interface sc0 1 10.130.70.251/255.255.255.0 10.130.70.255
    #module 1 : 2-port 1000BaseX Supervisor
    set trunk 1/1 on dot1q 1-1005,1025-4094
    set trunk 1/2 on dot1q 1-1005,1025-4094
    set port channel 1/1-2 mode on
    !
    #module 2 : 34-port Router Switch Card
    set vlan 100 2/19-34
    set trunk 2/1 on dot1q 1-1005,1025-4094
    set trunk 2/2 on dot1q 1-1005,1025-4094


    Part of WS-X4232-L3 config:
    interface Port-channel1
    no ip address
    no ip redirects
    ip directed-broadcast
    no ip mroute-cache
    hold-queue 300 in
    !
    interface Port-channel1.1
    description <<VLAN 1>>
    encapsulation dot1Q 1 native
    ip address 10.130.70.252 255.255.255.0
    no ip redirects
    no ip directed-broadcast
    no ip mroute-cache
    !
    interface Port-channel1.100
    description <<VLAN 100>>
    encapsulation dot1Q 100
    ip address 10.130.71.252 255.255.255.0
    no ip redirects
    no ip directed-broadcast
    no ip mroute-cache
    !
    interface GigabitEthernet3
    no ip address
    no ip directed-broadcast
    no negotiation auto
    channel-group 1
    !
    interface GigabitEthernet4
    no ip address
    no ip directed-broadcast
    no negotiation auto
    channel-group 1
    !

    Thx in advance
     
    Catalyst_user, Apr 4, 2005
    #1
    1. Advertising

  2. Catalyst_user

    thrill5 Guest

    I've never used a 4232 module before but a similar config that would work on
    a Catalyst 6k would be

    no interface port-channel 1.1
    no interface port-channel 1.2
    Interface vlan 1
    ip address 10.130.70.1 255.255.255.0

    Interface vlan 2
    ip address 10.130.71.1 255.255.255.0

    would be a start.

    Scott

    "Catalyst_user" <> wrote in message
    news:...
    > Hello all
    >
    > I've got a Catalyst 4006 with Supervisor II and an WS-X4232-L3 routing
    > module.
    > At the moment it's still in a testing environment without any real
    > router attached. I 've found some documentation about the module which
    > tells me that InterVLAN routing should be possible. I've been trying
    > for a week now, but still no routing between vlan's.
    >
    > Could anyone give me a sample configuration on how to route between
    > vlan's with this setup and without a real router involved ?
    >
    > VLAN 1: 10.130.70.0/24
    > VLAN 2: 10.130.71.0/24
    >
    > Part of Supervisor config:
    > #vtp
    > set vtp domain XXXXXXXXXX
    > set vtp mode transparent
    > set vlan 1 name default type ethernet mtu 1500 said 100001 state
    > active
    > set vlan 100 name RB-RD type ethernet mtu 1500 said 100100 state
    > active
    > #ip
    > set interface sc0 1 10.130.70.251/255.255.255.0 10.130.70.255
    > #module 1 : 2-port 1000BaseX Supervisor
    > set trunk 1/1 on dot1q 1-1005,1025-4094
    > set trunk 1/2 on dot1q 1-1005,1025-4094
    > set port channel 1/1-2 mode on
    > !
    > #module 2 : 34-port Router Switch Card
    > set vlan 100 2/19-34
    > set trunk 2/1 on dot1q 1-1005,1025-4094
    > set trunk 2/2 on dot1q 1-1005,1025-4094
    >
    >
    > Part of WS-X4232-L3 config:
    > interface Port-channel1
    > no ip address
    > no ip redirects
    > ip directed-broadcast
    > no ip mroute-cache
    > hold-queue 300 in
    > !
    > interface Port-channel1.1
    > description <<VLAN 1>>
    > encapsulation dot1Q 1 native
    > ip address 10.130.70.252 255.255.255.0
    > no ip redirects
    > no ip directed-broadcast
    > no ip mroute-cache
    > !
    > interface Port-channel1.100
    > description <<VLAN 100>>
    > encapsulation dot1Q 100
    > ip address 10.130.71.252 255.255.255.0
    > no ip redirects
    > no ip directed-broadcast
    > no ip mroute-cache
    > !
    > interface GigabitEthernet3
    > no ip address
    > no ip directed-broadcast
    > no negotiation auto
    > channel-group 1
    > !
    > interface GigabitEthernet4
    > no ip address
    > no ip directed-broadcast
    > no negotiation auto
    > channel-group 1
    > !
    >
    > Thx in advance
     
    thrill5, Apr 5, 2005
    #2
    1. Advertising

  3. Thx for the response thrill, although it's not a solution.
    I tried that before, but apparently the module doens't support that
    command.
    Here's the output:
    -----------------------------------------------------------------
    Router_Module#conf t
    Enter configuration commands, one per line. End with CNTL/Z.

    Router_Module(config)#int vlan ?
    <1-1000> Vlan interface number

    Router_Module(config)#int vlan 100
    ^
    % Invalid input detected at '^' marker.
    -----------------------------------------------------------------

    Maybe someone else has an idea about how to solve my problem ?

    One last remark, on my supervisor mod I get a certain error message
    over and over again when I'm changing the VLAN settings:

    2005 Mar 21 01:51:25 %SYS-3-MOD_ILCGSGNOREPLY:Exceeded max # of
    retries sending
    0x11b msg to ILC module 2
    2005 Mar 21 01:51:40 %SYS-3-MOD_ILCGSGNOREPLY:Exceeded max # of
    retries sending
    0x11b msg to ILC module 2
    2005 Mar 21 01:51:56 %SYS-3-MOD_ILCGSGNOREPLY:Exceeded max # of
    retries sending
    0x11b msg to ILC module 2

    Cisco explanation =>
    <<Error Message SYS-3-MOD_ILCGSGNOREPLY: Exceeded max # of retries
    sending 0x[hex] msg to ILC module [dec]

    Explanation This message indicates that the SCP message exchange
    between the NMP and the module exceeded the maximum number of retries.
    0x[hex] is the opcode in hexadecimal and [dec] is the module number.

    Recommended Action Verify that the module is online. If the problem
    persists, contact your technical support representative.>>

    The session (mod) 2 command to access the router module from
    supervisor doens't work either:
    switch (enable) session 2
    Trying IntlgLineCard-2...
    session: Unable to tunnel to IntlgLineCard-2 (57)

    I hope there's no link between the error messages and the fact that I
    can't ping from vlan 1 to vlan 100.


    "thrill5" <> wrote in message news:<>...
    > I've never used a 4232 module before but a similar config that would work on
    > a Catalyst 6k would be
    >
    > no interface port-channel 1.1
    > no interface port-channel 1.2
    > Interface vlan 1
    > ip address 10.130.70.1 255.255.255.0
    >
    > Interface vlan 2
    > ip address 10.130.71.1 255.255.255.0
    >
    > would be a start.
    >
    > Scott
     
    Catalyst_user, Apr 5, 2005
    #3
  4. Catalyst_user

    migrieb

    Joined:
    Nov 22, 2006
    Messages:
    1
    I am having eaxctly the same problem; I have recently taken over this device and the router-switch module was never used and now I want to use it... Let me know if you get a fix...

    I even get the same session error when trying access the router IOS..
    I can use the console port on the the router blade but cannot get connectivity to the other blades...
     
    migrieb, Nov 22, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rob
    Replies:
    1
    Views:
    617
  2. IHateSpam

    bootp on catalyst 4006 sup II ?

    IHateSpam, Mar 2, 2004, in forum: Cisco
    Replies:
    1
    Views:
    587
    Craig Johnson
    Mar 2, 2004
  3. AM
    Replies:
    1
    Views:
    1,745
  4. Catalyst_user

    TFTP from a Cisco Catalyst 4006 problem

    Catalyst_user, Mar 17, 2005, in forum: Cisco
    Replies:
    5
    Views:
    808
    Hansang Bae
    Mar 22, 2005
  5. Replies:
    3
    Views:
    763
Loading...

Share This Page