VLAN port with internet access can access only one vlan?

Discussion in 'Cisco' started by gooderthanyou@gmail.com, Apr 21, 2006.

  1. Guest

    I've been searching around for a while and have come up with more
    questions than answers

    I have two cisco switches (2950 and 3500) which are connected to
    eachother with a vlan 1 (default) and vlan 22.

    The vlan aspect is working fine as it should be, each switch is
    basically divied in half w/ half the ports on vlan 22 and half on vlan
    1. I have them trunked together and that works fine.

    Now on one switch I have my internet connection on a port.

    If I set the port to access mode and put in vlan 22 then vlan 22 has an
    internet connection
    If I put in vlan 1 then vlan 1 has the internet connection

    It will not let me put in vlan 1 & 22 at the same time!
    I have seen things such as ip-helper, which I don't think is a problem,
    apparently each machine is getting an ip address from the dhcp server
    (the router).

    Also I'm confused to as why a VLAN would have an IP address at all...
    what is the purpose? An example please? =)

    Here's the configuration file with the switch with internet connection
    port:


    ip subnet-zero
    no ip domain-lookup
    ip dhcp-server 192.168.2.1
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    !
    !
    interface FastEthernet0/1
    no ip address
    no cdp enable
    !
    interface FastEthernet0/2
    switchport access vlan 22
    no ip address
    no cdp enable
    !
    interface FastEthernet0/3
    no ip address
    no cdp enable
    !
    interface FastEthernet0/4
    no ip address
    no cdp enable
    !
    interface FastEthernet0/5
    no ip address
    no cdp enable
    !
    interface FastEthernet0/6
    no ip address
    no cdp enable
    !
    interface FastEthernet0/7
    no ip address
    no cdp enable
    !
    interface FastEthernet0/8
    no ip address
    no cdp enable
    !
    interface FastEthernet0/9
    no ip address
    no cdp enable
    !
    interface FastEthernet0/10
    no ip address
    no cdp enable
    !
    interface FastEthernet0/11
    switchport access vlan 22
    switchport mode trunk
    no ip address
    speed 100
    no cdp enable
    !
    interface FastEthernet0/12 --- Internet Connection in this port
    switchport mode access
    no ip address
    no cdp enable
    !
    interface Vlan1
    no ip address
    no ip route-cache
    shutdown
    !
    interface Vlan22
    ip address 192.168.2.3 255.255.255.0
    no ip route-cache
    !
    ip http server
    !
    no cdp run
    !
    line con 0
    !
    end
     
    , Apr 21, 2006
    #1
    1. Advertising

  2. In order to forward traffic between VLANs, you need something to
    perfrom routing. The 3500 is a multilayer switch, right? You will need
    to configure vlan interfaces and routing on the 3500 to support
    communication between vlans 1 and 22.

    You may also need some form of NAT as well.
     
    Mark Williams, Apr 21, 2006
    #2
    1. Advertising

  3. java321 Guest

    You need a L3 device to router traffic from both vlan 1 and vlan 22. Here
    are some suggestions:
    1) connect vlan 1 and 22 to different ports on the router (e.g. vlan 1 <->
    fa0/0 and vlan 22 <-> fa0/1)
    2)create a trunk port between router and the switch (define fastethernet
    subinterfaces)
    3) create layer 3 interfaces for vlan1 and 22 on the switch.

    Good luck
     
    java321, Apr 23, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?TWFyaw==?=

    can see each share folder/computer but only one can access?

    =?Utf-8?B?TWFyaw==?=, Jun 2, 2005, in forum: Wireless Networking
    Replies:
    5
    Views:
    2,778
    =?Utf-8?B?TWlrZVo=?=
    Jun 3, 2005
  2. avraham shir-el
    Replies:
    4
    Views:
    8,746
    avraham shir-el
    Jul 20, 2004
  3. JavierI
    Replies:
    0
    Views:
    753
    JavierI
    Nov 17, 2007
  4. Giuseppe
    Replies:
    11
    Views:
    1,418
  5. Replies:
    0
    Views:
    924
Loading...

Share This Page