VLAN Isolation

Discussion in 'Cisco' started by Nyerere, Mar 4, 2009.

  1. Nyerere

    Nyerere Guest

    I have two VLANs (10 & 20) configured on a Catakyst 2900 switch and a
    Cisco 1842 router. The configuration is as follows:

    Switch
    !
    interface
    FastEthernet0/18
    switchport access vlan10
    !
    interface
    FastEthernet0/19
    switchport access vlan
    20
    !
    interface
    FastEthernet0/24
    switchport mode trunk

    Router
    !
    interface
    FastEthernet0/0.10
    encapsulation dot1Q
    10
    ip address 192.168.10.1
    255.255.255.0
    !
    interface
    FastEthernet0/0.20
    encapsulation dot1Q
    20
    ip address 192.168.20.1 255.255.255.0
    !

    There is no routing protocol configured. I want to stop communication
    between VLAN 10 annd VLAN 20 and vice-versa. How's this possible?

    Regards
    Ayanda
     
    Nyerere, Mar 4, 2009
    #1
    1. Advertising

  2. Nyerere

    bod43 Guest

    On 4 Mar, 09:08, Nyerere <> wrote:
    >  I have two VLANs (10 & 20) configured on a Catakyst 2900 switch and a
    > Cisco 1842 router. The configuration is as follows:
    > Router
    > !
    > interface
    > FastEthernet0/0.10
    >  encapsulation dot1Q
    > 10
    >  ip address 192.168.10.1
    > 255.255.255.0
    > !
    > interface
    > FastEthernet0/0.20
    >  encapsulation dot1Q
    > 20
    >  ip address 192.168.20.1 255.255.255.0
    > !
    >
    > There is no routing protocol configured. I want to stop communication
    > between VLAN 10 annd VLAN 20 and vice-versa. How's this possible?


    You could have a look at:-

    ip access-list ACL.blocklocal.10.in
    deny ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
    permit ip any any

    ip access-list ACL.blocklocal.20.in
    deny ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
    permit ip any any

    int FastEthernet0/0.10
    ip access-g ACL.blocklocal.10.in in

    int FastEthernet0/0.20
    ip access-g ACL.blocklocal.20.in in
     
    bod43, Mar 4, 2009
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Paul

    VLAN or Not to VLAN

    Paul, Oct 27, 2003, in forum: Cisco
    Replies:
    0
    Views:
    596
  2. Neil Rowland

    Auxiliary VLAN V VLan

    Neil Rowland, Apr 13, 2004, in forum: Cisco
    Replies:
    1
    Views:
    598
    Phil Dotchon
    Apr 14, 2004
  3. PS2 gamer
    Replies:
    1
    Views:
    1,094
    Ivan Ostres
    May 28, 2004
  4. Active Vibration Isolation Systems

    , Jan 2, 2007, in forum: Digital Photography
    Replies:
    2
    Views:
    358
    Charles
    Jan 4, 2007
  5. Bababooey
    Replies:
    0
    Views:
    459
    Bababooey
    Jan 20, 2006
Loading...

Share This Page