vlan configuration not working

Discussion in 'Cisco' started by Daniel Eyholzer, Dec 23, 2004.

  1. Hi there


    I have two openbsd 3.6 hosts connected to a cisco catalyst 3550 series
    switch.

    OpenBSD host A: interface em1 192.168.134.90/29
    OpenBSD host B: interface em1 192.168.134.91/29

    Host A is connected on FE 0/1 port and host B on FE 0/2 port on the cisco
    switch. Both hosts are in vlan 1.

    interface FastEthernet0/1
    switchport mode dynamic desirable
    !
    interface FastEthernet0/2
    switchport mode dynamic desirable

    With this configuration both hosts can ping each other. Now I want to set
    up a trunk link on the cisco FE 0/2 port where host B is connected:

    interface FastEthernet0/2
    switchport trunk encapsulation dot1q
    switchport mode trunk

    hostB# ifconfig em1 delete
    hostB# ifconfig em1 up
    hostB# ifconfig vlan0 192.168.134.91 netmask 255.255.255.248 vlan 1 vlandev
    em1

    After this configuration change I can no longer ping from or to host B. Did
    I forget a configuration setting or what could be the problem?


    Thanks, Daniel
     
    Daniel Eyholzer, Dec 23, 2004
    #1
    1. Advertising

  2. Daniel Eyholzer

    PES Guest

    Daniel Eyholzer wrote:
    > Hi there
    >
    >
    > I have two openbsd 3.6 hosts connected to a cisco catalyst 3550 series
    > switch.
    >
    > OpenBSD host A: interface em1 192.168.134.90/29
    > OpenBSD host B: interface em1 192.168.134.91/29
    >
    > Host A is connected on FE 0/1 port and host B on FE 0/2 port on the cisco
    > switch. Both hosts are in vlan 1.
    >
    > interface FastEthernet0/1
    > switchport mode dynamic desirable
    > !
    > interface FastEthernet0/2
    > switchport mode dynamic desirable
    >
    > With this configuration both hosts can ping each other. Now I want to set
    > up a trunk link on the cisco FE 0/2 port where host B is connected:
    >
    > interface FastEthernet0/2
    > switchport trunk encapsulation dot1q
    > switchport mode trunk
    >
    > hostB# ifconfig em1 delete
    > hostB# ifconfig em1 up
    > hostB# ifconfig vlan0 192.168.134.91 netmask 255.255.255.248 vlan 1 vlandev
    > em1
    >
    > After this configuration change I can no longer ping from or to host B. Did
    > I forget a configuration setting or what could be the problem?
    >
    >
    > Thanks, Daniel


    I think the switch is expecting untagged packets at vlan 1 because it is
    the native vlan. By changing your configuration on the host you are
    likely tagging them as vlan 1. Try putting fa0/1 and 0/2 in vlan2 to
    test this.

    int fa0/1
    switchport mode access
    switchport access vlan 2

    int fa0/2
    switchport mode access
    switchport access vlan 2

    Test to make sure they can ping one another.

    Now take fa0/2 to a trunk

    interface FastEthernet0/2
    switchport trunk encapsulation dot1q
    switchport mode trunk



    hostB# ifconfig em1 delete
    hostB# ifconfig em1 up
    hostB# ifconfig vlan0 192.168.134.91 netmask 255.255.255.248 vlan 1
    vlandev em1

    You may also be able to change the native vlan as follows. This would
    make it expect to see vlan 1 packets tagged.

    int fa0/2
    switchport trunk native vlan 100

    --
    -------------------------
    Paul Stewart
    Lexnet Inc.
    Email address is in ROT13
     
    PES, Dec 23, 2004
    #2
    1. Advertising

  3. PES <> wrote:
    > I think the switch is expecting untagged packets at vlan 1 because it is
    > the native vlan. By changing your configuration on the host you are
    > likely tagging them as vlan 1. Try putting fa0/1 and 0/2 in vlan2 to
    > test this.


    Thanks! You are right, moving the hosts to another vlan than vlan 1 did
    solve the problem.


    Daniel
     
    Daniel Eyholzer, Dec 23, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RHJhZ29ueA==?=

    wifi not working on new hp, or not working after live update

    =?Utf-8?B?RHJhZ29ueA==?=, Oct 2, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    994
    =?Utf-8?B?RHJhZ29ueA==?=
    Oct 2, 2005
  2. Paul

    VLAN or Not to VLAN

    Paul, Oct 27, 2003, in forum: Cisco
    Replies:
    0
    Views:
    575
  3. Jack \(MVP-Networking\).

    Re: Windows Zero Configuration Not Working

    Jack \(MVP-Networking\)., Apr 2, 2007, in forum: Wireless Networking
    Replies:
    0
    Views:
    428
    Jack \(MVP-Networking\).
    Apr 2, 2007
  4. yoar_ind
    Replies:
    0
    Views:
    950
    yoar_ind
    Aug 27, 2007
  5. thegmanagain

    To vlan or to not vlan

    thegmanagain, May 8, 2008, in forum: Cisco
    Replies:
    2
    Views:
    578
    thegmanagain
    May 13, 2008
Loading...

Share This Page