VLAN and TRUNK on a c2960

Discussion in 'Cisco' started by BUZZ, Apr 12, 2006.

  1. BUZZ

    BUZZ Guest

    I need to configure a switch with VLAN ports and a few Trunk ports.
    It seems to work but I am a little unsure about the configuration. Have
    I missed something?
    Please se the configuration below:


    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname cisco-sw
    !
    enable secret 5 $1$WDrd$c9BBVIwpRdiVOxQSnsEEM/
    !
    no aaa new-model
    clock timezone UTC 1
    clock summer-time UTC recurring last Sun Mar 2:00 last Sun Oct 3:00
    ip subnet-zero
    !
    !
    !
    !
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface FastEthernet0/1
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/2
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/4
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/5
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/6
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/7
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/8
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/9
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/10
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/11
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/12
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/13
    description Trunk1
    switchport trunk native vlan 4
    switchport trunk allowed vlan 2-4
    switchport mode trunk
    switchport nonegotiate
    !
    interface FastEthernet0/14
    description Trunk1
    switchport trunk native vlan 4
    switchport trunk allowed vlan 2-4
    switchport mode trunk
    switchport nonegotiate
    !
    interface FastEthernet0/15
    description Trunk1
    switchport trunk native vlan 4
    switchport trunk allowed vlan 2-4
    switchport mode trunk
    switchport nonegotiate
    !
    interface FastEthernet0/16
    description Trunk1
    switchport trunk native vlan 4
    switchport trunk allowed vlan 2-4
    switchport mode trunk
    switchport nonegotiate
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface FastEthernet0/25
    !
    interface FastEthernet0/26
    !
    interface FastEthernet0/27
    !
    interface FastEthernet0/28
    !
    interface FastEthernet0/29
    !
    interface FastEthernet0/30
    !
    interface FastEthernet0/31
    !
    interface FastEthernet0/32
    !
    interface FastEthernet0/33
    !
    interface FastEthernet0/34
    !
    interface FastEthernet0/35
    !
    interface FastEthernet0/36
    !
    interface FastEthernet0/37
    !
    interface FastEthernet0/38
    !
    interface FastEthernet0/39
    !
    interface FastEthernet0/40
    !
    interface FastEthernet0/41
    !
    interface FastEthernet0/42
    !
    interface FastEthernet0/43
    !
    interface FastEthernet0/44
    !
    interface FastEthernet0/45
    switchport mode access
    !
    interface FastEthernet0/46
    switchport mode access
    !
    interface FastEthernet0/47
    switchport mode access
    !
    interface FastEthernet0/48
    description Admin InterFace
    switchport mode access
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
    ip address 192.168.1.50 255.255.255.0
    no ip route-cache
    !
    interface Vlan2
    no ip address
    no ip route-cache
    !
    ip default-gateway 10.0.0.1
    ip http server
    !
    control-plane
    !
    !
    line con 0
    line vty 0 4
    password pass
    login
    line vty 5 15
    password PASS
    login
    !
    !
    end
    BUZZ, Apr 12, 2006
    #1
    1. Advertising

  2. BUZZ

    dale Guest

    dale, Apr 12, 2006
    #2
    1. Advertising

  3. BUZZ

    BUZZ Guest

    dale wrote:
    > I would add the "switchport trunk encap dot1q" command to these ports as
    > well. Everything else looks good.
    >
    >


    This is all I can choose:

    cisco-sw(config-if)#switchport trunk ?
    allowed Set allowed VLAN characteristics when interface is in
    runking mode
    native Set trunking native characteristics when
    interface is in trunking mode
    pruning Set pruning VLAN characteristics when interface is in
    trunking mode
    BUZZ, Apr 12, 2006
    #3
  4. BUZZ

    Guest

    Hello,

    the configuration looks ok, except for the access ports, which should
    be configured with ' spanning-tree portfast' in order to prevent
    problems with machines getting access to the network (e.g. DHCP might
    time out if this is not configured):

    interface FastEthernet0/9
    switchport access vlan 3
    switchport mode access
    --> spanning-tree portfast

    HTH,

    GNT
    , Apr 12, 2006
    #4
  5. BUZZ

    BernieM Guest

    <> wrote in message
    news:...
    > Hello,
    >
    > the configuration looks ok, except for the access ports, which should
    > be configured with ' spanning-tree portfast' in order to prevent
    > problems with machines getting access to the network (e.g. DHCP might
    > time out if this is not configured):
    >
    > interface FastEthernet0/9
    > switchport access vlan 3
    > switchport mode access
    > --> spanning-tree portfast
    >
    > HTH,
    >
    > GNT
    >


    and in addition to this it's good configure bpduguard to avoid spanning-tree
    if another switch gets connected ...

    snanning-tree bpduguard enable

    BernieM
    BernieM, Apr 13, 2006
    #5
  6. BUZZ

    9walking Guest

    Also, if some or all of your trunked interfaces are going to the same
    switch, you should consider implementing etherchannel on the trunks
    going to the same remote switch to group them into one logical link.

    Scott
    9walking, Apr 13, 2006
    #6
  7. BUZZ

    BUZZ Guest

    9walking wrote:
    > Also, if some or all of your trunked interfaces are going to the same
    > switch, you should consider implementing etherchannel on the trunks
    > going to the same remote switch to group them into one logical link.
    >
    > Scott
    >

    Yes some of my trunks are going to the same host... What is etherchanal
    and do I have to use cisco in the other end?

    By the way, thank you all for your replys!

    Regards
    Martin
    BUZZ, Apr 13, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. martin
    Replies:
    1
    Views:
    1,068
    Everyman
    Oct 9, 2006
  2. Martin
    Replies:
    3
    Views:
    30,410
    Manie1982
    Apr 15, 2014
  3. Martin

    c2960 and GLC-SX-MM, no link

    Martin, Dec 10, 2007, in forum: Cisco
    Replies:
    6
    Views:
    997
    Martin
    Dec 13, 2007
  4. Thrill5
    Replies:
    2
    Views:
    2,085
    Thrill5
    Apr 20, 2009
  5. Michael T. Davis

    VLAN trunking protocol on C2960-S switches

    Michael T. Davis, Feb 10, 2012, in forum: Cisco
    Replies:
    2
    Views:
    1,405
    Markus Marquardt
    Feb 10, 2012
Loading...

Share This Page