Vista 64bit and System Mechanic

Discussion in 'Windows 64bit' started by =?Utf-8?B?UmF2eW5uZQ==?=, Mar 1, 2007.

  1. Hey all I know ths ma be in the wrong section, but I thought I would give it
    a try. Has anyone ever bought or installed the latest version of System
    mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    but I have been having trouble installing in the 64bit.
    The software will download, then starts the setup, as soon as it starts the
    setup, it does the updates, then it hangs after the update is finished. I
    really do like this program (paid for it too) and would like to have it
    work under x64 since the website said it is supported in 64bit Vista.
    If anyone has been having trouble before, and managed to get the sftware
    working, could you please tell me how? :)
    I almost thought of booting into safe mode then install to see if that would
    work. I have had antivirus off, firewall off, uac off and no change.

    Thanks.
     
    =?Utf-8?B?UmF2eW5uZQ==?=, Mar 1, 2007
    #1
    1. Advertising

  2. =?Utf-8?B?UmF2eW5uZQ==?=

    John Barnes Guest

    Some programs like that one require you to right click and run as
    administrator to install properly.

    "Ravynne" <> wrote in message
    news:D...
    > Hey all I know ths ma be in the wrong section, but I thought I would give
    > it
    > a try. Has anyone ever bought or installed the latest version of System
    > mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    > but I have been having trouble installing in the 64bit.
    > The software will download, then starts the setup, as soon as it starts
    > the
    > setup, it does the updates, then it hangs after the update is finished. I
    > really do like this program (paid for it too) and would like to have it
    > work under x64 since the website said it is supported in 64bit Vista.
    > If anyone has been having trouble before, and managed to get the sftware
    > working, could you please tell me how? :)
    > I almost thought of booting into safe mode then install to see if that
    > would
    > work. I have had antivirus off, firewall off, uac off and no change.
    >
    > Thanks.
     
    John Barnes, Mar 1, 2007
    #2
    1. Advertising

  3. Hi, thank you for your reply. I have done that, and even thought I should
    check the DEP settings. I will try again, but I am sure it will not go
    through.. I even turned off the UAC control to see if that will help.
    Any other suggestions would be appreciated :) Thanks.

    "John Barnes" wrote:

    > Some programs like that one require you to right click and run as
    > administrator to install properly.
    >
    > "Ravynne" <> wrote in message
    > news:D...
    > > Hey all I know ths ma be in the wrong section, but I thought I would give
    > > it
    > > a try. Has anyone ever bought or installed the latest version of System
    > > mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    > > but I have been having trouble installing in the 64bit.
    > > The software will download, then starts the setup, as soon as it starts
    > > the
    > > setup, it does the updates, then it hangs after the update is finished. I
    > > really do like this program (paid for it too) and would like to have it
    > > work under x64 since the website said it is supported in 64bit Vista.
    > > If anyone has been having trouble before, and managed to get the sftware
    > > working, could you please tell me how? :)
    > > I almost thought of booting into safe mode then install to see if that
    > > would
    > > work. I have had antivirus off, firewall off, uac off and no change.
    > >
    > > Thanks.

    >
    >
     
    =?Utf-8?B?UmF2eW5uZQ==?=, Mar 1, 2007
    #3
  4. =?Utf-8?B?UmF2eW5uZQ==?=

    John Barnes Guest

    The other point that is becoming obvious is that many programs that are
    labeled for Vista will only run or install on Vista86 and there is generally
    no warning. Microsoft has several such programs, but at least if you
    examine the fine print on the download site it tells you it isn't Vista64
    compatible. Apparently Microsoft has caved on the Vista designation.

    "Ravynne" <> wrote in message
    news:...
    >
    > Hi, thank you for your reply. I have done that, and even thought I should
    > check the DEP settings. I will try again, but I am sure it will not go
    > through.. I even turned off the UAC control to see if that will help.
    > Any other suggestions would be appreciated :) Thanks.
    >
    > "John Barnes" wrote:
    >
    >> Some programs like that one require you to right click and run as
    >> administrator to install properly.
    >>
    >> "Ravynne" <> wrote in message
    >> news:D...
    >> > Hey all I know ths ma be in the wrong section, but I thought I would
    >> > give
    >> > it
    >> > a try. Has anyone ever bought or installed the latest version of
    >> > System
    >> > mechanic and installed it in Vista 64 bit? I know it works in the 323
    >> > bit,
    >> > but I have been having trouble installing in the 64bit.
    >> > The software will download, then starts the setup, as soon as it starts
    >> > the
    >> > setup, it does the updates, then it hangs after the update is finished.
    >> > I
    >> > really do like this program (paid for it too) and would like to have
    >> > it
    >> > work under x64 since the website said it is supported in 64bit Vista.
    >> > If anyone has been having trouble before, and managed to get the
    >> > sftware
    >> > working, could you please tell me how? :)
    >> > I almost thought of booting into safe mode then install to see if that
    >> > would
    >> > work. I have had antivirus off, firewall off, uac off and no change.
    >> >
    >> > Thanks.

    >>
    >>
     
    John Barnes, Mar 1, 2007
    #4
  5. =?Utf-8?B?UmF2eW5uZQ==?=

    mikeyhsd Guest

    you can always ask the authors for assistance.

    @sport.rr.com

    "Ravynne" <> wrote in message news:D...
    Hey all I know ths ma be in the wrong section, but I thought I would give it
    a try. Has anyone ever bought or installed the latest version of System
    mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    but I have been having trouble installing in the 64bit.
    The software will download, then starts the setup, as soon as it starts the
    setup, it does the updates, then it hangs after the update is finished. I
    really do like this program (paid for it too) and would like to have it
    work under x64 since the website said it is supported in 64bit Vista.
    If anyone has been having trouble before, and managed to get the sftware
    working, could you please tell me how? :)
    I almost thought of booting into safe mode then install to see if that would
    work. I have had antivirus off, firewall off, uac off and no change.

    Thanks.
     
    mikeyhsd, Mar 2, 2007
    #5
  6. =?Utf-8?B?UmF2eW5uZQ==?=

    mike Guest

    On Thu, 1 Mar 2007 08:00:38 -0800, Ravynne
    <> wrote:

    >Hey all I know ths ma be in the wrong section, but I thought I would give it
    >a try. Has anyone ever bought or installed the latest version of System
    >mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    >but I have been having trouble installing in the 64bit.
    >The software will download, then starts the setup, as soon as it starts the
    >setup, it does the updates, then it hangs after the update is finished. I
    >really do like this program (paid for it too) and would like to have it
    >work under x64 since the website said it is supported in 64bit Vista.
    >If anyone has been having trouble before, and managed to get the sftware
    >working, could you please tell me how? :)
    >I almost thought of booting into safe mode then install to see if that would
    >work. I have had antivirus off, firewall off, uac off and no change.
    >
    >Thanks.



    I have exactly the same problem - I have tried to raise the problem
    with Iolo but their support system is truly terrible.

    I would recommend people consider not buying Iolo products until the
    level of support is improved.

    A very dissatisfied Iolo customer.
     
    mike, Mar 3, 2007
    #6
  7. =?Utf-8?B?UmF2eW5uZQ==?=

    John Barnes Guest

    Another product that was well supported and useful years ago with the
    originator, but after now several changes of ownership is like the products
    that end up in Norton's hands, worthless and unsupported. I used their
    System Suite for years and was very happy.


    "mike" <> wrote in message
    news:...
    > On Thu, 1 Mar 2007 08:00:38 -0800, Ravynne
    > <> wrote:
    >
    >>Hey all I know ths ma be in the wrong section, but I thought I would give
    >>it
    >>a try. Has anyone ever bought or installed the latest version of System
    >>mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    >>but I have been having trouble installing in the 64bit.
    >>The software will download, then starts the setup, as soon as it starts
    >>the
    >>setup, it does the updates, then it hangs after the update is finished. I
    >>really do like this program (paid for it too) and would like to have it
    >>work under x64 since the website said it is supported in 64bit Vista.
    >>If anyone has been having trouble before, and managed to get the sftware
    >>working, could you please tell me how? :)
    >>I almost thought of booting into safe mode then install to see if that
    >>would
    >>work. I have had antivirus off, firewall off, uac off and no change.
    >>
    >>Thanks.

    >
    >
    > I have exactly the same problem - I have tried to raise the problem
    > with Iolo but their support system is truly terrible.
    >
    > I would recommend people consider not buying Iolo products until the
    > level of support is improved.
    >
    > A very dissatisfied Iolo customer.
    >
     
    John Barnes, Mar 3, 2007
    #7
  8. Hey all, Iolo has just released a new update for System Mechanic. Thought you
    might want to know (those of you using System Mechanic) I have reported my
    problem twice, and they responded automatically with crap helps, then I
    recieved new email that there is a new version out that may help.. Hope you
    guys are able to get it working :)


    "John Barnes" wrote:

    > Another product that was well supported and useful years ago with the
    > originator, but after now several changes of ownership is like the products
    > that end up in Norton's hands, worthless and unsupported. I used their
    > System Suite for years and was very happy.
    >
    >
    > "mike" <> wrote in message
    > news:...
    > > On Thu, 1 Mar 2007 08:00:38 -0800, Ravynne
    > > <> wrote:
    > >
    > >>Hey all I know ths ma be in the wrong section, but I thought I would give
    > >>it
    > >>a try. Has anyone ever bought or installed the latest version of System
    > >>mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    > >>but I have been having trouble installing in the 64bit.
    > >>The software will download, then starts the setup, as soon as it starts
    > >>the
    > >>setup, it does the updates, then it hangs after the update is finished. I
    > >>really do like this program (paid for it too) and would like to have it
    > >>work under x64 since the website said it is supported in 64bit Vista.
    > >>If anyone has been having trouble before, and managed to get the sftware
    > >>working, could you please tell me how? :)
    > >>I almost thought of booting into safe mode then install to see if that
    > >>would
    > >>work. I have had antivirus off, firewall off, uac off and no change.
    > >>
    > >>Thanks.

    > >
    > >
    > > I have exactly the same problem - I have tried to raise the problem
    > > with Iolo but their support system is truly terrible.
    > >
    > > I would recommend people consider not buying Iolo products until the
    > > level of support is improved.
    > >
    > > A very dissatisfied Iolo customer.
    > >

    >
    >
     
    =?Utf-8?B?UmF2eW5uZQ==?=, Mar 11, 2007
    #8
  9. =?Utf-8?B?UmF2eW5uZQ==?=

    Theo Guest

    What is the point of your post? I cannot find anything on
    their web site that would lead one to believe they provide
    support for 64-bit Windows. Neither Win x64 nor Vista x64
    are listed as being supported.

    Ravynne wrote:
    > Hey all, Iolo has just released a new update for System Mechanic. Thought you
    > might want to know (those of you using System Mechanic) I have reported my
    > problem twice, and they responded automatically with crap helps, then I
    > recieved new email that there is a new version out that may help.. Hope you
    > guys are able to get it working :)
    >
    >
    > "John Barnes" wrote:
    >
    >> Another product that was well supported and useful years ago with the
    >> originator, but after now several changes of ownership is like the products
    >> that end up in Norton's hands, worthless and unsupported. I used their
    >> System Suite for years and was very happy.
    >>
    >>
    >> "mike" <> wrote in message
    >> news:...
    >>> On Thu, 1 Mar 2007 08:00:38 -0800, Ravynne
    >>> <> wrote:
    >>>
    >>>> Hey all I know ths ma be in the wrong section, but I thought I would give
    >>>> it
    >>>> a try. Has anyone ever bought or installed the latest version of System
    >>>> mechanic and installed it in Vista 64 bit? I know it works in the 323 bit,
    >>>> but I have been having trouble installing in the 64bit.
    >>>> The software will download, then starts the setup, as soon as it starts
    >>>> the
    >>>> setup, it does the updates, then it hangs after the update is finished. I
    >>>> really do like this program (paid for it too) and would like to have it
    >>>> work under x64 since the website said it is supported in 64bit Vista.
    >>>> If anyone has been having trouble before, and managed to get the sftware
    >>>> working, could you please tell me how? :)
    >>>> I almost thought of booting into safe mode then install to see if that
    >>>> would
    >>>> work. I have had antivirus off, firewall off, uac off and no change.
    >>>>
    >>>> Thanks.
    >>>
    >>> I have exactly the same problem - I have tried to raise the problem
    >>> with Iolo but their support system is truly terrible.
    >>>
    >>> I would recommend people consider not buying Iolo products until the
    >>> level of support is improved.
    >>>
    >>> A very dissatisfied Iolo customer.
    >>>

    >>
     
    Theo, Mar 11, 2007
    #9
  10. =?Utf-8?B?UmF2eW5uZQ==?=

    John Barnes Guest

    Count me out. Gave up on them back when they were Ontrack and were well
    supported by a great little start-up team. Their System Suite provided
    excellent AV protection (via TrendMicro) and many useful utilities well into
    the XP era. But it has been consistently downhill since the first sale.

    "Ravynne" <> wrote in message
    news:...
    > Hey all, Iolo has just released a new update for System Mechanic. Thought
    > you
    > might want to know (those of you using System Mechanic) I have reported
    > my
    > problem twice, and they responded automatically with crap helps, then I
    > recieved new email that there is a new version out that may help.. Hope
    > you
    > guys are able to get it working :)
    >
    >
    > "John Barnes" wrote:
    >
    >> Another product that was well supported and useful years ago with the
    >> originator, but after now several changes of ownership is like the
    >> products
    >> that end up in Norton's hands, worthless and unsupported. I used their
    >> System Suite for years and was very happy.
    >>
    >>
    >> "mike" <> wrote in message
    >> news:...
    >> > On Thu, 1 Mar 2007 08:00:38 -0800, Ravynne
    >> > <> wrote:
    >> >
    >> >>Hey all I know ths ma be in the wrong section, but I thought I would
    >> >>give
    >> >>it
    >> >>a try. Has anyone ever bought or installed the latest version of
    >> >>System
    >> >>mechanic and installed it in Vista 64 bit? I know it works in the 323
    >> >>bit,
    >> >>but I have been having trouble installing in the 64bit.
    >> >>The software will download, then starts the setup, as soon as it starts
    >> >>the
    >> >>setup, it does the updates, then it hangs after the update is finished.
    >> >>I
    >> >>really do like this program (paid for it too) and would like to have
    >> >>it
    >> >>work under x64 since the website said it is supported in 64bit Vista.
    >> >>If anyone has been having trouble before, and managed to get the
    >> >>sftware
    >> >>working, could you please tell me how? :)
    >> >>I almost thought of booting into safe mode then install to see if that
    >> >>would
    >> >>work. I have had antivirus off, firewall off, uac off and no change.
    >> >>
    >> >>Thanks.
    >> >
    >> >
    >> > I have exactly the same problem - I have tried to raise the problem
    >> > with Iolo but their support system is truly terrible.
    >> >
    >> > I would recommend people consider not buying Iolo products until the
    >> > level of support is improved.
    >> >
    >> > A very dissatisfied Iolo customer.
    >> >

    >>
    >>
     
    John Barnes, Mar 11, 2007
    #10
  11. I feel your pain with this package. Right after I switched to vista I also
    purchased the utility because it was "vista" certified. Boy was I wrong.
    Even with their update it refused to function. Luckily I purchased it at
    walmart so they refunded my money and I bought my next mistake windows
    liveonecare. Anyway I've also given up on them as a viable utility maker.
    Tis a shame because system mechanic pro 5 & 6 were great programs. I also
    recently made the move to vista ultimate 64 and find no utilities of this
    sort at all. Even liveonecare doesn't support 64 vista and I'm like what they
    hey ms? Don't even support your own os. What kind of garbage is that? But
    then again I get no support from creative labs for my x-fi fatal1ty sound
    card so somehow these things don't surprise me anymore.
     
    =?Utf-8?B?UHVmZm5zdHVmZg==?=, May 28, 2007
    #11
  12. =?Utf-8?B?UmF2eW5uZQ==?=

    mikeyhsd Guest

    what kind of utilities are you looking for.
    there are firewalls besides the built in one as well as several virus program that work great.







    "Puffnstuff" <> wrote in message news:...
    I feel your pain with this package. Right after I switched to vista I also
    purchased the utility because it was "vista" certified. Boy was I wrong.
    Even with their update it refused to function. Luckily I purchased it at
    walmart so they refunded my money and I bought my next mistake windows
    liveonecare. Anyway I've also given up on them as a viable utility maker.
    Tis a shame because system mechanic pro 5 & 6 were great programs. I also
    recently made the move to vista ultimate 64 and find no utilities of this
    sort at all. Even liveonecare doesn't support 64 vista and I'm like what they
    hey ms? Don't even support your own os. What kind of garbage is that? But
    then again I get no support from creative labs for my x-fi fatal1ty sound
    card so somehow these things don't surprise me anymore.
     
    mikeyhsd, May 29, 2007
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Adriano

    System Mechanic or System Mechanic Pro?

    Adriano, Sep 21, 2003, in forum: Computer Information
    Replies:
    0
    Views:
    910
    Adriano
    Sep 21, 2003
  2. *x@y*

    system mechanic:

    *x@y*, Nov 19, 2005, in forum: Computer Support
    Replies:
    10
    Views:
    687
    *x@y*
    Nov 21, 2005
  3. JF

    System Mechanic, problems?

    JF, Apr 11, 2006, in forum: Computer Support
    Replies:
    3
    Views:
    578
    JohnF
    Jun 9, 2006
  4. Charles Chambers

    XP 64bit and Vista 64bit questions

    Charles Chambers, Feb 19, 2007, in forum: Windows 64bit
    Replies:
    2
    Views:
    470
    S.SubZero
    Feb 20, 2007
  5. randalel
    Replies:
    3
    Views:
    922
    John Barnes
    Nov 26, 2008
Loading...

Share This Page