Video Conferencing Over a WAN

Discussion in 'Cisco' started by anthony.sweeney@gmail.com, Mar 8, 2008.

  1. Guest

    Hello, I am trying to troubleshoot poor video quality over a 2Mb WAN
    link (frame relay)
    The video is jerky and of relatively poor quality compared to the
    demonstration example. The hardware is Tandberg, the ip address of the
    box on network A is 172.16.1.16 and on network B it is 172.16.2.105.

    The cisco configs look fine to me, after some research on the internet
    it seems that the problem could well be autonegotiation of the
    ethernet ports connected to the Tandberg boxes (apparently they should
    be set to 100 /Full Duplex).

    I would be very grateful if someone could double check these configs
    for me just to be more sure that it is not a QoS problem!

    Thanks in advance.


    Configs (only relevant information presented) :

    Router A
    -------------

    ip multicast-routing

    class-map match-all video-fr
    match access-group 107
    class-map match-all video-in
    match access-group 106

    policy-map PBX
    class video-in
    set ip dscp 34
    class class-default
    set ip dscp 0

    policy-map LLQ
    class video-fr
    priority 384
    police cir 384000
    conform-action set-prec-transmit 6
    exceed-action drop
    violate-action drop

    class class-default
    fair-queue

    interface FastEthernet0/0
    ip address 172.16.1.5 255.255.255.0
    ip pim sparse-dense-mode
    speed 10
    half-duplex
    service-policy input PBX
    !
    interface Serial0/0
    bandwidth 2048
    no ip address
    encapsulation frame-relay IETF
    ip route-cache flow
    no ip mroute-cache
    no fair-queue
    frame-relay traffic-shaping
    frame-relay lmi-type ansi
    !
    interface Serial0/0.101 point-to-point
    ip unnumbered FastEthernet0/0
    ip pim sparse-dense-mode

    frame-relay interface-dlci 101
    class VOIPovFR
    !
    ip flow-export version 5
    ip flow-export destination 172.16.1.71 2048
    ip classless
    ip forward-protocol udp 1551
    ip route 0.0.0.0 0.0.0.0 172.16.1.8
    ip route 172.16.2.0 255.255.255.0 Serial0/0.101

    ip route 172.16.254.0 255.255.255.0 Serial0/0.101
    ip http server
    ip pim bidir-enable
    ip pim send-rp-announce FastEthernet0/0 scope 16
    ip pim send-rp-discovery FastEthernet0/0 scope 16

    map-class frame-relay VOIPovFR
    no frame-relay adaptive-shaping
    frame-relay cir 2048000
    frame-relay bc 20480
    frame-relay be 0
    frame-relay mincir 2048000
    service-policy output LLQ

    access-list 106 permit ip host 172.16.1.16 any
    access-list 107 permit ip any any dscp af41

    ---------------------------------------------------------------------------------------------------------------------

    Router B
    -------------


    class-map match-all video-fr
    match access-group 105
    class-map match-all video-in
    match access-group 106

    !
    !
    policy-map LLQ
    class video-fr
    priority 384
    police cir 384000
    conform-action set-prec-transmit 6
    exceed-action drop
    violate-action drop
    class class-default
    fair-queue

    policy-map pbx
    class video-in
    set ip dscp af41
    class class-default
    set ip dscp default
    !
    !
    !
    voice call carrier capacity active
    !
    !
    !
    !
    !
    !
    !
    !
    !
    mta receive maximum-recipients 0
    !
    !
    !
    interface FastEthernet0/0
    ip address 172.16.2.1 255.255.255.0
    ip helper-address 172.16.1.8
    ip helper-address 172.16.1.9
    ip helper-address 172.16.1.10
    ip helper-address 172.16.1.11
    ip helper-address 172.16.1.12
    ip helper-address 172.16.1.1
    ip helper-address 172.16.1.4
    ip route-cache flow
    no keepalive
    speed auto
    service-policy input pbx
    !
    interface Serial0/0
    bandwidth 2048
    no ip address
    encapsulation frame-relay IETF
    ip route-cache flow
    no fair-queue
    frame-relay traffic-shaping
    frame-relay lmi-type ansi
    !
    interface Serial0/0.101 point-to-point
    ip unnumbered FastEthernet0/0
    ip access-group 110 out
    frame-relay interface-dlci 101
    class VOIPovFR
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/0.101
    no ip http server
    ip flow-export version 5
    ip flow-export destination 172.16.1.71 2042
    !
    !
    !
    map-class frame-relay VOIPovFR
    frame-relay cir 2048000
    frame-relay bc 20480
    frame-relay be 0
    frame-relay mincir 2048000
    service-policy output LLQ

    access-list 105 permit ip any any dscp af41
    access-list 106 permit ip host 172.16.2.105 any
    , Mar 8, 2008
    #1
    1. Advertising

  2. Merv Guest

    not sure about the video stuff.

    the IP helpers that you have configured will send 7 copies of eachh
    UDP braodcast packet over you WAN

    ip helper-address 172.16.1.8
    ip helper-address 172.16.1.9
    ip helper-address 172.16.1.10
    ip helper-address 172.16.1.11
    ip helper-address 172.16.1.12
    ip helper-address 172.16.1.1
    ip helper-address 172.16.1.4


    also be aware that configured ip helpers also automatically enable the
    forwarding of the following UDP broadcasts:
    TFTP - port 69
    Domain Name System (DNS) - port 53
    Time service - port 37
    NetBIOS Name Server - port 137
    NetBIOS Datagram Server - port 138
    Bootstrap Protocol (BOOTP) - port 67
    TACACS - port 49


    see Cisco TAC article

    http://www.ciscotaccc.com/kaidara-advisor/iprout/showcase?case=K83798834


    do you have NETBIOS traffic tranversing your WAN ?

    do you have a WINS server ?


    Please post the output of show ip traffic and show interface from both
    routers


    you are also exporting netflow traffic across the WAN ???

    why not just collect it only on router A ?
    Merv, Mar 8, 2008
    #2
    1. Advertising

  3. Merv Guest

    you might want to test using a directed broadcast IP address
    with the ip helper to see if it provides you with the same
    functionality.

    If it does then you will only send a UDP forwarded braodcast once
    instead of 7 times.

    int fa 0/0
    ip helper 172.16.1.255
    Merv, Mar 8, 2008
    #3
  4. Guest

    Thanks for the replies, I will test out your suggestions. The config
    was not created by me, I am just in to troubleshoot it, so the actual
    in-depth setup of the network is unknown to me as yet.

    Thanks again!
    , Mar 17, 2008
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Melbourne

    IP-IP Gateway for Video Conferencing

    Matthew Melbourne, Oct 15, 2005, in forum: Cisco
    Replies:
    0
    Views:
    460
    Matthew Melbourne
    Oct 15, 2005
  2. rsjimmy
    Replies:
    3
    Views:
    7,909
    rsjimmy
    Mar 7, 2006
  3. skyper
    Replies:
    3
    Views:
    580
    Ivor Jones
    May 7, 2006
  4. Replies:
    0
    Views:
    614
  5. Theo Markettos

    VOIP over VPN over TCP over WAP over 3G

    Theo Markettos, Feb 3, 2008, in forum: UK VOIP
    Replies:
    2
    Views:
    809
    Theo Markettos
    Feb 14, 2008
Loading...

Share This Page