very simple cisco switch question

Discussion in 'Cisco' started by mina.moussa@hotmail.com, Nov 16, 2007.

  1. Guest

    hi guys why is it after i telnet into my cisco switch (3500) if i
    press "Set ?" it says "unrecognized command"

    ive tried this:

    conf t
    line vty 0 4
    password Cisco
    Login
    exit

    what am i doing wrong? the reason im doing this is to "set mls
    enable" ....

    thanx in advance
    Mina
     
    , Nov 16, 2007
    #1
    1. Advertising

  2. writes:
    >hi guys why is it after i telnet into my cisco switch (3500) if i
    >press "Set ?" it says "unrecognized command"


    set is a catos switch command. Both of the 35xx switch lines from
    Cisco run IOS.

    IOS switch code runs mls transparently.
     
    Doug McIntyre, Nov 16, 2007
    #2
    1. Advertising

  3. rogerz Guest

    On Nov 16, 12:21 pm, wrote:
    > hi guys why is it after i telnet into my cisco switch (3500) if i
    > press "Set ?" it says "unrecognized command"

    Did you input "enable" to enter priviledge exec mode?
    >
    > ive tried this:
    >
    > conf t
    > line vty 0 4
    > password Cisco
    > Login
    > exit
    >
    > what am i doing wrong? the reason im doing this is to "set mls
    > enable" ....
    >
    > thanx in advance
    > Mina
     
    rogerz, Nov 16, 2007
    #3
  4. Trendkill Guest

    On Nov 16, 6:46 am, rogerz <> wrote:
    > On Nov 16, 12:21 pm, wrote:> hi guys why is it after i telnet into my cisco switch (3500) if i
    > > press "Set ?" it says "unrecognized command"

    >
    > Did you input "enable" to enter priviledge exec mode?
    >
    >
    >
    > > ive tried this:

    >
    > > conf t
    > > line vty 0 4
    > > password Cisco
    > > Login
    > > exit

    >
    > > what am i doing wrong? the reason im doing this is to "set mls
    > > enable" ....

    >
    > > thanx in advance
    > > Mina


    I believe MLS is enabled by default, and the proper syntax on a per
    interface basis is:

    conf t
    int <interface>
    mls ip or no mls ip

    If this is for QoS purposes, the commands are no mls qos or mls qos.

    See section under "interface characteristics"
    http://www.cisco.com/en/US/docs/swi.../12.1_19_ea1/configuration/guide/3550scg.html

    Here is the config guide for the 3550, and the 3560
    http://www.cisco.com/en/US/docs/swi...se/12.1_12c_ea1/configuration/guide/SwCfg.pdf
    http://www.cisco.com/en/US/products...stallation_and_configuration_guides_list.html
     
    Trendkill, Nov 16, 2007
    #4
  5. Guest

    firstly this is an excellent forum, very quick replies, okay lets just
    takle the first problem:

    ive typed in "enable" and have gone into enable mode, and see the
    "Set" option when i type "?" but when I try use the "set" option it'll
    always say its unrecognized. I'd like to get the set command to work
    so i can use it for other purposes too ...


    we'll then go into why mls isnt working if i type conf t, int
    <interface> (this works then i type: ) mls qos (<< that says
    unrecognized)
     
    , Nov 18, 2007
    #5
  6. Guest

    ive set the mls priority through cisco network assistant for now by
    going:

    ports> port settings> then setting 802.1p priority to 6 as this is the
    priority i would like voice to have when leaving the port.


    but i defenitly want to knoww why i cant simply follow guides that
    display the "set" command from cisco documentation... why is set not
    working?

    im now trying to do this :

    (enable) set port auxiliaryVLAN 5/1-48 110


    taken from:

    http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080114aee.shtml
     
    , Nov 18, 2007
    #6
  7. Brian V Guest

    <> wrote in message
    news:...
    > ive set the mls priority through cisco network assistant for now by
    > going:
    >
    > ports> port settings> then setting 802.1p priority to 6 as this is the
    > priority i would like voice to have when leaving the port.
    >
    >
    > but i defenitly want to knoww why i cant simply follow guides that
    > display the "set" command from cisco documentation... why is set not
    > working?
    >
    > im now trying to do this :
    >
    > (enable) set port auxiliaryVLAN 5/1-48 110
    >
    >
    > taken from:
    >
    > http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080114aee.shtml


    Because the example is using a Catalyst 6500 running Cat OS. Completely
    different operating system.
     
    Brian V, Nov 18, 2007
    #7
  8. Trendkill Guest

    On Nov 17, 11:03 pm, "Brian V" <> wrote:
    > <> wrote in message
    >
    > news:...
    >
    >
    >
    > > ive set the mls priority through cisco network assistant for now by
    > > going:

    >
    > > ports> port settings> then setting 802.1p priority to 6 as this is the
    > > priority i would like voice to have when leaving the port.

    >
    > > but i defenitly want to knoww why i cant simply follow guides that
    > > display the "set" command from cisco documentation... why is set not
    > > working?

    >
    > > im now trying to do this :

    >
    > > (enable) set port auxiliaryVLAN 5/1-48 110

    >
    > > taken from:

    >
    > >http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note091...

    >
    > Because the example is using a Catalyst 6500 running Cat OS. Completely
    > different operating system.


    Yes, in short there are two OSes for switches. Catalyst is the older
    code that is on some of the more enterprise class switches, and IOS
    which is the same basic OS that is on routers. Cisco is gradually
    moving to IOS for everything, and enterprise class switches (like
    6500) have code sets for both (native ios = ios, hybrid = ios on msfc/
    router and catalyst code on switch side). So to answer your question,
    you need to find the config or command guide for your specific switch
    and specific code level. It appears that you are going off of a
    catalyst guide or information, and your switch is an IOS based switch
    such as a 2900, 3500. Hope this helps.
     
    Trendkill, Nov 18, 2007
    #8
  9. Guest

    thank you so much that helps :)
     
    , Nov 26, 2007
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rea Michaels
    Replies:
    2
    Views:
    641
    fearo
    Jul 21, 2004
  2. Amator
    Replies:
    3
    Views:
    361
    Hansang Bae
    Dec 23, 2005
  3. Thomas Reed

    Quick Book file access very very very slow

    Thomas Reed, Apr 9, 2004, in forum: Computer Support
    Replies:
    7
    Views:
    766
    Palindrome
    Apr 9, 2004
  4. Replies:
    7
    Views:
    4,265
    Kimba W. Lion
    Jan 26, 2007
  5. MeekiMoo
    Replies:
    0
    Views:
    664
    MeekiMoo
    Jul 28, 2009
Loading...

Share This Page