using the AUX port for dialing an ISP

Discussion in 'Cisco' started by Paul Cocker, Feb 2, 2005.

  1. Paul Cocker

    Paul Cocker Guest

    Hi, I'm trying to use the AUX port with a modem connected to dialup to an
    ISP. I know the connectivity to the modem is fine as I can reverse telnet
    to it and make it dial numbers with ATDT. I've setup the following config
    which I thought would kick the dialer into action when I pinged
    192.168.200.1 but it doesn't work.

    Can anyone shed any light on this for me please?

    Thanks
    Paul


    chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45
    CONNECT \c

    interface Async65
    no ip address
    ip nat outside
    encapsulation ppp
    dialer in-band
    dialer pool-member 20
    async default routing
    async mode dedicated

    interface Dialer10
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 20
    dialer idle-timeout 900
    dialer string <number deleted>
    ppp chap hostname <deleted>
    ppp chap password 7 <deleted>

    ip route 192.168.200.1 255.255.255.255 Dialer10

    line aux 0
    script dialer Dialout
    modem InOut
    modem autoconfigure type default
    transport input all
    stopbits 1
    speed 115200
    flowcontrol hardware
     
    Paul Cocker, Feb 2, 2005
    #1
    1. Advertising

  2. Paul Cocker

    Paul Cocker Guest

    I seem to have resolved this now.
    No reply needed.

    Thanks

    "Paul Cocker" <> wrote in message
    news:ctqric$le3$...
    > Hi, I'm trying to use the AUX port with a modem connected to dialup to an
    > ISP. I know the connectivity to the modem is fine as I can reverse telnet
    > to it and make it dial numbers with ATDT. I've setup the following config
    > which I thought would kick the dialer into action when I pinged
    > 192.168.200.1 but it doesn't work.
    >
    > Can anyone shed any light on this for me please?
    >
    > Thanks
    > Paul
    >
    >
    > chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45
    > CONNECT \c
    >
    > interface Async65
    > no ip address
    > ip nat outside
    > encapsulation ppp
    > dialer in-band
    > dialer pool-member 20
    > async default routing
    > async mode dedicated
    >
    > interface Dialer10
    > ip address negotiated
    > ip nat outside
    > encapsulation ppp
    > dialer pool 20
    > dialer idle-timeout 900
    > dialer string <number deleted>
    > ppp chap hostname <deleted>
    > ppp chap password 7 <deleted>
    >
    > ip route 192.168.200.1 255.255.255.255 Dialer10
    >
    > line aux 0
    > script dialer Dialout
    > modem InOut
    > modem autoconfigure type default
    > transport input all
    > stopbits 1
    > speed 115200
    > flowcontrol hardware
    >
     
    Paul Cocker, Feb 2, 2005
    #2
    1. Advertising

  3. You need "interesting traffic" - i.e.
    a dialer-group on your dialer interface pointing to
    a dialer-list.

    I think you're pretty good otherwise ... here's some
    debugs for you:

    debug dialer
    debug modem
    debug chat line 65
    debug ppp negotiation

    http://www.cisco.com/univercd/cc/td/doc/product/access/acs_fix/805/805swcfg/advscen.pdf
    has a pretty good sample config for you - see pp 4-15, 4-16.

    Cheers,

    Aaron

    ---

    ~ Hi, I'm trying to use the AUX port with a modem connected to dialup to an
    ~ ISP. I know the connectivity to the modem is fine as I can reverse telnet
    ~ to it and make it dial numbers with ATDT. I've setup the following config
    ~ which I thought would kick the dialer into action when I pinged
    ~ 192.168.200.1 but it doesn't work.
    ~
    ~ Can anyone shed any light on this for me please?
    ~
    ~ Thanks
    ~ Paul
    ~
    ~
    ~ chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45
    ~ CONNECT \c
    ~
    ~ interface Async65
    ~ no ip address
    ~ ip nat outside
    ~ encapsulation ppp
    ~ dialer in-band
    ~ dialer pool-member 20
    ~ async default routing
    ~ async mode dedicated
    ~
    ~ interface Dialer10
    ~ ip address negotiated
    ~ ip nat outside
    ~ encapsulation ppp
    ~ dialer pool 20
    ~ dialer idle-timeout 900
    ~ dialer string <number deleted>
    ~ ppp chap hostname <deleted>
    ~ ppp chap password 7 <deleted>
    ~
    ~ ip route 192.168.200.1 255.255.255.255 Dialer10
    ~
    ~ line aux 0
    ~ script dialer Dialout
    ~ modem InOut
    ~ modem autoconfigure type default
    ~ transport input all
    ~ stopbits 1
    ~ speed 115200
    ~ flowcontrol hardware
    ~
     
    Aaron Leonard, Feb 2, 2005
    #3
  4. Paul Cocker

    Paul Cocker Guest

    Thanks Aaron, appreciated.

    Paul


    "Aaron Leonard" <> wrote in message
    news:...
    > You need "interesting traffic" - i.e.
    > a dialer-group on your dialer interface pointing to
    > a dialer-list.
    >
    > I think you're pretty good otherwise ... here's some
    > debugs for you:
    >
    > debug dialer
    > debug modem
    > debug chat line 65
    > debug ppp negotiation
    >
    > http://www.cisco.com/univercd/cc/td/doc/product/access/acs_fix/805/805swcfg/advscen.pdf
    > has a pretty good sample config for you - see pp 4-15, 4-16.
    >
    > Cheers,
    >
    > Aaron
    >
    > ---
    >
    > ~ Hi, I'm trying to use the AUX port with a modem connected to dialup to
    > an
    > ~ ISP. I know the connectivity to the modem is fine as I can reverse
    > telnet
    > ~ to it and make it dial numbers with ATDT. I've setup the following
    > config
    > ~ which I thought would kick the dialer into action when I pinged
    > ~ 192.168.200.1 but it doesn't work.
    > ~
    > ~ Can anyone shed any light on this for me please?
    > ~
    > ~ Thanks
    > ~ Paul
    > ~
    > ~
    > ~ chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT
    > 45
    > ~ CONNECT \c
    > ~
    > ~ interface Async65
    > ~ no ip address
    > ~ ip nat outside
    > ~ encapsulation ppp
    > ~ dialer in-band
    > ~ dialer pool-member 20
    > ~ async default routing
    > ~ async mode dedicated
    > ~
    > ~ interface Dialer10
    > ~ ip address negotiated
    > ~ ip nat outside
    > ~ encapsulation ppp
    > ~ dialer pool 20
    > ~ dialer idle-timeout 900
    > ~ dialer string <number deleted>
    > ~ ppp chap hostname <deleted>
    > ~ ppp chap password 7 <deleted>
    > ~
    > ~ ip route 192.168.200.1 255.255.255.255 Dialer10
    > ~
    > ~ line aux 0
    > ~ script dialer Dialout
    > ~ modem InOut
    > ~ modem autoconfigure type default
    > ~ transport input all
    > ~ stopbits 1
    > ~ speed 115200
    > ~ flowcontrol hardware
    > ~
    >
     
    Paul Cocker, Feb 2, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tom Wu

    cisco aux port

    Tom Wu, Oct 25, 2003, in forum: Cisco
    Replies:
    5
    Views:
    17,225
    Phillip Remaker
    Oct 26, 2003
  2. erike
    Replies:
    2
    Views:
    1,366
    Guest
    Dec 31, 2003
  3. George Zaroubi

    AUX PORT

    George Zaroubi, Jan 22, 2004, in forum: Cisco
    Replies:
    6
    Views:
    2,742
    Jonathan Wilson
    Jan 27, 2004
  4. timJ

    Something's dialing my ISP

    timJ, Sep 10, 2004, in forum: Computer Security
    Replies:
    4
    Views:
    444
    AlanP
    Sep 14, 2004
  5. Giuen
    Replies:
    0
    Views:
    1,261
    Giuen
    Sep 12, 2008
Loading...

Share This Page