Using multiple outside interface with ip nat overload

Discussion in 'Cisco' started by Emanuel, Feb 17, 2004.

  1. Emanuel

    Emanuel Guest

    Hello,

    I am trying to figure out if it is possible to use more than one external
    interface with ip nat overload.

    This ist not the complete config, just a sample with the most inportant
    configuration tasks.

    eth0
    10.0.0.1 255.255.255.0
    ip nat inside

    bri0
    encapsulation ppp
    dialer pool-member 1
    dialer pool-member 2

    dialer1
    ip address negotiated
    ip nat outside
    dialer pool 1
    encapsulation ppp

    dialer2
    ip address negotiated
    ip nat outside
    dialer pool 2
    encapsulation ppp

    ip nat inside source list 101 dialer1 overload
    ip nat inside source list 102 dialer2 overload

    access-list 101 permit ip any any
    access-list 101 permit icmp any any
    access-list 102 permit ip any any
    access-list 102 permit icmp any any

    ip route 172.16.1.0 255.255.255.0 Dialer1
    ip route 172.16.2.0 255.255.255.0 Dialer2


    I tried it with a 800 and a 2500 cisco router with IOS 12.07 (T) without any
    success.
    If I have just one overload interface everything works fine, but I need to
    have two of them.

    Once again, I have 1x Eth and 1x BRI interface and want to use two
    overloaded Dialer.

    Thanks in advance,

    bye

    Emanuel
    Emanuel, Feb 17, 2004
    #1
    1. Advertising

  2. Emanuel

    Geert Guest

    Try this:

    access-list 101 permit ip any 172.16.1.0 0.0.0.255
    access-list 101 permit icmp any 172.16.1.0 0.0.0.255
    access-list 102 permit ip any 172.16.2.0 0.0.0.255
    access-list 102 permit icmp any 172.16.2.0 0.0.0.255

    ip route 172.16.1.0 255.255.255.0 Dialer1
    ip route 172.16.2.0 255.255.255.0 Dialer2

    -Geert

    Emanuel wrote:
    > Hello,
    >
    > I am trying to figure out if it is possible to use more than one external
    > interface with ip nat overload.
    >
    > This ist not the complete config, just a sample with the most inportant
    > configuration tasks.
    >
    > eth0
    > 10.0.0.1 255.255.255.0
    > ip nat inside
    >
    > bri0
    > encapsulation ppp
    > dialer pool-member 1
    > dialer pool-member 2
    >
    > dialer1
    > ip address negotiated
    > ip nat outside
    > dialer pool 1
    > encapsulation ppp
    >
    > dialer2
    > ip address negotiated
    > ip nat outside
    > dialer pool 2
    > encapsulation ppp
    >
    > ip nat inside source list 101 dialer1 overload
    > ip nat inside source list 102 dialer2 overload
    >
    > access-list 101 permit ip any any
    > access-list 101 permit icmp any any
    > access-list 102 permit ip any any
    > access-list 102 permit icmp any any
    >
    > ip route 172.16.1.0 255.255.255.0 Dialer1
    > ip route 172.16.2.0 255.255.255.0 Dialer2
    >
    >
    > I tried it with a 800 and a 2500 cisco router with IOS 12.07 (T) without any
    > success.
    > If I have just one overload interface everything works fine, but I need to
    > have two of them.
    >
    > Once again, I have 1x Eth and 1x BRI interface and want to use two
    > overloaded Dialer.
    >
    > Thanks in advance,
    >
    > bye
    >
    > Emanuel
    >
    >
    >
    Geert, Feb 25, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ronald de Leeuw
    Replies:
    2
    Views:
    14,204
  2. Replies:
    1
    Views:
    666
  3. skweetis
    Replies:
    0
    Views:
    1,174
    skweetis
    Dec 11, 2006
  4. Jack
    Replies:
    0
    Views:
    667
  5. jayteezer
    Replies:
    1
    Views:
    1,399
    bod43
    May 23, 2010
Loading...

Share This Page