Unstable Cisco Aironet 1231

Discussion in 'Cisco' started by Martin, Mar 12, 2007.

  1. Martin

    Martin Guest

    I have one Cisco Aironet 1231 access point. It does not use any kind of
    (server) functionality outside the Cisco device.
    I have one SSID and uses WPA-PSK (TKIP).

    The configuration seams wary straight forward, but something is wrong.
    The access point seams to be unstable. The clients use long time to
    connect to the access point and it looses connection a lot of times a
    day. Can I do something to speed up the “negotiation process” ?
    What could be the course of instability?

    The configuration was made with the “web configurator”, but I have a
    SSH/telnet dump:

    Best Regards
    Martin

    ---------------------------------------------------------------------------------



    AP1#sh run
    Building configuration...

    Current configuration : 2227 bytes
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname AP1
    !
    enable secret 5 $1$RnrI$w5mGlfNQAFToFgZMdXySR1
    !
    clock timezone GMT 1
    ip subnet-zero
    ip domain name mydom.com
    !
    !
    aaa new-model
    !
    !
    aaa group server radius rad_eap
    !
    aaa group server radius rad_mac
    !
    aaa group server radius rad_acct
    !
    aaa group server radius rad_admin
    !
    aaa group server tacacs+ tac_admin
    !
    aaa group server radius rad_pmip
    !
    aaa group server radius dummy
    !
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authorization exec default local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    !
    dot11 ssid myssid
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7 021705415A545C365F56584B561216085D5679
    !
    !
    !
    username Cisco password 7 14341B180F0B
    !
    bridge irb
    !
    !
    interface Dot11Radio0
    no ip address
    no ip route-cache
    !
    encryption mode ciphers tkip
    !
    ssid myssid
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0
    36.0 48.0 54.0
    channel 2412
    station-role root
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    !
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    no cdp enable
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    hold-queue 160 in
    !
    interface BVI1
    ip address 192.168.1.105 255.255.255.0
    no ip route-cache
    !
    ip http server
    no ip http secure-server
    ip http help-path
    http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1
    !
    access-list 111 permit tcp any any neq telnet
    no cdp run
    radius-server local
    no authentication leap
    no authentication mac
    !
    radius-server attribute 32 include-in-access-req format %h
    radius-server vsa send accounting
    !
    control-plane
    !
    bridge 1 route ip
    !
    !
    !
    line con 0
    access-class 111 in
    line vty 0 4
    access-class 111 in
    !
    sntp server 212.242.xx.207
    sntp broadcast client
    end

    AP1#
    Martin, Mar 12, 2007
    #1
    1. Advertising

  2. Martin,

    Your config looks fine. What could cause your clients' problems?
    Let's see ...

    - 802.11 interference from other nearby 802.11 devices
    - non-802.11 interference from other nearby 2.4GHz devices
    - flaky clients
    - poor RF coverage

    Tools to use here:

    - spectrum analysis
    - site survey tool
    - wireless sniffer
    - client debugs (driver dependent)

    Regards,

    Aaron

    ---

    ~ I have one Cisco Aironet 1231 access point. It does not use any kind of
    ~ (server) functionality outside the Cisco device.
    ~ I have one SSID and uses WPA-PSK (TKIP).
    ~
    ~ The configuration seams wary straight forward, but something is wrong.
    ~ The access point seams to be unstable. The clients use long time to
    ~ connect to the access point and it looses connection a lot of times a
    ~ day. Can I do something to speed up the “negotiation process” ?
    ~ What could be the course of instability?
    ~
    ~ The configuration was made with the “web configurator”, but I have a
    ~ SSH/telnet dump:
    ~
    ~ Best Regards
    ~ Martin
    ~
    ~ ---------------------------------------------------------------------------------
    ~
    ~
    ~
    ~ AP1#sh run
    ~ Building configuration...
    ~
    ~ Current configuration : 2227 bytes
    ~ !
    ~ version 12.3
    ~ no service pad
    ~ service timestamps debug datetime msec
    ~ service timestamps log datetime msec
    ~ service password-encryption
    ~ !
    ~ hostname AP1
    ~ !
    ~ enable secret 5 $1$RnrI$w5mGlfNQAFToFgZMdXySR1
    ~ !
    ~ clock timezone GMT 1
    ~ ip subnet-zero
    ~ ip domain name mydom.com
    ~ !
    ~ !
    ~ aaa new-model
    ~ !
    ~ !
    ~ aaa group server radius rad_eap
    ~ !
    ~ aaa group server radius rad_mac
    ~ !
    ~ aaa group server radius rad_acct
    ~ !
    ~ aaa group server radius rad_admin
    ~ !
    ~ aaa group server tacacs+ tac_admin
    ~ !
    ~ aaa group server radius rad_pmip
    ~ !
    ~ aaa group server radius dummy
    ~ !
    ~ aaa authentication login eap_methods group rad_eap
    ~ aaa authentication login mac_methods local
    ~ aaa authorization exec default local
    ~ aaa accounting network acct_methods start-stop group rad_acct
    ~ aaa session-id common
    ~ !
    ~ dot11 ssid myssid
    ~ authentication open
    ~ authentication key-management wpa
    ~ guest-mode
    ~ wpa-psk ascii 7 021705415A545C365F56584B561216085D5679
    ~ !
    ~ !
    ~ !
    ~ username Cisco password 7 14341B180F0B
    ~ !
    ~ bridge irb
    ~ !
    ~ !
    ~ interface Dot11Radio0
    ~ no ip address
    ~ no ip route-cache
    ~ !
    ~ encryption mode ciphers tkip
    ~ !
    ~ ssid myssid
    ~ !
    ~ speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0
    ~ 36.0 48.0 54.0
    ~ channel 2412
    ~ station-role root
    ~ no cdp enable
    ~ bridge-group 1
    ~ bridge-group 1 subscriber-loop-control
    ~ bridge-group 1 block-unknown-source
    ~ no bridge-group 1 source-learning
    ~ no bridge-group 1 unicast-flooding
    ~ bridge-group 1 spanning-disabled
    ~ !
    ~ interface FastEthernet0
    ~ no ip address
    ~ no ip route-cache
    ~ duplex auto
    ~ speed auto
    ~ no cdp enable
    ~ bridge-group 1
    ~ no bridge-group 1 source-learning
    ~ bridge-group 1 spanning-disabled
    ~ hold-queue 160 in
    ~ !
    ~ interface BVI1
    ~ ip address 192.168.1.105 255.255.255.0
    ~ no ip route-cache
    ~ !
    ~ ip http server
    ~ no ip http secure-server
    ~ ip http help-path
    ~ http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ~ ip radius source-interface BVI1
    ~ !
    ~ access-list 111 permit tcp any any neq telnet
    ~ no cdp run
    ~ radius-server local
    ~ no authentication leap
    ~ no authentication mac
    ~ !
    ~ radius-server attribute 32 include-in-access-req format %h
    ~ radius-server vsa send accounting
    ~ !
    ~ control-plane
    ~ !
    ~ bridge 1 route ip
    ~ !
    ~ !
    ~ !
    ~ line con 0
    ~ access-class 111 in
    ~ line vty 0 4
    ~ access-class 111 in
    ~ !
    ~ sntp server 212.242.xx.207
    ~ sntp broadcast client
    ~ end
    ~
    ~ AP1#
    Aaron Leonard, Mar 13, 2007
    #2
    1. Advertising

  3. Martin

    mak Guest

    Aaron Leonard wrote:

    > Tools to use here:
    >
    > - spectrum analysis


    any recomendation here?
    i would like to know what you are using.

    M
    mak, Mar 14, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Wil

    Aironet 1231 config

    Wil, Jul 23, 2005, in forum: Cisco
    Replies:
    4
    Views:
    7,150
    Uli Link
    Jul 23, 2005
  2. Munama

    Configuring Cisco Aironet 1231

    Munama, Jul 11, 2008, in forum: Cisco
    Replies:
    0
    Views:
    1,720
    Munama
    Jul 11, 2008
  3. Replies:
    0
    Views:
    457
  4. Replies:
    2
    Views:
    892
    Uli Link
    Sep 7, 2008
  5. Technolix

    Cisco Aironet 1231 setup TFTP

    Technolix, Mar 4, 2010, in forum: Cisco
    Replies:
    0
    Views:
    2,597
    Technolix
    Mar 4, 2010
Loading...

Share This Page