Two routers IGRP/OSPF problem

Discussion in 'Cisco' started by Simon Chamberlain, Jan 16, 2004.

  1. Hello,

    Can anyone figure this out? There are two Routers (1 and 2) connected via
    the serial ports. Router1 is running IGRP and Router2 is running OSPF and
    IGRP. On Router 2 OSPF is redistributed in IGRP and vice-versa. According to
    the book I have with the following configuration I should be able to ping
    the loopback interfaces and the ethernet interface on the opposite router.
    Can you spot what I'm doing wrong? The configs are below:

    Thanks,
    Simon


    Router1#show run
    Building configuration...

    Current configuration : 745 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router1
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 131.108.4.1 255.255.255.0
    !
    interface Loopback1
    ip address 131.108.5.1 255.255.255.0
    !
    interface Loopback2
    ip address 131.108.6.1 255.255.255.0
    !
    interface Ethernet0
    ip address 131.108.1.1 255.255.255.0
    !
    interface Ethernet1
    no ip address
    shutdown
    !
    interface Serial0
    ip address 131.108.3.1 255.255.255.0
    !
    interface Serial1
    no ip address
    shutdown
    !
    router igrp 1
    network 131.108.0.0
    !
    ip classless
    ip http server
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    end

    Router2#show run
    Building configuration...

    Current configuration : 1420 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router2
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 131.108.7.1 255.255.255.255
    !
    interface Loopback1
    ip address 131.108.8.1 255.255.255.255
    !
    interface Loopback2
    ip address 131.108.9.1 255.255.255.255
    !
    interface Ethernet0
    ip address 131.108.8.129 255.255.255.128
    !
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    !
    interface Serial1
    ip address 131.108.3.2 255.255.255.0
    clockrate 64000
    !
    interface Serial2
    no ip address
    shutdown
    !
    interface Serial3
    no ip address
    shutdown
    !
    interface BRI0
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    summary-address 131.108.9.0 255.255.255.0
    summary-address 131.108.7.0 255.255.255.0
    summary-address 131.108.8.0 255.255.255.0
    redistribute connected subnets
    redistribute igrp 1 metric 1 subnets
    network 131.108.7.1 0.0.0.0 area 0
    network 131.108.8.1 0.0.0.0 area 0
    network 131.108.8.129 0.0.0.0 area 0
    network 131.108.9.1 0.0.0.0 area 0
    !
    router igrp 1
    redistribute ospf 1 metric 64 20000 255 1 1500
    passive-interface Ethernet0
    passive-interface Loopback0
    passive-interface Loopback1
    passive-interface Loopback2
    network 131.108.0.0
    !
    ip classless
    ip http server
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    end

    Router1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
    area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    131.108.0.0/24 is subnetted, 5 subnets
    C 131.108.6.0 is directly connected, Loopback2
    C 131.108.5.0 is directly connected, Loopback1
    C 131.108.4.0 is directly connected, Loopback0
    C 131.108.3.0 is directly connected, Serial0
    C 131.108.1.0 is directly connected, Ethernet0
    Router1#

    Router2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
    area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    131.108.0.0/16 is variably subnetted, 9 subnets, 3 masks
    C 131.108.8.128/25 is directly connected, Ethernet0
    C 131.108.8.1/32 is directly connected, Loopback1
    C 131.108.9.1/32 is directly connected, Loopback2
    I 131.108.6.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    C 131.108.7.1/32 is directly connected, Loopback0
    I 131.108.5.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    I 131.108.4.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    C 131.108.3.0/24 is directly connected, Serial1
    I 131.108.1.0/24 [100/8576] via 131.108.3.1, 00:00:41, Serial1
    Router2#
    Simon Chamberlain, Jan 16, 2004
    #1
    1. Advertising

  2. Simon Chamberlain

    ETLALAR Guest

    Have a look at this http://www.cisco.com/warp/public/105/54.html , section
    General Behavior
    Sending Updates
    line 5

    - and compare R2 E0/Loopback netmasks and R2 S0 netmask.
    HTH,
    Cheers
    Alex

    "Simon Chamberlain" <> wrote in message
    news:bu915c$83j$...
    > Hello,
    >
    > Can anyone figure this out? There are two Routers (1 and 2) connected via
    > the serial ports. Router1 is running IGRP and Router2 is running OSPF and
    > IGRP. On Router 2 OSPF is redistributed in IGRP and vice-versa. According

    to
    > the book I have with the following configuration I should be able to ping
    > the loopback interfaces and the ethernet interface on the opposite router.
    > Can you spot what I'm doing wrong? The configs are below:
    >
    > Thanks,
    > Simon
    >
    >

    [snip]
    ETLALAR, Jan 16, 2004
    #2
    1. Advertising

  3. Simon Chamberlain

    firemarsh Guest

    Does anything change when you give each router a default gateway, or a
    default route?

    ip default-gateway xxx.yyy.zzz.bbb (where xxx.yyy.zzz.bbb is the next hop if
    not found in the routing tables)
    or
    ip route 0.0.0.0 0.0.0.0 xxx.yyy.zzz.bbb (next logical hop)
    also where are the following entries on your router 1, I think you have to
    tell igrp to advertise them with this, but I am not sure:
    > passive-interface Ethernet0
    > passive-interface Loopback0
    > passive-interface Loopback1
    > passive-interface Loopback2


    they all fall under the igrp 1 configs on your router 2...
    my 2 cents.



    --
    Roger Hilt
    Network Infrastructure Technician
    Langley, AFB VA
    "Simon Chamberlain" <> wrote in message
    news:bu915c$83j$...
    > Hello,
    >
    > Can anyone figure this out? There are two Routers (1 and 2) connected via
    > the serial ports. Router1 is running IGRP and Router2 is running OSPF and
    > IGRP. On Router 2 OSPF is redistributed in IGRP and vice-versa. According

    to
    > the book I have with the following configuration I should be able to ping
    > the loopback interfaces and the ethernet interface on the opposite router.
    > Can you spot what I'm doing wrong? The configs are below:
    >
    > Thanks,
    > Simon
    >
    >
    > Router1#show run
    > Building configuration...
    >
    > Current configuration : 745 bytes
    > !
    > version 12.1
    > no service single-slot-reload-enable
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Router1
    > !
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > !
    > !
    > !
    > interface Loopback0
    > ip address 131.108.4.1 255.255.255.0
    > !
    > interface Loopback1
    > ip address 131.108.5.1 255.255.255.0
    > !
    > interface Loopback2
    > ip address 131.108.6.1 255.255.255.0
    > !
    > interface Ethernet0
    > ip address 131.108.1.1 255.255.255.0
    > !
    > interface Ethernet1
    > no ip address
    > shutdown
    > !
    > interface Serial0
    > ip address 131.108.3.1 255.255.255.0
    > !
    > interface Serial1
    > no ip address
    > shutdown
    > !
    > router igrp 1
    > network 131.108.0.0
    > !
    > ip classless
    > ip http server
    > !
    > !
    > !
    > line con 0
    > exec-timeout 0 0
    > logging synchronous
    > line aux 0
    > line vty 0 4
    > !
    > end
    >
    > Router2#show run
    > Building configuration...
    >
    > Current configuration : 1420 bytes
    > !
    > version 12.1
    > no service single-slot-reload-enable
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Router2
    > !
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > !
    > !
    > !
    > interface Loopback0
    > ip address 131.108.7.1 255.255.255.255
    > !
    > interface Loopback1
    > ip address 131.108.8.1 255.255.255.255
    > !
    > interface Loopback2
    > ip address 131.108.9.1 255.255.255.255
    > !
    > interface Ethernet0
    > ip address 131.108.8.129 255.255.255.128
    > !
    > interface Serial0
    > no ip address
    > shutdown
    > no fair-queue
    > !
    > interface Serial1
    > ip address 131.108.3.2 255.255.255.0
    > clockrate 64000
    > !
    > interface Serial2
    > no ip address
    > shutdown
    > !
    > interface Serial3
    > no ip address
    > shutdown
    > !
    > interface BRI0
    > no ip address
    > shutdown
    > !
    > router ospf 1
    > log-adjacency-changes
    > summary-address 131.108.9.0 255.255.255.0
    > summary-address 131.108.7.0 255.255.255.0
    > summary-address 131.108.8.0 255.255.255.0
    > redistribute connected subnets
    > redistribute igrp 1 metric 1 subnets
    > network 131.108.7.1 0.0.0.0 area 0
    > network 131.108.8.1 0.0.0.0 area 0
    > network 131.108.8.129 0.0.0.0 area 0
    > network 131.108.9.1 0.0.0.0 area 0
    > !
    > router igrp 1
    > redistribute ospf 1 metric 64 20000 255 1 1500
    > passive-interface Ethernet0
    > passive-interface Loopback0
    > passive-interface Loopback1
    > passive-interface Loopback2
    > network 131.108.0.0
    > !
    > ip classless
    > ip http server
    > !
    > !
    > !
    > line con 0
    > exec-timeout 0 0
    > logging synchronous
    > line aux 0
    > line vty 0 4
    > !
    > end
    >
    > Router1#show ip route
    > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
    > area
    > * - candidate default, U - per-user static route, o - ODR
    > P - periodic downloaded static route
    >
    > Gateway of last resort is not set
    >
    > 131.108.0.0/24 is subnetted, 5 subnets
    > C 131.108.6.0 is directly connected, Loopback2
    > C 131.108.5.0 is directly connected, Loopback1
    > C 131.108.4.0 is directly connected, Loopback0
    > C 131.108.3.0 is directly connected, Serial0
    > C 131.108.1.0 is directly connected, Ethernet0
    > Router1#
    >
    > Router2#show ip route
    > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
    > area
    > * - candidate default, U - per-user static route, o - ODR
    > P - periodic downloaded static route
    >
    > Gateway of last resort is not set
    >
    > 131.108.0.0/16 is variably subnetted, 9 subnets, 3 masks
    > C 131.108.8.128/25 is directly connected, Ethernet0
    > C 131.108.8.1/32 is directly connected, Loopback1
    > C 131.108.9.1/32 is directly connected, Loopback2
    > I 131.108.6.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    > C 131.108.7.1/32 is directly connected, Loopback0
    > I 131.108.5.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    > I 131.108.4.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    > C 131.108.3.0/24 is directly connected, Serial1
    > I 131.108.1.0/24 [100/8576] via 131.108.3.1, 00:00:41, Serial1
    > Router2#
    >
    >
    firemarsh, Jan 17, 2004
    #3
  4. Simon Chamberlain

    firemarsh Guest

    Here's another thing.... IGRP *will not* advertise over an interface which
    are on the same major network, but do not have the same mask, as igrp does
    not support VLSM. It only sees classfull boundaries. so:

    r1 is able to advertise his information to r2 over s0, because the routes
    are :
    A) the same major net : 131.108.0.0 /16
    B) all have the same mask /24

    so r2 sees his advertisements.

    R2 is unable to send the advertisements because:

    Both S1 and the loopbacks are on the same major net, yet don't have the same
    Mask (s0 with /24 and loopbacks with /25)

    this happens because of route summarization:
    IGRP is a classful protocol which uses only classful boundaries. It see's
    your class b networks as /16 addresses, and not as subnets.


    this page
    http://www.cisco.com/en/US/tech/tk365/tk207/technologies_tech_note09186a0080093fd9.shtml
    Suggests this for your problem that is simulated on R2 as a fix for a larger
    net:ip route 131.108.0.0 255.255.255.0 null0
    router igrp
    redistribute static
    default metric 1
    --
    Roger Hilt
    Network Infrastructure Technician
    Langley, AFB VA
    "firemarsh" <> wrote in message
    news:he7Ob.3383$_H5.595@lakeread06...
    > Does anything change when you give each router a default gateway, or a
    > default route?
    >
    > ip default-gateway xxx.yyy.zzz.bbb (where xxx.yyy.zzz.bbb is the next hop

    if
    > not found in the routing tables)
    > or
    > ip route 0.0.0.0 0.0.0.0 xxx.yyy.zzz.bbb (next logical hop)
    > also where are the following entries on your router 1, I think you have to
    > tell igrp to advertise them with this, but I am not sure:
    > > passive-interface Ethernet0
    > > passive-interface Loopback0
    > > passive-interface Loopback1
    > > passive-interface Loopback2

    >
    > they all fall under the igrp 1 configs on your router 2...
    > my 2 cents.
    >
    >
    >
    > --
    > Roger Hilt
    > Network Infrastructure Technician
    > Langley, AFB VA
    > "Simon Chamberlain" <> wrote in message
    > news:bu915c$83j$...
    > > Hello,
    > >
    > > Can anyone figure this out? There are two Routers (1 and 2) connected

    via
    > > the serial ports. Router1 is running IGRP and Router2 is running OSPF

    and
    > > IGRP. On Router 2 OSPF is redistributed in IGRP and vice-versa.

    According
    > to
    > > the book I have with the following configuration I should be able to

    ping
    > > the loopback interfaces and the ethernet interface on the opposite

    router.
    > > Can you spot what I'm doing wrong? The configs are below:
    > >
    > > Thanks,
    > > Simon
    > >
    > >
    > > Router1#show run
    > > Building configuration...
    > >
    > > Current configuration : 745 bytes
    > > !
    > > version 12.1
    > > no service single-slot-reload-enable
    > > service timestamps debug uptime
    > > service timestamps log uptime
    > > no service password-encryption
    > > !
    > > hostname Router1
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > ip subnet-zero
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > interface Loopback0
    > > ip address 131.108.4.1 255.255.255.0
    > > !
    > > interface Loopback1
    > > ip address 131.108.5.1 255.255.255.0
    > > !
    > > interface Loopback2
    > > ip address 131.108.6.1 255.255.255.0
    > > !
    > > interface Ethernet0
    > > ip address 131.108.1.1 255.255.255.0
    > > !
    > > interface Ethernet1
    > > no ip address
    > > shutdown
    > > !
    > > interface Serial0
    > > ip address 131.108.3.1 255.255.255.0
    > > !
    > > interface Serial1
    > > no ip address
    > > shutdown
    > > !
    > > router igrp 1
    > > network 131.108.0.0
    > > !
    > > ip classless
    > > ip http server
    > > !
    > > !
    > > !
    > > line con 0
    > > exec-timeout 0 0
    > > logging synchronous
    > > line aux 0
    > > line vty 0 4
    > > !
    > > end
    > >
    > > Router2#show run
    > > Building configuration...
    > >
    > > Current configuration : 1420 bytes
    > > !
    > > version 12.1
    > > no service single-slot-reload-enable
    > > service timestamps debug uptime
    > > service timestamps log uptime
    > > no service password-encryption
    > > !
    > > hostname Router2
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > ip subnet-zero
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > interface Loopback0
    > > ip address 131.108.7.1 255.255.255.255
    > > !
    > > interface Loopback1
    > > ip address 131.108.8.1 255.255.255.255
    > > !
    > > interface Loopback2
    > > ip address 131.108.9.1 255.255.255.255
    > > !
    > > interface Ethernet0
    > > ip address 131.108.8.129 255.255.255.128
    > > !
    > > interface Serial0
    > > no ip address
    > > shutdown
    > > no fair-queue
    > > !
    > > interface Serial1
    > > ip address 131.108.3.2 255.255.255.0
    > > clockrate 64000
    > > !
    > > interface Serial2
    > > no ip address
    > > shutdown
    > > !
    > > interface Serial3
    > > no ip address
    > > shutdown
    > > !
    > > interface BRI0
    > > no ip address
    > > shutdown
    > > !
    > > router ospf 1
    > > log-adjacency-changes
    > > summary-address 131.108.9.0 255.255.255.0
    > > summary-address 131.108.7.0 255.255.255.0
    > > summary-address 131.108.8.0 255.255.255.0
    > > redistribute connected subnets
    > > redistribute igrp 1 metric 1 subnets
    > > network 131.108.7.1 0.0.0.0 area 0
    > > network 131.108.8.1 0.0.0.0 area 0
    > > network 131.108.8.129 0.0.0.0 area 0
    > > network 131.108.9.1 0.0.0.0 area 0
    > > !
    > > router igrp 1
    > > redistribute ospf 1 metric 64 20000 255 1 1500
    > > passive-interface Ethernet0
    > > passive-interface Loopback0
    > > passive-interface Loopback1
    > > passive-interface Loopback2
    > > network 131.108.0.0
    > > !
    > > ip classless
    > > ip http server
    > > !
    > > !
    > > !
    > > line con 0
    > > exec-timeout 0 0
    > > logging synchronous
    > > line aux 0
    > > line vty 0 4
    > > !
    > > end
    > >
    > > Router1#show ip route
    > > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    > > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    > > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    > > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    > > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS

    inter
    > > area
    > > * - candidate default, U - per-user static route, o - ODR
    > > P - periodic downloaded static route
    > >
    > > Gateway of last resort is not set
    > >
    > > 131.108.0.0/24 is subnetted, 5 subnets
    > > C 131.108.6.0 is directly connected, Loopback2
    > > C 131.108.5.0 is directly connected, Loopback1
    > > C 131.108.4.0 is directly connected, Loopback0
    > > C 131.108.3.0 is directly connected, Serial0
    > > C 131.108.1.0 is directly connected, Ethernet0
    > > Router1#
    > >
    > > Router2#show ip route
    > > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    > > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    > > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    > > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    > > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS

    inter
    > > area
    > > * - candidate default, U - per-user static route, o - ODR
    > > P - periodic downloaded static route
    > >
    > > Gateway of last resort is not set
    > >
    > > 131.108.0.0/16 is variably subnetted, 9 subnets, 3 masks
    > > C 131.108.8.128/25 is directly connected, Ethernet0
    > > C 131.108.8.1/32 is directly connected, Loopback1
    > > C 131.108.9.1/32 is directly connected, Loopback2
    > > I 131.108.6.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    > > C 131.108.7.1/32 is directly connected, Loopback0
    > > I 131.108.5.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    > > I 131.108.4.0/24 [100/8976] via 131.108.3.1, 00:00:40, Serial1
    > > C 131.108.3.0/24 is directly connected, Serial1
    > > I 131.108.1.0/24 [100/8576] via 131.108.3.1, 00:00:41, Serial1
    > > Router2#
    > >
    > >

    >
    >
    firemarsh, Jan 17, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tom Wu

    IGRP HELP

    Tom Wu, Nov 21, 2003, in forum: Cisco
    Replies:
    3
    Views:
    803
    Tom Wu
    Nov 22, 2003
  2. James Parks

    Two ISP -Two Routers - 1 PIX

    James Parks, Dec 8, 2003, in forum: Cisco
    Replies:
    5
    Views:
    3,648
    James Parks
    Dec 11, 2003
  3. E.Finlayson
    Replies:
    0
    Views:
    1,587
    E.Finlayson
    Sep 10, 2004
  4. Replies:
    5
    Views:
    5,819
    anilkarthik
    Jul 28, 2008
  5. Replies:
    4
    Views:
    802
Loading...

Share This Page