turning off automatic search

Discussion in 'Firefox' started by Vegetable Lasagne, Sep 28, 2006.

  1. Is there a way to disable the search function in firefox. I'm on the latest
    version.

    Sometimes I'll mistype a site and instead of just giving me a 404 which is
    fine, it arbitrarily takes me to a site with a similar name that wants to set
    cookies.

    IE has a feature that says don't do search from toolbar and I always have
    that turned on. Is there something like that in mozilla
     
    Vegetable Lasagne, Sep 28, 2006
    #1
    1. Advertising

  2. Vegetable Lasagne wrote:
    > Is there a way to disable the search function in firefox. I'm on the latest
    > version.
    >
    > Sometimes I'll mistype a site and instead of just giving me a 404 which is
    > fine, it arbitrarily takes me to a site with a similar name that wants to set
    > cookies.
    >
    > IE has a feature that says don't do search from toolbar and I always have
    > that turned on. Is there something like that in mozilla


    Well, you can read here:

    http://kb.mozillazine.org/Location_Bar_search

    The funny thing is my pref keyword.url is set for the feeling lucky
    search, but that doesn't happen if I mistype a url in the location bar.

    Still, you can go into about:config, filter for keyword.url, right
    click, choose modify, and remove the url, thus disabling the pref. See
    what that does.

    Lee
     
    Leonidas Jones, Sep 28, 2006
    #2
    1. Advertising

  3. Vegetable Lasagne <> wrote in
    news:Xns984C8DBB19289plonk@207.217.125.201:

    > Is there a way to disable the search function in firefox. I'm on the
    > latest version.
    >
    > Sometimes I'll mistype a site and instead of just giving me a 404 which
    > is fine, it arbitrarily takes me to a site with a similar name that
    > wants to set cookies.
    >
    > IE has a feature that says don't do search from toolbar and I always
    > have that turned on. Is there something like that in mozilla
    >


    sorry, ie option is not set for toolbar, but for the url window.
     
    Vegetable Lasagne, Sep 28, 2006
    #3
  4. Vegetable Lasagne

    Lukan Guest

    > fine, it arbitrarily takes me to a site with a similar name
    > that wants to set cookies.


    Not entirely on topic perhaps but you can set up FF to
    automatically delete all cookies (apart from the ones you
    actually want to keep) whenever you exit your browser, let me
    know if you need help with that.
     
    Lukan, Sep 30, 2006
    #4
  5. Lukan <> wrote in news:efkdhb$bq4$:

    >> fine, it arbitrarily takes me to a site with a similar name
    >> that wants to set cookies.

    >
    > Not entirely on topic perhaps but you can set up FF to
    > automatically delete all cookies (apart from the ones you
    > actually want to keep) whenever you exit your browser, let me
    > know if you need help with that.
    >


    I already prompt for every cookie, that's how I know. I allow them for the
    sites I want only, not for the five or six ad sites that go along with the
    ones I want.

    Thanks though
     
    Vegetable Lasagne, Oct 1, 2006
    #5
  6. Leonidas Jones <> wrote in
    news:TdUSg.246408$:

    > Vegetable Lasagne wrote:
    >> Is there a way to disable the search function in firefox. I'm on the
    >> latest version.
    >>
    >> Sometimes I'll mistype a site and instead of just giving me a 404 which
    >> is fine, it arbitrarily takes me to a site with a similar name that
    >> wants to set cookies.
    >>
    >> IE has a feature that says don't do search from toolbar and I always
    >> have that turned on. Is there something like that in mozilla

    >
    > Well, you can read here:
    >
    > http://kb.mozillazine.org/Location_Bar_search
    >
    > The funny thing is my pref keyword.url is set for the feeling lucky
    > search, but that doesn't happen if I mistype a url in the location bar.
    >
    > Still, you can go into about:config, filter for keyword.url, right
    > click, choose modify, and remove the url, thus disabling the pref. See
    > what that does.
    >
    > Lee


    Well, doh....

    I changed the prefs in the about:config (thanks for that info!) and falsed
    keyword enabled and changed the url to about:blank and it still didn't work.
    I watched the address bar at the bottom and it looks like earthlink, my isp,
    is getting involved as some sort of proxy search. Have to look there next.

    If i type something like mydoghasfleas, I don't want it to assume that I want
    www.mydoghasfleas.com, which is what it's doing. Who knows what exploits
    these lookalike sites could be doing?

    Thanks!
     
    Vegetable Lasagne, Oct 1, 2006
    #6
  7. Vegetable Lasagne <> wrote in
    news:Xns984C8DBB19289plonk@207.217.125.201:

    > Is there a way to disable the search function in firefox. I'm on the
    > latest version.
    >
    > Sometimes I'll mistype a site and instead of just giving me a 404 which
    > is fine, it arbitrarily takes me to a site with a similar name that
    > wants to set cookies.
    >
    > IE has a feature that says don't do search from toolbar and I always
    > have that turned on. Is there something like that in mozilla


    In case anyone's interested, I fixed the problem. The packet sniffer showed
    it coming from the browser, not externally.

    In firefox, put about:config in the address bar and make the following change

    browser search update true-->false

    I now get "Firefox can't find the server at mydoghasfleas." instead of having
    the browser go look for www.mydoghasflease.com

    This is what I wanted.
     
    Vegetable Lasagne, Oct 2, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jon Earley

    Turning off offline files sync on wireless connection

    Jon Earley, May 23, 2005, in forum: Wireless Networking
    Replies:
    0
    Views:
    688
    Jon Earley
    May 23, 2005
  2. BrainstormingSW

    Turning sounds off only in Mozilla

    BrainstormingSW, Apr 5, 2004, in forum: Firefox
    Replies:
    6
    Views:
    1,359
    Caffeine Junkie
    Apr 7, 2004
  3. panda
    Replies:
    7
    Views:
    16,034
    panda
    Oct 11, 2004
  4. Ben
    Replies:
    2
    Views:
    6,294
    =?iso-8859-2?Q?Jan_Werbi=F1ski?=
    Nov 23, 2004
  5. John Chajecki

    Turning off the '?' in IOS

    John Chajecki, Dec 17, 2005, in forum: Cisco
    Replies:
    4
    Views:
    417
    John Chajecki
    Dec 17, 2005
Loading...

Share This Page