tunnel, ospf problem

Discussion in 'Cisco' started by Dmitry Melekhov, Nov 15, 2004.

  1. Hello!

    We had connection over E1, but, unfortunately, due channel crash now
    we switched to tunnel over provider network.

    Here is config


    c3660(ethernet)<->provider's router<-e1->c1751

    c3660 IOS is 12.2.27 and c1751 ios is 12.2.15T14

    Here is tunnel config
    on c3660



    interface Tunnel0
    ip address 192.168.119.1 255.255.255.0
    ip ospf authentication-key ....
    tunnel source FastEthernet0/0.2
    tunnel destination 10.189.3.57
    tunnel path-mtu-discovery


    And here is for c1751

    interface Tunnel0
    ip address 192.168.119.2 ............
    ip nat inside
    ip ospf authentication-key 7 09645B10230B16171F
    tunnel source Serial0/0
    tunnel destination 10.189.3.61
    tunnel path-mtu-discovery


    ospf config in c 1751:

    router ospf 1
    log-adjacency-changes
    area 0 authentication message-digest
    redistribute connected
    network 192.168.200.0 0.0.0.255 area 0


    and ospf config on c3660:

    router ospf 1
    log-adjacency-changes
    area 0 authentication message-digest
    redistribute connected
    redistribute static
    redistribute rip
    network 192.168.200.0 0.0.0.255 area 0
    default-information originate


    Cisco 1751 get info about network 192.168.116.0/24 from ospf:

    O 192.168.116.0/24 [110/97] via 192.168.200.234, 00:06:25,
    Serial0/1

    And route to this network is static on c3660:

    S 192.168.116.0/24 is directly connected, Tunnel0


    If I add network 192.168.119.0 0.0.0.255 area 0
    on both routers and remove static route to 192.168.116.0/24 on c3660,
    c3660 receives path to 192.168.116.0/24 from c1751 using ospf.
    But if I try to traceroute 192.168.116.1 from LAN(connected to c3660)
    I see that
    c3660 sends packets to default gateway!
    O*E2 0.0.0.0/0 [110/1] via 192.168.200.253, 00:07:33, Serial1/0

    And I can't ping network 192.168.101.0/24 wich is also behing c1751
    and works woth static:
    192.168.101.0/24 is directly connected, Tunnel0

    If I remove network 192.168.119.0 from ospf 1 all becomes OK again.

    Any ideas?

    Thank you!
     
    Dmitry Melekhov, Nov 15, 2004
    #1
    1. Advertising

  2. Dmitry Melekhov

    Ivan Ostreš Guest

    In article <>,
    says...
    > Cisco 1751 get info about network 192.168.116.0/24 from ospf:
    >
    > O 192.168.116.0/24 [110/97] via 192.168.200.234, 00:06:25,
    > Serial0/1
    >
    > And route to this network is static on c3660:
    >
    > S 192.168.116.0/24 is directly connected, Tunnel0
    >
    >
    > If I add network 192.168.119.0 0.0.0.255 area 0
    > on both routers and remove static route to 192.168.116.0/24 on c3660,
    > c3660 receives path to 192.168.116.0/24 from c1751 using ospf.
    > But if I try to traceroute 192.168.116.1 from LAN(connected to c3660)
    > I see that
    > c3660 sends packets to default gateway!
    > O*E2 0.0.0.0/0 [110/1] via 192.168.200.253, 00:07:33, Serial1/0
    >
    > And I can't ping network 192.168.101.0/24 wich is also behing c1751
    > and works woth static:
    > 192.168.101.0/24 is directly connected, Tunnel0
    >
    > If I remove network 192.168.119.0 from ospf 1 all becomes OK again.
    >
    > Any ideas?
    >
    >


    Looks like you're learn paths trough both 10.189.3.X and your tunnel
    interface and it looks like a loop. Be carefull with that 'redistribute
    connected'. I think that the real problem here is that you're not sure
    what do you really want to do nor how to do it. Maybe is time to call
    someone expirienced to fix this for you?

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostreš, Nov 15, 2004
    #2
    1. Advertising

  3. Ivan Ostre? <> wrote in message

    > Looks like you're learn paths trough both 10.189.3.X and your tunnel
    > interface and it looks like a loop. Be carefull with that 'redistribute


    Good idea. I'll test this...

    > connected'. I think that the real problem here is that you're not sure
    > what do you really want to do nor how to do it. Maybe is time to call
    > someone expirienced to fix this for you?


    I know what I want, I want to have ospf over tunnel :)
     
    Dmitry Melekhov, Nov 16, 2004
    #3
  4. Dmitry Melekhov

    Ivan Ostreš Guest

    In article <>,
    says...
    > I know what I want, I want to have ospf over tunnel :)
    >
    >


    Hm... but you have it outside of the tunnel as well?!?

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostreš, Nov 16, 2004
    #4
  5. Ivan Ostre? <> wrote in message news:<>...
    >
    > Looks like you're learn paths trough both 10.189.3.X and your tunnel
    > interface and it looks like a loop. Be carefull with that 'redistribute
    > connected'. I think that the real problem here is that you're not sure


    Well, problem was similar :) But not completely.
    I forgot to write static route over provider's net and route
    aggregation announced routes to our nets as 10.0.0.0/8 , certanly to
    tun0 :)


    > what do you really want to do nor how to do it. Maybe is time to call
    > someone expirienced to fix this for you?


    As you see I can solve such problems myself :p
     
    Dmitry Melekhov, Nov 16, 2004
    #5
  6. Dmitry Melekhov

    Ivan Ostreš Guest

    In article <>,
    says...
    > > what do you really want to do nor how to do it. Maybe is time to call
    > > someone expirienced to fix this for you?

    >
    > As you see I can solve such problems myself :p
    >


    Good for you :). Why then posting here, anyway?

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostreš, Nov 16, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Garry Glendown

    OSPF routing over DMVPN tunnel ...

    Garry Glendown, Nov 14, 2003, in forum: Cisco
    Replies:
    4
    Views:
    6,872
    Scooby
    Nov 15, 2003
  2. E.Finlayson
    Replies:
    0
    Views:
    1,635
    E.Finlayson
    Sep 10, 2004
  3. a.nonny mouse
    Replies:
    2
    Views:
    1,129
  4. cristi27

    OSPF and IPSec tunnel "priority"

    cristi27, Sep 4, 2006, in forum: Cisco
    Replies:
    1
    Views:
    776
    cristi27
    Sep 4, 2006
  5. Replies:
    4
    Views:
    820
Loading...

Share This Page