trunking on ip phone ports?

Discussion in 'Cisco' started by P, Oct 17, 2003.

  1. P

    P Guest

    Hi

    I have seen lots of examples of ip phone ports set up like this..

    interface FastEthernet0/4
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 150
    switchport mode trunk
    switchport voice vlan 200
    spanning-tree portfast
    end

    and this is kind of what I expected, whan having no experience in VOIP,
    assumed that an ip phone would have to trunk if it was also handling a PC in
    a different VLAN.

    But when I read the "Configuring Voice VLAN" section of the IOS docco, I
    don't recall it making references to this need, and in fact CDP is used to
    handle the phone.

    Thus is this perfectly valid?

    interface FastEthernet0/4
    switchport access vlan 150
    switchport voice vlan 200
    spanning-tree portfast
    end

    I occasionally get the phones obtaining a DHCP address from VLAN 150, rather
    than 200. Would this be some breakdown in the CDP negotiation between
    phone->switch?

    Anybody seen this before?
     
    P, Oct 17, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jerry Abrams

    trunking with 2900 fiber module

    Jerry Abrams, Jul 22, 2003, in forum: Cisco
    Replies:
    0
    Views:
    517
    Jerry Abrams
    Jul 22, 2003
  2. Russ Johnson

    Re: Help with 2948G-L3 Trunking

    Russ Johnson, Oct 16, 2003, in forum: Cisco
    Replies:
    0
    Views:
    790
    Russ Johnson
    Oct 16, 2003
  3. Hamid

    HSRP problems with trunking

    Hamid, Nov 3, 2003, in forum: Cisco
    Replies:
    2
    Views:
    8,190
    Harri Suomalainen
    Nov 5, 2003
  4. DaZZa
    Replies:
    0
    Views:
    674
    DaZZa
    Feb 16, 2004
  5. Mike
    Replies:
    27
    Views:
    1,677
Loading...

Share This Page