Trunk Links (802.1q) And Native VLAN

Discussion in 'Cisco' started by Amy L., Dec 2, 2003.

  1. Amy L.

    Amy L. Guest

    For 802.1Q trunk links I noticed the following command can be used

    Switch(config-if)# switchport trunk native vlan vlan_num

    Can someone explain exactly what that command is for?

    I normally configure a trunk link as follows

    interface GigabitEthernet2/1
    description Trunk Connection To 3550-STACKA gig0/1
    switchport access vlan 42
    switchport trunk encapsulation dot1q
    switchport trunk pruning vlan none
    switchport mode trunk
    no logging event link-status

    Thanks
    Amy.
    Amy L., Dec 2, 2003
    #1
    1. Advertising

  2. If a frame arrives on that trunk from an attatched device and it has no
    802.1q tag embeded in the frame, the switch puts the frame into the native
    VLAN which is configured on a port by port basis. Often used on IP phones
    wgere the grames fro the phone itself are put into the voice VLAN but the
    data frames (untagged) from the attatched PC are out into the native VLAN.

    BSOF


    "Amy L." <> wrote in message
    news:...
    > For 802.1Q trunk links I noticed the following command can be used
    >
    > Switch(config-if)# switchport trunk native vlan vlan_num
    >
    > Can someone explain exactly what that command is for?
    >
    > I normally configure a trunk link as follows
    >
    > interface GigabitEthernet2/1
    > description Trunk Connection To 3550-STACKA gig0/1
    > switchport access vlan 42
    > switchport trunk encapsulation dot1q
    > switchport trunk pruning vlan none
    > switchport mode trunk
    > no logging event link-status
    >
    > Thanks
    > Amy.
    Balin, Son of Fundin, Dec 2, 2003
    #2
    1. Advertising

  3. (Amy L.) wrote in message news:<>...
    > For 802.1Q trunk links I noticed the following command can be used
    >
    > Switch(config-if)# switchport trunk native vlan vlan_num
    >
    > Can someone explain exactly what that command is for?
    >
    > I normally configure a trunk link as follows
    >
    > interface GigabitEthernet2/1
    > description Trunk Connection To 3550-STACKA gig0/1
    > switchport access vlan 42
    > switchport trunk encapsulation dot1q
    > switchport trunk pruning vlan none
    > switchport mode trunk
    > no logging event link-status
    >
    > Thanks
    > Amy.


    It changes the VLAN that you are going to use as the native VLAN.

    <SNIP from Cisco web page>
    In 802.1q trunking, all VLAN packets are tagged on the trunk link,
    except the native VLAN. The native VLAN packets are sent untagged on
    the trunk link. Therefore, the native VLAN should be the same on both
    switches configured for trunking. This way, you can deduce to which
    VLAN a frame belongs when you receive a frame with no tag. By default,
    VLAN 1 is the native VLAN on all switches.

    In CatOS, the native VLAN can be changed by issuing the set vlan
    <vlan-id><mod/port> command, where <mod/port > is the trunk port.

    In native IOS, the native VLAN can be changed by issuing the
    switchport trunk native vlan <vlan-id> interface command which is
    configured on the trunk port.

    Pete
    Pete Mainwaring, Dec 3, 2003
    #3
  4. Amy L.

    Amy L. Guest

    Pete,

    So let me see if I understand this correctly.

    Say I have a trunk link between Switch A and Switch B that carries
    VLAN 10 & 11. Normally when I hook a client up to a port on switch A
    I assign it to a vlan (either 10 or 11).

    Now if I didnt put that port in either VLAN 10 or 11 and that users
    packet crosses the trunk link would it be assigned to the "native
    vlan". Although, if I didnt assign the port a vlan wouldn't that port
    still be in its native vlan of the switch which would be vlan 1.

    I am having a hard time seeing the use for this command, because every
    switch port on these switches would be in some vlan either deafult or
    assigned manually.

    Thanks
    Amy.

    (Pete Mainwaring) wrote in message news:<>...
    > (Amy L.) wrote in message news:<>...
    > > For 802.1Q trunk links I noticed the following command can be used
    > >
    > > Switch(config-if)# switchport trunk native vlan vlan_num
    > >
    > > Can someone explain exactly what that command is for?
    > >
    > > I normally configure a trunk link as follows
    > >
    > > interface GigabitEthernet2/1
    > > description Trunk Connection To 3550-STACKA gig0/1
    > > switchport access vlan 42
    > > switchport trunk encapsulation dot1q
    > > switchport trunk pruning vlan none
    > > switchport mode trunk
    > > no logging event link-status
    > >
    > > Thanks
    > > Amy.

    >
    > It changes the VLAN that you are going to use as the native VLAN.
    >
    > <SNIP from Cisco web page>
    > In 802.1q trunking, all VLAN packets are tagged on the trunk link,
    > except the native VLAN. The native VLAN packets are sent untagged on
    > the trunk link. Therefore, the native VLAN should be the same on both
    > switches configured for trunking. This way, you can deduce to which
    > VLAN a frame belongs when you receive a frame with no tag. By default,
    > VLAN 1 is the native VLAN on all switches.
    >
    > In CatOS, the native VLAN can be changed by issuing the set vlan
    > <vlan-id><mod/port> command, where <mod/port > is the trunk port.
    >
    > In native IOS, the native VLAN can be changed by issuing the
    > switchport trunk native vlan <vlan-id> interface command which is
    > configured on the trunk port.
    >
    > Pete
    Amy L., Dec 4, 2003
    #4
  5. (Amy L.) wrote in message news:<>...
    > Pete,
    >
    > So let me see if I understand this correctly.
    >
    > Say I have a trunk link between Switch A and Switch B that carries
    > VLAN 10 & 11. Normally when I hook a client up to a port on switch A
    > I assign it to a vlan (either 10 or 11).
    >
    > Now if I didnt put that port in either VLAN 10 or 11 and that users
    > packet crosses the trunk link would it be assigned to the "native
    > vlan". Although, if I didnt assign the port a vlan wouldn't that port
    > still be in its native vlan of the switch which would be vlan 1.
    >
    > I am having a hard time seeing the use for this command, because every
    > switch port on these switches would be in some vlan either deafult or
    > assigned manually.
    >
    > Thanks
    > Amy.
    >


    I must say that I've never actually used this command myself - like
    you I couldn't see a situation that required it to be used, although
    I'm sure some of the other guys (like Walter Roberson or Hansang Bae)
    would be able to describe a situation where it was necessary. (Guys?)

    I think your assumptions are correct though. The port would be in the
    native VLAN if you didn't assign it. AFAIK the command would change
    the native VLAN from VLAN 1 to another VLAN of your choice (which must
    be the same at either end of the trunk of course).

    I can't really shed any more light on it than that, but I hope that
    helps.

    Pete
    Pete Mainwaring, Dec 5, 2003
    #5
  6. Program ended abnormally on 05/12/2003 03:46, Due to a catastrophic Pete
    Mainwaring error:
    > (Amy L.) wrote in message news:<>...
    >
    >>Pete,
    >>
    >>So let me see if I understand this correctly.
    >>
    >>Say I have a trunk link between Switch A and Switch B that carries
    >>VLAN 10 & 11. Normally when I hook a client up to a port on switch A
    >>I assign it to a vlan (either 10 or 11).
    >>
    >>Now if I didnt put that port in either VLAN 10 or 11 and that users
    >>packet crosses the trunk link would it be assigned to the "native
    >>vlan". Although, if I didnt assign the port a vlan wouldn't that port
    >>still be in its native vlan of the switch which would be vlan 1.
    >>
    >>I am having a hard time seeing the use for this command, because every
    >>switch port on these switches would be in some vlan either deafult or
    >>assigned manually.
    >>
    >>Thanks
    >>Amy.
    >>

    >
    >
    > I must say that I've never actually used this command myself - like
    > you I couldn't see a situation that required it to be used, although
    > I'm sure some of the other guys (like Walter Roberson or Hansang Bae)
    > would be able to describe a situation where it was necessary. (Guys?)


    The "native vlan" is not tagged, so it would allow you to send packets to a
    non-802.1q device on that link. You could do the following:


    vlan11 -- switch a --- switch b ---- switch c -- vlan11
    vlan10 --- ' '---- vlan10

    Where switch B doesn't understand 802.1q tagging, if you put the ports facing B
    of A and C in native vlan 11, the devices on switch B would be would be able to
    talk to devices on vlan 11 on all 3 switches, and the devices on A and C on vlan
    10 would be able to talk to one another.


    --
    Francois Labreque | The surest sign of the existence of extra-
    flabreque | terrestrial intelligence is that they never
    @ | bothered to come down here and visit us!
    videotron.ca | - Calvin
    Francois Labreque, Dec 5, 2003
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Amy L.
    Replies:
    3
    Views:
    19,301
    shope
    Dec 6, 2003
  2. PS2 gamer
    Replies:
    1
    Views:
    1,006
    Ivan Ostres
    May 28, 2004
  3. Andy
    Replies:
    1
    Views:
    12,049
    Walter Roberson
    Sep 21, 2005
  4. Replies:
    4
    Views:
    982
  5. paul1537
    Replies:
    0
    Views:
    1,719
    paul1537
    May 15, 2008
Loading...

Share This Page