Troubleshooting Trunks

Discussion in 'Cisco' started by bobneworleans@yahoo.com, Jun 17, 2010.

  1. Guest

    A host is connected to 3550 f0/12 assigned to VLAN 106. Int VLAN 106
    is 10.1.106.27, which the host can ping.
    A trunk is configured on G0/2 connecting it to 4507 int G2/1. Int
    VLAN 106 is 10.1.106.1 on the 4507. The host cannot ping this
    address.

    I suspect some problem in my trunks and included below some relevant
    info. Do you see what the problem is? Let me know if you need any
    additional info and I'll provide it.

    THANKS!
    Bob


    3550 Partial config

    vlan 106
    name Server_VLAN

    interface FastEthernet0/12
    switchport access vlan 106
    switchport mode dynamic desirable

    interface GigabitEthernet0/2
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,102,106
    switchport mode trunk

    interface Vlan1
    ip address 10.1.1.27 255.255.255.0

    interface Vlan106
    ip address 10.1.106.27 255.255.255.0


    Laurel-MDF-Sw27#sho vlan

    VLAN Name Status Ports
    ---- -------------------------------- ---------
    -------------------------------
    1 default active
    102 2ndFl_VLAN active Fa0/1, Fa0/2, Fa0/3,
    Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10
    Fa0/11, Fa0/13,
    Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20
    Fa0/21, Fa0/22,
    Fa0/23, Fa0/24
    106 Server_VLAN active Fa0/12


    Laurel-MDF-Sw27#sho int f0/12 sw
    Name: Fa0/12
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: static access
    Administrative Trunking Encapsulation: negotiate
    Operational Trunking Encapsulation: native
    Negotiation of Trunking: On
    Access Mode VLAN: 106 (Server_VLAN)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL


    Laurel-MDF-Sw27#sho int g0/2 sw
    Name: Gi0/2
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1,102,106


    Laurel-MDF-Sw27#sho int tr

    Port Mode Encapsulation Status Native vlan
    Gi0/1 on 802.1q trunking 1
    Gi0/2 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Gi0/1 1,102,106
    Gi0/2 1,102,106

    Port Vlans allowed and active in management domain
    Gi0/1 1,102,106
    Gi0/2 1,102,106

    Port Vlans in spanning tree forwarding state and not pruned
    Gi0/1 1,102,106
    Gi0/2 1,102,106




    4507 partial config

    interface GigabitEthernet1/1
    description to MDF stack, switch 21
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,102,105,106
    switchport mode trunk
    storm-control broadcast level 50.00 40.00
    storm-control action shutdown
    spanning-tree guard root

    interface GigabitEthernet2/1
    description to MDF stack, switch 27
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,102,105,106
    switchport mode trunk
    storm-control broadcast level 50.00 40.00
    storm-control action shutdown
    spanning-tree guard root

    interface Vlan1
    description Management_Vlan
    ip address 10.1.1.1 255.255.255.0 secondary
    ip address 10.1.99.99 255.255.255.0
    no ip redirects

    interface Vlan106
    ip address 10.1.106.1 255.255.255.0


    LAUREL-MDF-4507#sho int trunk

    Port Mode Encapsulation Status Native vlan
    Gi1/1 on 802.1q trunking 1
    Gi2/1 on 802.1q trunking 1
    Gi3/3 on 802.1q trunking 1
    Gi3/4 on 802.1q trunking 1
    Gi3/5 on 802.1q trunking 1
    Gi4/1 on 802.1q trunking 1
    Gi4/3 on 802.1q trunking 1
    Gi4/4 on 802.1q trunking 1
    Gi4/5 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Gi1/1 1,102,105-106
    Gi2/1 1,102,105-106
    Gi3/3 1,103,105
    Gi3/4 1,104-105
    Gi3/5 1,101,105
    Gi4/1 1-4094
    Gi4/3 1,103,105
    Gi4/4 1,104-105
    Gi4/5 1,101,105

    Port Vlans allowed and active in management domain
    Gi1/1 1,102,105-106
    Gi2/1 1,102,105-106
    Gi3/3 1,103,105
    Gi3/4 1,104-105
    Gi3/5 1,101,105
    Gi4/1 1,101-106
    Gi4/3 1,103,105
    Gi4/4 1,104-105
    Gi4/5 1,101,105

    Port Vlans in spanning tree forwarding state and not pruned
    Gi1/1 1,102,105-106
    Gi2/1 1,105
    Gi3/3 1,105
    Gi3/4 1,104-105
    Gi3/5 1,105
    Gi4/1 1,101-106
    Gi4/3 1,105
    Gi4/4 1
    Gi4/5 1,105


    LAUREL-MDF-4507#sho vlan

    VLAN Name Status Ports
    ---- -------------------------------- ---------
    -------------------------------
    1 default active Gi1/2, Gi2/2, Gi3/2,
    Gi3/6, Gi4/2, Gi4/6, Fa5/1, Fa5/2, Fa5/3, Fa5/4
    Fa5/5, Fa5/6, Fa5/7,
    Fa5/8, Fa5/9, Fa5/10, Fa5/11, Fa5/12, Fa5/13
    Fa5/14, Fa5/15,
    Fa5/16, Fa5/17, Fa5/18, Fa5/19, Fa5/20, Fa5/21, Fa5/22
    Fa5/23, Fa5/24,
    Fa5/25, Fa5/26, Fa5/27, Fa5/28, Fa5/29, Fa5/30, Fa5/31
    Fa5/32, Fa5/33,
    Fa5/34, Fa5/35, Fa5/36, Fa5/37, Fa5/38, Fa5/39, Fa5/40
    Fa5/41, Fa5/42,
    Fa5/43, Fa5/44, Fa5/45, Fa5/46, Fa5/47, Fa5/48
    101 1st_Floor_VLAN active
    102 2ndFl_VLAN active
    103 3rdFl_VLAN active
    104 Annex_VLAN active
    105 Wireless_VLAN active
    106 Server_VLAN active


    LAUREL-MDF-4507#sho int g1/1 sw
    Name: Gi1/1
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1,102,105,106


    LAUREL-MDF-4507#sho int g2/1 sw
    Name: Gi2/1
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1,102,105,106
    , Jun 17, 2010
    #1
    1. Advertising

  2. Guest

    Never mind. I got it working by unplugging one of the two links from
    the 4507 to the group of switches. Now I can troubleshoot where the
    problem is.
    , Jun 17, 2010
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chris Marva

    Re: vlan1 on trunks 2924XL 2950

    Chris Marva, Jul 7, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,731
    Chris Marva
    Jul 7, 2003
  2. Replies:
    2
    Views:
    3,135
    Aaron Leonard
    Sep 30, 2005
  3. Replies:
    4
    Views:
    559
    Kevin Widner
    Jan 25, 2006
  4. Replies:
    2
    Views:
    1,346
    Walter Roberson
    Feb 28, 2006
  5. Matt
    Replies:
    2
    Views:
    444
Loading...

Share This Page