Trouble connecting to modem. Need some help.

Discussion in 'Cisco' started by Bill, Aug 4, 2006.

  1. Bill

    Bill Guest

    Hello:
    I am new to working with Cisco products and I am trying to setup my 1760
    router to make a dialup connection to my ISP with the WIC-1T serial card
    and an external V.92 modem. I realize it's an involved process and I am
    trying to read all the Cisco documents that relate to my situation. I'm
    taking it one step at a time. Right now I can't open a session to the
    modem to look at it's configuration (I'm doing this in hyperterminal in
    MS Windows with a console connection). Also I think I have properly put
    the Serial interface into async mode, but the Serial interface never
    seems to go into an up state. Slot 0 LED is on, CONN led on the card is
    on when the modem is on. Power and transmit LED's on the modem are on.
    There must be some configurations I have missed. Help would be
    appreciated. Below is some output.
    Thanks
    Bill


    Router#telnet 192.10.0.3 2001
    Trying 192.10.0.3, 2001 ...
    % Destination unreachable; gateway or host down
    Router#show line
    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
    Int
    * 0 CTY - - - - - 0 4 0/0
    -
    1 TTY 115200/115200- inout - - - 0 0 0/0
    Se0/0

    5 AUX 9600/9600 - - - - - 0 0 0/0
    -
    6 VTY - - - - - 0 0 0/0
    -
    7 VTY - - - - - 0 0 0/0
    -
    8 VTY - - - - - 0 0 0/0
    -
    9 VTY - - - - - 0 0 0/0
    -
    10 VTY - - - - - 0 0 0/0
    -

    Line(s) not in async mode -or- with no hardware support:
    2-4

    Router#show line 1
    1 TTY 115200/115200- inout - - - 0 0 0/0
    Se0/0


    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 115200/115200, no parity, 2 stopbits, 8 databits
    Status: No Exit Banner
    Capabilities: Modem Callout, Modem RI is CD, Modem Autoconfigure
    Modem state: Idle
    Modem hardware state: CTS noDSR DTR RTS, Modem Configured
    Special Chars: Escape Hold Stop Start Disconnect Activation
    ^^x none - - none
    Timeouts: Idle EXEC Idle Session Modem Answer Session
    Dispatch
    00:10:00 never none not
    set
    Idle Session Disconnect Warning
    never
    Login-sequence User Response
    00:00:30
    Autoselect Initial Wait
    not set
    Modem type is default.
    Session limit is not set.
    Time since activation: never
    Editing is enabled.
    History is enabled, history size is 20.
    DNS resolution in show commands is enabled
    Full user help is disabled
    Allowed input transports are none.
    Allowed output transports are pad udptn telnet rlogin ssh.
    Preferred transport is telnet.
    No output characters are padded
    No special data dispatching characters

    Router#show interface
    FastEthernet0/0 is up, line protocol is down
    Hardware is PQUICC_FEC, address is 0007.8580.6939 (bia 0007.8580.6939)
    Internet address is 192.10.0.3/24
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Auto-duplex, Auto Speed, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 05:21:55, output 00:00:02, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    94 packets input, 11826 bytes
    Received 94 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    2861 packets output, 207183 bytes, 0 underruns
    37 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    37 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    Serial0/0 is down, line protocol is down
    Hardware is PQUICC Serial in async mode (TTY1)
    MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Closed, loopback not set
    Keepalive not set
    DTR is pulsed for 5 seconds on reset
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 07:29:05
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 6 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
     
    Bill, Aug 4, 2006
    #1
    1. Advertising

  2. www.BradReese.Com, Aug 5, 2006
    #2
    1. Advertising

  3. Bill

    Merv Guest

    Merv, Aug 5, 2006
    #3
  4. Bill

    Guest

    Bill wrote:
    > Hello:
    > I am new to working with Cisco products and I am trying to setup my 1760
    > router to make a dialup connection to my ISP with the WIC-1T serial card
    > and an external V.92 modem. I realize it's an involved process and I am
    > trying to read all the Cisco documents that relate to my situation. I'm
    > taking it one step at a time. Right now I can't open a session to the
    > modem to look at it's configuration (I'm doing this in hyperterminal in
    > MS Windows with a console connection). Also I think I have properly put
    > the Serial interface into async mode, but the Serial interface never
    > seems to go into an up state. Slot 0 LED is on, CONN led on the card is
    > on when the modem is on. Power and transmit LED's on the modem are on.
    > There must be some configurations I have missed. Help would be
    > appreciated. Below is some output.
    > Thanks
    > Bill
    >
    >
    > Router#telnet 192.10.0.3 2001
    > Trying 192.10.0.3, 2001 ...
    > % Destination unreachable; gateway or host down
    > 1 TTY 115200/115200- inout - - - 0 0 0/0
    > Se0/0


    > Modem hardware state: CTS noDSR DTR RTS, Modem Configured


    > Router#show interface
    > FastEthernet0/0 is up, line protocol is down
    > Serial0/0 is down, line protocol is down


    The reason that you attempt to telnet from the router to
    itself on port 2001 is failing is that the interface
    192.10.0.3 is down.

    Plug something in to bring it up and that will be one problem
    out of the way. IF you dont have the facilities to bring up the
    ethernet port then create a loopback interface with
    any address you care and use that. Of course
    the "localhost" address should work (127.0.0.1)
    but I have had problems with that (not on cisco)
    and don't trust it.

    "When the port is in data terminal equipment (DTE) mode, the CONN
    LED indicates that Data Set Ready (DSR), Data Carrier Detect (DCD),
    and Clear To Send (CTS) have been detected. When the port is in data
    communications equipment (DCE) mode, it indicates that Data Terminal
    Ready (DTR) and Request To Send (RTS) have been detected."

    Yours says: CTS noDSR DTR RTS

    I forget what to make of that. Check out the telnet
    and report back.

    show run int se 0/0 woudl be good.
    also details of the cable(s)
     
    , Aug 6, 2006
    #4
  5. Bill

    Bill Guest

    "Merv" <> wrote in
    news::

    > to access the modem, you would use a reverse telnet session.
    >
    > see Cisco doc
    >
    > http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configu
    > ration_guide_chapter09186a00800871ec.html
    >
    >


    Thank you both for the leads. I was able to telnet to the modem after I
    connected my laptop to the ethernet port on the router, this brought
    fastethernet0\0 up/up. But when I terminated the telnet session IOS told
    me that the modem autoconfigure failed. I'm wondering if this because the
    serial interface is still down/down (no matter what I do, proper cables,
    power all around, IOS configured as cisco recommends). At this point I
    have taken off the ip address to see if it was causing a problem. Or
    weather I just have to get to the point where I start a call and it will
    come up. Any comments on this would be appreciated.

    Serial0/0 is down, line protocol is down
    Hardware is PQUICC Serial in async mode (TTY1)
    MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Closed, loopback not set
    Keepalive not set
    DTR is pulsed for 5 seconds on reset
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 02:12:59
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 86 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions

    after terminating telnet session.

    11:31:23: %TTY-3-AUTOCONFIG: TTY1: Modem auto-configuration failed
     
    Bill, Aug 6, 2006
    #5
  6. Bill

    truthjustice Guest

    >> Modem hardware state: CTS noDSR DTR RTS, Modem Configured

    Cisco doc on router modem connections says this is the normal idle state.

    > The reason that you attempt to telnet from the router to
    > itself on port 2001 is failing is that the interface
    > 192.10.0.3 is down.


    I hooked my laptop into the ethernet port and was able to telnet to the
    modem.

    > show run int se 0/0 woudl be good.
    > also details of the cable(s)


    modemcap entry Multitech:MSC=&FS0=1&C4&D3$SB115200
    !
    !
    interface FastEthernet0/0
    ip address 192.10.0.3 255.255.255.0
    speed auto
    !
    interface Serial0/0
    physical-layer async
    no ip address
    encapsulation ppp
    !
    ip classless
    no ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    !
    line con 0
    line 1
    modem InOut
    modem autoconfigure type Multitech
    transport input all
    stopbits 1
    speed 115200
    flowcontrol hardware
    line aux 0
    line vty 0
    login
    modem autoconfigure discovery
    line vty 1 4
    login
    !
    end

    I checked twice, I have the right cable Cisco CAB-232MT 60 pin at router
    and 25 pin at modem (males)
    Is it possible my modem cap is wrong? Should it have the MSC= at the
    front? When I terminate the telnet session IOS tells me the modem auto
    configure has failed.
    11:31:23: %TTY-3-AUTOCONFIG: TTY1: Modem auto-configuration failed
    Can you shead some light on that?

    Thanks
     
    truthjustice, Aug 6, 2006
    #6
  7. Bill

    Guest

    truthjustice wrote:
    > >> Modem hardware state: CTS noDSR DTR RTS, Modem Configured

    >
    > Cisco doc on router modem connections says this is the normal idle state.
    >
    > > The reason that you attempt to telnet from the router to
    > > itself on port 2001 is failing is that the interface
    > > 192.10.0.3 is down.

    >
    > I hooked my laptop into the ethernet port and was able to telnet to the
    > modem.
    >
    > > show run int se 0/0 woudl be good.
    > > also details of the cable(s)

    >
    > modemcap entry Multitech:MSC=&FS0=1&C4&D3$SB115200
    > interface Serial0/0
    > physical-layer async
    > no ip address
    > encapsulation ppp


    > line con 0
    > line 1
    > modem InOut
    > modem autoconfigure type Multitech
    > transport input all
    > stopbits 1
    > speed 115200
    > flowcontrol hardware


    > 11:31:23: %TTY-3-AUTOCONFIG: TTY1: Modem auto-configuration failed
    > Can you shead some light on that?


    Sorry not really. I just spotted the telnet thing. I have never used
    a modem on a router.

    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a00800872d3.html
    Looks nice.

    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a00800871ec.html

    I can just offer general troubshooting advice.

    Remove everything you don't need from the config and
    try basic stuff.

    E.g. when you send the modem AT go you get OK back?

    Look at the debugs described in the docs.

    DEBUG has a few gotchas.

    In general possible performane hit is /huge/.
    Howerer that is not an issue here.

    logg buff deb
    logg buff 30000
    logg con

    If you are telnetted to the router you need
    to issue

    term mon

    term no mon ! to turn off

    sh log

    In general I don't have console logging on
    for production.
     
    , Aug 6, 2006
    #7
  8. Bill

    Merv Guest

    Please post the complete config as it now stands after you remove the
    following:

    config t

    line vty 0
    no modem autoconfigure discovery
    end
    wri mem



    Also for future debugging, suggest you configure:

    config t
    logging buffer 10000 debug
    no logging console
    end
    wri mem


    see Cisco doc "Understanding the 1-Port Serial WAN Interface Card
    (WIC-1T)"
    http://www.cisco.com/en/US/products/hw/modules/ps3129/products_tech_note09186a00800b0859.shtml

    which also referrs one to the following Cisco doc for more info on
    using the WIC-1T in async mode
    "If your platform supports async, then use the physical-layer async
    command for async mode. Such an application is useful to
    connect an external modem to the router. Refer to the document 2 Port
    Async/Sync WAN Interface Card (WIC-2A/S) for an example."

    http://www.cisco.com/warp/customer/107/wic-2as.shtml



    see Cisco doc "Configuring Dialout Using a Modem on the AUX Port"
    http://www.cisco.com/warp/customer/471/mod-aux-dialout.html

    In your case the modem is not on the AUX port but the serial 0/0
    which has been configured into async mode op operation
     
    Merv, Aug 6, 2006
    #8
  9. www.BradReese.Com, Aug 7, 2006
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andres Perez

    Trouble connecting in public hot spots

    Andres Perez, Jul 16, 2004, in forum: Wireless Networking
    Replies:
    2
    Views:
    1,538
    shockwaveriderz
    Jul 16, 2004
  2. Manish Bhasin
    Replies:
    1
    Views:
    1,026
    CCGolfer
    Jun 10, 2004
  3. Jack B. Pollack

    Having trouble connecting to SOME sites

    Jack B. Pollack, May 9, 2006, in forum: Computer Support
    Replies:
    3
    Views:
    459
    Zoned
    May 10, 2006
  4. John Ritchie

    Modem trouble, need help

    John Ritchie, Aug 2, 2007, in forum: Computer Information
    Replies:
    7
    Views:
    473
  5. Replies:
    2
    Views:
    476
    SNOman
    Sep 13, 2006
Loading...

Share This Page