Trixbox - no incoming audio with Voiptalk

Discussion in 'VOIP' started by Telephoneman, Sep 1, 2006.

  1. Telephoneman

    Telephoneman Guest

    Can anyone shed any light on this? I've set up 3 trunks - Voiptalk, Voipfone
    and Sipgate. With Voipfone and Sipgate I get 2 way audio but with Voiptalk
    the other party can hear me but I can't hear them.

    Voiptalk CS won't support trixbox at the moment, although they helpfully
    sent me a config that another customer had used successfully. If the problem
    was across all Carriers I'd suspect a NAT or port forwarding issue but with
    just one I'm scratching my head a bit.

    TIA

    Liam
     
    Telephoneman, Sep 1, 2006
    #1
    1. Advertising

  2. Telephoneman wrote:
    > Can anyone shed any light on this? I've set up 3 trunks - Voiptalk, Voipfone
    > and Sipgate. With Voipfone and Sipgate I get 2 way audio but with Voiptalk
    > the other party can hear me but I can't hear them.
    >
    > Voiptalk CS won't support trixbox at the moment, although they helpfully
    > sent me a config that another customer had used successfully. If the problem
    > was across all Carriers I'd suspect a NAT or port forwarding issue but with
    > just one I'm scratching my head a bit.


    Are you using SIP on Sipgate & Voipfone but IAX with Voiptalk?

    If so, IAX requires a different (single) port to operate.
    Have you forwarded TCP / UDP or both?

    Looking at their site it appears they support Asterisk, tell them your
    using Asterisk and get them to tell you what should be in the *.conf
    files and what ports should be set. Make a note, then add it to the
    freepbx interface later (will overight *.conf files).

    Let us know how you get on.
     
    Daviey Walker, Sep 1, 2006
    #2
    1. Advertising

  3. Telephoneman

    paul123 Guest

    Telephoneman wrote:
    > Can anyone shed any light on this? I've set up 3 trunks - Voiptalk, Voipfone
    > and Sipgate. With Voipfone and Sipgate I get 2 way audio but with Voiptalk
    > the other party can hear me but I can't hear them.
    >
    > Voiptalk CS won't support trixbox at the moment, although they helpfully
    > sent me a config that another customer had used successfully. If the problem
    > was across all Carriers I'd suspect a NAT or port forwarding issue but with
    > just one I'm scratching my head a bit.
    >


    Calling Jono, What did you do to get Voiptalk working?

    Liam's tried my settings which work fine here, but gets this one-way
    audio issue.

    Funnily, I tried my settings from my normal Trixbox in my experimental
    Vmware version, and I'm getting this same issue......
     
    paul123, Sep 1, 2006
    #3
  4. Telephoneman

    paul123 Guest

    paul123 wrote:
    > Telephoneman wrote:
    > > Can anyone shed any light on this? I've set up 3 trunks - Voiptalk, Voipfone
    > > and Sipgate. With Voipfone and Sipgate I get 2 way audio but with Voiptalk
    > > the other party can hear me but I can't hear them.
    > >
    > > Voiptalk CS won't support trixbox at the moment, although they helpfully
    > > sent me a config that another customer had used successfully. If the problem
    > > was across all Carriers I'd suspect a NAT or port forwarding issue but with
    > > just one I'm scratching my head a bit.
    > >

    >
    > Calling Jono, What did you do to get Voiptalk working?
    >
    > Liam's tried my settings which work fine here, but gets this one-way
    > audio issue.
    >
    > Funnily, I tried my settings from my normal Trixbox in my experimental
    > Vmware version, and I'm getting this same issue......


    Sorry to answer my own post, but it now works on the vmware version
    too.

    In config edit->sip_nat.conf I had to add:

    externip=myfixedIP (not my dyndnsname)
    localnet=192.168.1.0/255.255.255.0 (this would be the same on your
    716g)

    Calls in and out are working fine
     
    paul123, Sep 1, 2006
    #4
  5. Telephoneman

    Telephoneman Guest

    "paul123" <> wrote in message
    news:...
    >
    > paul123 wrote:
    >> Telephoneman wrote:
    >> > Can anyone shed any light on this? I've set up 3 trunks - Voiptalk,
    >> > Voipfone
    >> > and Sipgate. With Voipfone and Sipgate I get 2 way audio but with
    >> > Voiptalk
    >> > the other party can hear me but I can't hear them.
    >> >
    >> > Voiptalk CS won't support trixbox at the moment, although they
    >> > helpfully
    >> > sent me a config that another customer had used successfully. If the
    >> > problem
    >> > was across all Carriers I'd suspect a NAT or port forwarding issue but
    >> > with
    >> > just one I'm scratching my head a bit.
    >> >

    >>
    >> Calling Jono, What did you do to get Voiptalk working?
    >>
    >> Liam's tried my settings which work fine here, but gets this one-way
    >> audio issue.
    >>
    >> Funnily, I tried my settings from my normal Trixbox in my experimental
    >> Vmware version, and I'm getting this same issue......

    >
    > Sorry to answer my own post, but it now works on the vmware version
    > too.
    >
    > In config edit->sip_nat.conf I had to add:
    >
    > externip=myfixedIP (not my dyndnsname)
    > localnet=192.168.1.0/255.255.255.0 (this would be the same on your
    > 716g)
    >
    > Calls in and out are working fine


    Hi Paul,

    I had the above in sip.conf under [general] but with the dyndns name. I
    removed it and put it in sip_nat.conf with the IP address. Still no joy.
    Re-booted linux/asterisk and made 1 call on Voiptalk - still one-way audio
    but subsequent attempts to call on this trunk get the asterisk lady telling
    me it's busy...

    I'm going out to buy some Strowger switches...

    Liam
     
    Telephoneman, Sep 1, 2006
    #5
  6. Telephoneman

    Jono Guest

    on 01/09/2006, paul123 supposed :
    > Calling Jono, What did you do to get Voiptalk working?


    Alas, nothing. It's not a provider I use.
     
    Jono, Sep 1, 2006
    #6
  7. Telephoneman

    paul123 Guest

    Jono wrote:
    > on 01/09/2006, paul123 supposed :
    > > Calling Jono, What did you do to get Voiptalk working?

    >
    > Alas, nothing. It's not a provider I use.


    Aha, never mind, it's just that I had assumed you'd got it working -
    voiptalk had come up in an earlier thread (about the free signup for a
    geo number), where you'd had some probs.

    Not to worry, we'll get there in the end.
     
    paul123, Sep 1, 2006
    #7
  8. Telephoneman

    Jono Guest

    paul123 laid this down on his screen :
    > Jono wrote:
    >> on 01/09/2006, paul123 supposed :
    >>> Calling Jono, What did you do to get Voiptalk working?

    >>
    >> Alas, nothing. It's not a provider I use.

    >
    > Aha, never mind, it's just that I had assumed you'd got it working -
    > voiptalk had come up in an earlier thread (about the free signup for a
    > geo number), where you'd had some probs.
    >
    > Not to worry, we'll get there in the end.


    Bugger. Yes, I was thinking "voipfone". You're right. Duh!

    I had to play around with getting the inbound DID working, I can't say
    there was much wrong with the audio, however, here're my trunk
    settings:

    PEER:
    allow=ulaw
    authuser=12345678
    canreinvite=no
    context=from-pstn
    defaultexpirey=160
    disallow=all
    fromdomain=voiptalk.org
    fromuser=12345678
    host=voiptalk.org
    insecure=very
    maxexpirey=180
    nat=yes
    secret=abcDefg
    type=friend
    username=12345678

    User Context: ext-did

    Incoming settings:
    allow=ulaw
    authuser=12345678
    canreinvite=no
    context=ext-did
    defaultexpirey=160
    disallow=all
    fromdomain=voiptalk.org
    fromuser=12345678
    host=voiptalk.org
    insecure=very
    maxexpirey=180
    nat=yes
    secret=abcDefg
    type=peer
    username=12345678

    I've also got this in extensions_custom.conf:
    [custom-voiptalk]
    exten => 12345678,1,Goto(ext-did,12345678,1)

    I have also created an inbound route for 12345678.

    I think I have a bit more in sip.conf:

    port = 5060 ; Port to bind to (SIP is 5060)
    bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
    disallow=all
    allow=ulaw
    allow=alaw
    allow=gsm
    context = from-trunk
    ;defaultexpirey = 600 ; include this only if necessary
    ;maxexpirey = 3600 ; include this only if necessary
    progressinband = yes
    dtmfmode=auto

    callerid = Unknown
    externip = my.dyndns.hostname
    localnet=192.168.1.0/255.255.255.0
    nat=yes

    #include sip_nat.conf
    #include sip_custom.conf
    #include sip_additional.conf
     
    Jono, Sep 1, 2006
    #8
  9. Telephoneman

    paul123 Guest

    Jono wrote:
    > paul123 laid this down on his screen :
    > > Jono wrote:
    > >> on 01/09/2006, paul123 supposed :
    > >>> Calling Jono, What did you do to get Voiptalk working?
    > >>
    > >> Alas, nothing. It's not a provider I use.

    > >
    > > Aha, never mind, it's just that I had assumed you'd got it working -
    > > voiptalk had come up in an earlier thread (about the free signup for a
    > > geo number), where you'd had some probs.
    > >
    > > Not to worry, we'll get there in the end.

    >
    > Bugger. Yes, I was thinking "voipfone". You're right. Duh!

    <snip>

    You're not the only one to mix those two up. Easily done! I was
    recently in email contact with someone and I sent them to voipfone
    instead of voiptalk. Not surprisingly, they couldn't find what I was
    talking about.
     
    paul123, Sep 2, 2006
    #9
  10. Telephoneman

    linker3000 Guest

    Jono wrote:

    defaultexpirey=160


    Eh?
     
    linker3000, Sep 2, 2006
    #10
  11. Telephoneman

    Jono Guest

    linker3000 pretended :
    > Jono wrote:
    >
    > defaultexpirey=160
    >
    >
    > Eh?


    Hmm.

    I didn't write my configs myself! I got them here from.....paul123
    <http://groups.google.co.uk/group/uk.telecom.voip/tree/browse_frm/thread/6f602f2a3e0468a1/e90748215e800e83?rnum=21&hl=en&q=unbeatable+voiptalk+offer%3F&_done=%2Fgroup%2Fuk.telecom.voip%2Fbrowse_frm%2Fthread%2F6f602f2a3e0468a1%2F67637652895864be%3Ftvc%3D1%26q%3Dunbeatable+voiptalk+offer%3F%26hl%3Den%26#doc_3fae756fba793790>

    .......paul123, why are you asking me how I got voiptalk working, when
    you told me?
     
    Jono, Sep 2, 2006
    #11
  12. Telephoneman

    paul123 Guest

    Jono wrote:
    > linker3000 pretended :
    > > Jono wrote:
    > >
    > > defaultexpirey=160
    > >
    > >
    > > Eh?

    >
    > Hmm.
    >
    > I didn't write my configs myself! I got them here from.....paul123
    > <http://groups.google.co.uk/group/uk.telecom.voip/tree/browse_frm/thread/6f602f2a3e0468a1/e90748215e800e83?rnum=21&hl=en&q=unbeatable+voiptalk+offer%3F&_done=%2Fgroup%2Fuk.telecom.voip%2Fbrowse_frm%2Fthread%2F6f602f2a3e0468a1%2F67637652895864be%3Ftvc%3D1%26q%3Dunbeatable+voiptalk+offer%3F%26hl%3Den%26#doc_3fae756fba793790>
    >
    > ......paul123, why are you asking me how I got voiptalk working, when
    > you told me?


    lol, :) yes, I know, but I thought that you had initial audio problems
    too and that maybe you'd had to adjust something to get it going OK.
    But now, looking back at that thread, I see that it was dialling format
    that was the problem.
     
    paul123, Sep 2, 2006
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Julian Zelones

    Windows Messenger - no incoming audio

    Julian Zelones, Oct 27, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    475
    Julian Zelones
    Oct 27, 2004
  2. Julian Zelones

    MSN Messenger 6.2 - no incoming audio

    Julian Zelones, Oct 29, 2004, in forum: Computer Support
    Replies:
    1
    Views:
    541
    Pauline
    Oct 29, 2004
  3. Telephoneman

    Trixbox - no incoming audio with Voiptalk

    Telephoneman, Sep 1, 2006, in forum: UK VOIP
    Replies:
    11
    Views:
    861
    paul123
    Sep 2, 2006
  4. Michael Bower
    Replies:
    3
    Views:
    4,593
    beenthere
    Oct 1, 2006
  5. R. Giskard Reventlov

    No Incoming Calls on VoipTalk

    R. Giskard Reventlov, Apr 22, 2009, in forum: UK VOIP
    Replies:
    0
    Views:
    849
    R. Giskard Reventlov
    Apr 22, 2009
Loading...

Share This Page