Traffic Shaping / Policing Question

Discussion in 'Cisco' started by jere.cassidy@gmail.com, Apr 25, 2007.

  1. Guest

    I must have a problem with my configuration. Thanks in advance for
    the help.

    I simply have some TDMoIP boxes (T1 to ethernet) on each side of a
    slow WAN link (approx 24Mbps). On each end of the WAN link is a
    2620XL router running 12.2.40a. These routers have FastEthernet
    interfaces facing the WAN link. The TDMoIP boxes use 3Mbps of
    constant bandwidth. The customer has run fine for a few years, but
    has started seeing drops
    associated with high loads on their link.

    My reasoning in setting up the service policy was that I needed to
    reserve (priority) 3 Mbps of traffic for the TDMoIP and then throttle
    the rest to an ammount less than the capacity of the WAN link.

    So I create 2 classes: VOIP with priority 3072 and class-default with
    shape average 15000000. (using a total of 18Mbps). This should be
    well under the link capacity (24Mbps) and I should not see congestion.

    When I apply the service policy, I can see the counters in each class
    respond as expected.
    Total traffic seems limited to approximately 18Mbps.
    But the TDM boxes suffer greatly when the link is loaded. All
    interactive traffic is also thwarted big time under shaping or
    policing.

    I have tried nesting the service policies as seen in some examples
    on Cisco's page, but even then, the problems did not subside.

    I have tried policing instead of shaping with various burst values for
    both.

    Here is my config (its the same on both routers save for the source
    and destination are swapped for classifying the Voice traffic):

    class-map match-all VoiceRAD
    match access-group 157
    !
    !
    policy-map RadioLink_pmap
    class VoiceRAD
    priority 3072
    class class-default
    shape average 15000000
    !
    interface FastEthernet0/0
    ip address 172.31.1.121 255.255.0.0
    service-policy output RadioLink_pmap
    !
    access-list 157 permit ip host 10.35.1.10 host 10.34.9.95
    access-list 157 permit ip host 172.31.1.121 any


    I added the router's own IP in the access-list since it was my means
    of configuring the router. Even after adding it to the priority
    class, I would routinely wait 60-90 seconds for keystrokes to appear.

    Here is the output of the show service policy int:


    cte2600#show policy-map int
    FastEthernet0/0

    Service-policy output: RadioLink_pmap

    Class-map: VoiceRAD (match-all)
    4716486 packets, 424579155 bytes
    5 minute offered rate 2950000 bps, drop rate 0 bps
    Match: access-group 157
    Queueing
    Strict Priority
    Output Queue: Conversation 264
    Bandwidth 3072 (kbps) Burst 76800 (Bytes)
    (pkts matched/bytes matched) 4444/496383
    (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
    1258995 packets, 1746625441 bytes
    5 minute offered rate 14188000 bps, drop rate 0 bps
    Match: any
    Traffic Shaping
    Target/Average Byte Sustain Excess Interval
    Increment
    Rate Limit bits/int bits/int (ms)
    (bytes)
    15000000/15000000 93750 375000 375000 25 46875

    Adapt Queue Packets Bytes Packets Bytes
    Shaping
    Active Depth Delayed Delayed
    Active
    - 0 1259057 1746711591 226821 324632790 no



    This snapshot was taken shorly after load was removed, but you can see
    the offered 5-minute rate was under the threshold set, and also the 5-
    minute load on the voice traffic was as expected (3Mbps) and has a
    drop rate of 0. The only thing odd that I noticed was the line:
    (pkts matched/bytes matched) 4444/496383
    under the Voice section - I dont know what it means by matches - all
    4.7 million packets in that policy should be considered for the class.

    I thought policing would be better - just drop anything over 15000000
    bps, but it didnt seem to work either.

    I am at a loss of what to do next. I've tried a bunch of different
    ways to configure the shaping/policing without success.

    Thanks again.
    , Apr 25, 2007
    #1
    1. Advertising

  2. Scooby Guest

    <> wrote in message
    news:...
    >I must have a problem with my configuration. Thanks in advance for
    > the help.
    >
    > I simply have some TDMoIP boxes (T1 to ethernet) on each side of a
    > slow WAN link (approx 24Mbps). On each end of the WAN link is a
    > 2620XL router running 12.2.40a. These routers have FastEthernet
    > interfaces facing the WAN link. The TDMoIP boxes use 3Mbps of
    > constant bandwidth. The customer has run fine for a few years, but
    > has started seeing drops
    > associated with high loads on their link.
    >
    > My reasoning in setting up the service policy was that I needed to
    > reserve (priority) 3 Mbps of traffic for the TDMoIP and then throttle
    > the rest to an ammount less than the capacity of the WAN link.
    >
    > So I create 2 classes: VOIP with priority 3072 and class-default with
    > shape average 15000000. (using a total of 18Mbps). This should be
    > well under the link capacity (24Mbps) and I should not see congestion.
    >
    > When I apply the service policy, I can see the counters in each class
    > respond as expected.
    > Total traffic seems limited to approximately 18Mbps.
    > But the TDM boxes suffer greatly when the link is loaded. All
    > interactive traffic is also thwarted big time under shaping or
    > policing.
    >
    > I have tried nesting the service policies as seen in some examples
    > on Cisco's page, but even then, the problems did not subside.
    >
    > I have tried policing instead of shaping with various burst values for
    > both.
    >
    > Here is my config (its the same on both routers save for the source
    > and destination are swapped for classifying the Voice traffic):
    >
    > class-map match-all VoiceRAD
    > match access-group 157
    > !
    > !
    > policy-map RadioLink_pmap
    > class VoiceRAD
    > priority 3072
    > class class-default
    > shape average 15000000
    > !
    > interface FastEthernet0/0
    > ip address 172.31.1.121 255.255.0.0
    > service-policy output RadioLink_pmap
    > !
    > access-list 157 permit ip host 10.35.1.10 host 10.34.9.95
    > access-list 157 permit ip host 172.31.1.121 any
    >
    >
    > I added the router's own IP in the access-list since it was my means
    > of configuring the router. Even after adding it to the priority
    > class, I would routinely wait 60-90 seconds for keystrokes to appear.
    >
    > Here is the output of the show service policy int:
    >
    >
    > cte2600#show policy-map int
    > FastEthernet0/0
    >
    > Service-policy output: RadioLink_pmap
    >
    > Class-map: VoiceRAD (match-all)
    > 4716486 packets, 424579155 bytes
    > 5 minute offered rate 2950000 bps, drop rate 0 bps
    > Match: access-group 157
    > Queueing
    > Strict Priority
    > Output Queue: Conversation 264
    > Bandwidth 3072 (kbps) Burst 76800 (Bytes)
    > (pkts matched/bytes matched) 4444/496383
    > (total drops/bytes drops) 0/0
    >
    > Class-map: class-default (match-any)
    > 1258995 packets, 1746625441 bytes
    > 5 minute offered rate 14188000 bps, drop rate 0 bps
    > Match: any
    > Traffic Shaping
    > Target/Average Byte Sustain Excess Interval
    > Increment
    > Rate Limit bits/int bits/int (ms)
    > (bytes)
    > 15000000/15000000 93750 375000 375000 25 46875
    >
    > Adapt Queue Packets Bytes Packets Bytes
    > Shaping
    > Active Depth Delayed Delayed
    > Active
    > - 0 1259057 1746711591 226821 324632790 no
    >
    >
    >
    > This snapshot was taken shorly after load was removed, but you can see
    > the offered 5-minute rate was under the threshold set, and also the 5-
    > minute load on the voice traffic was as expected (3Mbps) and has a
    > drop rate of 0. The only thing odd that I noticed was the line:
    > (pkts matched/bytes matched) 4444/496383
    > under the Voice section - I dont know what it means by matches - all
    > 4.7 million packets in that policy should be considered for the class.
    >
    > I thought policing would be better - just drop anything over 15000000
    > bps, but it didnt seem to work either.
    >
    > I am at a loss of what to do next. I've tried a bunch of different
    > ways to configure the shaping/policing without success.
    >
    > Thanks again.
    >


    What does the CPU look like during the peak traffic times? I would suspect
    that the 2620 doesn't have enough horse power for what you are trying to do.
    Scooby, Apr 25, 2007
    #2
    1. Advertising

  3. Guest

    On Apr 25, 8:49 am, "Scooby" <> wrote:
    > <> wrote in message
    >
    > news:...
    >
    >
    >
    >
    >
    > >I must have a problem with my configuration. Thanks in advance for
    > > the help.

    >
    > > I simply have some TDMoIP boxes (T1 to ethernet) on each side of a
    > > slow WAN link (approx 24Mbps). On each end of the WAN link is a
    > > 2620XL router running 12.2.40a. These routers have FastEthernet
    > > interfaces facing the WAN link. The TDMoIP boxes use 3Mbps of
    > > constant bandwidth. The customer has run fine for a few years, but
    > > has started seeing drops
    > > associated with high loads on their link.

    >
    > > My reasoning in setting up the service policy was that I needed to
    > > reserve (priority) 3 Mbps of traffic for the TDMoIP and then throttle
    > > the rest to an ammount less than the capacity of the WAN link.

    >
    > > So I create 2 classes: VOIP with priority 3072 and class-default with
    > > shape average 15000000. (using a total of 18Mbps). This should be
    > > well under the link capacity (24Mbps) and I should not see congestion.

    >
    > > When I apply the service policy, I can see the counters in each class
    > > respond as expected.
    > > Total traffic seems limited to approximately 18Mbps.
    > > But the TDM boxes suffer greatly when the link is loaded. All
    > > interactive traffic is also thwarted big time under shaping or
    > > policing.

    >
    > > I have tried nesting the service policies as seen in some examples
    > > on Cisco's page, but even then, the problems did not subside.

    >
    > > I have tried policing instead of shaping with various burst values for
    > > both.

    >
    > > Here is my config (its the same on both routers save for the source
    > > and destination are swapped for classifying the Voice traffic):

    >
    > > class-map match-all VoiceRAD
    > > match access-group 157
    > > !
    > > !
    > > policy-map RadioLink_pmap
    > > class VoiceRAD
    > > priority 3072
    > > class class-default
    > > shape average 15000000
    > > !
    > > interface FastEthernet0/0
    > > ip address 172.31.1.121 255.255.0.0
    > > service-policy output RadioLink_pmap
    > > !
    > > access-list 157 permit ip host 10.35.1.10 host 10.34.9.95
    > > access-list 157 permit ip host 172.31.1.121 any

    >
    > > I added the router's own IP in the access-list since it was my means
    > > of configuring the router. Even after adding it to the priority
    > > class, I would routinely wait 60-90 seconds for keystrokes to appear.

    >
    > > Here is the output of the show service policy int:

    >
    > > cte2600#show policy-map int
    > > FastEthernet0/0

    >
    > > Service-policy output: RadioLink_pmap

    >
    > > Class-map: VoiceRAD (match-all)
    > > 4716486 packets, 424579155 bytes
    > > 5 minute offered rate 2950000 bps, drop rate 0 bps
    > > Match: access-group 157
    > > Queueing
    > > Strict Priority
    > > Output Queue: Conversation 264
    > > Bandwidth 3072 (kbps) Burst 76800 (Bytes)
    > > (pkts matched/bytes matched) 4444/496383
    > > (total drops/bytes drops) 0/0

    >
    > > Class-map: class-default (match-any)
    > > 1258995 packets, 1746625441 bytes
    > > 5 minute offered rate 14188000 bps, drop rate 0 bps
    > > Match: any
    > > Traffic Shaping
    > > Target/Average Byte Sustain Excess Interval
    > > Increment
    > > Rate Limit bits/int bits/int (ms)
    > > (bytes)
    > > 15000000/15000000 93750 375000 375000 25 46875

    >
    > > Adapt Queue Packets Bytes Packets Bytes
    > > Shaping
    > > Active Depth Delayed Delayed
    > > Active
    > > - 0 1259057 1746711591 226821 324632790 no

    >
    > > This snapshot was taken shorly after load was removed, but you can see
    > > the offered 5-minute rate was under the threshold set, and also the 5-
    > > minute load on the voice traffic was as expected (3Mbps) and has a
    > > drop rate of 0. The only thing odd that I noticed was the line:
    > > (pkts matched/bytes matched) 4444/496383
    > > under the Voice section - I dont know what it means by matches - all
    > > 4.7 million packets in that policy should be considered for the class.

    >
    > > I thought policing would be better - just drop anything over 15000000
    > > bps, but it didnt seem to work either.

    >
    > > I am at a loss of what to do next. I've tried a bunch of different
    > > ways to configure the shaping/policing without success.

    >
    > > Thanks again.

    >
    > What does the CPU look like during the peak traffic times? I would suspect
    > that the 2620 doesn't have enough horse power for what you are trying to do.- Hide quoted text -
    >


    This was one of my fears. The CPU does appear to be hammered for
    short periods of time- spiking up to 99%/99% on the 5 second average.
    But generally, it was ranging in the 75-90% range. The CLI goes
    unresponsive, but I took that as more of a packet drop/delay problem
    than a CPU issue.

    Is there a way to determine how much a 2620XL should be able to shape
    and/or police? again, I am working with a 24Mbps link trying to
    prioritize 3Mbps and limit all other data to 18Mbps.
    Is there a chart / whitepaper on Cisco's site?

    They also have a 4607R on just one side of the link. I am not sure
    what type of switch is on the other side, but I'd expect a 2950 or
    some kind of workgroup switch. I may try to attack the traffic
    shaping/policing with those devices.

    Thanks for the help!

    -Jere
    , Apr 26, 2007
    #3
  4. Scooby Guest

    <> wrote in message
    news:...
    > On Apr 25, 8:49 am, "Scooby" <> wrote:
    >> <> wrote in message
    >>
    >> news:...
    >>
    >>
    >>
    >>
    >>
    >> >I must have a problem with my configuration. Thanks in advance for
    >> > the help.

    >>
    >> > I simply have some TDMoIP boxes (T1 to ethernet) on each side of a
    >> > slow WAN link (approx 24Mbps). On each end of the WAN link is a
    >> > 2620XL router running 12.2.40a. These routers have FastEthernet
    >> > interfaces facing the WAN link. The TDMoIP boxes use 3Mbps of
    >> > constant bandwidth. The customer has run fine for a few years, but
    >> > has started seeing drops
    >> > associated with high loads on their link.

    >>
    >> > My reasoning in setting up the service policy was that I needed to
    >> > reserve (priority) 3 Mbps of traffic for the TDMoIP and then throttle
    >> > the rest to an ammount less than the capacity of the WAN link.

    >>
    >> > So I create 2 classes: VOIP with priority 3072 and class-default with
    >> > shape average 15000000. (using a total of 18Mbps). This should be
    >> > well under the link capacity (24Mbps) and I should not see congestion.

    >>
    >> > When I apply the service policy, I can see the counters in each class
    >> > respond as expected.
    >> > Total traffic seems limited to approximately 18Mbps.
    >> > But the TDM boxes suffer greatly when the link is loaded. All
    >> > interactive traffic is also thwarted big time under shaping or
    >> > policing.

    >>
    >> > I have tried nesting the service policies as seen in some examples
    >> > on Cisco's page, but even then, the problems did not subside.

    >>
    >> > I have tried policing instead of shaping with various burst values for
    >> > both.

    >>
    >> > Here is my config (its the same on both routers save for the source
    >> > and destination are swapped for classifying the Voice traffic):

    >>
    >> > class-map match-all VoiceRAD
    >> > match access-group 157
    >> > !
    >> > !
    >> > policy-map RadioLink_pmap
    >> > class VoiceRAD
    >> > priority 3072
    >> > class class-default
    >> > shape average 15000000
    >> > !
    >> > interface FastEthernet0/0
    >> > ip address 172.31.1.121 255.255.0.0
    >> > service-policy output RadioLink_pmap
    >> > !
    >> > access-list 157 permit ip host 10.35.1.10 host 10.34.9.95
    >> > access-list 157 permit ip host 172.31.1.121 any

    >>
    >> > I added the router's own IP in the access-list since it was my means
    >> > of configuring the router. Even after adding it to the priority
    >> > class, I would routinely wait 60-90 seconds for keystrokes to appear.

    >>
    >> > Here is the output of the show service policy int:

    >>
    >> > cte2600#show policy-map int
    >> > FastEthernet0/0

    >>
    >> > Service-policy output: RadioLink_pmap

    >>
    >> > Class-map: VoiceRAD (match-all)
    >> > 4716486 packets, 424579155 bytes
    >> > 5 minute offered rate 2950000 bps, drop rate 0 bps
    >> > Match: access-group 157
    >> > Queueing
    >> > Strict Priority
    >> > Output Queue: Conversation 264
    >> > Bandwidth 3072 (kbps) Burst 76800 (Bytes)
    >> > (pkts matched/bytes matched) 4444/496383
    >> > (total drops/bytes drops) 0/0

    >>
    >> > Class-map: class-default (match-any)
    >> > 1258995 packets, 1746625441 bytes
    >> > 5 minute offered rate 14188000 bps, drop rate 0 bps
    >> > Match: any
    >> > Traffic Shaping
    >> > Target/Average Byte Sustain Excess Interval
    >> > Increment
    >> > Rate Limit bits/int bits/int (ms)
    >> > (bytes)
    >> > 15000000/15000000 93750 375000 375000 25 46875

    >>
    >> > Adapt Queue Packets Bytes Packets Bytes
    >> > Shaping
    >> > Active Depth Delayed Delayed
    >> > Active
    >> > - 0 1259057 1746711591 226821 324632790 no

    >>
    >> > This snapshot was taken shorly after load was removed, but you can see
    >> > the offered 5-minute rate was under the threshold set, and also the 5-
    >> > minute load on the voice traffic was as expected (3Mbps) and has a
    >> > drop rate of 0. The only thing odd that I noticed was the line:
    >> > (pkts matched/bytes matched) 4444/496383
    >> > under the Voice section - I dont know what it means by matches - all
    >> > 4.7 million packets in that policy should be considered for the class.

    >>
    >> > I thought policing would be better - just drop anything over 15000000
    >> > bps, but it didnt seem to work either.

    >>
    >> > I am at a loss of what to do next. I've tried a bunch of different
    >> > ways to configure the shaping/policing without success.

    >>
    >> > Thanks again.

    >>
    >> What does the CPU look like during the peak traffic times? I would
    >> suspect
    >> that the 2620 doesn't have enough horse power for what you are trying to
    >> do.- Hide quoted text -
    >>

    >
    > This was one of my fears. The CPU does appear to be hammered for
    > short periods of time- spiking up to 99%/99% on the 5 second average.
    > But generally, it was ranging in the 75-90% range. The CLI goes
    > unresponsive, but I took that as more of a packet drop/delay problem
    > than a CPU issue.
    >
    > Is there a way to determine how much a 2620XL should be able to shape
    > and/or police? again, I am working with a 24Mbps link trying to
    > prioritize 3Mbps and limit all other data to 18Mbps.
    > Is there a chart / whitepaper on Cisco's site?
    >
    > They also have a 4607R on just one side of the link. I am not sure
    > what type of switch is on the other side, but I'd expect a 2950 or
    > some kind of workgroup switch. I may try to attack the traffic
    > shaping/policing with those devices.
    >
    > Thanks for the help!
    >
    > -Jere
    >


    The policing/shaping is not the problem. This router is just not strong
    enough to handle that volume of traffic. Do make sure that you have CEF
    enabled, but I still think you will need to replace the router to get the
    throughput you are looking for. That said, it probably is wise to move
    where you are doing the shaping. You want to handle this as close to the
    source as you can. You may need to find the setting that keeps the traffic
    on your router to a managable level. But, that means you are wasting
    bandwidth.

    Cisco does have some white papers available. I don't have any links
    available - sorry. I have reviewed them before and they are worth looking
    at, just don't have them handy. The maximum throughput on routers is not
    rated on bandwidth, but on pps. The idea being that it takes about as much
    processing power for a small packet as it does for a big one. Try searching
    Cisco's site for pps throughput and your router model. You can do the math
    on the pps numbers to get the max bandwidth expected based on min/max packet
    sizes.

    Hope that helps,

    Jim
    Scooby, Apr 26, 2007
    #4
  5. Guest

    On Apr 26, 12:16 pm, "Scooby" <> wrote:
    > <> wrote in message
    >
    > news:...
    >
    >
    >
    >
    >
    > > On Apr 25, 8:49 am, "Scooby" <> wrote:
    > >> <> wrote in message

    >
    > >>news:...

    >
    > >> >I must have a problem with my configuration. Thanks in advance for
    > >> > the help.

    >
    > >> > I simply have some TDMoIP boxes (T1 to ethernet) on each side of a
    > >> > slow WAN link (approx 24Mbps). On each end of the WAN link is a
    > >> > 2620XL router running 12.2.40a. These routers have FastEthernet
    > >> > interfaces facing the WAN link. The TDMoIP boxes use 3Mbps of
    > >> > constant bandwidth. The customer has run fine for a few years, but
    > >> > has started seeing drops
    > >> > associated with high loads on their link.

    >
    > >> > My reasoning in setting up the service policy was that I needed to
    > >> > reserve (priority) 3 Mbps of traffic for the TDMoIP and then throttle
    > >> > the rest to an ammount less than the capacity of the WAN link.

    >
    > >> > So I create 2 classes: VOIP with priority 3072 and class-default with
    > >> > shape average 15000000. (using a total of 18Mbps). This should be
    > >> > well under the link capacity (24Mbps) and I should not see congestion.

    >
    > >> > When I apply the service policy, I can see the counters in each class
    > >> > respond as expected.
    > >> > Total traffic seems limited to approximately 18Mbps.
    > >> > But the TDM boxes suffer greatly when the link is loaded. All
    > >> > interactive traffic is also thwarted big time under shaping or
    > >> > policing.

    >
    > >> > I have tried nesting the service policies as seen in some examples
    > >> > on Cisco's page, but even then, the problems did not subside.

    >
    > >> > I have tried policing instead of shaping with various burst values for
    > >> > both.

    >
    > >> > Here is my config (its the same on both routers save for the source
    > >> > and destination are swapped for classifying the Voice traffic):

    >
    > >> > class-map match-all VoiceRAD
    > >> > match access-group 157
    > >> > !
    > >> > !
    > >> > policy-map RadioLink_pmap
    > >> > class VoiceRAD
    > >> > priority 3072
    > >> > class class-default
    > >> > shape average 15000000
    > >> > !
    > >> > interface FastEthernet0/0
    > >> > ip address 172.31.1.121 255.255.0.0
    > >> > service-policy output RadioLink_pmap
    > >> > !
    > >> > access-list 157 permit ip host 10.35.1.10 host 10.34.9.95
    > >> > access-list 157 permit ip host 172.31.1.121 any

    >
    > >> > I added the router's own IP in the access-list since it was my means
    > >> > of configuring the router. Even after adding it to the priority
    > >> > class, I would routinely wait 60-90 seconds for keystrokes to appear.

    >
    > >> > Here is the output of the show service policy int:

    >
    > >> > cte2600#show policy-map int
    > >> > FastEthernet0/0

    >
    > >> > Service-policy output: RadioLink_pmap

    >
    > >> > Class-map: VoiceRAD (match-all)
    > >> > 4716486 packets, 424579155 bytes
    > >> > 5 minute offered rate 2950000 bps, drop rate 0 bps
    > >> > Match: access-group 157
    > >> > Queueing
    > >> > Strict Priority
    > >> > Output Queue: Conversation 264
    > >> > Bandwidth 3072 (kbps) Burst 76800 (Bytes)
    > >> > (pkts matched/bytes matched) 4444/496383
    > >> > (total drops/bytes drops) 0/0

    >
    > >> > Class-map: class-default (match-any)
    > >> > 1258995 packets, 1746625441 bytes
    > >> > 5 minute offered rate 14188000 bps, drop rate 0 bps
    > >> > Match: any
    > >> > Traffic Shaping
    > >> > Target/Average Byte Sustain Excess Interval
    > >> > Increment
    > >> > Rate Limit bits/int bits/int (ms)
    > >> > (bytes)
    > >> > 15000000/15000000 93750 375000 375000 25 46875

    >
    > >> > Adapt Queue Packets Bytes Packets Bytes
    > >> > Shaping
    > >> > Active Depth Delayed Delayed
    > >> > Active
    > >> > - 0 1259057 1746711591 226821 324632790 no

    >
    > >> > This snapshot was taken shorly after load was removed, but you can see
    > >> > the offered 5-minute rate was under the threshold set, and also the 5-
    > >> > minute load on the voice traffic was as expected (3Mbps) and has a
    > >> > drop rate of 0. The only thing odd that I noticed was the line:
    > >> > (pkts matched/bytes matched) 4444/496383
    > >> > under the Voice section - I dont know what it means by matches - all
    > >> > 4.7 million packets in that policy should be considered for the class.

    >
    > >> > I thought policing would be better - just drop anything over 15000000
    > >> > bps, but it didnt seem to work either.

    >
    > >> > I am at a loss of what to do next. I've tried a bunch of different
    > >> > ways to configure the shaping/policing without success.

    >
    > >> > Thanks again.

    >
    > >> What does the CPU look like during the peak traffic times? I would
    > >> suspect
    > >> that the 2620 doesn't have enough horse power for what you are trying to
    > >> do.- Hide quoted text -

    >
    > > This was one of my fears. The CPU does appear to be hammered for
    > > short periods of time- spiking up to 99%/99% on the 5 second average.
    > > But generally, it was ranging in the 75-90% range. The CLI goes
    > > unresponsive, but I took that as more of a packet drop/delay problem
    > > than a CPU issue.

    >
    > > Is there a way to determine how much a 2620XL should be able to shape
    > > and/or police? again, I am working with a 24Mbps link trying to
    > > prioritize 3Mbps and limit all other data to 18Mbps.
    > > Is there a chart / whitepaper on Cisco's site?

    >
    > > They also have a 4607R on just one side of the link. I am not sure
    > > what type of switch is on the other side, but I'd expect a 2950 or
    > > some kind of workgroup switch. I may try to attack the traffic
    > > shaping/policing with those devices.

    >
    > > Thanks for the help!

    >
    > > -Jere

    >
    > The policing/shaping is not the problem. This router is just not strong
    > enough to handle that volume of traffic. Do make sure that you have CEF
    > enabled, but I still think you will need to replace the router to get the
    > throughput you are looking for. That said, it probably is wise to move
    > where you are doing the shaping. You want to handle this as close to the
    > source as you can. You may need to find the setting that keeps the traffic
    > on your router to a managable level. But, that means you are wasting
    > bandwidth.
    >
    > Cisco does have some white papers available. I don't have any links
    > available - sorry. I have reviewed them before and they are worth looking
    > at, just don't have them handy. The maximum throughput on routers is not
    > rated on bandwidth, but on pps. The idea being that it takes about as much
    > processing power for a small packet as it does for a big one. Try searching
    > Cisco's site for pps throughput and your router model. You can do the math
    > on the pps numbers to get the max bandwidth expected based on min/max packet
    > sizes.
    >
    > Hope that helps,
    >
    > Jim- Hide quoted text -
    >
    > - Show quoted text -


    Thanks a lot Jim. I have located the pps numbers on the 2620XL and
    its 30000 pps. But that is straight from the data sheet and I am
    sure is the standard packet rate without any kind of shaping or
    policing. I will look arround for some papers that indicate how the
    PPS would be reduced by shaping/policing. I did notice that the
    backplane of the 4507R was 75million pps. So that device should have
    a lot more leeway with shaping/policing applied. If the switch on the
    remote side is an old 2950 or something, I'll just have to deal with
    that in another way.

    Thanks again!
    , Apr 26, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Kenny D
    Replies:
    1
    Views:
    632
    Remien, Carsten
    Dec 5, 2003
  2. Josh
    Replies:
    0
    Views:
    567
  3. Replies:
    2
    Views:
    551
  4. Hypno999

    traffic-shaping limit ftp traffic

    Hypno999, Oct 7, 2005, in forum: Cisco
    Replies:
    5
    Views:
    3,607
  5. Nova
    Replies:
    2
    Views:
    931
    ~misfit~
    Mar 20, 2006
Loading...

Share This Page