tftp & ftp troubles

Discussion in 'Cisco' started by Draschl Clemens, Jul 9, 2003.

  1. hi,

    seems, that I've got a strange thing on my cisco 1720, running IOS
    12.1(5)-YB4. None of the copy-commands for backing up the startup-config or
    updating the IOS in the flash works. I tried:

    copy startup-config tft
    copy startup-config ftp

    copy tftp flash
    copy ftp flash

    Every time I recieve an error message like "%Error opening
    flash:start-config (No such device)" when backing up the startup-config to
    a ftp/tftp-server.

    When i try to load an image from tftp/ftp, "%Error opening
    ftp://username:password@location/ios-image (No such device)"

    i verified the ftp-server and the tftp server, both are working correctly.
    But it's funny, that backing up the IOS-image to the ftp-serve works well,
    only copying back ends with one of the error-messages above. I've set the
    tftp-source-interface (as far as I know, this only takes effect if the
    router is a tftp-server itself), I minimized the interface, where the
    tftp-server is connected to nothing, only the IP-address. No access-lists,
    o fw/ids, no crypto. Nothing. But it doesn't work. Using the console cable
    isn't possible due to geographical distance (Europe -> USA).

    Anybody knows what's wrong here?


    Thanks in advance

    /cd

    config:

    Current configuration : 4483 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    !
    logging rate-limit console 10 except errors
    !
    memory-size iomem 20
    ip subnet-zero
    !
    !
    no ip finger
    no ip ftp passive
    no ip domain-lookup
    !
    ip inspect name fw http java-list 51 timeout 30
    ip inspect name fw smtp
    ip inspect name fw h323
    ip inspect name fw udp
    ip inspect name fw ftp
    ip inspect name fw fragment maximum 256 timeout 1
    ip inspect name fw tcp
    ip audit notify log
    ip audit po max-events 100
    no ip dhcp-client network-discovery
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.254 255.255.255.0
    no ip redirects
    ip nat inside
    no ip route-cache
    no ip mroute-cache
    half-duplex
    !
    interface FastEthernet0
    no ip address
    shutdown
    speed auto
    !
    interface Serial0
    bandwidth 1024
    ip address xxxx
    no ip redirects
    ip nat outside
    ip inspect fw out
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    !
    ip nat inside source list 110 interface Serial0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    no ip http server
    !
    [access-lists]
    !
    !
    !
    line con 0
    exec-timeout 0 0
    transport input none
    escape-character 27
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    login
    escape-character 27
    !
    end
     
    Draschl Clemens, Jul 9, 2003
    #1
    1. Advertising

  2. Draschl Clemens

    REBOOT

    Joined:
    Oct 8, 2008
    Messages:
    1
    Try issuing the "dir" command at a CLI prompt:

    This should tell you what filesystem type you're using.

    Remember to use ftp you need to tell it the username and password

    ip ftp username <name>
    ip ftp password <passwd>

    service password-encryptiton
     
    REBOOT, Oct 8, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Saket Badola
    Replies:
    3
    Views:
    7,820
    Saket Badola
    Apr 5, 2004
  2. JR

    FTP vs TFTP

    JR, Aug 15, 2004, in forum: Cisco
    Replies:
    6
    Views:
    33,622
    bryanpalacios
    Feb 16, 2010
  3. JR

    FTP vs. TFTP

    JR, Aug 15, 2004, in forum: Cisco
    Replies:
    0
    Views:
    614
  4. JR

    FTP vs. TFTP

    JR, Aug 16, 2004, in forum: Cisco
    Replies:
    2
    Views:
    4,577
  5. Sharad
    Replies:
    0
    Views:
    650
    Sharad
    Feb 13, 2007
Loading...

Share This Page