Terminal Services QoS

Discussion in 'Cisco' started by jjfunaz@gmail.com, Feb 23, 2005.

  1. Guest

    Hello, I need some help setting up a QoS for Terminal Services on
    several on our Routers. First let me explain our current set up. Router
    A is a 1721, with two Serial Wics. One T1 to the internet, one PtP to
    another facility. Router B is also a 1721 and getting internet through
    router A. Both Routers A and B are connecting to a Terminal Server farm
    in our Home Office which is network 12.x.x.0. Both Routers A and B are
    performing PAT and have a VPN to our Home office, but we don't want
    them pushing RDP traffic through the VPN and are connecting externally
    to the TS farm. Lately We've been having problems with a single user on
    behind router A or B that has been sucking up almost the Entire
    bandwith causing all other users to slow down considerably and
    sometimes causing other users to get disconnected. I'm looking to
    Implement a QoS so that this no longer happens and that no one user can
    suck that much Bandiwth. I've pasted the relevent configs below and
    help you can offer will be much appriciated.

    Router A

    crypto isakmp policy 1
    hash md5
    authentication pre-share
    crypto isakmp xxxxxxxx address x.x.x.x
    crypto isakmp keepalive 10 2
    !
    !
    crypto ipsec transform-set to_vpn esp-3des esp-md5-hmac
    !
    crypto map to_vpn 10 ipsec-isakmp
    set peer x.x.x.x
    set transform-set to_vpn
    match address 101
    !
    !
    !
    !
    interface FastEthernet0
    description RouterA LAN
    ip address 192.168.100.1 255.255.255.0
    ip nat inside
    speed 10
    half-duplex
    !
    interface Serial0
    description Router A to Internet
    ip address x.x.x.x 255.255.255.252
    ip nat outside
    no fair-queue
    crypto map to_vpn
    !
    interface Serial1
    description Router A point to point to Router B
    ip address x.x.x.x 255.255.255.252
    no ip route-cache
    no ip mroute-cache
    service-module t1 clock source internal
    !
    ip nat pool mypool x.x.x.x x.x.x.x netmask 255.255.255.252
    ip nat inside source route-map nonat pool mypool overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    no ip http server
    ip pim bidir-enable
    !
    logging source-interface FastEthernet0
    logging x.x.x.x

    route-map nonat permit 10
    match ip address 110



    Router B

    crypto isakmp policy 1
    hash md5
    authentication pre-share
    crypto isakmp xxxxxxxx address x.x.x.x
    crypto isakmp keepalive 10 2
    !
    !
    crypto ipsec transform-set to_vpn esp-3des esp-md5-hmac
    !
    crypto map to_vpn 10 ipsec-isakmp
    set peer x.x.x.x
    set transform-set to_vpn
    match address 101
    !
    !
    !
    !
    interface FastEthernet0
    description RouterB LAN
    ip address 192.168.101.1 255.255.255.0
    ip nat inside
    speed 10
    half-duplex
    !
    interface Serial0
    description Router B Poing to Point to Router A
    ip address x.x.x.x 255.255.255.252
    ip nat outside
    no fair-queue
    crypto map to_vpn
    !
    !
    ip nat pool mypool x.x.x.x x.x.x.x netmask 255.255.255.252
    ip nat inside source route-map nonat pool mypool overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    no ip http server
    ip pim bidir-enable
    !
    logging source-interface FastEthernet0
    logging x.x.x.x

    route-map nonat permit 10
    match ip address 110


    Thanks in advance for any help.
     
    , Feb 23, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?aXMgVGVybWluYWwgc2VydmVycyBjb21wYXRpYmxl

    Terminal services and VNC

    =?Utf-8?B?aXMgVGVybWluYWwgc2VydmVycyBjb21wYXRpYmxl, Jan 13, 2005, in forum: Wireless Networking
    Replies:
    2
    Views:
    7,413
    =?Utf-8?B?U3RldmU=?=
    Feb 3, 2005
  2. hook

    terminal services via wireless

    hook, Mar 17, 2005, in forum: Wireless Networking
    Replies:
    0
    Views:
    592
  3. brutus

    Using EV-DO connection with MS Terminal Services

    brutus, Oct 27, 2005, in forum: Wireless Networking
    Replies:
    2
    Views:
    465
    brutus
    Oct 28, 2005
  4. Jarrod Lash
    Replies:
    0
    Views:
    1,015
    Jarrod Lash
    Jun 11, 2004
  5. Nathan

    PIX 501 and Terminal Services

    Nathan, Sep 18, 2004, in forum: Cisco
    Replies:
    7
    Views:
    2,816
    Nathan
    Sep 20, 2004
Loading...

Share This Page