Telecom %$#@! Web Caching

Discussion in 'NZ Computing' started by Lawrence D'Oliveiro, May 25, 2011.

  1. Two different clients of mine have trouble fetching packages from Linux
    repositories. The symptom is a “hash sum†problem, indicating the downloaded
    package is corrupted and cannot be installed.

    One client is running Debian on servers, and I was able to work around the
    problem by accessing the repositories via FTP rather than HTTP. The other
    one is trying to set up an Ubuntu machine, and as far as I can tell the
    Ubuntu repositories don’t offer that option.

    Both are using Telecom as their ISP. I’m pretty sure this is being caused by
    caching that Telecom are interposing on accesses via port 80; we previously
    saw this quite clearly with the first client when they updated a web page on
    a hosting site but all the HTTP clients (not just browsers, but wget as
    well) at the client’s premises kept showing the old version, while if I used
    SSH to connect to another client’s place and wget the same page from there,
    it showed the updated version.

    I really don’t see why it’s worth Telecom’s while to pull this kind of crap
    on a broadband connection. Has anybody else hit this?
    Lawrence D'Oliveiro, May 25, 2011
    #1
    1. Advertising

  2. Lawrence D'Oliveiro

    Richard Guest

    On 25/05/2011 7:17 p.m., Lawrence D'Oliveiro wrote:
    > Two different clients of mine have trouble fetching packages from Linux
    > repositories. The symptom is a “hash sum†problem, indicating the downloaded
    > package is corrupted and cannot be installed.
    >
    > One client is running Debian on servers, and I was able to work around the
    > problem by accessing the repositories via FTP rather than HTTP. The other
    > one is trying to set up an Ubuntu machine, and as far as I can tell the
    > Ubuntu repositories don’t offer that option.
    >
    > Both are using Telecom as their ISP. I’m pretty sure this is being caused by
    > caching that Telecom are interposing on accesses via port 80; we previously
    > saw this quite clearly with the first client when they updated a web page on
    > a hosting site but all the HTTP clients (not just browsers, but wget as
    > well) at the client’s premises kept showing the old version, while if I used
    > SSH to connect to another client’s place and wget the same page from there,
    > it showed the updated version.
    >
    > I really don’t see why it’s worth Telecom’s while to pull this kind of crap
    > on a broadband connection. Has anybody else hit this?


    Faster response time when loading pages, saves them money.

    Is there no way to get the package manager to send a no-cache header?
    The telecom servers do honor those aswell as the server directives not
    to cache and expiration when I last looked into it.
    Richard, May 25, 2011
    #2
    1. Advertising

  3. In message <irinn7$u19$>, Richard wrote:

    > Is there no way to get the package manager to send a no-cache header?


    Whaddaya know, the apt.conf(5) man page documents just such an option.

    I shall give that a try.
    Lawrence D'Oliveiro, May 25, 2011
    #3
  4. Lawrence D'Oliveiro

    Boots Guest

    On Wed, 25 May 2011 19:17:41 +1200, Lawrence D'Oliveiro wrote:

    > I really don’t see why it’s worth Telecom’s while to pull this kind of
    > crap on a broadband connection. Has anybody else hit this?


    This is called censoring what you can access.


    --
    "Filtering the Internet is like trying to boil the ocean"
    Boots, May 25, 2011
    #4
  5. Lawrence D'Oliveiro

    AD. Guest

    On May 25, 7:17 pm, Lawrence D'Oliveiro <l...@geek-
    central.gen.new_zealand> wrote:
    > I really don’t see why it’s worth Telecom’s while to pull this kindof crap
    > on a broadband connection. Has anybody else hit this?


    I haven't noticed it with Telecom/Xtra, but it was a constant problem
    on a TelstraClear cable connection.

    --
    Cheers
    Anton
    AD., May 26, 2011
    #5
  6. In message <irior8$sa1$>, Lawrence D'Oliveiro wrote:

    > In message <irinn7$u19$>, Richard wrote:
    >
    >> Is there no way to get the package manager to send a no-cache header?

    >
    > Whaddaya know, the apt.conf(5) man page documents just such an option.
    >
    > I shall give that a try.


    I tried

    apt-get -o Acquire::Http::Cache-control=no-cache ...

    but it didn’t make any difference.

    The client suspects it’s their Mako box. But the Mako is under customer
    control, so presumably they should be able to figure out some rule to make
    an exception for this.
    Lawrence D'Oliveiro, May 30, 2011
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. news.tm.net.my
    Replies:
    0
    Views:
    555
    news.tm.net.my
    Jul 17, 2003
  2. JD
    Replies:
    4
    Views:
    940
    JamesBenson
    Jul 29, 2004
  3. Knowing About
    Replies:
    0
    Views:
    617
    Knowing About
    Oct 13, 2006
  4. Daniel Parker

    Cisco WCCP Transparent Web Caching..

    Daniel Parker, Jan 5, 2005, in forum: NZ Computing
    Replies:
    1
    Views:
    1,125
    Gordon Smith
    Jan 6, 2005
  5. Lawrence D'Oliveiro

    Telecom !@#$% Web Caching

    Lawrence D'Oliveiro, Mar 11, 2010, in forum: NZ Computing
    Replies:
    7
    Views:
    372
    Old Wolf
    Mar 14, 2010
Loading...

Share This Page