tacacs-plus help in debian

Discussion in 'Cisco' started by ggs234@googlemail.com, Nov 24, 2005.

  1. Guest

    Hi,

    We have seen your site and it looks good.We are having one problem in
    tacacs+ in debian machine.We have installed
    tacacs-plus package from debian site.WE have configured without any
    problem.

    Configuration as follows

    We have created two groups one is admin and another is users

    We want to restrict user group to use the enable command in our
    routers.

    We have checked many documents and we didn't find the solution

    Please helpus if you have any ideas about this.

    Best Regards
     
    , Nov 24, 2005
    #1
    1. Advertising

  2. Vivek Guest

    Hi,

    I do not have experience in debian tacacs+ but i can tell you that "cmd"
    attribute is used to restrict/permit commands. An example of a user profile
    with restricted access is as follows :-

    # This user is limitted in allowed commands when aaa authorization is
    enabled:
    user = abcd {
    login = cleartext "telnet"
    cmd = enable {
    deny .*
    }
    cmd = exit {
    permit .*
    }
    }

    And ofcourse you need to enable command authorization in the NAS.

    Hope this helps.
     
    Vivek, Nov 25, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. MigelDeBaño

    Help, Tacacs+ message

    MigelDeBaño, Sep 30, 2004, in forum: Cisco
    Replies:
    2
    Views:
    5,827
    hocco
    Jul 27, 2007
  2. Replies:
    1
    Views:
    1,525
    Vivek
    Nov 14, 2005
  3. Trouble

    TACACS or RADIUS-Help Please

    Trouble, Aug 11, 2006, in forum: Cisco
    Replies:
    4
    Views:
    1,125
    Alan Strassberg
    Aug 13, 2006
  4. DUser
    Replies:
    0
    Views:
    427
    DUser
    Jan 11, 2004
  5. chazaswell
    Replies:
    0
    Views:
    960
    chazaswell
    Aug 14, 2009
Loading...

Share This Page