TabBrowser activity

Discussion in 'Firefox' started by Steve IA, Aug 20, 2005.

  1. Steve IA

    Steve IA Guest

    I'm using Tabbroweser v1.14 on FF 1.06 and can't get it to do what I
    want. I'd like to have links from a Google search page (I'm not using a
    Google search bar if that makes any difference)open in a new tab. It
    seems I've tried every combination but can't find the right switch to
    allow this to happen.
    Thanks for suggestions.
    Steve
    41N
     
    Steve IA, Aug 20, 2005
    #1
    1. Advertising

  2. Steve IA

    Roland Guest

    On 20-8-2005 12:18, Steve IA wrote:
    > I'm using Tabbroweser v1.14 on FF 1.06 and can't get it to do what I
    > want. I'd like to have links from a Google search page (I'm not using a
    > Google search bar if that makes any difference)open in a new tab. It
    > seems I've tried every combination but can't find the right switch to
    > allow this to happen.
    > Thanks for suggestions.
    > Steve
    > 41N

    Don't know exactly which extension you're using: there's "Tabbrowser
    Extensions" and "Tabbrowser Preferences" (and maybe more).

    But you should be able to configure it without the Tabbrowser extension
    (unless the extension causes a different behavior).

    First, make sure that you configure Google to display result links in a
    new window: open the Google preferences link (next to the input field)
    and check the checkbox "Open search results in a new browser window" (at
    bottom of the page). Press the "Save Preferences" button.

    Then in Firefox, open
    Tools -> Options -> Advanced -> Tabbed Browsing
    and check the checkbox
    Force links that open new windows to open in
    and select
    a new tab
    just below it.

    If you don't see the checkbox "Force links that ...", type
    about:config
    in the addressbar, locate the preference
    browser.tabs.showSingleWindowModePrefs
    and change its value to
    true
    by double clicking on it.

    The settings of the "Force links ..." checkbox and the options just
    below it are controlled by the preference
    browser.link.open_newwindow
    So it's also possible to change its value immediately:
    2 (default) : in a new window
    3 : in a new tab
    1 (or anything else): in the current window
    See also <http://kb.mozillazine.org/About:config_entries#Browser..2A>
    --
    Regards,

    Roland de Ruiter
    ` ___ ___
    `/__/ w_/ /__/
    / \ /_/ / \
     
    Roland, Aug 20, 2005
    #2
    1. Advertising

  3. Steve IA

    Steve IA Guest

    Roland wrote:
    > On 20-8-2005 12:18, Steve IA wrote:
    >
    >> I'm using Tabbroweser v1.14 on FF 1.06 and can't get it to do what I
    >> want. I'd like to have links from a Google search page (I'm not using
    >> a Google search bar if that makes any difference)open in a new tab. It
    >> seems I've tried every combination but can't find the right switch to
    >> allow this to happen.
    >> Thanks for suggestions.
    >> Steve
    >> 41N

    >
    > Don't know exactly which extension you're using: there's "Tabbrowser
    > Extensions" and "Tabbrowser Preferences" (and maybe more).


    I'm using Tabbrowser Extensions v1.14
    >
    > But you should be able to configure it without the Tabbrowser extension
    > (unless the extension causes a different behavior).
    >
    > First, make sure that you configure Google to display result links in a
    > new window: open the Google preferences link (next to the input field)
    > and check the checkbox "Open search results in a new browser window" (at
    > bottom of the page). Press the "Save Preferences" button.
    >

    Did this.

    > Then in Firefox, open
    > Tools -> Options -> Advanced -> Tabbed Browsing
    > and check the checkbox
    > Force links that open new windows to open in
    > and select
    > a new tab
    > just below it.


    My Tabbed Browsing says nothing about "Force", but in the 'LINKS' box at
    the top I could follow your directions, and did.

    > If you don't see the checkbox "Force links that ...", type
    > about:config
    > in the addressbar, locate the preference
    > browser.tabs.showSingleWindowModePrefs
    > and change its value to
    > true
    > by double clicking on it.


    Did this too.

    >
    > The settings of the "Force links ..." checkbox and the options just
    > below it are controlled by the preference
    > browser.link.open_newwindow
    > So it's also possible to change its value immediately:
    > 2 (default) : in a new window
    > 3 : in a new tab
    > 1 (or anything else): in the current window


    Changed this value to 3.

    > See also <http://kb.mozillazine.org/About:config_entries#Browser..2A>


    Then, I opened my TAB tab on FF
    Tabbrowser Extensions Preference --> Use Tab --> Links -->New Window
    Links --> selected open in new tab.

    Tabbrowser Extensions Preference --> Use Tab --> Links -->Advanced
    Options for Links -->New Tab Actions --> Normal Link Loading. selected
    Open in new Tab.

    Tabbrowser Extensions Preference --> Use Tab --> Links -->Advanced
    Options for Links -->New Tab Actions --> Links which refer to other
    site. Selecte Open in New Tab.

    Tabbrowser Extensions Preference --> Use Tab --> Links -->Advanced
    Options for Links --> Links in Locked Tabs. Selected Open in New Tab.

    Tabbrowser Extensions Preference --> Use Tab --> External Links -->New
    Window Links --> selected open in new tab.

    Well, that's better, Now I get ONE link from Google to open in a new
    tab. The next link selected opens in the same tab. I'd like to have each
    selected link open it's own tab.

    Thanks for your help.

    Steve
     
    Steve IA, Aug 20, 2005
    #3
  4. Steve IA

    Tom Betz Guest

    Quoth Steve IA <> in news:de7u0r$38u$:

    > I'm using Tabbrowser Extensions v1.14


    That's a highly unrecommended extension, even by its developer!

    From <http://piro.sakura.ne.jp/xul/tabextensions/index.html.en>:

    This extension strongly unrecommended. Tab Mix is recommended
    instead of this, because it is stable, light, and it covers
    most useful features of this.

    I found that following his recomendation of TabMix instead
    Tabbrowser Extensions stopped my Firefox from crashing so often.

    --
    George Bush's War of Choice on Iraq is a totally unnecessary war.
    Every life lost, every limb lost, every disfigurement, every
    disability caused there is more blood on George W. Bush's hands,
    and on the hands of everyone who voted for George W. Bush.
     
    Tom Betz, Aug 20, 2005
    #4
  5. Steve IA

    Steve IA Guest

    Tom Betz wrote:
    > Quoth Steve IA <> in news:de7u0r$38u$:
    >
    >
    >>I'm using Tabbrowser Extensions v1.14

    >
    >
    > That's a highly unrecommended extension, even by its developer!
    >
    > From <http://piro.sakura.ne.jp/xul/tabextensions/index.html.en>:
    >
    > This extension strongly unrecommended. Tab Mix is recommended
    > instead of this, because it is stable, light, and it covers
    > most useful features of this.
    >
    > I found that following his recomendation of TabMix instead
    > Tabbrowser Extensions stopped my Firefox from crashing so often.
    >

    Thanks all. I've uninstalled the TabBrowser Extensions and am starting
    over. I'll come back if I need more help. Thanks again.
    Steve
     
    Steve IA, Aug 20, 2005
    #5
  6. Steve IA

    Roland Guest

    On 20-8-2005 20:50, Steve IA wrote:

    > Roland wrote:
    >
    >> On 20-8-2005 12:18, Steve IA wrote:
    >>
    >>> I'm using Tabbroweser v1.14 on FF 1.06 and can't get it to do what I
    >>> want. I'd like to have links from a Google search page (I'm not using
    >>> a Google search bar if that makes any difference)open in a new tab.
    >>> It seems I've tried every combination but can't find the right switch
    >>> to allow this to happen.
    >>> Thanks for suggestions.
    >>> Steve
    >>> 41N

    >>
    >>
    >> Don't know exactly which extension you're using: there's "Tabbrowser
    >> Extensions" and "Tabbrowser Preferences" (and maybe more).

    >
    >
    > I'm using Tabbrowser Extensions v1.14
    >
    >>
    >> But you should be able to configure it without the Tabbrowser
    >> extension (unless the extension causes a different behavior).
    >>
    >> First, make sure that you configure Google to display result links in
    >> a new window: open the Google preferences link (next to the input
    >> field) and check the checkbox "Open search results in a new browser
    >> window" (at bottom of the page). Press the "Save Preferences" button.
    >>

    > Did this.
    >
    >> Then in Firefox, open
    >> Tools -> Options -> Advanced -> Tabbed Browsing
    >> and check the checkbox
    >> Force links that open new windows to open in
    >> and select
    >> a new tab
    >> just below it.

    >
    >
    > My Tabbed Browsing says nothing about "Force", but in the 'LINKS' box at
    > the top I could follow your directions, and did.
    >
    >> If you don't see the checkbox "Force links that ...", type
    >> about:config
    >> in the addressbar, locate the preference
    >> browser.tabs.showSingleWindowModePrefs
    >> and change its value to
    >> true
    >> by double clicking on it.

    >
    >
    > Did this too.
    >
    >>
    >> The settings of the "Force links ..." checkbox and the options just
    >> below it are controlled by the preference
    >> browser.link.open_newwindow
    >> So it's also possible to change its value immediately:
    >> 2 (default) : in a new window
    >> 3 : in a new tab
    >> 1 (or anything else): in the current window

    >
    >
    > Changed this value to 3.
    >
    >> See also <http://kb.mozillazine.org/About:config_entries#Browser..2A>

    >
    >
    > Then, I opened my TAB tab on FF
    > Tabbrowser Extensions Preference --> Use Tab --> Links -->New Window
    > Links --> selected open in new tab.
    >
    > Tabbrowser Extensions Preference --> Use Tab --> Links -->Advanced
    > Options for Links -->New Tab Actions --> Normal Link Loading. selected
    > Open in new Tab.
    >
    > Tabbrowser Extensions Preference --> Use Tab --> Links -->Advanced
    > Options for Links -->New Tab Actions --> Links which refer to other
    > site. Selecte Open in New Tab.
    >
    > Tabbrowser Extensions Preference --> Use Tab --> Links -->Advanced
    > Options for Links --> Links in Locked Tabs. Selected Open in New Tab.
    >
    > Tabbrowser Extensions Preference --> Use Tab --> External Links -->New
    > Window Links --> selected open in new tab.
    >
    > Well, that's better, Now I get ONE link from Google to open in a new
    > tab. The next link selected opens in the same tab. I'd like to have each
    > selected link open it's own tab.
    >
    > Thanks for your help.
    >
    > Steve
    >

    Works for me in FF1.0.6 with "browser.link.open_newwindow" set to 3, but
    I don't have "Tabbrowser Extensions". Apparently TBE is interfering with
    tabbed browsing.

    Just for testing, you could try to disable TBE temporarily (open Tools
    -> Extensions, select TBE, right-click on it, select "Disable" from the
    context-menu, and restart FF).

    When this causes the desired behavior, you might want to drop TBE and
    find another extension with similar functionality. (Tom already
    suggested "Tab Mix"
    <http://www.extensionsmirror.nl/index.php?showtopic=2291>
    <http://tabmix-en.blogspot.com/>
    but there's also "Tab Mix Plus"
    <http://tmp.gary.elixant.com/>
    --
    Regards,

    Roland de Ruiter
    ` ___ ___
    `/__/ w_/ /__/
    / \ /_/ / \
     
    Roland, Aug 20, 2005
    #6
  7. Steve IA

    Peterg Guest

    In article <430793ae$0$11070$4all.nl>,
    wrote...
    > Works for me in FF1.0.6 with "browser.link.open_newwindow" set to 3, but
    > I don't have "Tabbrowser Extensions". Apparently TBE is interfering with
    > tabbed browsing.
    >
    > Just for testing, you could try to disable TBE temporarily (open Tools
    > -> Extensions, select TBE, right-click on it, select "Disable" from the
    > context-menu, and restart FF).
    >
    > When this causes the desired behavior, you might want to drop TBE and
    > find another extension with similar functionality. (Tom already
    > suggested "Tab Mix"
    > <http://www.extensionsmirror.nl/index.php?showtopic=2291>
    > <http://tabmix-en.blogspot.com/>
    > but there's also "Tab Mix Plus"
    > <http://tmp.gary.elixant.com/>
    >


    I should just add that the development re Tabmix (not Tabmix Plus) is
    almost moribund with Tabmix going through about 3 developers this year
    and I and many others have essentially dropped it from serious
    consideration.

    Tabmix Plus has a couple of highly enthusiastic developers and they are
    continually advancing the extension and accepting a lot of input from
    users.

    Just look at this long thread at the forum home for Tabmix Plus with
    plenty of feedback from the developers:

    http://forums.mozillazine.org/viewtopic.php?t=274995

    65 pages long and started just in June!

    Peter
     
    Peterg, Aug 21, 2005
    #7
  8. Steve IA

    Steve IA Guest

    Peterg wrote:
    > In article <430793ae$0$11070$4all.nl>,
    > wrote...
    >
    >>Works for me in FF1.0.6 with "browser.link.open_newwindow" set to 3, but
    >>I don't have "Tabbrowser Extensions". Apparently TBE is interfering with
    >>tabbed browsing.
    >>
    >>Just for testing, you could try to disable TBE temporarily (open Tools
    >>-> Extensions, select TBE, right-click on it, select "Disable" from the
    >>context-menu, and restart FF).
    >>
    >>When this causes the desired behavior, you might want to drop TBE and
    >>find another extension with similar functionality. (Tom already
    >>suggested "Tab Mix"
    >> <http://www.extensionsmirror.nl/index.php?showtopic=2291>
    >> <http://tabmix-en.blogspot.com/>
    >>but there's also "Tab Mix Plus"
    >> <http://tmp.gary.elixant.com/>
    >>

    >
    > I should just add that the development re Tabmix (not Tabmix Plus) is
    > almost moribund with Tabmix going through about 3 developers this year
    > and I and many others have essentially dropped it from serious
    > consideration.
    >
    > Tabmix Plus has a couple of highly enthusiastic developers and they are
    > continually advancing the extension and accepting a lot of input from
    > users.
    >
    > Just look at this long thread at the forum home for Tabmix Plus with
    > plenty of feedback from the developers:
    >
    > http://forums.mozillazine.org/viewtopic.php?t=274995
    >
    > 65 pages long and started just in June!
    >
    > Peter


    Thanks to all who replied. I have since uninstalled all previous
    tabbing extensions and installed Tab Mix Plus, Beta. It does everything
    I want and More. The Ctrl-Tab function is wowie!
    The only thing I haven't solved is opening links from 'My Yahoo' to a
    new tab with left click. I can open to new tab with center click, but
    not left. Old dog, new trick thing, I guess. I'm still working on it.
    Thanks again for the suggestions and help.

    Steve
    41N
     
    Steve IA, Aug 21, 2005
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lee
    Replies:
    0
    Views:
    472
  2. Colonel Blip
    Replies:
    1
    Views:
    536
    Mueen Nawaz
    Jul 13, 2004
  3. J Taylor

    Tabbrowser extension killed Firefox

    J Taylor, Aug 11, 2004, in forum: Firefox
    Replies:
    3
    Views:
    1,025
    mike555
    Aug 16, 2004
  4. Chuck

    Tabbrowser Extensions

    Chuck, Sep 27, 2004, in forum: Firefox
    Replies:
    1
    Views:
    494
    Achim Schumacher
    Oct 18, 2004
  5. Alexander Fischer
    Replies:
    1
    Views:
    804
    Alexander Fischer
    Oct 1, 2004
Loading...

Share This Page