Switching before routing. (Diverting a VLAN.)

Discussion in 'Cisco' started by professorguy, Jan 17, 2007.

  1. professorguy

    professorguy

    Joined:
    Sep 15, 2006
    Messages:
    39
    I have a 3750 that is acting as a switch (no ip routing) which has trunks with vlan 17, 18 & 19 on them. I want all traffic tagged as 18 & 19 to go to the default gateway (core router) for routing. But I want the vlan 17 traffic to go directly to the vlan 17 server (10.17.17.1) on port 17.

    If the trunk to the core does not allow vlan 17, those packets won't get to the core, and the switching function should allow the packets to get untagged and sent to the server. Correct?

    Here's kind of what I mean:

    interface GigabitEthernet1/0/15
    description Trunk to Core
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 18,19
    switchport mode trunk
    !
    interface GigabitEthernet1/0/16
    description Trunk from Access Switch
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 17,18,19
    switchport mode trunk
    !
    interface GigabitEthernet1/0/17
    description VLAN 17 Server (10.17.17.1)
    switchport access vlan 17
    !

    Will vlan17 packets coming in on Gi1/0/16 end up going out (de-tagged) on Gi1/0/17 ? Remember, this is a switch with no ip routing....
    professorguy, Jan 17, 2007
    #1
    1. Advertising

  2. professorguy

    swapnendu

    Joined:
    Sep 13, 2006
    Messages:
    57
    any traffic that belongs to Vlan 17 (source IP belongs to Vlan 17 subnet) and with a destination IP of 10.17.17.1 will always go via GigabitEthernet1/0/17.
    swapnendu, Jan 18, 2007
    #2
    1. Advertising

  3. professorguy

    professorguy

    Joined:
    Sep 15, 2006
    Messages:
    39
    Sure enough.

    Yesterday we moved our server room to a new wing and our new network relies on this "manual vlan pruning" to prevent loops and efficiently dedicate trunk bandwidth. So far, so good....

    Thanks everyone for your helpful feedback.
    professorguy, Jan 19, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andreas Seeking
    Replies:
    1
    Views:
    1,125
    Arnold Nipper
    Jan 29, 2005
  2. matt r

    Before Sunset & Before Sunrise

    matt r, Nov 24, 2004, in forum: DVD Video
    Replies:
    2
    Views:
    546
    matt r
    Nov 25, 2004
  3. asdf
    Replies:
    7
    Views:
    7,919
    Christophe Fillot
    May 29, 2007
  4. JohnD
    Replies:
    3
    Views:
    4,175
    stephen
    Dec 18, 2007
  5. Lobster
    Replies:
    2
    Views:
    926
    Lobster
    Nov 18, 2008
Loading...

Share This Page