switch 3750 Vlan and Routing Problem

Discussion in 'Cisco' started by kamal1352, Apr 5, 2008.

  1. kamal1352

    kamal1352

    Joined:
    Apr 5, 2008
    Messages:
    8
    Hi, I have a 3750 L3 Switch and 2811 Router and some 2960's L2 Switch
    and I set 4 Vlan's in 3750:
    Vlan2->Users Vlan3->Servers Vlan4->Printers Vlan5->Valid IP's(such as router and web's)
    now I want to contrrol traffice in 3750 switch for example:
    if user want a service from servers, packets are routed to Server Vlan
    if user want print, Packets are routed to Printer Vlan
    if user want internet service, Packets are routed to Router for NAT and exit from my lan
    but I cannot set routing!!! Please halp me
    Best Regurds
    Kamal
    kamal1352, Apr 5, 2008
    #1
    1. Advertising

  2. kamal1352

    ironcobra

    Joined:
    Apr 5, 2008
    Messages:
    2
    Kamal,
    Can you provide a copy of your running configuration? Without it all I could do is guess and ask a few questions such as is ip routing enabled? Did you us e the no switchport command on the interface connecting to your default router (this would make the interface layer capable). I can refer you to the following link for for more help http://www.cisco.com/en/US/tech/tk3...ation_example09186a008019e74e.shtml#maintask1
    ironcobra, Apr 5, 2008
    #2
    1. Advertising

  3. kamal1352

    kamal1352

    Joined:
    Apr 5, 2008
    Messages:
    8
    This is my cisco 3750 switch config:
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    hostname Switch_3750
    enable secret 5 $1$lyQ8$oMvwGQd3.dRleLxSeh/9/.
    enable password ...
    ip subnet-zero
    ip routing
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending

    interface GigabitEthernet1/0/1
    !
    interface GigabitEthernet1/0/2
    !
    interface GigabitEthernet1/0/3
    !
    interface GigabitEthernet1/0/4
    !
    interface GigabitEthernet1/0/5
    !
    interface GigabitEthernet1/0/6
    switchport access vlan 4
    interface GigabitEthernet1/0/7
    switchport access vlan 4
    interface GigabitEthernet1/0/8
    !
    interface GigabitEthernet1/0/9
    !
    interface GigabitEthernet1/0/10
    switchport access vlan 3
    interface GigabitEthernet1/0/11
    switchport access vlan 3
    interface GigabitEthernet1/0/12
    !
    interface GigabitEthernet1/0/13
    switchport access vlan 2
    interface GigabitEthernet1/0/14
    !
    interface GigabitEthernet1/0/15
    !
    interface GigabitEthernet1/0/16
    !
    interface GigabitEthernet1/0/17
    switchport access vlan 2
    !
    interface GigabitEthernet1/0/18
    !
    interface GigabitEthernet1/0/19
    !
    interface GigabitEthernet1/0/20
    !
    interface GigabitEthernet1/0/21
    switchport access vlan 5
    interface GigabitEthernet1/0/22
    switchport access vlan 5
    interface GigabitEthernet1/0/23
    switchport access vlan 5
    !
    interface GigabitEthernet1/0/24
    !
    interface Vlan1
    ip address 192.168.0.200 255.255.255.0
    !
    interface Vlan2
    ip address 172.16.215.1 255.255.255.0
    !
    interface Vlan3
    ip address 172.16.216.1 255.255.255.0
    !
    interface Vlan4
    ip address 172.16.217.1 255.255.255.0
    !
    interface Vlan5
    ip address 194.225.174.252 255.255.255.0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Vlan5
    ip route 172.16.215.0 255.255.255.0 Vlan2
    ip route 172.16.216.0 255.255.255.0 Vlan3
    ip route 172.16.217.0 255.255.255.0 Vlan4
    ip route 192.168.0.0 255.255.255.0 Vlan1
    ip route 194.225.174.0 255.255.255.0 Vlan5

    ip http server
    ip http secure-server
    control-plane
    line con 0
    line vty 0 4
    password ...
    no login
    line vty 5 15
    password
    no login
    end
    kamal1352, Apr 6, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bgraham34@gmail.com
    Replies:
    9
    Views:
    579
    bgraham34@gmail.com
    May 22, 2007
  2. Arthur Brain

    Inter-VLAN routing on 3750 switches:

    Arthur Brain, Jul 11, 2007, in forum: Cisco
    Replies:
    1
    Views:
    1,128
    Brian V
    Jul 11, 2007
  3. H.A.M
    Replies:
    1
    Views:
    1,842
    stephen
    Oct 6, 2007
  4. Dil
    Replies:
    0
    Views:
    934
  5. midejan
    Replies:
    0
    Views:
    1,458
    midejan
    May 2, 2010
Loading...

Share This Page