Strange RIP behavious

Discussion in 'Cisco' started by Marco Matarazzo, Jun 20, 2005.

  1. Hi all,

    today I had a problem I cannot explain.
    I'm using Cisco 3550-48-SMI with IOS 12.1(22)EA1 as access switches for
    our customers. Each customer has a routed port on the 3550. The 3550
    announces the connected and static routes via RIP to a couple of 7206 (my
    borders). The 7206 announce via RIP the default to the 3550.
    Everything works fine, but today all of sudden, a static route was marked
    as "possibly down", and my borders began to throw all traffic destined to
    that subnet to Null0 (as designed).

    This is the relevant sanitized config:

    interface FastEthernet0/35
    description CustomerX PtP
    no switchport
    ip address 1.2.3.4 255.255.255.252
    service-policy input 2mbit-in
    service-policy output 2mbit-out
    no cdp enable

    router rip
    version 2
    timers basic 3 10 0 10
    redistribute connected
    redistribute static
    passive-interface default
    no passive-interface FastEthernet0/32
    network 1.0.0.0
    neighbor 1.2.2.3
    neighbor 1.2.2.4
    no auto-summary

    ip route 1.6.7.8 255.255.255.240 1.2.3.5

    Normaly a show ip rip database shows:

    1.6.7.8/28 redistributed
    1.2.3.4/30 directly connected, FastEthernet0/35

    During the outage (that affected only this customer out of 40 on this
    3550), it showed:

    1.6.7.8/28 possibly down
    1.2.3.4/30 directly connected, FastEthernet0/35

    What strikes me is: how could it be possible to have a static selected as
    possibly down, when the connected route is (and has always be) up? I
    could ping the point to point fine from the router, no problems. The way
    to recover was simply to shut/unshut the relevant interface. Any hints
    what could be happened?

    --
    Ciao!
    ]\/[arco
     
    Marco Matarazzo, Jun 20, 2005
    #1
    1. Advertising

  2. Marco Matarazzo

    csouth Guest

    Marco,
    Your rip timers may be the issue. What are the timers set too on the
    7200(s)?
     
    csouth, Jun 20, 2005
    #2
    1. Advertising

  3. "csouth" <> wrote in comp.dcom.sys.cisco:

    > Marco,
    > Your rip timers may be the issue. What are the timers set too on the
    > 7200(s)?


    The timers are set to "timers basic 3 10 0 10" on all routers. I didn't
    mention this in my previuos post, as the issue happened on the same router
    that had the connected route and the static route. The borders were seeing
    the router possibly down because it was marked possibly down on the 3550,
    and what I was wondering why it was marked possibly down in the first
    place, given the fact that the connected interface never flapped...

    --
    Ciao!
    ]\/[arco
     
    Marco Matarazzo, Jun 21, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ivan Ostres

    ipx rip bug or not?

    Ivan Ostres, Oct 22, 2003, in forum: Cisco
    Replies:
    0
    Views:
    391
    Ivan Ostres
    Oct 22, 2003
  2. Mark Smythe
    Replies:
    3
    Views:
    684
    John Agosta
    Nov 29, 2003
  3. Pedro Ribeiro
    Replies:
    0
    Views:
    1,087
    Pedro Ribeiro
    Dec 14, 2003
  4. Wendell

    converting accuset 1200 HW rip to software rip

    Wendell, Jun 5, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    1,095
    Wendell
    Jun 5, 2004
  5. Replies:
    1
    Views:
    889
    Plato
    Aug 26, 2006
Loading...

Share This Page