Strange persistant blocking of open ports

Discussion in 'Windows 64bit' started by =?Utf-8?B?SkJU?=, Sep 3, 2007.

  1. At work I'm running an all up to date Windows XP Professional x64 Edition,
    Version 2003 SP2 on an Asus Vintage V2-PE2 board with built-in NIC
    (VIA Rhine II Fast Ethernet Adapter).
    For that I found drivers from the ASUS site, which installed succesfully.

    Not once in my life have I been unable to open a port in ANY O.S.
    but this time it seems impossible to accomplish! I'm at a loss here.
    I'm an expert in networking and routing, but I have to turn to MS for this,
    since it's not clear what the OS is doing.

    On one and same LAN I have several machines, servers even, with
    no problem having some ports opened and using those ports.
    The LAN is behind a Thomson SpeedTouch 780 WL
    in which I've opened up port 59622 to point to this PC running XP x64.

    Firewall is off (service in XP isn't even running anymore).
    I have also switched off ICS, IPSEC and Windows Security Center.
    There's no need to use those in my situation.
    No third party virus-scanner is actively blocking anything,
    there are NO processes I know about doing anything
    regarding access to open ports.

    The only thing left is Windows kernel core or some MS quirk I don't know
    about.
    This is pretty much a clean install of Windows XP x64 edition, except for
    having a lot of services Disabled. There are no security policies active
    as far as I know.

    Please do not tell me how to open ports, because that is not the problem.
    Windows Firewall is not in use, I'm not running it, and I know how to open
    ports
    in the Win firewall (which I have already done just to be sure).
    I have also switched UTP wires between different PC's, just to make sure
    it wasn't the cable (one can never be certain enough it isn't
    hardware-related)
    or the Thomson modem.

    My ISP isn't blocking ports.
    Open port 59623 on a separate machine works just fine.
    (This machine is running a good old reliable Windows 2000.)

    When for example trying at http://www.canyouseeme.org/
    to check if the port is listened for, it just keeps saying
    it's not open (for the particular PC running XP x64),
    and so does the software that I need to use the open port with.

    Can someone with MicroSoft expertise please tell me
    how to switch off EVERY little hidden security layer
    that might cause ports to still be closed more or less?

    Thanks in advance.
    =?Utf-8?B?SkJU?=, Sep 3, 2007
    #1
    1. Advertising

  2. JBT wrote:

    >At work I'm running an all up to date Windows XP Professional x64 Edition,
    >Version 2003 SP2 on an Asus Vintage V2-PE2 board with built-in NIC
    >(VIA Rhine II Fast Ethernet Adapter).
    >For that I found drivers from the ASUS site, which installed succesfully.
    >
    >Not once in my life have I been unable to open a port in ANY O.S.
    >but this time it seems impossible to accomplish! I'm at a loss here.
    >I'm an expert in networking and routing, but I have to turn to MS for this,
    >since it's not clear what the OS is doing.
    >
    >On one and same LAN I have several machines, servers even, with
    >no problem having some ports opened and using those ports.
    >The LAN is behind a Thomson SpeedTouch 780 WL
    >in which I've opened up port 59622 to point to this PC running XP x64.
    >
    >Firewall is off (service in XP isn't even running anymore).
    >I have also switched off ICS, IPSEC and Windows Security Center.
    >There's no need to use those in my situation.
    >No third party virus-scanner is actively blocking anything,
    >there are NO processes I know about doing anything
    >regarding access to open ports.
    >
    >The only thing left is Windows kernel core or some MS quirk I don't know
    >about.
    >This is pretty much a clean install of Windows XP x64 edition, except for
    >having a lot of services Disabled. There are no security policies active
    >as far as I know.
    >
    >Please do not tell me how to open ports, because that is not the problem.
    >Windows Firewall is not in use, I'm not running it, and I know how to open
    >ports
    >in the Win firewall (which I have already done just to be sure).
    >I have also switched UTP wires between different PC's, just to make sure
    >it wasn't the cable (one can never be certain enough it isn't
    >hardware-related)
    >or the Thomson modem.
    >
    >My ISP isn't blocking ports.
    >Open port 59623 on a separate machine works just fine.
    >(This machine is running a good old reliable Windows 2000.)
    >
    >When for example trying at http://www.canyouseeme.org/
    >to check if the port is listened for, it just keeps saying
    >it's not open (for the particular PC running XP x64),
    >and so does the software that I need to use the open port with.
    >
    >Can someone with MicroSoft expertise please tell me
    >how to switch off EVERY little hidden security layer
    >that might cause ports to still be closed more or less?


    So what application is supposed to be listening on these odd port numbers?
    And how do you know that it is operating properly?

    --
    Steve Foster [SBS MVP]
    ---------------------------------------
    MVPs do not work for Microsoft. Please reply only to the newsgroups.
    Steve Foster [SBS MVP], Sep 3, 2007
    #2
    1. Advertising

  3. "Steve Foster [SBS MVP]" wrote:

    > So what application is supposed to be listening on these odd port numbers?


    The application or port-number isn't the problem, it's Windows XP x64.
    Like I wrote, even detecting it using ANY type of webbrowser, or looking
    with wireshark or using a portscanner from the outside; It's CLOSED.
    (I can set it to ANY portnumber I like, makes no difference.)

    > And how do you know that it is operating properly?


    Have you even read my post?
    Like I wrote: This is the FIRST time in my 25+ years
    of working in IT that I'm actually at a complete loss
    as to why opening up a port does not work.
    I'm sysadministrating several MS Win systems, none
    of them have this issue. On the same hardware, even.
    The only difference is this is a x64 XP OS.
    Any Linux 64 bit OS on the exact same hardware
    and LAN does not have any open port issues.
    Any Windows 2003 server OS doesn't have this problem,
    any Win 2000 Pro doesn't have this, normal 32 bit
    XP Home desktop machines don't have this etc. etc.

    Since this x64 system isn't my design, I have no idea
    what MicroSoft has done with it, but let me assure you:
    It's not good, and it's NOT me or my choice of software.

    I also really dislike how MS has decided to default to
    only 10 TCPMaxHalfOpen connections for tcpip.sys
    This is ridiculously low for the hardware and connection
    speeds we have today.

    Now if you don't know the answers, try not to make one up
    and try not to bother me with silly comments, please.
    =?Utf-8?B?SkJU?=, Sep 4, 2007
    #3
  4. JBT wrote:

    >"Steve Foster [SBS MVP]" wrote:
    >
    >>So what application is supposed to be listening on these odd port numbers?

    >
    >The application or port-number isn't the problem, it's Windows XP x64.


    Um, yes, it is. Ports don't magically do anything by themselves. There
    needs to be an application running that binds to the relevant socket for
    listening or nothing is going to happen.


    >Like I wrote, even detecting it using ANY type of webbrowser, or looking
    >with wireshark or using a portscanner from the outside; It's CLOSED.
    >(I can set it to ANY portnumber I like, makes no difference.)


    And as I wrote, unless an application is actively listening, this is what
    you would expect.


    >>And how do you know that it is operating properly?

    >
    >Have you even read my post?


    Yes, it's full of waffly ranting without anything of substance. Hence my
    questions.

    >Like I wrote: This is the FIRST time in my 25+ years
    >of working in IT that I'm actually at a complete loss
    >as to why opening up a port does not work.


    Perhaps it's time you learned how TCP/IP works then, since "opening ports"
    is a meaningless and inaccurate phrase.

    For a port to be "open", some [server] application has to be running that
    binds to the socket and opens it for listening. Depending on the OS
    configuration, firewall settings may also need to be set or changed in
    order to allow such a server application to bind certain/all sockets.

    There are several lines of investigation open that should be verified, and
    making sure the application that binds the relevant socket is running and
    in an error-free state is a reasonable first step.

    >I'm sysadministrating several MS Win systems, none
    >of them have this issue. On the same hardware, even.
    >The only difference is this is a x64 XP OS.
    >Any Linux 64 bit OS on the exact same hardware
    >and LAN does not have any open port issues.


    You mean you can run the exact same binary application on multiple
    platforms? Really neat - you should patent the method quick so that you
    can make a fortune.

    >Any Windows 2003 server OS doesn't have this problem,
    >any Win 2000 Pro doesn't have this, normal 32 bit
    >XP Home desktop machines don't have this etc. etc.
    >
    >Since this x64 system isn't my design, I have no idea
    >what MicroSoft has done with it, but let me assure you:
    >It's not good, and it's NOT me or my choice of software.
    >
    >I also really dislike how MS has decided to default to
    >only 10 TCPMaxHalfOpen connections for tcpip.sys
    >This is ridiculously low for the hardware and connection
    >speeds we have today.
    >
    >Now if you don't know the answers, try not to make one up
    >and try not to bother me with silly comments, please.


    If you're not going to post an actual question, with some useful
    information, we aren't going to be able to help you. As that was the case
    with your first post, I posted questions looking to elicit the information
    we do need in order to be able to help you.

    But if you'd rather just rant, fine.

    --
    Steve Foster [SBS MVP]
    ---------------------------------------
    MVPs do not work for Microsoft. Please reply only to the newsgroups.
    Steve Foster [SBS MVP], Sep 4, 2007
    #4
  5. "Steve Foster [SBS MVP]" wrote:

    > JBT wrote:
    >
    > >"Steve Foster [SBS MVP]" wrote:
    > >
    > >>So what application is supposed to be listening on these odd port numbers?

    > >
    > >The application or port-number isn't the problem, it's Windows XP x64.

    >
    > Um, yes, it is. Ports don't magically do anything by themselves. There
    > needs to be an application running that binds to the relevant socket for
    > listening or nothing is going to happen.


    Trust me: When I want to open up a port, something is listening
    to the port I want to use it for. It doesn't matter which software
    is listening. Be it VNC, or µTorrent, or any type of server I like
    to use, I can change its default port to any portnumber I like,
    and this x64 OS doesn't open its ports. It seems to do some
    part of it, but never really open the port the way it should
    (and the way Windows systems used to do it).

    I was hoping to get some expert replies here, not the amateuristic
    attempts at blaming the third party application. Don't bother replying.
    I'll wait for someone with more experience using x64.
    =?Utf-8?B?SkJU?=, Sep 4, 2007
    #5
  6. JBT:
    This application:
    http://www.nirsoft.net/utils/cports.html
    might help you in the analysis of your problem.

    There is a downloadable x64 version here:
    http://www.nirsoft.net/utils/cports-x64.zip
    and it seems to be freeware.

    Best of luck!
    Carlos

    "JBT" wrote:

    > At work I'm running an all up to date Windows XP Professional x64 Edition,
    > Version 2003 SP2 on an Asus Vintage V2-PE2 board with built-in NIC
    > (VIA Rhine II Fast Ethernet Adapter).
    > For that I found drivers from the ASUS site, which installed succesfully.
    >
    > Not once in my life have I been unable to open a port in ANY O.S.
    > but this time it seems impossible to accomplish! I'm at a loss here.
    > I'm an expert in networking and routing, but I have to turn to MS for this,
    > since it's not clear what the OS is doing.
    >
    > On one and same LAN I have several machines, servers even, with
    > no problem having some ports opened and using those ports.
    > The LAN is behind a Thomson SpeedTouch 780 WL
    > in which I've opened up port 59622 to point to this PC running XP x64.
    >
    > Firewall is off (service in XP isn't even running anymore).
    > I have also switched off ICS, IPSEC and Windows Security Center.
    > There's no need to use those in my situation.
    > No third party virus-scanner is actively blocking anything,
    > there are NO processes I know about doing anything
    > regarding access to open ports.
    >
    > The only thing left is Windows kernel core or some MS quirk I don't know
    > about.
    > This is pretty much a clean install of Windows XP x64 edition, except for
    > having a lot of services Disabled. There are no security policies active
    > as far as I know.
    >
    > Please do not tell me how to open ports, because that is not the problem.
    > Windows Firewall is not in use, I'm not running it, and I know how to open
    > ports
    > in the Win firewall (which I have already done just to be sure).
    > I have also switched UTP wires between different PC's, just to make sure
    > it wasn't the cable (one can never be certain enough it isn't
    > hardware-related)
    > or the Thomson modem.
    >
    > My ISP isn't blocking ports.
    > Open port 59623 on a separate machine works just fine.
    > (This machine is running a good old reliable Windows 2000.)
    >
    > When for example trying at http://www.canyouseeme.org/
    > to check if the port is listened for, it just keeps saying
    > it's not open (for the particular PC running XP x64),
    > and so does the software that I need to use the open port with.
    >
    > Can someone with MicroSoft expertise please tell me
    > how to switch off EVERY little hidden security layer
    > that might cause ports to still be closed more or less?
    >
    > Thanks in advance.
    =?Utf-8?B?Q2FybG9z?=, Sep 5, 2007
    #6
  7. JBT wrote:

    >"Steve Foster [SBS MVP]" wrote:
    >
    >>JBT wrote:
    >>
    >>>"Steve Foster [SBS MVP]" wrote:
    >>>
    >>>>So what application is supposed to be listening on these odd port
    >>>>numbers?
    >>>
    >>>The application or port-number isn't the problem, it's Windows XP x64.

    >>
    >>Um, yes, it is. Ports don't magically do anything by themselves. There
    >>needs to be an application running that binds to the relevant socket for
    >>listening or nothing is going to happen.

    >
    >Trust me: When I want to open up a port, something is listening
    >to the port I want to use it for. It doesn't matter which software
    >is listening. Be it VNC, or µTorrent, or any type of server I like
    >to use, I can change its default port to any portnumber I like,
    >and this x64 OS doesn't open its ports. It seems to do some
    >part of it, but never really open the port the way it should
    >(and the way Windows systems used to do it).
    >
    >I was hoping to get some expert replies here, not the amateuristic
    >attempts at blaming the third party application. Don't bother replying.
    >I'll wait for someone with more experience using x64.


    No blame has been assigned. Your continued refusal to post any useful
    information mitigates against you getting a reply that can actually help
    solve the problem.

    Gratuitously insulting me will not help you either.

    In general terms, I can tell you that XP x64 is based on the Windows
    Server 2003 x64 codebase (this is why XP x64 service packs align with
    WS2003 SPs and not XP SPs), and I can assure you that there's nothing
    substantially different than any other Windows OS. The rest of us are not
    having any difficulty in running service/server applications that listen
    on TCP/IP ports in either XP x64, WS2003 x64 or Vista x64 - you'd be
    seeing a whole lot of posts in this group if we were.

    The only native OS elements that can control/interfere with TCP/IP
    activity are the usual ones:

    * IPSec
    * TCP/IP Filtering (nic properties)
    * Windows Firewall (listening sockets only)

    3rd-party elements that can control/interfere are:

    * anti-malware (inc. AV)
    * Firewall

    Once again, if you'd care to post the specific application that you're
    having difficulty with, relevant OS settings, and the precise diagnostic
    steps taken so far, we have a shot at helping you resolve this.

    --
    Steve Foster [SBS MVP]
    ---------------------------------------
    MVPs do not work for Microsoft. Please reply only to the newsgroups.
    Steve Foster [SBS MVP], Sep 5, 2007
    #7
  8. =?Utf-8?B?SkJU?=

    jorgen Guest

    JBT wrote:

    > I was hoping to get some expert replies here, not the amateuristic
    > attempts at blaming the third party application. Don't bother replying.
    > I'll wait for someone with more experience using x64.


    I think he is fishing for you to use netstat as your first tool, to
    check the status of the port. Is something listening on the port, and
    what...

    If something is listening, and it's TCP, my first choice is telnet.
    Telnet to it locally and from another machine on your local network.

    Those two steps can say a lot
    jorgen, Sep 6, 2007
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    2
    Views:
    425
    Aaron Leonard
    Apr 21, 2006
  2. neville

    persistant light rain

    neville, Apr 17, 2005, in forum: Computer Support
    Replies:
    16
    Views:
    623
    Old Gringo
    Apr 17, 2005
  3. Rustiferion

    Keyloggers are persistant...

    Rustiferion, Jun 29, 2005, in forum: Computer Support
    Replies:
    3
    Views:
    4,714
    joevan
    Jun 30, 2005
  4. Anidazen
    Replies:
    0
    Views:
    739
    Anidazen
    Oct 7, 2006
  5. George Orwell

    Questions from a newbie regarding persistant viruses

    George Orwell, Jan 20, 2009, in forum: Computer Security
    Replies:
    0
    Views:
    408
    George Orwell
    Jan 20, 2009
Loading...

Share This Page