Strange legacy software problem - can anyone help?

Discussion in 'A+ Certification' started by Barry Watzman, Aug 4, 2003.

  1. I've run into a strange legacy software problem. Anyone got any ideas?

    My system is dual boot with 98SE on C: and XP on D:

    I use an old 1980’s MS-DOS TSR for which there is not a good modern
    replacement (it’s called Addresselope, and it addresses envelopes on a
    laser printer in an easy, straightforward fashion; no earth-shattering
    task, but one that’s simply missing from the scene never the less).
    Addresselope works under both 98 and XP in a DOS window (but read on).

    This weekend I replaced the motherboard in my system, moving from an
    Asus P4T-E (850 chipset) to an Asus P4T533 (850e chipset). I did not do
    anything to either operating system or the hard drive. All cards in the
    system are the same and the motherboards, while different in some
    regards, are overall quite similar and use the same Intel chipset
    drivers. Both 98 and XP took their time “detecting new hardware”, but
    both seem fine with the swap, overall, without a full reinstallation.

    However, as mentioned, Addresselope was originally a TSR (although I use
    it now “stand alone” in a DOS box), and it was activated with the key
    combination ALT-INSERT. So I run the command prompt program to get a
    command prompt windows, type “Addresselope” at the prompt, hit
    Alt-Insert, do my envelope and exit, closing the command prompt window.

    Well, when I tried to use Addresselope tonight under XP, it would not
    activate. It was not “getting” the ALT-INSERT combination. The
    motherboard is the “only” thing that’s changed, and no BIOS setting
    (including turning off legacy keyboard emulation) would fix the problem.
    Addresselope simply would not “Pop-Up” under XP. The Window just sits
    there.

    So I figured that there is some issue in the Keyboard controller or the
    ROM or KBC BIOS that won’t pass the ALT-INSERT on the P4T533
    motherboard. Bummer.

    But then I booted Windows 98 on the same computer and tried Addresselope
    under Windows 98 AND IT WORKED JUST FINE.

    ????

    Now I didn’t do anything to Windows XP, where Addresselope worked
    previously with the P4T-E. And there isn’t a problem in the keyboard
    controller or the ROM or keyboard controller BIOS of the new
    motherboard, or it would not work under 98. So why isn’t it working
    under XP and, more to the point, is there anything that I can do about it?

    I tried to run Command.COM from Windows 98 under XP, but it pops up and
    then disappears instantly, not allowing me to leave it open as a command
    window. Turns out that it's quitting becuase of "incorrect Windows
    version". Anyone know a way to block version detection? Setting the XP
    compatability attributes for the program to 98/ME does NOT allow 98SE's
    command.com to run under XP, but a one or two-byte patch would kill it's
    version detection (if I knew which byte to change to what), and I'd love
    to know if using 98SE's command.com under XP would fix the problem with
    Addresselope.

    Anyway, I’d like to get Addresselope working again (without surgery on
    Addresselope itself). It worked under the very same XP (literally the
    same, on the same drive) with the P4T-E.

    Anyone have any ideas?
     
    Barry Watzman, Aug 4, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    2
    Views:
    748
    Niche
    Nov 24, 2004
  2. Klein

    Legacy video card question - pre-AGP

    Klein, Jan 9, 2004, in forum: Computer Support
    Replies:
    4
    Views:
    1,925
  3. Gerry Wolf

    Legacy SB PCI 16 sound

    Gerry Wolf, Feb 24, 2005, in forum: Computer Support
    Replies:
    2
    Views:
    878
    Gerry Wolf
    Feb 25, 2005
  4. Edge
    Replies:
    3
    Views:
    777
    VWWall
    Aug 11, 2006
  5. =?Utf-8?B?RWRyYWRvdXI=?=

    Legacy driver issues - can I move off XP64?

    =?Utf-8?B?RWRyYWRvdXI=?=, Aug 10, 2005, in forum: Windows 64bit
    Replies:
    4
    Views:
    376
    Tony Sperling
    Aug 10, 2005
Loading...

Share This Page