Still Having Vlan Routing Problems

Discussion in 'Cisco' started by Boxxa, Nov 17, 2006.

  1. Boxxa

    Boxxa Guest

    I am still having problems using dot1q and routing between vlans on a
    switch.

    The hardware is a 2600 router and a 2950 switch.

    I have two interfaces on the router, 10.10.100.1 amd 10.10.200.1 and pcs
    on the switch in each vlan. I can ping the gateways from both pcs but
    not eachother.

    Can anyone help me out with this as this little problem has become a
    very large headache.

    Bryan
    Boxxa, Nov 17, 2006
    #1
    1. Advertising

  2. Boxxa

    Mike Jones Guest

    post your configs dude


    "Boxxa" <> wrote in message
    news:ejj9n5$g7g$...
    >I am still having problems using dot1q and routing between vlans on a
    >switch.
    >
    > The hardware is a 2600 router and a 2950 switch.
    >
    > I have two interfaces on the router, 10.10.100.1 amd 10.10.200.1 and pcs
    > on the switch in each vlan. I can ping the gateways from both pcs but not
    > eachother.
    >
    > Can anyone help me out with this as this little problem has become a very
    > large headache.
    >
    > Bryan
    Mike Jones, Nov 17, 2006
    #2
    1. Advertising

  3. Boxxa

    Boxxa Guest

    Here is the configs... All internal vlan works but it will not allow me
    to use encapsulation to get off the vlan to ping pcs on the other.

    I have tried route statements and everything.

    ROUTER 2621 CONFIG:
    *************************************

    !
    Version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    ip subnet-zero
    spanning-tree vlan 1 priority
    !
    !
    !
    !
    !
    !
    !
    !
    interface Serial0
    no ip address
    no ip directed-broadcast
    shutdown
    !
    interface FastEthernet0/0
    no ip address
    no ip directed-broadcast
    shutdown
    !
    interface FastEthernet0/1
    no ip address
    no ip directed-broadcast
    !
    interface FastEthernet0/1.100
    encapsulation dot1q 100
    ip address 10.10.100.1 255.255.255.0
    !
    interface FastEthernet0/1.200
    encapsulation dot1q 200
    ip address 10.10.200.1 255.255.255.0
    !
    !
    ip classless
    no ip http server
    !
    !
    !
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    !
    no scheduler allocate
    end


    ****************************************

    SWITCH 2950 CONFIG:
    *************************************

    !
    Version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    ip subnet-zero
    spanning-tree extend system-id
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/1
    switchport access vlan 100
    !
    interface FastEthernet0/2
    switchport access vlan 200
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    switchport access vlan 100
    !
    interface FastEthernet0/5
    switchport access vlan 200
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    switchport access vlan 200
    switchport trunk allowed vlan 1-1005
    switchport trunk encapsulation dot1q
    !
    vtp Server
    vtp domain bigdomain
    !
    interface Vlan 1
    no ip address
    no ip route-cache
    !
    vlan 100 name vlan0100
    vlan 200 name vlan0200
    !
    ip classless
    no ip http server
    !
    !
    !
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 15
    !
    no scheduler allocate
    end


    *******************************************


    Mike Jones wrote:
    > post your configs dude
    >
    >
    > "Boxxa" <> wrote in message
    > news:ejj9n5$g7g$...
    >> I am still having problems using dot1q and routing between vlans on a
    >> switch.
    >>
    >> The hardware is a 2600 router and a 2950 switch.
    >>
    >> I have two interfaces on the router, 10.10.100.1 amd 10.10.200.1 and pcs
    >> on the switch in each vlan. I can ping the gateways from both pcs but not
    >> eachother.
    >>
    >> Can anyone help me out with this as this little problem has become a very
    >> large headache.
    >>
    >> Bryan

    >
    >
    Boxxa, Nov 17, 2006
    #3
  4. Boxxa

    Brian V Guest

    "Boxxa" <> wrote in message
    news:ejjv27$q8o$...
    > Here is the configs... All internal vlan works but it will not allow me to
    > use encapsulation to get off the vlan to ping pcs on the other.
    >
    > I have tried route statements and everything.
    >
    > ROUTER 2621 CONFIG:
    > *************************************
    >
    > !
    > Version 12.1
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Router
    > !
    > !
    > !
    > ip subnet-zero
    > spanning-tree vlan 1 priority
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > interface Serial0
    > no ip address
    > no ip directed-broadcast
    > shutdown
    > !
    > interface FastEthernet0/0
    > no ip address
    > no ip directed-broadcast
    > shutdown
    > !
    > interface FastEthernet0/1
    > no ip address
    > no ip directed-broadcast
    > !
    > interface FastEthernet0/1.100
    > encapsulation dot1q 100
    > ip address 10.10.100.1 255.255.255.0
    > !
    > interface FastEthernet0/1.200
    > encapsulation dot1q 200
    > ip address 10.10.200.1 255.255.255.0
    > !
    > !
    > ip classless
    > no ip http server
    > !
    > !
    > !
    > !
    > line con 0
    > transport input none
    > line aux 0
    > line vty 0 4
    > !
    > no scheduler allocate
    > end
    >
    >
    > ****************************************
    >
    > SWITCH 2950 CONFIG:
    > *************************************
    >
    > !
    > Version 12.1
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Switch
    > !
    > !
    > !
    > ip subnet-zero
    > spanning-tree extend system-id
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport access vlan 100
    > !
    > interface FastEthernet0/2
    > switchport access vlan 200
    > !
    > interface FastEthernet0/3
    > !
    > interface FastEthernet0/4
    > switchport access vlan 100
    > !
    > interface FastEthernet0/5
    > switchport access vlan 200
    > !
    > interface FastEthernet0/6
    > !
    > interface FastEthernet0/7
    > !
    > interface FastEthernet0/8
    > !
    > interface FastEthernet0/9
    > !
    > interface FastEthernet0/10
    > !
    > interface FastEthernet0/11
    > !
    > interface FastEthernet0/12
    > switchport access vlan 200
    > switchport trunk allowed vlan 1-1005
    > switchport trunk encapsulation dot1q
    > !
    > vtp Server
    > vtp domain bigdomain
    > !
    > interface Vlan 1
    > no ip address
    > no ip route-cache
    > !
    > vlan 100 name vlan0100
    > vlan 200 name vlan0200
    > !
    > ip classless
    > no ip http server
    > !
    > !
    > !
    > !
    > line con 0
    > transport input none
    > line aux 0
    > line vty 0 15
    > !
    > no scheduler allocate
    > end
    >
    >
    > *******************************************
    >
    >
    > Mike Jones wrote:
    >> post your configs dude
    >>
    >>
    >> "Boxxa" <> wrote in message
    >> news:ejj9n5$g7g$...
    >>> I am still having problems using dot1q and routing between vlans on a
    >>> switch.
    >>>
    >>> The hardware is a 2600 router and a 2950 switch.
    >>>
    >>> I have two interfaces on the router, 10.10.100.1 amd 10.10.200.1 and pcs
    >>> on the switch in each vlan. I can ping the gateways from both pcs but
    >>> not eachother.
    >>>
    >>> Can anyone help me out with this as this little problem has become a
    >>> very large headache.
    >>>
    >>> Bryan

    >>


    What port on the switch is patched in to the router? Looking at your configs
    I'm guessing it's 0/12. If thats the case, you should not have "switchport
    access vlan 200"

    If it is 0/12 paste the following in:
    conf t
    int f0/12
    no switchport access vlan 200
    switchport trunk encap dot1q
    switchport mode trunk

    -Brian
    Brian V, Nov 17, 2006
    #4
  5. Boxxa

    Boxxa Guest

    Brian V wrote:
    > "Boxxa" <> wrote in message
    > news:ejjv27$q8o$...
    >> Here is the configs... All internal vlan works but it will not allow me to
    >> use encapsulation to get off the vlan to ping pcs on the other.
    >>
    >> I have tried route statements and everything.
    >>
    >> ROUTER 2621 CONFIG:
    >> *************************************
    >>
    >> !
    >> Version 12.1
    >> service timestamps debug uptime
    >> service timestamps log uptime
    >> no service password-encryption
    >> !
    >> hostname Router
    >> !
    >> !
    >> !
    >> ip subnet-zero
    >> spanning-tree vlan 1 priority
    >> !
    >> !
    >> !
    >> !
    >> !
    >> !
    >> !
    >> !
    >> interface Serial0
    >> no ip address
    >> no ip directed-broadcast
    >> shutdown
    >> !
    >> interface FastEthernet0/0
    >> no ip address
    >> no ip directed-broadcast
    >> shutdown
    >> !
    >> interface FastEthernet0/1
    >> no ip address
    >> no ip directed-broadcast
    >> !
    >> interface FastEthernet0/1.100
    >> encapsulation dot1q 100
    >> ip address 10.10.100.1 255.255.255.0
    >> !
    >> interface FastEthernet0/1.200
    >> encapsulation dot1q 200
    >> ip address 10.10.200.1 255.255.255.0
    >> !
    >> !
    >> ip classless
    >> no ip http server
    >> !
    >> !
    >> !
    >> !
    >> line con 0
    >> transport input none
    >> line aux 0
    >> line vty 0 4
    >> !
    >> no scheduler allocate
    >> end
    >>
    >>
    >> ****************************************
    >>
    >> SWITCH 2950 CONFIG:
    >> *************************************
    >>
    >> !
    >> Version 12.1
    >> service timestamps debug uptime
    >> service timestamps log uptime
    >> no service password-encryption
    >> !
    >> hostname Switch
    >> !
    >> !
    >> !
    >> ip subnet-zero
    >> spanning-tree extend system-id
    >> !
    >> !
    >> !
    >> !
    >> !
    >> !
    >> !
    >> !
    >> interface FastEthernet0/1
    >> switchport access vlan 100
    >> !
    >> interface FastEthernet0/2
    >> switchport access vlan 200
    >> !
    >> interface FastEthernet0/3
    >> !
    >> interface FastEthernet0/4
    >> switchport access vlan 100
    >> !
    >> interface FastEthernet0/5
    >> switchport access vlan 200
    >> !
    >> interface FastEthernet0/6
    >> !
    >> interface FastEthernet0/7
    >> !
    >> interface FastEthernet0/8
    >> !
    >> interface FastEthernet0/9
    >> !
    >> interface FastEthernet0/10
    >> !
    >> interface FastEthernet0/11
    >> !
    >> interface FastEthernet0/12
    >> switchport access vlan 200
    >> switchport trunk allowed vlan 1-1005
    >> switchport trunk encapsulation dot1q
    >> !
    >> vtp Server
    >> vtp domain bigdomain
    >> !
    >> interface Vlan 1
    >> no ip address
    >> no ip route-cache
    >> !
    >> vlan 100 name vlan0100
    >> vlan 200 name vlan0200
    >> !
    >> ip classless
    >> no ip http server
    >> !
    >> !
    >> !
    >> !
    >> line con 0
    >> transport input none
    >> line aux 0
    >> line vty 0 15
    >> !
    >> no scheduler allocate
    >> end
    >>
    >>
    >> *******************************************
    >>
    >>
    >> Mike Jones wrote:
    >>> post your configs dude
    >>>
    >>>
    >>> "Boxxa" <> wrote in message
    >>> news:ejj9n5$g7g$...
    >>>> I am still having problems using dot1q and routing between vlans on a
    >>>> switch.
    >>>>
    >>>> The hardware is a 2600 router and a 2950 switch.
    >>>>
    >>>> I have two interfaces on the router, 10.10.100.1 amd 10.10.200.1 and pcs
    >>>> on the switch in each vlan. I can ping the gateways from both pcs but
    >>>> not eachother.
    >>>>
    >>>> Can anyone help me out with this as this little problem has become a
    >>>> very large headache.
    >>>>
    >>>> Bryan

    >
    > What port on the switch is patched in to the router? Looking at your configs
    > I'm guessing it's 0/12. If thats the case, you should not have "switchport
    > access vlan 200"
    >
    > If it is 0/12 paste the following in:
    > conf t
    > int f0/12
    > no switchport access vlan 200
    > switchport trunk encap dot1q
    > switchport mode trunk
    >
    > -Brian
    >
    >


    I think its my simulator that is weird but if the port ins't in a vlan,
    any other vlan will not ping except 100. Therefore I actually put it in
    vlan 1,100,200 so I can ping the gateways.


    Any idea on the routing issue with the encapsulation? There is no way to
    route to sub interfaces with my simulator using ip route so would that
    be the case?
    Boxxa, Nov 17, 2006
    #5
  6. In article <ejj9n5$g7g$>,
    Boxxa <> wrote:

    > I am still having problems using dot1q and routing between vlans on a
    > switch.
    >
    > The hardware is a 2600 router and a 2950 switch.
    >
    > I have two interfaces on the router, 10.10.100.1 amd 10.10.200.1 and pcs
    > on the switch in each vlan. I can ping the gateways from both pcs but
    > not eachother.


    Have you set the default gateway on the PCs?

    --
    Barry Margolin,
    Arlington, MA
    *** PLEASE post questions in newsgroups, not directly to me ***
    *** PLEASE don't copy me on replies, I'll read them in the group ***
    Barry Margolin, Nov 17, 2006
    #6
  7. Boxxa

    Boxxa Guest

    Drake wrote:
    >> Bryan

    >
    > Try and load the attached files in the boson netsim.
    >
    > 1. router - 2620
    > 2. switch - 2950
    > 3. pc1
    > 4. pc2
    >
    > There is one problem with the simulated cat 2950 switch.
    > Apparently it does not accept the ip default-gateway command.
    > so the 2 pcs can ping each other but not vlan 1.
    >
    > Notice that I leave vlan 1 (the management Vlan) alone and setup
    > two other vlans for the PCs.
    >
    >


    Can you please post your Netsim Netmap and also the main file from
    saving multi device configs? I am still not able to ping between the vlans.
    Boxxa, Nov 17, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Robert H. Risch

    Still Having Problems Switching Focus

    Robert H. Risch, Aug 29, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    462
    Robert H. Risch
    Aug 29, 2003
  2. md

    Still having problems Compaq 5452

    md, Sep 22, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    510
    Miggsee
    Sep 22, 2003
  3. Treb
    Replies:
    15
    Views:
    21,353
  4. Enforcement Team

    still having problems with wirless router

    Enforcement Team, Feb 7, 2004, in forum: Computer Support
    Replies:
    1
    Views:
    551
    richard
    Feb 7, 2004
  5. JohnD
    Replies:
    3
    Views:
    4,149
    stephen
    Dec 18, 2007
Loading...

Share This Page