static nat with backup interface

Discussion in 'Cisco' started by Manolis Anastasakis, Sep 8, 2006.

  1. Hi all

    it is feasible in same router to become nat in the two otherwise interface
    one for backup ? with static nat ?


    interface FastEthernet0/0
    ip address 192.168.5.1 255.255.255.0
    ip nat inside



    interface Serial0/0/0.2 point-to-point
    ip address 10.16.129.170 255.255.255.252
    ip nat outside
    frame-relay class internet
    frame-relay interface-dlci 16

    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 2

    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 2
    dialer-group 2
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname xxxxxxx
    ppp chap password 7 xxxxxxxxx
    ppp ipcp dns request
    --

    ip route 0.0.0.0 0.0.0.0 10.16.129.169
    ip route 0.0.0.0 0.0.0.0 dialer 1 200 **********

    ip nat pool internet 10.251.82.103 10.251.82.103 netmask 255.255.255.240
    ip nat inside source list 1 pool internet overload **********
    ip nat source list 2 interface dialer 1 overload **********
    ip nat inside source static 192.168.5.4 10.251.82.105
    ip nat inside source static 192.168.5.4 dialer 1 (for backup )
    *********

    access-list 1 permit 192.168.5.0 0.0.0.255
    access-list 2 permit 192.168.5.0 0.0.0.255
    **********


    _____________________________________________________________________________
    Manolis Anastasakis, Sep 8, 2006
    #1
    1. Advertising

  2. Manolis Anastasakis

    Guest

    Interesting question if I'm understanding it right:

    You're asking if when interface A is up, if a static NAT can be in
    effect (ie IP 10.10.10.1 -> 5.5.5.5) but if interface A goes down and
    dialer B comes up, if that static NAT can change dynamically (ie IP
    10.10.10.1 now -> 6.6.6.6).

    I have no idea (I would think it would require more than static NAT's
    to accomplish this) but I would be interested if someone with more
    expertise could answer this definitively.

    Jason


    Manolis Anastasakis wrote:
    > Hi all
    >
    > it is feasible in same router to become nat in the two otherwise interface
    > one for backup ? with static nat ?
    >
    >
    > interface FastEthernet0/0
    > ip address 192.168.5.1 255.255.255.0
    > ip nat inside
    >
    >
    >
    > interface Serial0/0/0.2 point-to-point
    > ip address 10.16.129.170 255.255.255.252
    > ip nat outside
    > frame-relay class internet
    > frame-relay interface-dlci 16
    >
    > interface ATM0/1/0
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 8/35
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 2
    >
    > interface Dialer1
    > ip address negotiated
    > ip nat outside
    > encapsulation ppp
    > ip tcp adjust-mss 1452
    > dialer pool 2
    > dialer-group 2
    > no cdp enable
    > ppp authentication chap pap callin
    > ppp chap hostname xxxxxxx
    > ppp chap password 7 xxxxxxxxx
    > ppp ipcp dns request
    > --
    >
    > ip route 0.0.0.0 0.0.0.0 10.16.129.169
    > ip route 0.0.0.0 0.0.0.0 dialer 1 200 **********
    >
    > ip nat pool internet 10.251.82.103 10.251.82.103 netmask 255.255.255.240
    > ip nat inside source list 1 pool internet overload **********
    > ip nat source list 2 interface dialer 1 overload **********
    > ip nat inside source static 192.168.5.4 10.251.82.105
    > ip nat inside source static 192.168.5.4 dialer 1 (for backup )
    > *********
    >
    > access-list 1 permit 192.168.5.0 0.0.0.255
    > access-list 2 permit 192.168.5.0 0.0.0.255
    > **********
    >
    >
    > _____________________________________________________________________________
    , Sep 10, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrea
    Replies:
    0
    Views:
    826
    Andrea
    Apr 19, 2004
  2. Anonymous Poster
    Replies:
    0
    Views:
    10,502
    Anonymous Poster
    Apr 26, 2004
  3. erik erasmus
    Replies:
    0
    Views:
    338
    erik erasmus
    Jul 8, 2005
  4. skweetis
    Replies:
    0
    Views:
    1,147
    skweetis
    Dec 11, 2006
  5. Replies:
    1
    Views:
    441
    Brian V
    Sep 22, 2007
Loading...

Share This Page