SQL Server 2005 Migration Assistant Autonumber problem.

Discussion in 'MCTS' started by LarryWestMCSD, Mar 24, 2007.

  1. I am trying to migrate an Access 2003 database to SQL Server 2005 using the
    SQL Server Migration Assistant for Access and am having various problems:

    1. On one table, the migration gives the following on an autonumber field:
    A2SS0023: SQL Server Migration Assistant for Access Warning Message: Default
    value '0' added to target column (1), followed later on by
    A2SS0028: Auto-increment attribute of the column 'MSEQ' was not converted to
    Identity because the column has a default value.

    This table has about 80,000 records.

    2. If I include another table in the migration, this one with 3.4 million
    records (hence our need to upgrade to SQL server 2005), I am getting a
    timeout error, even when I try to migrate the table by itself. I have
    verified that all timeout options are set to zero (unlimited time).

    Any suggestions would be appreciated.

    -- Larry J. West, MCSD, MCPD, MCTS: SQL Server 2005 [so yes, I should know
    the answer to this, but I don't], MOUS, FLMI, ACS
     
    LarryWestMCSD, Mar 24, 2007
    #1
    1. Advertising

  2. Sorry, we don't have 2000, only 2005.
    I assume the reason it doesn't work is that Access 2003 isn't compatible
    with 2005 since it came later, and running the upsizing wizard didn't work
    properly.
    Is there a free version of 2000 anywhere that I can temporarily download and
    use?
    --
    Larry J. West, MCSD, MCPD, MCTS:SQL Server 2005, MOUS, FLMI, ACS


    "Jonathan Roberts" wrote:

    > LarryWestMCSD wrote:
    > > I am trying to migrate an Access 2003 database to SQL Server 2005 using the
    > > SQL Server Migration Assistant for Access and am having various problems:
    > >
    > > 1. On one table, the migration gives the following on an autonumber field:
    > > A2SS0023: SQL Server Migration Assistant for Access Warning Message: Default
    > > value '0' added to target column (1), followed later on by
    > > A2SS0028: Auto-increment attribute of the column 'MSEQ' was not converted to
    > > Identity because the column has a default value.
    > >
    > > This table has about 80,000 records.
    > >
    > > 2. If I include another table in the migration, this one with 3.4 million
    > > records (hence our need to upgrade to SQL server 2005), I am getting a
    > > timeout error, even when I try to migrate the table by itself. I have
    > > verified that all timeout options are set to zero (unlimited time).
    > >
    > > Any suggestions would be appreciated.
    > >
    > > -- Larry J. West, MCSD, MCPD, MCTS: SQL Server 2005 [so yes, I should know
    > > the answer to this, but I don't], MOUS, FLMI, ACS
    > >

    >
    > Larry,
    >
    > I should know also but don't as I haven't converted data to/from 2005
    > yet. However, I did this numerous times under SQL 2000. Can you try
    > importing into 2000 and then moving to 2005? Is that an option for this
    > environment/project?
    >
    > Good luck...
    >
    > --
    > Jonathan Roberts
    > MCTS: SQL Server 2005, MCP
    >
    > Information on MS VHD Images: http://tinyurl.com/y5bozl
    > Great MS Blog: http://blogs.msdn.com/trika/default.aspx
    > Feedback on 70-431 Exam: http://www.jonathanroberts.eu/?p=6
    >
     
    LarryWestMCSD, Mar 28, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. gemeaux | tt

    New Exams for SQL Server 2005 and Visual Studio 2005

    gemeaux | tt, Oct 23, 2004, in forum: Microsoft Certification
    Replies:
    1
    Views:
    610
    Oyvind Mjolund
    Oct 25, 2004
  2. DST
    Replies:
    8
    Views:
    949
  3. Pedro Simoes
    Replies:
    0
    Views:
    581
    Pedro Simoes
    Nov 24, 2005
  4. Pedro Simoes
    Replies:
    0
    Views:
    943
    Pedro Simoes
    Nov 24, 2005
  5. Replies:
    0
    Views:
    1,475
Loading...

Share This Page