spanning tree and BPDU question

Discussion in 'Cisco' started by NNTP, Nov 10, 2004.

  1. NNTP

    NNTP Guest

    I have turned spanning tree off with the following command on a new
    cisco 3750 switch running IOS 12.1. is has 5 vlans defined on it.


    no spanning-tree vlan 1

    sw#sh spanning-tree

    Spanning tree 1 is not currently active
    The following parameters have been configured :

    Stp Status : Disabled
    Protocol : IEEE
    Max Age (sec) : 20
    Hello time (sec) : 2
    Forward Delay (sec): 15
    Bridge Priority : 32768


    I still see that BPDUs are received on the switch and just the other
    day we had a problem where the other end of our uplink switch port was
    (managed by other group) set into trunk mode and that took us down
    with the following messages in the logs.

    Received 802.1Q BPDU on non trunk FastEthernet0/11 on vlan 2.
    00:25:00: %SPANTREE-2-BLOCK_PORT_TYPE: Blocking FastEthernet0/11 on
    vlan 2.
    Inconsistent port type.

    we then had to call the other group and had them put the port back to
    whatever state it was in before and that brought the link bak up.

    question is, is there anything I can do on this end to make sure that
    I ignore the BPDUs received? I thought I turned spanning tree off here
    but aparantly I receive BPDUs!!!
     
    NNTP, Nov 10, 2004
    #1
    1. Advertising

  2. With the command "no spanning-tree vlan 1' you only disabled
    spanning-tree for vlan 1. If the 3750 is like almost all other Cisco
    switches it does PVST, which is Per-VLAN Spanning-Tree. PVST means
    there is an instance of the Spanning-Tree algorithm running on every
    VLAN. So with your configuration you can still receive BPDUs and send
    out BPDUs your 4 additional VLANs. The error message you reference
    below indicates the BPDU is an 802.1q packet on VLAN 2.

    So to ignore all BPDUs, you will need to disable spanning-tree on all
    VLANs. I am not sure if that turning off BPDUs is going to solve your
    problem with the error messages you referenced, because regardless of
    whether you get an 802.1q BPDU or just an 802.1q packet, as soon as
    that access link receives the 802.1q encapsulated packet, you will
    probably get the same error. The problem there is more-than-likely
    that the other end somehow thought it was an 802.1q trunk and was
    trying to send encapsulated packets to your FastEthernet0/11 which I
    am assuming is configured as an access link for VLAN 2.

    I have not specifically worked with Catalyst 3750s so maybe some
    things have changed in this newer switch, but that's what the problem
    appears to be.

    Good Luck
    -Robert

    On 9 Nov 2004 19:01:44 -0800, (NNTP) wrote:

    >I have turned spanning tree off with the following command on a new
    >cisco 3750 switch running IOS 12.1. is has 5 vlans defined on it.
    >
    >
    >no spanning-tree vlan 1
    >
    >sw#sh spanning-tree
    >
    >Spanning tree 1 is not currently active
    >The following parameters have been configured :
    >
    >Stp Status : Disabled
    >Protocol : IEEE
    >Max Age (sec) : 20
    >Hello time (sec) : 2
    >Forward Delay (sec): 15
    >Bridge Priority : 32768
    >
    >
    >I still see that BPDUs are received on the switch and just the other
    >day we had a problem where the other end of our uplink switch port was
    >(managed by other group) set into trunk mode and that took us down
    >with the following messages in the logs.
    >
    >Received 802.1Q BPDU on non trunk FastEthernet0/11 on vlan 2.
    >00:25:00: %SPANTREE-2-BLOCK_PORT_TYPE: Blocking FastEthernet0/11 on
    >vlan 2.
    >Inconsistent port type.
    >
    >we then had to call the other group and had them put the port back to
    >whatever state it was in before and that brought the link bak up.
    >
    >question is, is there anything I can do on this end to make sure that
    >I ignore the BPDUs received? I thought I turned spanning tree off here
    >but aparantly I receive BPDUs!!!
     
    Robert B. Phillips, II, Nov 10, 2004
    #2
    1. Advertising

  3. NNTP

    NNTP Guest

    Thanks rob, that was helpfull. yes the port on my side was an 'access'
    port

    I turned off spanning tree on all vlans. I still need to find out if
    there is any way to just ignore BPDUs received on that port, is this
    doable with access lists or access lists are just for layer3?


    "Robert B. Phillips, II" <> wrote in message news:<>...
    > With the command "no spanning-tree vlan 1' you only disabled
    > spanning-tree for vlan 1. If the 3750 is like almost all other Cisco
    > switches it does PVST, which is Per-VLAN Spanning-Tree. PVST means
    > there is an instance of the Spanning-Tree algorithm running on every
    > VLAN. So with your configuration you can still receive BPDUs and send
    > out BPDUs your 4 additional VLANs. The error message you reference
    > below indicates the BPDU is an 802.1q packet on VLAN 2.
    >
    > So to ignore all BPDUs, you will need to disable spanning-tree on all
    > VLANs. I am not sure if that turning off BPDUs is going to solve your
    > problem with the error messages you referenced, because regardless of
    > whether you get an 802.1q BPDU or just an 802.1q packet, as soon as
    > that access link receives the 802.1q encapsulated packet, you will
    > probably get the same error. The problem there is more-than-likely
    > that the other end somehow thought it was an 802.1q trunk and was
    > trying to send encapsulated packets to your FastEthernet0/11 which I
    > am assuming is configured as an access link for VLAN 2.
    >
    > I have not specifically worked with Catalyst 3750s so maybe some
    > things have changed in this newer switch, but that's what the problem
    > appears to be.
    >
    > Good Luck
    > -Robert
    >
    > On 9 Nov 2004 19:01:44 -0800, (NNTP) wrote:
    >
    > >I have turned spanning tree off with the following command on a new
    > >cisco 3750 switch running IOS 12.1. is has 5 vlans defined on it.
    > >
    > >
    > >no spanning-tree vlan 1
    > >
    > >sw#sh spanning-tree
    > >
    > >Spanning tree 1 is not currently active
    > >The following parameters have been configured :
    > >
    > >Stp Status : Disabled
    > >Protocol : IEEE
    > >Max Age (sec) : 20
    > >Hello time (sec) : 2
    > >Forward Delay (sec): 15
    > >Bridge Priority : 32768
    > >
    > >
    > >I still see that BPDUs are received on the switch and just the other
    > >day we had a problem where the other end of our uplink switch port was
    > >(managed by other group) set into trunk mode and that took us down
    > >with the following messages in the logs.
    > >
    > >Received 802.1Q BPDU on non trunk FastEthernet0/11 on vlan 2.
    > >00:25:00: %SPANTREE-2-BLOCK_PORT_TYPE: Blocking FastEthernet0/11 on
    > >vlan 2.
    > >Inconsistent port type.
    > >
    > >we then had to call the other group and had them put the port back to
    > >whatever state it was in before and that brought the link bak up.
    > >
    > >question is, is there anything I can do on this end to make sure that
    > >I ignore the BPDUs received? I thought I turned spanning tree off here
    > >but aparantly I receive BPDUs!!!
     
    NNTP, Nov 10, 2004
    #3
  4. NNTP

    mathew

    Joined:
    Oct 2, 2008
    Messages:
    1
    int#spanning-tree portfast
     
    mathew, Oct 2, 2008
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Amy L.
    Replies:
    0
    Views:
    2,422
    Amy L.
    Jul 24, 2003
  2. ws00sw

    Spanning-Tree 802.1D TCN BPDU

    ws00sw, Jan 31, 2005, in forum: Cisco
    Replies:
    0
    Views:
    2,101
    ws00sw
    Jan 31, 2005
  3. lfnetworking
    Replies:
    2
    Views:
    2,023
    Scooby
    May 16, 2005
  4. John Carter

    Question for Spanning tree experts

    John Carter, Jan 9, 2006, in forum: Cisco
    Replies:
    14
    Views:
    3,006
  5. Replies:
    1
    Views:
    865
    donjohnston
    Dec 30, 2008
Loading...

Share This Page